• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

vsftpd Fehler "500 OOPS: missing value in config file for: "

f0x

Haudegen
Themenstarter #1
Hi,

ich versuch seid Tagen nen vsftpd ans laufen zu bekommen, aber immer wieder treten Fehler auf. Jetzt steh ich vor nem Problem bei dem selbst google keine Antwort weis (so wie es scheint zumindest)

beim ausführen von vsftpd kommt folgende Meldung
Code:
500 OOPS: missing value in config file for:
und das wars. Keine Line, kein bestimmter Command der den Fehler auslöst.

Meine vsftpd.conf sieht so aus
Code:
listen_port=21
pasv_min_port=49152
pasv_max_port=65535
pasv_promiscuous=NO
port_promiscuous=NO
connect_timeout=60
data_connection_timeout=140
idle_session_timeout=120
cmds_allowed=ABOR,CWD,LIST,MDTM,MKD,NLST,PASS,PASV,PWD,QUIT,RETR,RMD,RFNR,RNTO,SIZE,STOR,TYPE,USER,ACCT,APPE,CDUP,HELP,MODE,NOOP,REIN,STAT,STOU,STRU,SYST
write_enable=YES
max_client=3
max_per_ip=2

ascii_upload_enable=YES
ascii_download_enable=YES
hide_ids=YES
ls_recurse_enable=NO
use_localtime=NO

anonymous_enable=YES
anon_max_rate=0
anon_mkdir_write_enable=NO
anon_root=/home/ftp/
anon_world_readable_only=NO
anon_umask=0022
anon_upload_enable=NO
anon_other_write_enable=NO
no_anon_password=NO

local_enable=YES
local_max_rate=0
local_umask=0022
chroot_local_users=YES
check_shell=NO
chmod_enable=YES
secure_chroot_dir=/var/dev/
userlist_enable=YES
userlist_deny=NO
userlist_file=/etc/vsftpd_users

xferlog_enable=YES
log_ftp_protocol=YES
xferlog_file=/var/log/vsftpd.log
Könnt ihr Irgendetwas erkennen was ich übersehe oder was evtl noch fehlt??

Achja und wie und wo kann ich das anonymous Passwort festlegen???

Danke im Vorraus.

MfG

f0x
 
Zuletzt bearbeitet:

oenone

Programmierer
#2
Welche OpenBSD-Version benutzt du? Die Version von vsftpd für OpenBSD 4.4 kennt da ein paar der Einstellungen nicht...
 

f0x

Haudegen
Themenstarter #3
OpenBSD 4.4
Das wusst ich nicht. Haste vllt n link oder so was wo steht welche Befehle gehen und welche ersatzweise benutzt werden können???
 

oenone

Programmierer
#4
Bei mir hat sich vsftpd über die beschwert:
Code:
max_client
chroot_local_users
wobei das wohl beides tippfehler sind, wie ich gerade merke. vsftpd.conf(5) gibt dir alle Optionen.
 

f0x

Haudegen
Themenstarter #5
Jau waren Schreibfehler...
Eigentlich ist es ja so, dass der wenn man versucht vsftpd zu starten nach und nach sag was in der .conf file nicht passt, bei den ersten paar Fehlern wurde das auch noch angezeigt, nu zeigt der aber nur noch die Fehlermessage ohne den eigentlich Fehler an, was ich n bissl seltsam finde.... :confused:

Noch weitere Vorschläge???
 

f0x

Haudegen
Themenstarter #6
Ich hab heute noch mal versuch den vsftpd zum laufen zu bekommen und habe ein par how To's aus dem Internet benutzt.

Jetzt habe ich folgendes Problem.

Wenn ich einfach nur
Code:
/usr/local/sbin/vsftpd
aufrufe kann ich zwar auf den Server auf port 21 zugreifen, jedoch werden keinerlei dateien angezeigt - der Server scheint noch nicht richtig zu laufen.
Laut tutorial soll man den Daemon auch mit vsftpd start ausführen, jedoch kommt bei mir folgende Meldung
Code:
# /usr/local/sbin/vsftpd start 500 OOPS: vsftpd: cannot open config file:start
Googlen hat lediglich einige chinesische Seiten und diesen link ergeben, leider werde ich daraus nicht schlau. Ich habe jetzt einfach diese Beispiel conf benutzt
Code:
#######################################################
###  Calomel.org  vsftpd.conf   BEGIN
#######################################################
# manpage: http://vsftpd.beasts.org/vsftpd_conf.html
# Setup specially for an OpenBSD install
#
# Run in daemon mode
background=YES
listen=YES
listen_address=120.111.222.111
#pasv_address=127.0.0.1
#
# User to run daemon as
nopriv_user=_vsftpd
ftp_username=_ftp
#
# Ftp ports
connect_from_port_20=NO
ftp_data_port=20
listen_port=21
pasv_min_port=49152
pasv_max_port=65535
pasv_promiscuous=NO
port_enable=NO
port_promiscuous=NO
#
# SSL (force options for a SSL only server)
#ssl_enable=YES
#ssl_tlsv1=YES
#ssl_sslv2=NO
#ssl_sslv3=NO
#rsa_cert_file=/etc/ssl/private/vsftpd.pem
#allow_anon_ssl=YES
#force_anon_data_ssl=YES
#force_anon_logins_ssl=YES
#force_local_data_ssl=YES
#force_local_logins_ssl=YES
#
# Timeouts
connect_timeout=60
data_connection_timeout=120
idle_session_timeout=120
#
# Information messages
banner_file=/etc/banner
dirmessage_enable=YES
ftpd_banner=Calomel.org ftp server
#
# Access limits and controls
async_abor_enable=NO
cmds_allowed=ABOR,CWD,DELE,LIST,MDTM,MKD,NLST,PASS,PASV,PWD,QUIT,RETR,RMD,RNFR,RNTO,SIZE,STOR,TYPE,USER,ACCT,APPE,CDUP,HELP,MODE,NOOP,REIN,STAT,STOU,STRU,SYST
guest_enable=NO
write_enable=YES
max_clients=300
max_per_ip=20
hide_file={.*,*.mp3}
deny_file={.*,*.mp3}
#
# Preferences
ascii_upload_enable=NO
ascii_download_enable=NO
hide_ids=YES
ls_recurse_enable=NO
use_localtime=NO
#
# Allow anonymous FTP?
anonymous_enable=YES
anon_max_rate=0
anon_mkdir_write_enable=NO
anon_root=/disk01/ftp/
anon_world_readable_only=YES
anon_umask=0022
anon_upload_enable=NO
anon_other_write_enable=NO
no_anon_password=NO
#
# Allow local user access?
local_enable=YES
local_max_rate=0
local_umask=0022
chroot_local_user=YES
check_shell=NO
chmod_enable=NO
secure_chroot_dir=/var/empty
userlist_enable=YES
userlist_deny=NO
userlist_file=/etc/vsftpd_users
#
# Logging
xferlog_enable=YES
log_ftp_protocol=YES
xferlog_file=/var/log/vsftpd.log
#
#######################################################
###  Calomel.org  vsftpd.conf  END
#######################################################
und lediglich die Pfadnamen angepasst.

Hat irgendwer von euch eine Idee was ich machen kann um den Server zum laufen zu bekommen?

MfG

f0x