• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Web-Browser langsam / resolve-Problem?

hippodriver

Well-Known Member
Themenstarter #1
Hallo board member!

Auf meinem frisch installierten FreeBSD 6.2 Release, ist die Anzeige von vielen Web-Seiten stark verzögert bis unmöglich. bsdforen ist eine der wenigen Ausnahmen. Selbst bei www.google.de wird das Google-Logo nicht komplett geladen. Auch nach 5 Minuten versucht der Web-Browser noch Teile des Logos zu laden. Bei www.freshports.org bekomme ich gar keine Anzeige.

Das Problem tritt mit Konqueror, Firefox, Opera und lynx auf.

Ich vermute ein Problem mit DNS und IPv6. Ein Setzen der KDE_NO_IPV6 Umgebungsvariable in Xsession brachte aber selbst beim Konqueror keine Abhilfe. Ein DNS lookup mit dem host Kommando liefert hingegen deutlich unter einer Sekunde die entsprechenden IP Adressen.

Nach langer und langsamer Suche im Web, habe ich zwei, nennen wir es mal, "Umgehungsansätze" gesehen:

1. lokalen DNS Server aufsetzen -> http://wiki.bsdforen.de/Namensauflösung
2. Neuen Kernel ohne IPv6 kompilieren

Das kann doch nicht das Standardverfahren sein.
"sysctl -a | grep inet6" liefert ja einige Treffer, aber ich finde keine Dokumentation für die Variablen. Irgendwie muß man doch die IPv6 Unterstützung auch zur Laufzeit ausschalten können?

In der Manpage von sysctl standen einige Header, mal sehen ob ich dort wirklich Doku für sysctl finde.

Jetzt meine Frage: Wie löse ich das obige Problem richtig?


Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #2
Die entsprechenden sysctl Variablen sind in /usr/src/sys/netinet6/in6.h
dokumentiert. Leider gibt es keine, um IPv6 abzuschalten. Deshalb habe ich den kernel, ohne IPv6, neu gebaut. Das Problem mit den Web-Browsern bleibt aber bestehen. Damit fällt IPv6 als Fehlerursache schonmal weg.

Ich habe jetzt die Einträge in rc.conf, hosts, resolv.conf und nsswitch.conf überprüft. Mir fällt dort nichts auf.

ifconfig:
Code:
gandalf# ifconfig -a
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=1b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
        inet 192.168.0.5 netmask 0xffffff00 broadcast 192.168.0.255
        ether 00:16:e6:6b:9e:19
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        inet 127.0.0.1 netmask 0xff000000
rc.conf:
Code:
defaultrouter="192.168.0.1"
hostname="gandalf.gondor"
ifconfig_re0="inet 192.168.0.5  netmask 255.255.255.0"
...
hosts:
Code:
::1                     localhost.gondor localhost
127.0.0.1               localhost.gondor localhost
192.168.0.5             gandalf.gondor gandalf
resolv.conf:
Code:
search  gondor
#nameserver     192.168.0.1
nameserver      82.141.0.101
nsswitch.conf:
Code:
group: compat
group_compat: nis
hosts: files dns
networks: files
passwd: compat
passwd_compat: nis
shells: files
Die routing Tabelle sieht auch gut aus:
Code:
gandalf# netstat -rW
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use    Mtu    Netif Expire
default            192.168.0.1        UGS         0      488   1500      re0
localhost          localhost          UH          0        0  16384      lo0
192.168.0          link#1             UC          0        0   1500      re0
192.168.0.1        00:01:e3:42:d5:47  UHLW        2        0   1500      re0   1155
Was mir aber komisch vorkommt ist:
Code:
gandalf# host 192.168.0.5
Host 5.0.168.192.in-addr.arpa not found: 3(NXDOMAIN)
gandalf# host gandalf.gondor
Host gandalf.gondor not found: 3(NXDOMAIN)
gandalf# host gandalf
Host gandalf not found: 3(NXDOMAIN)
Es scheint so, als würden die Einträge in /etc/hosts ignoriert :confused:


Mit freundlichen Grüßen
Michael Krauß
 

Kamikaze

Warrior of Sunlight
#3
Das liegt daran, dass host beim Nameserver fragt. Der kennt doch deinen Hostnamen nicht.

Benutzt du zufällig einen (transparenten) Proxy?
 

soul_rebel

ist immer auf der flucht
#4
versuch mal statt deinem router oder deinem jetzigen dns-server einen anderen öffentlichen zu nehmen.
z.b. einen von opennic

hatte ein ähnliches problem. seltsamerweise nur mit freebsd clients. aber der neue dns-server hat abhilfe geschaffen.
 

hippodriver

Well-Known Member
Themenstarter #5
Das liegt daran, dass host beim Nameserver fragt. Der kennt doch deinen Hostnamen nicht.
Stimmt. Lokal funktioniert die Auflösung:
Code:
gandalf# ping gandalf
PING gandalf.gondor (192.168.0.5): 56 data bytes
64 bytes from 192.168.0.5: icmp_seq=0 ttl=64 time=0.044 ms
Benutzt du zufällig einen (transparenten) Proxy?
Nein, nicht daß ich wüsste. Der Rechner hängt direkt an einem Hardware DSL Router (Gigaset SE515 dsl). Der IP Filter auf dem Router ist deaktiviert.

Ich habe, um besser im Netz nach Lösungen suchen zu können, parallel Arch Linux installiert. Das läuft, ebenfalls mit IP 192.168.0.5, problemlos.

Auf der questions Mailingliste von FreeBSD gibt es immer mal wieder ähnliche Probleme. Aber meistens verliefen die Anfragen im Sand.
Probleme mit klaren Fehlermeldungen sind halt einfacher zu lösen.


Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #6
versuch mal statt deinem router oder deinem jetzigen dns-server einen anderen öffentlichen zu nehmen.
z.b. einen von opennic

hatte ein ähnliches problem. seltsamerweise nur mit freebsd clients. aber der neue dns-server hat abhilfe geschaffen.
Habe die zwei DNS von opennic probiert:
ns1.de.opennic.glue (Cologne, DE) - 217.115.138.24
ns1.be.opennic.glue (Luik, Belgium) - 83.217.93.246

außerdem den DNS der FU Berlin. Leider brachte das keine Besserung.
Ich habe jetzt den Aufruf von www.google.de mitgeschnitten. Nach den 2 Minuten war das Google-Logo immer noch nicht aufgebaut:

Code:
gandalf# tcpdump -i re0 host 192.168.0.5
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on re0, link-type EN10MB (Ethernet), capture size 96 bytes
14:49:57.646820 IP gandalf.gondor.54079 > 72.14.221.99.http: S 317888745:317888745(0) win 65535 <mss 1460,nop,wscale 1,nop,nop,timestamp 1544883 0,sac
kOK,eol>
14:49:57.707646 IP 72.14.221.99.http > gandalf.gondor.54079: S 444296775:444296775(0) ack 317888746 win 8190 <mss 1420>
14:49:57.707694 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 1 win 65535
14:49:57.707865 IP gandalf.gondor.54079 > 72.14.221.99.http: P 1:481(480) ack 1 win 65535
14:49:57.762685 IP gandalf.gondor.50204 > ns1.fu-berlin.de.domain:  32222+ PTR? 99.221.14.72.in-addr.arpa. (43)
14:49:57.798531 IP 72.14.221.99.http > gandalf.gondor.54079: . ack 481 win 6432
14:49:57.815815 IP 72.14.221.99.http > gandalf.gondor.54079: . 1:1421(1420) ack 481 win 6432
14:49:57.819816 IP 72.14.221.99.http > gandalf.gondor.54079: P 1421:1862(441) ack 481 win 6432
14:49:57.819847 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 1862 win 65535
14:49:57.840651 IP ns1.fu-berlin.de.domain > gandalf.gondor.50204:  32222- 0/4/4 (189)
14:49:57.847783 IP gandalf.gondor.54079 > 72.14.221.99.http: P 481:939(458) ack 1862 win 65535
14:49:57.950859 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:49:57.961895 IP 72.14.221.99.http > gandalf.gondor.54079: . 3282:4702(1420) ack 939 win 7504
14:49:57.961930 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 4702 win 65320
14:49:57.974013 IP 72.14.221.99.http > gandalf.gondor.54079: . 4702:6122(1420) ack 939 win 7504
14:49:58.076013 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 6122 win 65535
14:49:58.597875 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:49:58.597910 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 6122 win 65535
14:49:58.863611 IP gandalf.gondor.53596 > ns1.fu-berlin.de.domain:  32223+ PTR? 8.8.45.160.in-addr.arpa. (41)
14:49:58.939565 IP ns1.fu-berlin.de.domain > gandalf.gondor.53596:  32223*- 1/3/3 PTR[|domain]
14:49:59.747960 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:49:59.747994 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 6122 win 65535
14:50:01.397995 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:50:01.398029 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 6122 win 65535
14:50:02.705968 arp who-has gandalf.gondor tell 192.168.0.1
14:50:02.705989 arp reply gandalf.gondor is-at 00:16:e6:6b:9e:19 (oui Unknown)
14:50:03.063930 IP gandalf.gondor.51208 > ns1.fu-berlin.de.domain:  32224+ PTR? 1.0.168.192.in-addr.arpa. (42)
14:50:03.139622 IP ns1.fu-berlin.de.domain > gandalf.gondor.51208:  32224*- 0/1/0 (111)
14:50:03.549126 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:50:03.549158 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 6122 win 65535
14:50:07.848995 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:50:07.849029 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 6122 win 65535
14:50:07.951021 IP 72.14.221.99.http > gandalf.gondor.54079: . 6122:7542(1420) ack 939 win 7504
14:50:07.962079 IP 72.14.221.99.http > gandalf.gondor.54079: . 7542:8962(1420) ack 939 win 7504
14:50:07.962105 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 8962 win 65320
14:50:16.106541 IP gandalf.gondor.61327 > 64.147.113.42.http: . 321073179:321073180(1) ack 2155526742 win 65535
14:50:16.449236 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:50:16.449268 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 8962 win 65535
14:50:16.551466 IP gandalf.gondor.53078 > ns1.fu-berlin.de.domain:  32225+ PTR? 42.113.147.64.in-addr.arpa. (44)
14:50:16.630124 IP ns1.fu-berlin.de.domain > gandalf.gondor.53078:  32225- 0/7/8 (335)
14:50:27.886242 IP gandalf.gondor.53523 > 64.147.113.42.http: . 3350452907:3350452908(1) ack 1043535932 win 65535
14:50:31.712401 IP gandalf.gondor.54910 > 64.147.113.42.http: . 3971649000:3971649001(1) ack 198447150 win 65535
14:50:33.649754 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:50:33.649788 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 8962 win 65535
14:50:53.652351 IP 72.14.221.99.http > gandalf.gondor.54079: . 1862:3282(1420) ack 939 win 7504
14:50:53.652383 IP gandalf.gondor.54079 > 72.14.221.99.http: . ack 8962 win 65535
14:50:58.648082 arp who-has gandalf.gondor tell 192.168.0.1
14:50:58.648104 arp reply gandalf.gondor is-at 00:16:e6:6b:9e:19 (oui Unknown)
14:51:09.383635 arp who-has gandalf.gondor (Broadcast) tell 192.168.0.1
14:51:09.383651 arp reply gandalf.gondor is-at 00:16:e6:6b:9e:19 (oui Unknown)
14:51:18.001160 IP gandalf.gondor.61327 > 64.147.113.42.http: . 0:1(1) ack 1 win 65535
14:51:29.786969 IP gandalf.gondor.53523 > 64.147.113.42.http: . 0:1(1) ack 1 win 65535
14:51:33.613087 IP gandalf.gondor.54910 > 64.147.113.42.http: . 0:1(1) ack 1 win 65535
Da passiert zuweilen 10 Sekunden lang gar nichts.


Mit freundlichen Grüßen
Michael Krauß
 

soul_rebel

ist immer auf der flucht
#7
ping google.de mal eine halbe stunde lang und guck mal wieviel / ob du paketverlust hast. wenn der zum aufbauen des ersten pings lange braucht (also das paket nicht direkt losschickt) hast du auf jeden fall ein dns-problem.

versuch alternativ ob der seitenaufbau von seiten schneller geht wenn du ihre ip-adresse statt dem hostnamen verwendest.

danach solltest du mal versuchen die MTU auf deinen device stark zu drosseln, z.b. auf 1024
 

hippodriver

Well-Known Member
Themenstarter #8
ping google.de mal eine halbe stunde lang und guck mal wieviel / ob du paketverlust hast. wenn der zum aufbauen des ersten pings lange braucht (also das paket nicht direkt losschickt) hast du auf jeden fall ein dns-problem.
ping läuft ganz sauber durch:
Code:
gandalf# ping google.de
PING google.de (216.239.59.104): 56 data bytes
64 bytes from 216.239.59.104: icmp_seq=0 ttl=242 time=90.910 ms
64 bytes from 216.239.59.104: icmp_seq=1 ttl=242 time=88.748 ms
64 bytes from 216.239.59.104: icmp_seq=2 ttl=242 time=88.330 ms
64 bytes from 216.239.59.104: icmp_seq=3 ttl=242 time=89.431 ms
64 bytes from 216.239.59.104: icmp_seq=4 ttl=242 time=88.248 ms
...
64 bytes from 216.239.59.104: icmp_seq=909 ttl=242 time=88.304 ms
64 bytes from 216.239.59.104: icmp_seq=910 ttl=242 time=88.518 ms
64 bytes from 216.239.59.104: icmp_seq=911 ttl=242 time=88.066 ms
64 bytes from 216.239.59.104: icmp_seq=912 ttl=242 time=88.077 ms
64 bytes from 216.239.59.104: icmp_seq=913 ttl=242 time=84.387 ms
^C
--- google.de ping statistics ---
914 packets transmitted, 912 packets received, 0% packet loss
round-trip min/avg/max/stddev = 82.631/88.223/348.308/10.705 ms
versuch alternativ ob der seitenaufbau von seiten schneller geht wenn du ihre ip-adresse statt dem hostnamen verwendest.
Habe ich mit den IPs von www.heise.de und www.freshports.org versucht -- es hat keine Auswirkung. Heise braucht lange bis zum kompletten Aufbau und bei freshports tut sich garnichts.

danach solltest du mal versuchen die MTU auf deinen device stark zu drosseln, z.b. auf 1024
Code:
gandalf# ifconfig re0 mtu 1024
gandalf# ifconfig re0
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1024
        options=1b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING>
        inet 192.168.0.5 netmask 0xffffff00 broadcast 192.168.0.255
        ether 00:16:e6:6b:9e:19
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
Das hilft leider auch nichts (auch mit mtu=512).


Mit freunlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #10
Wie sieht's denn bei Seiten aus, die du über https erreichen kannst?

https://amazon.de/

Mir ist gerade nichts anderes eingefallen.
ca. 5 Minuten lang steht "waiting for amazon.de..." in der Statuszeile.
Dann kommt der Warnhinweis vonwegen "Encrypted...".
Nachdem ich mit OK bestätige, passiert garnichts mehr: Keine Anzeige, aber ein "OK" in der Statuszeile.


Mit freundlichen Grüßen
Michael Krauß
 

thyrver

till evighet
#11
Hast du schon mal gondor.home (oder .lan, .space, .private, allerdings dürfen es keine gültige TLDs des Internets sein) anstatt nur gondor als Domain probiert? Dh. deine Rechner so konfiguriert, das sie in dieser Domain (gondor.home) liegen?

Btw. in /etc/hosts würde ich die Einträge für ::1 und 127.0.0.1 auf
Code:
::1			localhost localhost.my.domain
127.0.0.1		localhost localhost.my.domain
ändern.
 
Zuletzt bearbeitet:

hippodriver

Well-Known Member
Themenstarter #12
Hast du schon mal gondor.home (oder .lan, .space, .private ...) anstatt nur gondor als Domain probiert?
Eben probiert, habe rc.conf und hosts angepasst:
Code:
gandalf# uname -n
gandalf.gondor.lan
gandalf# sysctl -a | grep name
kern.hostname: gandalf.gondor.lan
kern.domainname:
       soname    69     8K       -      631  16,32,64,128
kern.sched.name: 4BSD
user.tzname_max: 255
compat.linux.osname: Linux
security.jail.set_hostname_allowed: 1
Auch das schafft keine Abhilfe.


Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #15
Auch resolv.conf? Und wenn ja, was passiert dann beim AUfrufen von
Code:
host gandalf
/etc/resolv.conf sieht so aus:
Code:
gandalf# cat /etc/resolv.conf
search  gondor.lan
#nameserver     192.168.0.1
nameserver      82.141.0.101
#nameserver 160.45.8.8
host liefert:
Code:
gandalf# host gandalf
Host gandalf not found: 3(NXDOMAIN)
gandalf# host gandalf.gondor
Host gandalf.gondor not found: 3(NXDOMAIN)
gandalf# host gandalf.gondor.lan
Host gandalf.gondor.lan not found: 3(NXDOMAIN)
also das selbe wie in Beitrag 2. Oder auch
Code:
gandalf# host -v gandalf
Trying "gandalf.gondor.lan"
Trying "gandalf"
Host gandalf not found: 3(NXDOMAIN)
Received 25 bytes from 82.141.0.101#53 in 55 ms
Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #16
Also bei google.de und www.heise.de funktioniert das ganz schnell, aber bei www.freshports.org nicht:

Code:
gandalf# fetch http://google.de
fetch: http://google.de: size of remote file is not known
google.de                                             2908  B  295 kBps
gandalf# fetch http://www.heise.de
fetch: http://www.heise.de: size of remote file is not known
www.heise.de                                            38 kB   70 kBps
gandalf# fetch http://www.freshports.org
^Cfetch: transfer interrupted

gandalf# time fetch http://www.freshports.org
^Cfetch: transfer interrupted
0.000u 0.003s 1:51.88 0.0%      0+0k 0+0io 0pf+0w
Bei Google dauert ja auch nur das Laden des Logos sehr lange. Die html Seite selbst wird schnell geladen. Wenn ich hingegen das Logo laden will:
Code:
gandalf# time fetch http://www.google.de/intl/de_de/images/logo.gif
logo.gif                                       67% of 9121  B   25  Bps 01m57s^C
fetch: transfer interrupted
0.000u 0.006s 4:02.38 0.0%      0+0k 0+4io 0pf+0w
braucht das ewig. Gleichzeitig wird der firefox extrem träge :confused:


Mit freundlichen Grüßen
Michael Krauß
 

thyrver

till evighet
#18
Hab gerade herausgefunden, dass host angeblich sowieso nicht den freebsd resolver nutzt, so wie auch angeblich dig und nslookup nicht. Wenn ein ping auf gandalf oder gandalf.gondor.lan deine IP (die für die NIC) findet, funktioniert deine laninterne Namensauflösung. Extern scheint sie auch zu funktionieren (ping auf google, heise und freshports funktionieren, bzw. host/dig/nsloockup auf diese Server?) Wenn das alles funktioniert würde ich das Problem nicht bei der Namensauflösung sehen.
 
#19
1.) Damit die Namensauflösung in einem hinter einem Router steckenden Heimnetz funktioniert, musst Du einen lokalen DNS-Server einsetzen. Die Anleitung dazu kennst Du ja schon bereits..

2.) Solange IPv6 nicht in /etc/rc.conf explizit eingeschaltet wird, läuft kein IPv6. Sprich ein Kernel neukompilieren ist nicht notwendig!

3.) Sobald ein Nameserver ansprechbar ist, sind die Einträge in der /etc/hosts praktisch nutzlos.

4.) DNS-Namensauflösung testet man mit nslookup und nicht mit host.
Syntax: # nslookup <Aufzulösender FQDN> <IP-Adresse des Nameserver>

5.) Wenn Du in FreeBSD einen Nameserver ausserhalb des Heimnetzes verwenden möchtest, musst Du sicherstellen, dass Dein Router auch die UDP-Pakete für die Namensauflösung durchlässt. Ein:
# nslookup www.bsdforen.de 83.217.93.246
sagt Dir schnell, ob UDP-Pakete für die Namensauflösung vom Router durchgelassen werden.
 

hippodriver

Well-Known Member
Themenstarter #21
Ich versuche mich mal an einer Sammelantwort.
Erst die Dinge, die schnell zu handhaben sind.

Ein Verkleinern der MTU auf 1412 bringt keinen Erfolg.

pings auf alle Geräte im Heimnetz funktioniert:
Code:
gandalf# ping gandalf
PING gandalf.gondor.lan (192.168.0.5): 56 data bytes
64 bytes from 192.168.0.5: icmp_seq=0 ttl=64 time=0.038 ms
^C
--- gandalf.gondor.lan ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.038/0.038/0.038/0.000 ms
gandalf# ping routi
PING routi (192.168.0.1): 56 data bytes
64 bytes from 192.168.0.1: icmp_seq=0 ttl=255 time=0.961 ms
^C
--- routi ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.961/0.961/0.961/0.000 ms
gandalf# ping frodo
PING frodo (192.168.0.3): 56 data bytes
64 bytes from 192.168.0.3: icmp_seq=0 ttl=64 time=0.208 ms
^C
--- frodo ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.208/0.208/0.208/0.000 ms
gandalf# ping drucker
PING drucker (192.168.0.6): 56 data bytes
64 bytes from 192.168.0.6: icmp_seq=0 ttl=60 time=1.436 ms
^C
--- drucker ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.436/1.436/1.436/0.000 ms

2.) Solange IPv6 nicht in /etc/rc.conf explizit eingeschaltet wird, läuft kein IPv6. Sprich ein Kernel neukompilieren ist nicht notwendig!
Gut zu wissen. Beim nächsten Kernel aktiviere ich's dann wieder.

4.) DNS-Namensauflösung testet man mit nslookup und nicht mit host.
Syntax: # nslookup <Aufzulösender FQDN> <IP-Adresse des Nameserver>

5.) Wenn Du in FreeBSD einen Nameserver ausserhalb des Heimnetzes verwenden möchtest, musst Du sicherstellen, dass Dein Router auch die UDP-Pakete für die Namensauflösung durchlässt. Ein:
# nslookup www.bsdforen.de 83.217.93.246
sagt Dir schnell, ob UDP-Pakete für die Namensauflösung vom Router durchgelassen werden.
Wenn ich die Ausgabe richtig deute, funktioniert hier alles:
Code:
gandalf# nslookup www.bsdforen.de 83.217.93.246
Server:         83.217.93.246
Address:        83.217.93.246#53

Non-authoritative answer:
Name:   www.bsdforen.de
Address: 212.204.60.79

gandalf# nslookup www.bsdforen.de 82.141.0.101
Server:         82.141.0.101
Address:        82.141.0.101#53

Non-authoritative answer:
Name:   www.bsdforen.de
Address: 212.204.60.79

gandalf# nslookup www.freshports.org 82.141.0.101
Server:         82.141.0.101
Address:        82.141.0.101#53

Non-authoritative answer:
Name:   www.freshports.org
Address: 64.147.113.42

gandalf# nslookup www.google.de 82.141.0.101
Server:         82.141.0.101
Address:        82.141.0.101#53

Non-authoritative answer:
www.google.de   canonical name = www.google.com.
www.google.com  canonical name = www.l.google.com.
Name:   www.l.google.com
Address: 209.85.129.147
Name:   www.l.google.com
Address: 209.85.129.99
Name:   www.l.google.com
Address: 209.85.129.104
1.) Damit die Namensauflösung in einem hinter einem Router steckenden Heimnetz funktioniert, musst Du einen lokalen DNS-Server einsetzen. Die Anleitung dazu kennst Du ja schon bereits..

3.) Sobald ein Nameserver ansprechbar ist, sind die Einträge in der /etc/hosts praktisch nutzlos.
Das finde ich jetzt erstaunlich. Ich dachte, wenn ich "hosts: files dns" in /etc/nsswitch.conf eintrage, wird zur Namensauflösung erst die /etc/hosts Datei verwendet und nur bei einem Fehlschlag der nameserver aus /etc/resolv.conf befragt.

Wie dem auch sei -- das Aufsetzen eines lokalen DNS-Servers ist die letzte Option, die mir noch bleibt. Das mußte ich bisher weder unter NetBSD noch unter Linux machen. Naja, alle Systeme sind anders...


Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #22
Nachdem ich mir die man pages von hosts und nsswitch.conf nochmal durchgelesen habe, verstehe ich nicht, wozu ich einen lokalen nameserver brauche?

In hosts(5) steht:
The hosts file contains information regarding the known hosts on the net-
work. It can be used in conjunction with DNS, and the NIS maps
`hosts.byaddr' and `hosts.byname', as controlled by nsswitch.conf(5).

Und in nsswitch.conf(5) finde ich:
The configuration file controls how a process looks up various databases
containing information regarding hosts, users (passwords), groups, etc.
Each database comes from a source (such as local files, DNS, and NIS),
and the order to look up the sources is specified in nsswitch.conf.
...
To lookup hosts in /etc/hosts and then from the DNS, and lookup user
information from NIS then files, use:

hosts: files dns
passwd: nis [notfound=return] files
group: nis [notfound=return] files


Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #23
Jetzt wird's richtig lustig.
Eine Installation von FreeBSD 6.2 auf meinem Notebook funktioniert einwandfrei. :confused:
Das Gerät hängt an dem selben DSL-Router, wie der andere Rechner.
Die config files sind auch nicht wesendlich anders:

rc.conf:
Code:
ifconfig_fxp0="inet 192.168.0.3  netmask 255.255.255.0"
defaultrouter="192.168.0.1"
hostname="frodo.gondor"
Code:
frodo# cat /etc/hosts
::1                     localhost.gondor localhost
127.0.0.1               localhost.gondor localhost
192.168.0.3             frodo.gondor frodo
192.168.0.3             frodo.gondor.

frodo# cat /etc/resolv.conf 
domain  gondor
nameserver      195.62.97.177

frodo# cat /etc/nsswitch.conf 
group: compat
group_compat: nis
hosts: files dns
networks: files
passwd: compat
passwd_compat: nis
shells: files

frodo# ifconfig fxp0
fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=8<VLAN_MTU>
        inet 192.168.0.3 netmask 0xffffff00 broadcast 192.168.0.255
        ether 00:06:1b:cb:94:65
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active

frodo# netstat -Wr
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use    Mtu    Netif Expire
default            192.168.0.1        UGS         0      632   1500     fxp0
localhost          localhost          UH          0        0  16384      lo0
192.168.0          link#1             UC          0        0   1500     fxp0
192.168.0.1        00:01:e3:42:d5:47  UHLW        2        0   1500     fxp0   1088

Internet6:
Destination        Gateway            Flags    Refs      Use    Mtu    Netif Expire
localhost.gondor   localhost.gondor   UHL         0        0  16384      lo0
fe80::%lo0         fe80::1%lo0        U           0        0  16384      lo0
fe80::1%lo0        link#3             UHL         0        0  16384      lo0
ff01:3::           fe80::1%lo0        UC          0        0  16384      lo0
ff02::%lo0         fe80::1%lo0        UC          0        0  16384      lo0
Morgen baue ich eine andere Netzwerkkarte ein. Es kann ja nur irgendwie an Hardware oder Treibern liegen.
Und wie Mr. Spock schon sagte: "Man muß das Unmögliche ausschließen, dann ist das, was übrig bleibt, egal wie unwahrscheinlich es ist, die Wahrheit."


Mit freundlichen Grüßen
Michael Krauß
 

hippodriver

Well-Known Member
Themenstarter #24
[solved] Web-Browser langsam / resolve-Problem?

Juhu, ungeahnte Geschwindigkeiten, weit entfernte Web-Server,...

Es lag nicht an der Konfiguration. Mit der 3Com Karte, die ich jetzt eingebaut habe, funktioniert alles wunderbar :)

Es gibt also ein Hardware- oder Treiberproblem mit dem Realtek Chip.

Für das Protokoll:
Es handelt sich um einen onboard chip von Realtek (RTL8111B) auf einem Gigabyte GA-945GM-S2 Mainboard.
Code:
gandalf# pciconf -lv | less
[...]
re0@pci2:0:0:   class=0x020000 card=0xe0001458 chip=0x816810ec rev=0x01 hdr=0x00
    vendor   = 'Realtek Semiconductor'
    class    = network
    subclass = ethernet
[...]
Dieser chip funktioniert nicht zuverlässig mit dem re(4) Treiber von FreeBSD 6.2 Release.

Vielen Dank an alle, die mich auf der Reise durch die unendlichen Weiten des DNS geführt haben.


Mit freunlichen Grüßen
Michael Krauß