• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Welche Temperaturanzeige ist korrekt?

cabriofahrer

Well-Known Member
Themenstarter #1
Habe da eine Verständnisfrage. Wenn ich die Temperatur meines Prozessors wissen will, kann ich im Falle eines Intel-Prozessors ein "kldload coretemp" und im Falle eines AMD-Prozwessors ein "kldload amdtemp" machen und dann ein "sysctl -a | grep temperature".

Hier meine Ausgabe:

Code:
$ sysctl -a | grep temperature
hw.acpi.thermal.tz0.temperature: 40.1C
dev.cpu.1.temperature: 52.0C
dev.cpu.0.temperature: 57.0C
$
Und welche Anzeige ist nun korrekt? Und was ist "hw.acpi.thermal.tz0.temperature"? Etwas anderes als die jeweiligen Temperaturen der Prozessorkerne?
Und gibt es vielleicht einen Port, der das Ganze permanent, aktualisiert und hübsch grafisch anzeigt?
 

cabriofahrer

Well-Known Member
Themenstarter #4
hw.acpi.thermal.tz0.temperature -> Fühler irgendwo auf dem Mainboard (dennoch meist in Sockelnähe)
Aha, vielen Dank! Wie kann man den herausfinden, wo genau sich diese Fühler befinden, insbesondere bei einem Notebook? Könnte es auch eher in Chipsatznähe sein? Ich habe hier die Werte von meinem PC gepostet, dort erscheint nur ein Wert für "hw.acpi.thermal.tz0.temperature", aber auf meinem Notebook erscheinen dort zwei Werte und die liegen ca. 10°C höher als die der CPU-Kerne. Könnte damit vielleicht das Überhitzungsproblem nach dem Einbau einer SSD zusammenhängen? Mehr Wärme des Chipsatzes durch höheren oder schnelleren Datendurchsatz?

Kann ich hiermit die Dauer und Intensität der Fanspeed manipulieren, wenn es im BIOS dazu keine Möglichkeit gibt? Z.B. wenn ich eine konstante höhere Fanspeed haben will?
 

mr44er

moderater Moderator
Mitarbeiter
#5
Wie kann man den herausfinden, wo genau sich diese Fühler befinden, insbesondere bei einem Notebook?
Wenn du eine Layoutgrafik dieses Boards hast und dazu noch Glück, dann ist es eingezeichnet/dokumentiert. Ansonsten musst du dich auf dein Wärmeempfinden/Bauchgefühl verlassen, wo dieser Fühler stecken könnte. Externe Meßfühler für Kühltruhen helfen da. Oft dort wo Kühlrippen sind, bzw. was heiß werden könnte und ja, es ist seltsam, wenn die höher als die der Kerne ist. Dann ist das ein Indikator für fehlenden Luftdurchlass.
 

pit234a

Well-Known Member
#6
Könnte damit vielleicht das Überhitzungsproblem nach dem Einbau einer SSD zusammenhängen? Mehr Wärme des Chipsatzes durch höheren oder schnelleren Datendurchsatz?
Das kann ich mir gar nicht vorstellen.
Durch eine SSD werden ja nicht mehr Datentransfers erzeugt, sie erfolgen nur schneller.
In meinen Systemen werden die meisten Daten von den SSDs beim Booten geholt und dann, wenn ich irgendwelche Programme starte. Das ist aber eher selten und nur recht kurz.
Dateien kopieren oder verschieben, macht man doch auch nur relativ selten und nicht sehr lang.
Die dauernden Zugriffe durch Dateisystem-Mechanismen, besonders bei ZFS (wo ich noch nicht gelernt habe, die ab zu schalten), sind auch nur kurze und kleine Bursts.
Keines meiner Systeme ist durch Umrüsten auf SSD wärmer geworden. Auch nicht mein geiler Laptop, in dem ich zwei SSDs in einem ZFS-Mirror laufen habe. Eher im Gegenteil. SSDs verringerten die System-Temperatur in meinen Rechnern.
 

cabriofahrer

Well-Known Member
Themenstarter #7
Das kann ich mir gar nicht vorstellen.
Es ist aber tatsächlich so: Ich habe, um es zu testen, die alte Platte wieder reingemacht. Das Laptop lief viel länger, bis es zur Überhitzung kam. Ich kann nur spekulieren, dass das vielleicht damit zusammenhängt, dass die SSD rein aus Plastik ist und kein Blechgehäuse hat wie die alte Festplatte und zudem noch ein freier Luftraum von ungefähr einem halben Zentimeter zwischen der SSD und einem dünnen Blech am Plastikgehäuse entsteht. Wenn es eine ein paar Millimeter dicke Metallplatte mit der Fläche einer 2.5" Festplatte gäbe, könnte das für zusätzliche Kühlung sorgen.

Das Problem wäre aber mit Sicherheit gelöst, wenn ich es irgendwie anstellen könnte, dass der Ventilator unabhängig von irgendwelchem Automatismus oder Powermanagement einfach konstant in einer bestimmten Geschwindigkeit laufen würde.
Denn auffällig ist, dass der Ventilator beim Einschalten sofort auf vollen Touren läuft, aber nur für ein paar Sekunden und dann geht er aus oder dreht extrem langsam. Manchmal ist später wieder erhöhte Ventilatoraktivität zu hören, aber nie so intensiv wie beim Einschalten.
Das BIOS hat keinerlei Einstellmöglichkeit oder auch nur Monitor für den Ventilator.

Ich frage also nochmal: Kann ich es mit den Bordmitteln von FreeBSD hinbekommen, dass der Ventilator einfach nur ständig zu einer konstanten Geschwindigkeit läuft?
 

mr44er

moderater Moderator
Mitarbeiter
#8
Kann ich es mit den Bordmitteln von FreeBSD hinbekommen, dass der Ventilator einfach nur ständig zu einer konstanten Geschwindigkeit läuft?
Soweit ich weiß, nein. Es sind zwei ältere tools in den Ports, die unterstützen aber nur eine halbe Hand voll ebenso alter Chipsätze und da ging es auch nur um fanspeed auslesen.

dass der Ventilator beim Einschalten sofort auf vollen Touren läuft, aber nur für ein paar Sekunden und dann geht er aus oder dreht extrem langsam.
Das ist Teil der selfcheck des boards. 'Teste, ob Lüfter ok, danach wird geregelt, soviel pusten wie nötig'. Wenn das im BIOS nichtmal verfügbar ist, dann kannst du eher nichts tun oder Holzhammer -> Lüfter extern mit Strom versorgen und dann nach Bedarf regeln oder eben Vollgas laufen lassen.

Ich könnte mir das auch anders erklären: der Chipsatz hat bei eingebauter HDD mehr Zeit abzukühlen, weil von der HDD nicht so schnell Daten reinkommen. Mit SSD ist der Datenfluss höher, Chip erhitzt zu schnell.
 
Zuletzt bearbeitet:

cabriofahrer

Well-Known Member
Themenstarter #9
Ich könnte mir das auch anders erklären: der Chipsatz hat bei eingebauter HDD mehr Zeit abzukühlen, weil von der HDD nicht so schnell Daten reinkommen. Mit SSD ist der Datenfluss höher, Chip erhitzt zu schnell.
Das war ja auch eine meiner ursprünglichen Vermutzungen. Vielleicht könnte man einen Kühlkörper auf dem Chipsatz anbringen, wenn man denn weiß, welcher das beim Notebook ist. Das Anbringen mit Wärmeleitpaste wird wohl nicht zum Kleben reichen, wohl eher ein Wärmeleitpad?
 

pit234a

Well-Known Member
#11
Ich kann nur spekulieren, dass das vielleicht damit zusammenhängt, dass die SSD rein aus Plastik ist und kein Blechgehäuse hat wie die alte Festplatte
Also, wenn die zusätzliche Temperatur von der SSD direkt käme, müsste die ja auch wärmer werden, als die HD. Das wiederum kann man mit smartctl auslesen:
Code:
pit@Celsius ~:- > smartctl -a /dev/ada0 | grep -i temper
194 Temperature_Celsius     0x0022   071   050   000    Old_age   Always       -       29 (Min/Max 0/50)
pit@Celsius ~:- > smartctl -a /dev/ada1 | grep -i temper
194 Temperature_Celsius     0x0022   069   050   000    Old_age   Always       -       31 (Min/Max 0/50)
pit@Celsius ~:- > smartctl -a /dev/ada2 | grep -i temper
194 Temperature_Celsius     0x0022   071   049   000    Old_age   Always       -       29 (Min/Max 0/51)
pit@Celsius ~:- > smartctl -a /dev/ada3 | grep -i temper
194 Temperature_Celsius     0x0022   080   060   000    Old_age   Always       -       20 (Min/Max 18/40)
Die ersten drei sind in diesem Rechner mein ZFS-Mirror mit den Systemplatten und sie liegen übereinander und auf Schaumstoff gebettet. Das dürfte sie eher noch wärmer machen, als wenn sie wirklich in einem Rahmen eingebaut wären und von Luft um-strömt werden könnten. Die letzte ist einfach eine zusätzliche SSD, für mehr Platz und interne Backups und sie liegt ganz oben, ist also nicht auf zwei Seiten von Schaumstoff umschlossen.
Es ist in meinem Zimmer hier nicht eiskalt, aber auch nicht geheizt. Vielleicht zum Vergleich, obwohl das verwirrend sein mag, die Werte aus meinem File-Server, der aber im Augenblick nicht gefordert ist. Da lese ich das gelegentlich mit einem Script aus und kopiere die Ausgaben mal her (wobei die Temperaturwerte bei mir bunt dargestellt werden und zwar derzeit alle in grün, was aber schon mal zu gelb wird). Diese HDs sind zwar auch nicht sauber in einem Rahmen aufgehängt, sie liegen auf isoliertem Material in etwas mehr als 1cm Abstand zueinander und werden aber von Luft um-strömt und enthalten keine Systemdaten.
Ich glaube, man kann die Ausgaben nicht wirklich vergleichen, aber sagen wir mal als Fazit, dass bei mir wohl eher HDs in Grundlast wärmer werden.
Code:
/dev/ad14

WDC WD40EFRX-68N32N0
4,000,787,030,016 bytes [4,00 TB]
ATA Version is: 8
Airflow_Temperature:
Temperature_Celsius:        28
Power_On_Hours:             5101

/dev/ad12

WDC WD40EFRX-68N32N0
4,000,787,030,016 bytes [4,00 TB]
ATA Version is: 8
Airflow_Temperature:
Temperature_Celsius:        29
Power_On_Hours:             5101

/dev/ad10

WDC WD40EFRX-68N32N0
4,000,787,030,016 bytes [4,00 TB]
ATA Version is: 8
Airflow_Temperature:
Temperature_Celsius:        29
Power_On_Hours:             5101

/dev/ad8

WDC WD40EFRX-68N32N0
4,000,787,030,016 bytes [4,00 TB]
ATA Version is: 8
Airflow_Temperature:
Temperature_Celsius:        29
Power_On_Hours:             5101

/dev/ad6

WDC WD40EFRX-68N32N0
4,000,787,030,016 bytes [4,00 TB]
ATA Version is: 8
Airflow_Temperature:
Temperature_Celsius:        28
Power_On_Hours:             5181

/dev/ad4

WDC WD40EFRX-68N32N0
4,000,787,030,016 bytes [4,00 TB]
ATA Version is: 8
Airflow_Temperature:
Temperature_Celsius:        30
Power_On_Hours:             5101