WLAN Bridge automatisch starten

ringo

Well-Known Member
Hallo!

Könnte mir vielleicht jemand sagen wie man - wie im Titel beschrieben - eine WLAN-Bridge automatisch startet(beim Booten oder über ne exec-file). Ich meine ohne jedesmal die Befehle über die Konsole eingeben zu müssen:

# kldload bridge
# sysctl net.link.ether.bridge.enable=1
# sysctl net.link.ether.bridge.config="wi0,rl0"
# sysctl net.inet.ip.forwarding=1
...

ringo(newbee :) )

PS: Thx für jede Hilfe
 

ringo

Well-Known Member
Hab mir jetzt ne kleine skript-file geschrieben - startwlan - mit der ich die einzelnen befehle ausführe. Es bleibt, wie kann ich diese Datei jetzt beim Booten starten?
 

asg

push it, don´t hype
Wie wäre es den Kram dahinzuschreiben wo er hingehört in die /etc/sysctl.conf:
Code:
net.link.ether.bridge.enable=1
net.link.ether.bridge.config="wi0 rl0"
net.inet.ip.forwarding=1
 

asg

push it, don´t hype
@Ice
Ja wahnsinn, dann kann ich hexen. Oder mir wird auf meinem Laptop seit einem Jahr nur eine Verbindung vorgegaukelt und ich habe eigentlich keinen Zugriff aufs Netz....
 

Ice

Well-Known Member
@asg
Kann schon sein, dass Du hexen kannst, wenn Du auf Deinem Laptop einen AP im Bridge Mode eingerichtet hast!!!!!!!!! ;)
Wie oft rebootest Du denn Deinen AP? Und danach funzt alles einwandfrei???
Aber wenn Du hexen kannst, dann kannst Du mir doch sicher auch sagen, was ich in dem genannten thread falsch gemacht habe? ;)
 

asg

push it, don´t hype
Ice schrieb:
@asg
Kann schon sein, dass Du hexen kannst, wenn Du auf Deinem Laptop einen AP im Bridge Mode eingerichtet hast!!!!!!!!! ;)

Unter uns Pastorentöchtern, ich kann natürlich nicht hexen, und mein Laptop ist auch kein AP, er greift nur auf diesen zu.

Wie oft rebootest Du denn Deinen AP? Und danach funzt alles einwandfrei???

uptime
1:04pm up 26 days,...

Und ja, es geht danach wieder alles einwandfrei.

Neben den angegeben sysctl Variablen habe ich in meiner kernel conf:
Code:
# AP fyr wireless LAN
options BRIDGE
# wireless LAN
device  ath
device  ath_hal
device  wlan

In der /etc/rc.conf:
Code:
# WLAN
ifconfig_ath0="inet 192.168.1.254 netmask 255.255.255.0 ssid encephalon channel 6 mode 11g mediaopt hostap up"

Das war es dann auch an Konfiguration. Und ja, es geht bei mir.

Ich sehe eben das ihr "wi" nutzt und nicht "ath". Kann sein das es damit nicht so geht. Genaueres weiss ich nicht, da kein "wi". Mailingliste fragen.
Habe eben ein Script gefunden:
Code:
#!/bin/sh
ifconfig wi0 inet up ssid my_wifi media DS/11Mbps mediaopt hostap

wicontrol -e 1

wicontrol -k 0xXXXXXXXXXXXXXXXXXXXXXXXXXX -v 1
wicontrol -k 0xXXXXXXXXXXXXXXXXXXXXXXXXXX -v 2
wicontrol -k 0xXXXXXXXXXXXXXXXXXXXXXXXXXX -v 3
wicontrol -k 0xXXXXXXXXXXXXXXXXXXXXXXXXXX -v 4

wicontrol -T 1

wicontrol -f 6

wicontrol -s "FreeBSD_AP"

sysctl net.link.ether.bridge=1
sysctl net.link.ether.bridge_cfg="wi0 rl0"
sysctl net.inet.ip.forwarding=1

Anscheinend geht das nicht anders. Entweder liegts wirklich an wi, oder in 5.3 hat sich was geändert was ich nun nicht nachvollziehen kann da mein AP unter 5.2.1 rennt.
 

Ice

Well-Known Member
@asg

War mir schon klar, dass Du den Laptop nicht als AP nutzt. ;)
Soweit ich mich recht erinnere hast Du die MA311 von Netgear im Einsatz, oder?
Ich habe die WAG311 und nutze folglich ebenfalls den ath.
Wenn ich meine Konfiguration (siehe http://www.bsdforen.de/showthread.p...&highlight=wlan ) mit Deiner vergleiche, dann sehe ich absolut keinen Unterschied und im Einsatz hatte ich damals auch FBSD 5.2.1 !
Hmmm, das ist schon sehr rätselhaft......
Aber um zum usprünglichen Thema zurückzukehren:
Da es offensichtlich funktioniert, sollten die sysctl-Anweisungen auf jeden in die Datei /etc/sysctl.cionf eingetragen werden! ;)

Gruß,

Ice
 

asg

push it, don´t hype
Naja, es läuft bei mir, evtl. sollte ringo es mal versuchen. Wenn nicht auf ein Script zurückgreifen, aber auch mal die mailingliste anschreiben oder Scott (der ist doch für ath da, oder?).
 
Oben