• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Wlaninterface wi0 von inet6 auf inet stellen?

Themenstarter #1
Hallo,

ich moechte das wi0 Interface von ipv6 (inet6) auf ipv4 (inet) umsetellen.

Nur habe ich auch nach laengerem googlen nichts gefunden, wie ich das nun genau mache....

Bin fuer jede Hilfe dankbar .....
 
#2
Hugh,

ifconfig wi0 inet xxx.xxx.xxx.xxx netmask yyy.yyy.yyy.yyy up

wobei xxx durch IPs deiner private Range und yyy deines Subnetzes zu ersetzen sind.

--->man ifconfig


So long
 
#4
also du koenntest in der rc.conf ipv6_enable="NO" stellen, dann solltest du es los sein, aber ob das die Loesung ist die du moechtest weiss ich allerding nicht.
Was steht den in der /etc/hostname.wi0 drin?
 
Themenstarter #5
alles probiert, nichts geht ...

in rc.conf steht ziemlich oft

#sysinstall generated deltas
ifconfig_wi0 inet ......

außerdem habe ich inet6_enable"NO" gesetzt.

in der hosts steht sie auch drin ?!

Was kann ich denn noch machen?
 
#6
Original geschrieben von genin
alles probiert, nichts geht ...

in rc.conf steht ziemlich oft

#sysinstall generated deltas
ifconfig_wi0 inet ......

außerdem habe ich inet6_enable"NO" gesetzt.

in der hosts steht sie auch drin ?!

Was kann ich denn noch machen?
Poste doch mal bitte den gesamten Output von ifconfig.

Gruß
 
Themenstarter #7
Hier die Ausgabe von ifconfig

rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet 192.168.5.17 netmask 0xffffff00 broadcast 192.168.5.255
inet6 fe80::202:3fff:feb2:3c8e%rl0 prefixlen 64 scopeid 0x1
ether 00:02:3f:b2:3c:8e
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
inet 127.0.0.1 netmask 0xff000000
wi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::202:2dff:fe8a:301d%wi0 prefixlen 64 scopeid 0x4
ether 00:02:2d:8a:30:1d
media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
status: no carrier
ssid "" 1:""
stationname "FreeBSD WaveLAN/IEEE node"
channel 10 authmode OPEN powersavemode OFF powersavesleep 100
wepmode OFF weptxkey 1
 
#8
Original geschrieben von genin
Hier die Ausgabe von ifconfig

rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet 192.168.5.17 netmask 0xffffff00 broadcast 192.168.5.255
inet6 fe80::202:3fff:feb2:3c8e%rl0 prefixlen 64 scopeid 0x1
ether 00:02:3f:b2:3c:8e
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
inet 127.0.0.1 netmask 0xff000000
wi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::202:2dff:fe8a:301d%wi0 prefixlen 64 scopeid 0x4
ether 00:02:2d:8a:30:1d
media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
status: no carrier
ssid "" 1:""
stationname "FreeBSD WaveLAN/IEEE node"
channel 10 authmode OPEN powersavemode OFF powersavesleep 100
wepmode OFF weptxkey 1
So wie ich das sehe, hast du eigentlich garkein Problem.
inet6 fe80::202:2dff:fe8a:301d%wi0 prefixlen 64 scopeid 0x4 Dieser Eintrag (oder ähnliches) ist vollkommen normal, wenn du IPv6 im Kernel hast - eventuell einfach mal rausnehmen.
Ansonsten kenn ich mich mit WLAN nicht aus, aber prinzipiell müsste es ausreichend sein, wenn du per ifconfig wi0 inet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx eine IPv4 an das Interface bindest.

Gruß