• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

WOL will nicht

Chiron

Active Member
Themenstarter #1
Hallo,

Ich hab hier eine FreeBSD-Kiste, mit 2 NICs:

alc0@pci0:2:0:0: class=0x020000 card=0xe0001458 chip=0x10911969 rev=0x10 hdr=0x00
vendor = 'Qualcomm Atheros'
device = 'AR8161 Gigabit Ethernet'
class = network
subclass = ethernet
rl0@pci0:3:6:0: class=0x020000 card=0x813910ec chip=0x813910ec rev=0x10 hdr=0x00
vendor = 'Realtek Semiconductor Co., Ltd.'
device = 'RTL-8100/8101L/8139 PCI Fast Ethernet Adapter'
class = network
subclass = ethernet

Beide haben WOL-unterstuetzung:

alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c319a<TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether 74:d4:35:7c:34:f2
hwaddr 74:d4:35:7c:34:f2
inet 192.168.1.5 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
rl0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=2008<VLAN_MTU,WOL_MAGIC>
ether 00:11:6b:93:94:1a
hwaddr 00:11:6b:93:94:1a
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect
status: active

Ich hab mal zum testen eine Platte mit WIndows 7 reingehangen, da funktioniert nachdem herunterfahren WOL.
Vorher lief 11.2, nachdem Upgrade auf 11.2 hat WOL auch genau einmal geklappt. Danach nicht mehr. Unter Win7 klappt es problemlos.
Also liegt es wohl daran, wie FreeBSD den Rechner runterfaehrt. Probiert habe poweroff und shutdown -p now.

Hat da jemand eine Idee?
 

Andy_m4

Well-Known Member
#3
Wurde dem Interface eine statische Adresse vergeben, die in /etc/rc.conf definiert wurde und existiert eine default Route?
Eine Frage für mich zum Verständnis:
Eingetragene Routen oder IP-Adressen auf zu zu weckenden Rechner müssten doch eigentlich egal sein, da dem ja ein Wake-on-LAN-Paket an die Hardwareadresse (MAC-Adresse) geschickt wird?!
 

das.chaos

Duracellhase 2.0
#8
Ich habe es per shutdown -p now runtergefahren.
Das OS wurde dadurch auf das Runlevel 0 versetzt, d. h. dasz das OS keine Dienste erbringen kann, da es angehalten bzw. runtergefahren und _nicht_ in den Suspend-mode versetzt wurde. Deswegen funktioniert Suspend und Resume nicht.

Suspend und Resume ist nur moeglich, wenn diese Funktionalitaet von einem Device unterstuetzt wird bzw. vom Geraetetreiber als Methoden implementiert wurden und das OS entweder im Single- oder Multi-user Mode [Runlevel 1 oder 6] operiert.
 
Zuletzt bearbeitet:

Tronar

aus Überzeugung altmodisch
#9
Das stimmt so nicht. WOL ist eine Hardware-Sache, das OS muß keine Dienste erbringen. Nur die Netzwerkkarte muß halt unter Strom stehen, d. h. bei ganz ausgeschaltetem Rechner muß die Hardware entsprechend gebaut sein. Normale PC-Hardware kann das meistens nicht, da geht WOL nur für ein Resume nach Suspend. Mehr professionelle Rechner können das aber.
Übrigens müssen WOL-Pakete nicht ausschließlich Ethernet-Pakete sein, auch IP-Pakete sind möglich. Wenn Dein DSL-Router den Port geeignet forwardet, kann man den Computer auch von Wladiwostok aus aufwecken.
 

Tronar

aus Überzeugung altmodisch
#11
Noch zwei Ideen:

Ich erinnere mich dunkel, daß es Treiber gibt, die verlangen, daß man mittels Sysctl das WOL erst scharf stellt, bevor man den Rechner herunterfährt. Such mal danach: sysctl -a | grep -i wake

Hat Dein Netzwerkgerät vielleicht eine geforgete MAC-Adresse? WOL spricht nur an, wenn das Paket an die hardwaremäßig eincodierte MAC-Adresse geschickt wird. Also: War die MAC-Adresse, an die Du den Weckruf unter Windows geschickt hast, dieselbe, die nun unter FreeBSD angezeigt wird?
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#12
Interessant wäre auch noch die Frage, ob nach dem Herunterfahren des FreeBSDs die NIC und der Port am Switch weiterhin einen Link anzeigen. Also ob die LEDs leuchten. Wenn nicht, ist da schon das erste Problem.
 

kira12

Well-Known Member
#13
Hallo,

vor 20 Jahren wo WOL noch mit separatem Spannungsversorgungskabel vom Mainboard gearbeitet wurde musst ich unter Linux die NIC für WOL vorbereiten vor dem Shutdown, nur so überlebte die NIC den Shutdown als WOL-fähig...

Gruß ré