XFCE + Abfrage gnome-keyring nach Anmelung abschalten

kraekers

Well-Known Member
Moin liebes Forum,

ich habe einmal folgende Frage. Wie kann man die lästige Passwortabfrage für den gnome-keyring abschalten ohne an Sicherheit einzubüßen?

Ich benutze unter XFCE Evolution und muss gnome-keyring installiert haben, damit Evolution überhaupt startet. Aber nun habe ich das Problem, dass jedes Mal
nach der Anmeldung unter XFCE die Passwortabfrage erscheint.

Ich bedanke mich im Voraus und wünsche Euch noch weiterhin schöne Weihnachten.

Liebe Grüße
kraekers
 

mr44er

moderater Moderator
Teammitglied
Unter Mate nimmt man den Dienst aus dem autostart raus, dann kann man ihn einfach installiert lassen. Ich kenne XFCE nicht so gut, dass ich dir sagen kann, wo man das Pendant dazu findet.
Schnellschuss mit google gab mir das: XFCE4 Settings xfce4-settings-manager → Tab "Application Autostart"
 

Anhänge

  • keyring.png
    keyring.png
    77 KB · Aufrufe: 30

Photor

Well-Known Member
Im gleichen Einstellungsdialog vielleicht auch mal unter "Erweitert" schauen. Dort kann man die Dienste für Gnome und KDE beim Starten laden lassen.

Mal mit den Einstellungen spielen: ich nutze selbst Evolution unter XFCE und muss NICHT bei jedem Start die Passworte neu eingeben (ich starte die Gnome-Dienste beim laden mit - Haken da gesetzt).

Ciao,
Photor
 

kraekers

Well-Known Member
Moinsen,

ich habe es im XFCE-Einstellungsdialog mit "Dienste für GNOME beim Starten laden" mit ein und aus probiert, kein Erfolg. Mein Haken ist dort eigentlich immer standardmäßig gesetzt. In den Starteinstellungen habe ich es mit Start und ohne Start des Schlüsselagenten probiert, ebenfalls kein Erfolg. Ich forsche weiter und bedanke mich für Eure Mühen.

LG
kraekers
 

Photor

Well-Known Member
War eine Idee. Nutze XFCE hier aber unter ArchLinux (die FreeBSD-Installation ist sehr alt und ist ohne Evolution - also schlecht zu testen).

Ciao,
Photor
 

obsigna

Active Member
Im April 2022 hatte ich einen Bug-Report eingereicht, in dem es um fehlende PAM-Einstellungen unter /usr/local/etc/pam.d/gdm-password ging. Ich benutze gdm zur Anmeldung und die fehlenden Einstellungen hatten zur Folge, daß der Schlüsselbund bei der Anmeldung gesperrt blieb, und man zum Entsperren das Passwort später ein zweites Mal eintippen mußte.

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=263309

Ich gehe einmal davon aus, daß XFCE nicht gdm zur Anmeldung nutzt (ich kenne mich mit XFCE nicht aus), aber das Symptom ist sowas von eindeutig, und ganz bestimmt fehlt auch hier irgendwas in den PAM-Einstellungen. Gibt es vielleicht unter /usr/local/etc/pam.d/ irgend eine Konfigurationsdatei, die was mit XFCE zu tun hat?
 

kraekers

Well-Known Member
Moinsen,
dass PAM eine Rolle spielt hatte ich auch gelesen. Ich forsche einmal nach.

Lieben Dank und Grüße

kraekers
 
Oben