XFree - flackern || absturz

antic_eye

ITist
Hi Leutz,

ich hab mir FreeBSD 5.1 aufm Lappi geknallt und bin bis jetzt sehr zufrieden nur mein X läuft nicht wie es soll. Ich hab eine ProSavage DDR onBoard drinnen und wen ich in der XFCon... als driver savage einstelle flackert mein display. hab schon x modlines und alle möglichen einstellungen an Horiz. und vertik. Frequenz probiert aber nix geht :(

Ich hab dann einfach versucht den standard vesa treiber zu nehmen das geht wunderbar und nix flackert aber wenn ich von X aus in eine Konsole wikll oder den wm beende friert mein System ein .. der Bildschirm wird schwarz (geht nicht aus) und alles hängt ... es hilft nur ausschalten :(

Kann mir irgendwer helfen? Ich brauche entweder einen funktion. savage treiber oder den grund und die lösung für das Einfrieren beim beenden von X

Vielen Dank schonmal im vorraus ... :)

Achso: hab mir schon das XFree 4.3.0 oder so über die ports besorgt ... keine änderung ;'(
 

antic_eye

ITist
Hi danke für die schnelle reaktion ..
also in der /var/log/XFree86.0.log stehen weder WW noch EE drinn (ich poste also die 742 Zeilen mal nicht :) )

Wird noch irgendwo anders geloggt wenn X abschmiert?
 

antic_eye

ITist
hi,

ich denke ja, das es wohl nix mit der XFreeConfig zu tun hat, sondern mit dem Treiber. Das es unter dem Standard - VESA Treiber nich' rund läuft ist ja kein wunder aber warum der savage Treiber so ein schickes flackern auf den screen schmeißt wüßtze ich wirklich gern ... gibt's denn hier keinen Hacker, der mal fix nen kleinen Treiber zuammenhacken kann *gg* Ich verzweifle noch weil man wirklich nicht damit arbeiten kann :(

und noch ein Problem: gibt's unter BSD irgendsowas wie cpufreqd unter Linux ? Das scheiß gekühle nervt auch ganz schön ... der regelt den Prozzi nicht runter obwohl acpi eigentlich gut läuft ...
 

Ice

Well-Known Member
Versuch doch einfach mal ACPI auszuschalten. Das wurde hier ja bereits schon oft als Störenfried für X indentifiziert.

Gruß,

Ice
 
Oben