• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

ZFS:_zwei faulted devices, kann ich davon eine rausnehmen?

bsd4ever

Active Member
Themenstarter #1
Hallo, kurze Frage zu einem ZFS Pool.

expand4.eli wollte ich gegen expand4neu.eli tauschen, die neue scheint aber auch Probleme zu haben.
Wie gehe ich nun weiter vor, kann ich die expand4.eli einfach rausnehmen? Verschwindet dann das replacing-3 ?

zpool remove expand expand4.eli ?


Code:
  pool: expand
 state: DEGRADED
  scan: resilvered 14.8G in 5h56m with 0 errors on Fri Mar  1 23:59:55 2019
config:

        NAME                      STATE     READ WRITE CKSUM
        expand                    DEGRADED     0     0     0
          raidz2-0                DEGRADED     0     0     0
            gpt/expand1.eli       ONLINE       0     0     0
            gpt/expand2.eli       ONLINE       0     0     0
            gpt/expand3.eli       ONLINE       0     0     0
            replacing-3           UNAVAIL      0     0     0
              gpt/expand4.eli     FAULTED      0 1.34K     0  too many errors
              gpt/expand4neu.eli  FAULTED      0   203     0  too many errors

errors: No known data errors

Danke & Grüße
bsd4ever
 

peterle

Forenkasper
#2
Um das replacing kommst Du nicht rum. Ich würde es mal mit einer funktionstüchtigen Platte statt der *neu.eli probieren.
Manchmal kommen so Platten kurz wieder, wenn sie abgekühlt sind.
 

Crest

rm -rf /*
Mitarbeiter
#3
Wie groß sind die Platten in deinem Pool? Wie voll ist dein Pool? Da es nen RAID-Z2 ist hast du N - 2 Redundanz. Du kannst das Risiko eingehen expand4.eli aund expand4neu.eli zu entfernen und anschließend aus der Parity eine neue Platte zu resilvern.
 

bsd4ever

Active Member
Themenstarter #4
Hallo!

das sind 6TB WD RED Platten. ZFS list - used: 2.9T , available: 7.3T
Ich habe, wie man siehtr, schon mehrere Platten probiert, auch in unterschiedlichen Slots, es kommen dennoch Fehler. Ich habe ja die Vermutung, dass das auch an dem Gehäuse / Backplane (SC836) liegt. Ich werde dazu einen Thread aufmachen..
 

bsd4ever

Active Member
Themenstarter #6
bisher sind die error counter unverändert.
also kann ich eine der beiden removen?

zpool remove expand expand4.eli
 

pit234a

Well-Known Member
#7
bisher sind die error counter unverändert.
also kann ich eine der beiden removen?

zpool remove expand expand4.eli
Die beiden gpt/expand*eli sind ja offenbar hin. Das bedeutet, sie nützen dir nun auch nichts. Dein Pool hat derzeit Eine-Platte-Redundanz.
Du hast natürlich einen aktuellen und gültigen Backup zur Verfügung. Falls nicht, wäre das jetzt eine gute Chance dafür.
Das remove macht (nach meiner Erfahrung und Deutung der man-Page) nur Sinn, wenn die betroffene Platte noch vollständig ansprechbar ist. Also, bei einer funktionierenden Platte.
Das replace kann ebenfalls bei einer funktionierenden Platte ausgeführt und alte Platte gegen neue Platte getauscht werden.
Das replace kann aber auch ausgeführt werden, nachdem eine Platte gestorben ist und deshalb aus dem Pool entfernt wurde. Ich sag mal, dies dürfte sogar der Normalfall sein. Wir warten ja immer, bis Platten ausfallen und ersetzen sie dann.

Zieh beide defekte Platten ab, bau eine gute Platte ein und starte deinen Pool. Der wird nun einen Fehler melden, eine Platte fehlt, eine andere kennt er nicht (im Pool, den label kannst du vergeben, einfach expand4.eli, wie die alte, der Label wird erkannt). Dann erkläre dem Pool, was du möchtest, nämlich ein zpool replace gpt/expand4.eli und er wird eben das tun. Er nimmt die neue expand4.eli und ersetzt damit die alte. Du musst nicht einen neuen, anderen Label benutzen. Tust du das aber, dann musst das im replace angeben.

Vielleicht noch ein generelles Wort dazu. Also zu Labeln. Meine Meinung.
Label sind gut, ohne Frage und es wird immer empfohlen, sie zu benutzen, weil Platten nicht zuverlässig immer wieder die gleiche Gerätebezeichnung erhalten. Das habe ich mit FreeBSD noch nie erlebt. In Linux scheint das mitunter eher ein Problem zu sein. Aber auch da wurde bei mir immer die gleiche Gerätebezeichnung vergeben und zwar abhängig von der Position der Platte.
Deshalb habe ich in meinen Pools keine Labels benutzt.
Als ich letztens einen Pool wieder aus dem Schrott zusammenbaute und dabei die Reihenfolge der Platten wild mixte, funktionierte der Pool anschließend trotzdem. ZFS erkennt das und vergibt dann neue Label (benutzt die Platten-ID).
Ich denke, dass die Zuordnung einer Platte, also, der physikalischen Lage innerhalb des Pools das entscheidende ist und dabei helfen Labels wenig. Also, Labels helfen wohl, nämlich in Form von beschrifteten Aufklebern auf den Platten.