1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Gnome 2 Classik Modus

Dieses Thema im Forum "FreeBSD - Allgemein" wurde erstellt von Merlin, 20 November 2017.

  1. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Hallo gibt es ein BSD Derivat das den Gnome 2 Klassik Modus an Board hat?
    Oder kann man den Gnome 2 Classik Modus nachträglich installieren und wenn ja wie?? << Ich bin BSD Einsteiger ohne Kenntnisse
     
  2. holgerw

    holgerw Well-Known Member

    Registriert seit:
    29 Februar 2016
    Beiträge:
    1.185
    Ort:
    Simtshausen - Hessen
    Hallo

    Du kannst entweder das auf FreeBSD aufsetzende GhostBSD verwenden, was ein einsteigerfreundliches Desktopsystem bieten möchte und mit Mate als Standard DE kommt, oder aber Dich etwas mit dem Original FreeBSD befassen und Dir dort Mate installieren.

    Zum Gnome2 Klasikmodus kann ich Dir leider nicht weiter helfen, aber Mate ist ja gerade als Gnome Fork mit dem Anspruch entstanden, eine Art modernes Gnome2 weiter zu führen.

    Viele Grüße
    Holger
     
  3. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Was muss ich nachdem Ghostbsd in der Virtualbox Host = ubuntu installiert habe am Bootprompt (mountroot) eingeben damit der Desktop von GhostBSD erscheint??
     
  4. ralli

    ralli Well-Known Member

    Registriert seit:
    1 Juni 2012
    Beiträge:
    1.771
    Hallo @Merlin ,

    erst Mal herzlich willkommen im Forum, so viel Zeit sollte und muß sein. :)

    Normalerweise bin ich mit Empfehlungen sparsam, aber warum nimmst Du nicht gleich das Original FreeBSD 11.1? Das ist stabil und schnell und hat sich schon sehr bewährt. Nach der Grundinstallation einfach
    Code:
    pkg install xorg
    und
    pkg install mate
    absetzen und mit ee /etc/rc.conf folgendes eintragen:
    Code:
    hald_enable="YES"
    dbus_enable="YES"
    
    Du solltest dann in deinem Homeverzeichnis eine neue frische .xinitrc Datei erstellen mit folgendem Inhalt:
    Code:
    export LANG=de_DE.UTF-8
    setxkbmap de
    exec mate-session
    
    Nach einem Neustart loggst Du Dich ein und gibst auf der Konsole startx ein. Wenn Du mit Gnome2 vertraut warst, wirst Du Dich sofort im Mate Desktop zurechtfinden. Die wichtigsten Programme sind bereits an Bord, sie funktionieren genau wie in Gnome2, Du wirst kaum einen Unterschied feststellen. Der Mate Desktop ist, wie @holgerw schon schrieb, ein Gnome2 Fork, nur eher GTK3 zentriert und ist vom Technischen her etwas moderner. Bei der Arbeit wirst Du kaum einen Unterschied merken. Probier es einfach aus, wenn Du noch Fragen hast, nur zu, wir helfen gerne. Du kannst auch einen Loginmanager benutzen, dann brauchst Du den Mate Desktop nicht manuell von der Konsole starten mit startx. Einfach
    Code:
    pkg install slim
    Dann trägst Du in der /etc/rc.conf noch folgendes ein:
    Code:
    slim_enable="YES"
    damit wird der Loginmanager nach einem Neustart aktiviert und Du brauchst startx nicht mehr. Viel Erfolg, probier es einfach, es ist leichter als Du denkst.
     
  5. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Danke @ralli
    Das sieht schon einmal Verheissungsvoll aus, danke für deine Mühe.
     
  6. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    @ralli
    Ich hatte so wie oben, eventuell mit Fehlern deinen code eingegeben, Es kommt zu einer ewigen Anmeldeschleife in slim, was kann ich in der Virtualbox(Gast) da machen?
     
  7. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Muss es so richtig installiert werden >>>
    pkg install mate-desktop mate xorg
     
  8. holgerw

    holgerw Well-Known Member

    Registriert seit:
    29 Februar 2016
    Beiträge:
    1.185
    Ort:
    Simtshausen - Hessen
    Dann deinstalliere slim zunächst (pkg delete slim) und schau, ob mit startx der Mate Desktop startet.

    Ich habe mal gerade testweise folgendes durchgeführt: (habe eigentlich ein KDE System)
    1. pkg install mate-desktop mate xorg
    2. Einen testuser hinzu gefügt (mit Gruppenzugehörigkeit wheel und operator)
    3. Mit dem testuser eine .xinitrc angelegt:
    Code:
    export LANG=de_DE.UTF-8
    setxkbmap de
    exec mate-session
    4. Die .login_conf wie folgt abgeändert:
    Code:
    me:\
            :charset=UTF-8:\
            :lang=de_DE.UTF-8:
    5. Per startx bekomme ich eine Mateoberfläche in deutscher Lokalisierung.
     
  9. Rakor

    Rakor Moderator Mitarbeiter

    Registriert seit:
    17 September 2009
    Beiträge:
    2.025
    Ort:
    Mannheim
    Merlin könntest du bitte für normale Texte auch einfach eine normale Formatierung verwenden? Wer schlecht sieht stellt sich seinen Browser schon entsprechend ein und die anderen wollen nicht angeschrien werden.

    Was meinst du mit Anmeldeschleife? Könnte es sein, dass es an falschem Keyboardlayout liegt? Bei der Installation hattest du vermutlich auf 'de' gestellt und dein Xorg startet nun zunächst mit 'us'-Layout. Solltest du also äöüyz oder irgendwelche Sonderzeichen im Passwort haben liegt es ggf, daran.
     
  10. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    @holgerw
    Leider kann ich slim nicht deleten da ich mich in slim befinde und dort nach Passworteingabe wieder zurück befinde. Gibt es einen recoverymodus, auszuwählen im Bootmanager ?
    Als fehlermeldung steht in slim: Failed to execute login command
     
  11. holgerw

    holgerw Well-Known Member

    Registriert seit:
    29 Februar 2016
    Beiträge:
    1.185
    Ort:
    Simtshausen - Hessen
    Hallo @Merlin

    Du brauchst vielleicht noch eine /usr/local/etc/X11/xorg.conf.d/input.conf mit folgendem Inhalt:
    Code:
    Section "InputClass"
        Identifier      "Keyboard defaults"
        Driver          "keyboard"
        MatchIsKeyboard "on"
        Option          "XkbLayout" "de"
    EndSection
    Viele Grüße
    Holger
     
  12. ralli

    ralli Well-Known Member

    Registriert seit:
    1 Juni 2012
    Beiträge:
    1.771
    Ich habe den Mate Desktop bestimmt ein Dutzend Mal so installiert, wie ich es beschrieben habe. Das lief bei mir immer auch mit deutschen Tastaturlayout und deutscher Benutzeroberfläche einwandfrei. Ob sich das in Virtualbox anders verhält, kann ich zwecks mangelnder Erfahrung nicht beurteilen. Warum ich nur
    Code:
    pkg install mate
    genommen habe, ist ganz einfach zu erklären, es zieht das Paket mate-desktop als Abhängigkeit mit. Input.conf kann angelegt werden, aber ich würde eh keinen User mit deutschen Umlauten anlegen. Und slim liest ja die .xinitrc automatisch ein, es ist daher nicht zwingend erforderlich, in meiner Konfiguration ist gewährleistet, das alles in deutsch funktioniert.
     
  13. ralli

    ralli Well-Known Member

    Registriert seit:
    1 Juni 2012
    Beiträge:
    1.771
    Jetzt kann ich nur vermuten, das keine .xinitrc existiert oder sie mit falschen Inhalten befüllt wurde. Slim ersetzt das anlegen einer .xinitrc nicht, er braucht sie, sonst kann der Mate Desktop nicht gestartet werden, und dadurch bist du natürlich in einer Endlosschleife.
     
  14. ralli

    ralli Well-Known Member

    Registriert seit:
    1 Juni 2012
    Beiträge:
    1.771
    Du kann in slim mit der Tastenkombination STRG-ALT-F1 X verlassen und auf die Konsole kommen und dich als root einloggen und dann slim deleten. Aber nicht slim ist das Problem .... mit STRG-ALT-F9 konmmst Du zurück nach X. Wenn Du in slim als User halt eingibst und Dein root Passwort, wird der Rechner ordnungsgemäß heruntergefahren. Überprüf bitte Deine .xinitrc, da hast Du Dich vielleicht vertippt?
     
  15. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Du kann in slim mit der Tastenkombination STRG-ALT-F1 X
    Leider funktioniert das nicht das einzige was ich nach dem hineinklicken in Freebsd bekomme ist ein blinkender Cursor.
    Gibt es für BSD eine Recovery Konsole??
     
  16. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    8.886
    Ort:
    Schleswig-Holstein
    Probiere mal STRG-ALT-F2, denn auf der ersten Konsole wird eventuell Slim selbst selbst "laufen".
     
  17. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Das
    STRG-ALT-F2
    hat nicht funktioniert weil ich dann in der TTY Konsole von ubuntu lande.
     
  18. KobRheTilla

    KobRheTilla used register

    Registriert seit:
    20 Januar 2011
    Beiträge:
    1.184
    Du musst mit deinen Ausführungen präziser sein, sonst kann niemand nachvollziehen, was du meinst.
    Was meinst du denn mit hineinklicken?

    Rob
     
  19. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    8.886
    Ort:
    Schleswig-Holstein
    Ist das FreeBSD in einer virtuellen Maschine auf Ubuntu?
     
  20. Merlin

    Merlin New Member

    Registriert seit:
    20 November 2017
    Beiträge:
    19
    Yamagi
    Ja FreeBSD in der Virtualbox und der Host ist Ubuntu 16.04.3 (64 Bit)
     
    Zuletzt bearbeitet: 24 November 2017
  21. pit234a

    pit234a Well-Known Member

    Registriert seit:
    8 Juli 2006
    Beiträge:
    3.237
    OT: das mit dem Editor ist vielleicht gar nicht so gut...
     
  22. Yamagi

    Yamagi Possessed With Psi Powers Mitarbeiter

    Registriert seit:
    14 April 2004
    Beiträge:
    8.886
    Ort:
    Schleswig-Holstein
    Ja, so heiße ich. Das hätte ich aber auch gewusst ohne es ins Gesicht gebrüllt zu bekommen. Kannst du bitte @rakors Hinweis ernst nehmen und Texte normal formatieren? Dein Gemüse aus Klein-, Groß- und Fettschreibung nervt.

    Dann darfst du nun eine Transferleistung erbringen und strg-alt-f1 an deinen Gast senden.
     
  23. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.135
    Gnome3 bietet auch einen Klassikmodus. Den kann man im Login von GDM3 (muss glaube ich separat mittels "pkg install gdm" installiert werden) auswählen. Ist nicht ganz so wie das alte Gnome2, aber wie hier schon gesagt ist MATE praktisch das alte Gnome2. Cinnamon wäre auch eine modernere Weiterführung von Gnome2.
     
  24. ralli

    ralli Well-Known Member

    Registriert seit:
    1 Juni 2012
    Beiträge:
    1.771
    Der Classikmodus von Gnome3 funktionierte bei mir unter FreeBSD 11.1 nie. Cinnamon war der einzige Dektop, den ich unter FreeBSD 11.1 nie ans Laufen bekam. Vielleicht melden sich mal User, bei denen das wirklich in der Praxis läuft.
     
  25. cabriofahrer

    cabriofahrer Active Member

    Registriert seit:
    27 November 2004
    Beiträge:
    1.135
    Ich hatte Gnome3 mal ausprobiert und soweit ich mich erinnern kann, lief der Klassikmodus. Wichtig bei Gnome3/GDM3 ist, dass man 3D-Beschleunigung hat. Mit Nvidia-Treiber out of the box kein Problem, bei ATI/Mesa muss man als User das Recht auf 3D-Beschleunigung haben, ich glaube, den eigenen User der Gruppe "video" zuweisen.
    Obwohl 3D und Gnome3/GDM3 bei mir funktionierten, lief Cinnamon komischerweise bei mir auch nicht und meldete fehlende 3D-Beschleunigung...

    Also ich wäre auch dafür, dass jemand genauer über Cinnamon berichten könnte.