• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Berechtigungen auf USB-device????

Ice

Well-Known Member
Themenstarter #1
Hi Leute,

wie kann ich die Berechtigungen auf ein USB-device (Scanner) dauerhaft setzen?

Gruß,

Ice
 

Ice

Well-Known Member
Themenstarter #3
Hmm, mal ausprobieren!
Ich hatte es mit
perm uscanner0 0660
probiert.
das hat aber nicht funktioniert!
Gleich mal mit Ownership probieren.

Thx, schonmal!
 

Ice

Well-Known Member
Themenstarter #4
Shit, funzt nicht! Versteh ich nicht!
FBSD 5.2.1 ?
Hat jemand ne Ahnung warum das nicht funktioniert?
 

Lamer

Well-Known Member
#5
würde mal neu starten.

falls das immer noch nicht geht.
schreibe die Zeile zweimal oder wo anders hin.
Ich hatte z.B. Probleme bei acd0.

Deswegen schaut meine Datei so aus:

own acd1 lamer:lamer
own acd0 lamer:lamer
own uscanner0 lamer:lamer
own acd0 lamer:lamer
 

Ice

Well-Known Member
Themenstarter #6
Coolo, das ist ja der Hammer:
Wenn er beim erstenmal nicht will, dann schreiben wir ihm die Zeile halt einfach nochmal hin!!!! :)

Tatsächlich - es funktioniert!

Thx, Lamer !!!!!
 

Ice

Well-Known Member
Themenstarter #8
Das kann schon sein!!!!!!! ;)
Thx nochmal! Schätze, da wäre ich dran verzweifelt!
 

Ice

Well-Known Member
Themenstarter #9
Tjka, da hab ich mich wohl zu früh gerfreut!
Der doppelte Eintrag half genau ein einziges mal! Jetzt nach einem Reboot setzt er die Rechte auf das USB-DEvice (den Scanner) wieder auf
rw-r--r-- 1 root operator 156, 0 2 Mär 08:53 uscanner0
Shit!

Hat noch jemand eine Idee, wie ich es hinkriege, dass devfs die Berechtigungen richtig setzt?
 

Ice

Well-Known Member
Themenstarter #12
Das Komische ist ja, dass ich schon in der Gruppe Operator bin, aber ohne Schreibrechte nicht auf den Scanner zugreifen kann!
Sehr seltsam, ich weiß, aber so ist es halt nunmal!
devfs hab ich schon mehrfach neu gestartet!

Ich frage mich nur ernsthaft, warum die Einträge in devfs.conf einfach ignoriert werden! Gestern ging es mit doppeltem Eintrag einmal korrekt und heute ignoriert er die Einstellung einfach wieder komplett!
 
#13
Vielleicht existiert das Device noch garnicht, wenn devfs startet. Dann laeuft das entsprechende chmod(1) ins Leere. Bei USB-Geraeten ist es deshalb sinnvoller das ganze per usbd(8) zu konfigurieren. In usbd(8) steht alles was du dazu wissen musst.
 

Ice

Well-Known Member
Themenstarter #14
Hmmm, den Ansatz hatte ich gestern auch schonmal.
Hab aber gedacht, dass über devfs einfacher wäre.
Nun gut, nachdem ich jetzt die usbd.conf angepasst habe funktioniert es erstmal wieder. Ich denke auch, dass es diesmal hält!

Thx, Mr. Fixit für den guten Tip!

Gruß,

Ice