• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Fragen zu pf =(

McSnoop

Well-Known Member
Themenstarter #1
1. Wieso muss ALTQ im Kernel aktiviert sein damit pf funktioniert? zumindestens geht "pfctl -r rules" nicht.

2. Wo kann ich pf manuell beenden respektive starten. wenn ich "whereis pf" in die Console gebe bekomm ich 0 results.

3. über pftop bekomm ich 0 Ausgaben, da müsste doch min meine SSL Verbindung stehen wenn ich testweise von nem anderen Rechner über SSL auf den FreeBSD Rechner geh oder?

;'(
 

xbit

Well-Known Member
#2
Zu 2.
Code:
pfctl -e
pfctl -d
Hilft Dir, oder pfctl --help. pf bezeichnet den Paket Filter insgesamt und pfctl steuert diesen.

Zu 1.
ALTQ muss im Kernel aktiviert sein, weil ALTQ soweit ich weiss auch eng mit dem jeweiligen Netzwerkkartentreiber zusammenarbeitet.

Zu 3.
Solange PF nicht laeuft, wird pftop Dir auch nichts anzeigen.

Weitere Details zu PF findest Du in jedem Fall in der PF FAQ auf der OpenBSD Seite. Ein Link zu der Seite steht notfalls auch im Handbuch. Ansonsten OpenBSD Website und dann unter FAQ. ;)

HTH
 

McSnoop

Well-Known Member
Themenstarter #3
danke danke für die schnelle Antwort. =)

wenn ich

Code:
pfctl -e
pfctl -d
kann ich pf an und ausmachen(kommt direkt als ausschrift pf enabled, pf disabled ), aber pftop bringt trotzdem keine ausschrift.

Ich werd mir mal das Handbuch zur Brust nehmen, hab noch nie im Kernel rumhantiert. Der muss ja sicher neu kompelliert werden wenn dort Optionen verändert werden. =)
 

McSnoop

Well-Known Member
Themenstarter #5
wenn pfctl und pftop auf ALTQ angewiesen sind dann sollte ich das doch aktivieren oder nicht?

wie meinste läßt sich leicht nachträglich einschalten??