• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD Cryptoservices eingefroren?

ed1949

Well-Known Member
Themenstarter #1
Nun hat es die FreeBSD 5.4 Kiste wieder erwischt:

Nach vielen Tagen (> 45d) tun auf einmal keine verschluesselten Dienste mehr. Das sieht dann so aus, dass der entsprechende Dienst sein TCP Handshake und die unverschluesselten Teile (laut tcpdump) macht, und beim ersten verschluesselten Paket welches vom Server kommen sollte nichts mehr bekommt. Soweit ich das von Remote sehen kann, sind es SSH (*grmpf*), POP/IMAP ueber SSL und SMTP mit STARTTLS. Andere Services sind evtl. auch betroffen, kann ich aber nicht sagen da ich nicht mehr auf die Maschine komme (SSH). Lustigerweise aktzeptiert derselbe SMTP (exim) der nach dem STARTTLS einfriert, weiterhin Mails ueber SMTP ohne TLS. Von meinem SSH Client sieht das dann z.Bsp. so aus:
Code:
~> ssh -v XXX.de
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to XXX.de [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file /home/XXX/.ssh/identity type -1
debug1: identity file /home/XXX/.ssh/id_rsa type -1
debug1: identity file /home/XXX/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.8.1p1 FreeBSD-20040419
debug1: match: OpenSSH_3.8.1p1 FreeBSD-20040419 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1 Debian-8.sarge.4
debug1: SSH2_MSG_KEXINIT sent
... <irgendwann timeout>
Alle Services laufen in Jails. Ausserdem ist die PF Packet Filter und ALTQ involviert, wobei die unverschluesselten Dienste problemlos weiter laufen. Wenn ich die Kiste neu starte, sehe ich in den Logs meine Verbindungsanfragen mit einem Timeout. Hat den Effekt schon mal jemand beobachtet, oder sogar eine Loesung?