• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Immernoch Kernel-Panic mit nvidia-driver aus den Packages bei Upgrade auf 11.2?

Yamagi

Possessed With Psi Powers
Mitarbeiter
#26
Der Commit hat es wirklich in die BETA4 geschafft. Der Port muss noch angepasst werden, das sollte in den nächsten Tagen passieren.
 

cabriofahrer

Well-Known Member
Themenstarter #27
Wenn ich das richtig verstehe, wird dann FreeBSD 12-RELEASE mit nvidia-driver sowohl Linux 32 als auch 64 bit Spiele automatich ausführen können?

Bin immernoch auf 11.1, da warte ich doch besser noch ein paar Wochen, um auf 12 upzugraden.
 

pit234a

Well-Known Member
#29
Es gibt inzwischen FreeBSD in Version 12, derzeit RC-3 und demnächst als RELEASE.
Auf zwei unterschiedlichen Rechnern habe ich es gerade laufen und mit einem mache ich ernst. Darauf habe ich nvidia-driver-390.87 als Paket installiert, den gibt es auch gar nicht als Port, wenn ich das recht verstehe.
Dieser funktioniert "wunderbar" , also er geht. Das Bild ist nicht besser oder schärfer, als mit älteren Karten und das leidige Thema Tearing ist noch immer aktuell.
Bei dem zweiten System muss ich ein wenig ausholen, wenn man das verstehen will und dort brauche ich nvidia-driver-340-340.107_1.

Das erste System ist "mein neuer PC". Es ist neue HW im alten Gehäuse, das ich gut finde und deshalb auch in etlichen Punkten angepasst habe, damit ich die neue HW darin einbauen konnte. Geblieben sind nur die drei SDs mit dem System darauf. Motherboard, CPU, RAM, GraKa und Netzteil sind neu. Außerdem kann die neue HW auch USB3, weswegen ich auf eine entsprechende zusätzliche Karte verzichten konnte und ich brauchte auch die zusätzliche Netzwerkkarte nicht mehr (die nach Ausfall der Onboard-Lösung nötig geworden war).
Ich merke schon, dass es langsam verwirrend wird und bitte schon mal vorsorglich um Entschuldigung.
Das alte System hatte quasi einen Vorläufer und da waren SAS-HDs drin, die ich dann durch die neuen SATA-SDs ersetzt hatte, die nun immer noch im neuen System arbeiten.
Bei einem vollkommen anderen, ebenfalls sehr alten PC, wollte ich die alten und ausgesonderten SAS-HDs benutzen und dann dort ein neues System aufsetzen. Weil ich den Einstieg ins BIOS verpasste, bootete das System und lief mit dem alten FreeBSD auf den SAS-HDs wie am Schnürchen. Ich glaube, das System auf den SAS-HDs war ein 10.4, bin aber nicht wirklich sicher.
Nun hatte ich noch ein sehr altes Gehäuse rumliegen. Und der Grund, weshalb ich neue HW überhaupt bestellt hatte, habe ich in diesem Thread ein wenig beschrieben: https://www.bsdforen.de/threads/free-bereich-im-ram-einstellbar.34664/
und er blieb mir nicht ganz plausibel.
Mit der alten HW in meiner Bastelkiste, dem übrigen Gehäuse und den alten SAS-HDs reifte deshalb in mir der Gedanke, dies alles mal zusammen zu bringen und ausgiebiger zu testen.
Vollkommen unproduktiv und nahezu unsinnig und weil das Gehäuse nicht passte und eher billiger Schrott ist, auch wieder mit Bohren, Sägen und Feilen. Totaler Unsinn!
Was ich als erstes feststellte nachdem ich das alte Bastelsystem booten konnte: der Grafiktreiber passte nicht. Ich hatte nämlich irgendwann schon mal die GraKa gewechselt und hätte nun die ältere einbauen können, um damit weiter zu testen, aber es gibt da das Problem, dass ich keine Monitore mehr übrig habe.
Die beiden, die ich noch habe, besitzen jeweils unterschiedliche Eingänge und wie es das Schicksal fügt, konnte ich eine GraKa in den Bastel-PC einbauen, die genau die freien Eingänge meiner Monitore nutzen konnte. Damit ist es mir also einfach möglich, meinen aktuellen PC und diesen Bastel-PC an den gleichen Monitoren zu betreiben.
Nur: dazu brauchte es dann auch einen neuen Treiber für die GraKa, weshalb ich eben entschloss, zuerst auf 12-RC3 upzudaten.

Inzwischen bedauere ich wirklich, dass "kurz" mir nicht gelingen will.
Ich versuche es nochmal.
Bei beiden 12.0-RC3 - Systemen, einmal mit benötigtem Treiber nvidia-driver-340-340.107_1 und dann mit nvidia-driver-390.87 konnte ich keinerlei Zusammenbrüche mit den installierten Paketen erleben. Die HW wird erkannt und funktioniert, das System crashed nicht beim Booten.
Die GraKa meines neuen Systems lief nicht out of the Box.
Ich musste Dinge probieren und einstellen, die ich für üblich halte. Hauptsächlich, weil ich zwei Monitore angeschlossen habe. Das macht kein Automatismus so, wie ich das will.
Auf meinem Bastelsystem habe ich bisher keine Lust, diese Dinge richtig zu machen und nochmal nachzulesen. Deshalb weiß ich nicht, ob es nicht vielleicht irgendwo noch unlösbare (für Unbedarfte wie mich unlösbare) Probleme gibt.
Auf Anhieb sieht alles gut aus, Tastatur und Maus gehen nicht, aber sonst wird alles erkannt.
Solche Dinge sind ja oft nur Kleinigkeiten.

Was möchte ich mit so einem Beitrag?
Mut machen, zur 12.0-RC3, bzw zur demnächst (in den nächsten beiden Wochen) veröffentlichen RELEASE.
Es crashed nichts mehr (bei mir), wenn ich NVIDIA-Pakete nutze.
 
#30

pit234a

Well-Known Member
#33
gdm nutze ich übrigens, weil es xdmcp unterstützt
naja dann: XDM.
Nicht so nett, aber einfach und sparsam und irgendwie kann es xdmcp (oder konnte es mal, ich nutze das schon lange nicht mehr). Nicht sehr komfortabel, aber sicher irgendwo detailliert beschrieben.
Früher nutzte ich gerne (sehr gerne) KDM.
der kann (konnte) das auch, musste aber in der .conf auch frei geschaltet werden.
 
#34
Danke auch für diesen Tipp. Da das ganze jetzt aber zu sehr OT wird: Ich werde in Kürze einen Thread dazu aufmachen und mich dazu ein wenig "auslassen". :)
 

Django

Active Member
#35
Bei mir funktioniert GDM mit Gnome unter Freebsd 12 einwandfrei.:) Habe allerdings folgenden Patch durchgeführt:

  • You need to download attachment 191260 from the first message of PR 226403.
  • Copy x11_nvidia-driver_Makefile.diff to /usr/ports/x11/nvidia-driver.
  • Go to /usr/ports/x11/nvidia-driver.
  • Execute patch Makefile < x11_nvidia-driver_Makefile.diff and then make install clean (or use portmaster(8) for example). If you have already installed the driver before and you are installing it manually, run make deinstall first.

Ausserdem muss # kldload linux64 vor dem Kompilieren ausgeführt werden.
 

holgerw

Well-Known Member
#36
Danke für den Tipp! Das sieht zumindest mal nett aus und startet auch. sddm startet mir jedoch immer eine englische xfce-Sitzung. Das ganze über "Usersitzung" zu starten will ich nicht. Dann bleibe ich lieber bei startx bis gdm wieder läuft. gdm nutze ich übrigens, weil es xdmcp unterstützt :ugly::)
Hallo,

dann trage mal bitte in die /etc/profile folgendes ein:
Code:
export LANG=de_DE.UTF-8
Das führt dazu, dass:
1. sddm in deutsch lokalisiert startet
2. Deine Sitzung dann auch in deutsch lokalisiert starten sollte (ist bei mir mit plasma5 so, vermutlich dann auch bei xfce4)

Viele Grüße
Holger

P.S.: Ja, xfce4 startet dann in deutsch lokalisiert, habe es gerade getestet.