• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Kann keine Pakete in Jail installieren

Sickboy

Müßiggänger
Themenstarter #1
Unter FreeBSD 12 habe ich eine Jail laufen, die Pakete von meinem Poudriere-Server beziehen soll. Leider klappt das nicht:
Code:
root@devel:~ # uname -a
FreeBSD devel.ticonderoga 12.0-RELEASE-p7 FreeBSD 12.0-RELEASE-p7 GENERIC  amd64
root@devel:~ # pkg-static install -f pkg
pkg-static: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
Updating poudriere repository catalogue...
[devel.ticonderoga] Fetching meta.txz: 100%    820 B   0.8kB/s    00:01    
[devel.ticonderoga] Fetching packagesite.txz: 100%  227 KiB 232.9kB/s    00:01    
Processing entries:   0%
pkg-static: wrong architecture: FreeBSD:12:amd64 instead of FreeBSD:11:amd64
pkg-static: repository poudriere contains packages with wrong ABI: FreeBSD:12:amd64
Processing entries: 100%
Unable to update repository poudriere
Error updating repositories!
Das System läuft mit FreeBSD 12, die Jail mit FreeBSD 12 und der Poudriere-Server ebenfalls mit FreeBSD 12. Trotzdem werden Pakete für FreeBSD 11 erwartet. Hat jemand einen Hinweis?
 

Sickboy

Müßiggänger
Themenstarter #3
Code:
root@devel:~ # freebsd-version -u
11.0-RELEASE-p1
Damit ging es:
Code:
# freebsd-update -b /usr/jails/devel --currently-running 11.0-RELEASE -r 12.0-RELEASE upgrade
 

mr44er

moderater Moderator
Mitarbeiter
#5
Hat auch hier geholfen, mismatch bei freebsd-version -ku

Obwohl die jail schon auf 12.1 war, hab ich hier 12.0 'reingeschwindelt'.

Code:
freebsd-update -b /usr/jails/jail1 --currently-running 12.0-RELEASE -r 12.1-RELEASE upgrade
Lüppt! :)
 

Crest

rm -rf /*
Mitarbeiter
#6
Du hast vergessen die Jail auf einen kompatiblen Release zu aktualiseren. FreeBSD verbietet es Pakete die auf einem neueren System gebaut wurden auf einem alten zu installieren. Dein altes FreeBSD 11.x Userland ist ich kompatibel zu FreeBSD 12.y Paketen. Für manche einfachen Pakete mag es dennoch (halbwegs) funktionieren, aber das ist nur weil es keiner absichtlich kaputt gemacht hat.
 

mr44er

moderater Moderator
Mitarbeiter
#7
Ich kann dir gar nichtmal sagen, ob die jail mit 11.x aufgesetzt wurde oder erst später.
Aus der Erinnerung heraus nur noch die letzten beiden Ziffern vom userland zum mismatch-> 86 (jedenfalls der kleinere Wert)

Oder meintest du sickboy?