• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

KDE5 - Kann keine Dateien und Ordner mit Umlauten öffnen.

sterum

Well-Known Member
Themenstarter #1
Ergänzend zum Titel muss ich hinzufügen, das sich mit manchen Programmen sehr wohl Dateien und Ordner mit Umlauten öffnen lassen, aber nicht mit allen.
Dolphin, Kate, Kwrite, Ark und Okteta zum Beispiel, können problemlos Dateien mit Umlauten öffnen während hingegen Gwenview folgende Meldung ausgibt:
Code:
Der angegebene Ordner existiert nicht oder ist nicht lesbar
. Auch LyX als Qt5 Programm kann nicht mit Umlauten umgehen. VirtualBox hingegen hat wieder kein Problem mit Umlauten.
Und Digikam 5 zeigt erst gar keine Ordner mit Umlauten an.
Alles sehr verwirrend das ganze. Was mir noch aufgefallen ist: Die Programme die funktionieren haben einen anderen "Datei öffnen" Dialog als die bei denen es nicht funktioniert.
Ich habe die nicht funktionierenden Programme auch schon mal unter TWM ausgeführt aber das Problem hab ich dort auch.

Installiert habe ich KDE5 aus area51 (kde5-5.9.2_1)

Zu den Einstellungen:
Code:
[stefan@saturn /home/stefan] % locale 
LANG=de_AT.UTF-8 
LC_CTYPE="de_AT.UTF-8" 
LC_COLLATE="de_AT.UTF-8" 
LC_TIME="de_AT.UTF-8" 
LC_NUMERIC="de_AT.UTF-8" 
LC_MONETARY="de_AT.UTF-8" 
LC_MESSAGES="de_AT.UTF-8" 
LC_ALL=
In den Systemeinstellungen von KDE ist unter: Regionaleinstellungen -> Sprache "Bevorzugte Sprache: Deutsch" eingestellt.
Unter: Regionaleinstellungen -> Formate "Region: Österreich - de_AT".

Code:
[stefan@saturn /home/stefan] % env 
XCURSOR_PATH=/usr/local/share/icons::~/.icons:/usr/share/icons:/usr/share/pixmaps:/usr/X11R6/lib/X
11/icons 
KDE_SESSION_VERSION=5 
LANG=de_AT.UTF-8 
MAIL=/var/mail/stefan 
XDG_DATA_DIRS=:/usr/share:/usr/local/share:/usr/local/share:/usr/local/share/gnome 
SHELL_SESSION_ID=7ebd476a66b1464b840299d2a5583850 
XCURSOR_THEME=breeze_cursors 
KONSOLE_PROFILE_NAME=Profile 1 
GROUP=stefan 
GS_LIB=/home/stefan/.fonts 
QML2_IMPORT_PATH=/usr/local/lib/qml:/usr/local/lib/qt5/qml:/usr/local/lib/qt5/imports: 
KDE_FORK_SLAVES=1 
DISPLAY=unix:0.0 
XAUTHORITY=/home/stefan/.Xauthority 
WINDOWID=62914566 
BLOCKSIZE=K 
VIDEO_FORMAT=pal 
KDE_SESSION_UID=1001 
EDITOR=ee 
HOSTTYPE=FreeBSD 
KONSOLE_DBUS_SERVICE=:1.42 
XDG_CURRENT_DESKTOP=KDE 
HOME=/home/stefan 
QT_PLUGIN_PATH=/usr/local/lib/plugins:/usr/local/lib/qt5/plugins: 
USER=stefan 
KONSOLE_DBUS_SESSION=/Sessions/1 
LOGNAME=stefan 
XDG_CONFIG_DIRS=:/etc/xdg:/usr/local/etc/xdg:/usr/local/etc/xdg/xfce:/usr/local/etc/xdg 
VENDOR=amd 
KDE_FULL_SESSION=true 
QMLSCENE_DEVICE= 
COLORFGBG=15;0 
OSTYPE=FreeBSD 
XDG_SESSION_COOKIE=bc74fd6d76fceea3ae3205605894aebf-1489861462.338750-598585594 
QT_AUTO_SCREEN_SCALE_FACTOR=0 
COLORTERM=truecolor 
PWD=/home/stefan 
PATH=/bin:/usr/bin:/usr/games:/usr/local/bin:/usr/local/sbin:/sbin:/usr/sbin:/home/stefan/bin 
SESSION_MANAGER=local/saturn.lan:/tmp/.ICE-unix/1218,inet6/saturn.lan:49174,inet/saturn.lan:20991 
PAGER=less 
TERM=xterm-256color 
CLICOLOR=1 
SHELL=/bin/csh 
MM_CHARSET=UTF-8 
HOST=saturn.lan 
LANGUAGE=de 
KONSOLE_DBUS_WINDOW=/Windows/1 
MACHTYPE=x86_64 
PROFILEHOME= 
QSG_RENDER_LOOP= 
SHLVL=1
Jetzt stellt sich halt die Frage wo ich da noch was umstellen muss damit ich die Probleme los werde.