• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Matlab installation funktioniert nicht

_JC_

New Member
Themenstarter #1
Hallo zusammen, ich habe nun einfach mal das "Experiment" PC BSD gewagt.

Intern ist das ja Free BSD, und laut google & co läut matlab auf FreeBSD recht gut.

Ich gehe bei der installation nach folgenden "Anleitungen" vor:
http://forums.freebsd.org/showthread.php?t=10076
und
www.freebsd.org/doc/de/books/handbook/linuxemu-matlab.html

Ich kann alles was mir da gesagt wird durchführen, und ich denke ich verstehe auch so mehr oder weniger was ich da tue. Ich bekomme den Matlab installer auch gestartet, allerdings kommt er nur bis zu dem Punkt wo er die eigentlich Installation anfangen sollte. Dort bekomme ich dann ein Matlab fenster das mir sagt:

There was an error extracting the archives for MATLAB.
This is usually caused by a lack of disc space, or a permissions error (there may be a pre-existing installation of MATLAB for a different user), or a missing download archive.
Wat nu?

Festplattenplatz habe ich genug, und für einen anderen user ist es auch nicht installiert.

also ist der Download korrupt? Allerdings bekomme ich diese Meldung auch bei der älteren Version, und das beide Downloads hinüber sind kann ich mir nicht vorstellen.

Könnte es vieleicht an folgendem liegen?

Die erste anleitung sagt ja das ich emulators/linux_base-f10 installieren soll. Also quasi fedora10, wenn ich das richtig verstehe.

Führe ich nun also #/cd /usr/ports/emulators/linux_base-f10 && make install clean
aus, so lädt die Kiste soweit ich das sehe das ganze runter und checkt es, aber dann bekomme ich folgende meldung:
Code:
...
=> SHA256 Checksum OK for rpm/i386/fedora/10/mesa-libGLw-6.5.1-5.fc9.i386.rpm.
===>   linux-f10-xorg-libs-7.4_1 depends on file: /usr/local/bin/rpm2cpio - found
===>  Patching for linux-f10-xorg-libs-7.4_1
===>  Configuring for linux-f10-xorg-libs-7.4_1
===>  Installing for linux-f10-xorg-libs-7.4_1
===>   linux-f10-xorg-libs-7.4_1 depends on file: /compat/linux/bin/sh - found
===>   linux-f10-xorg-libs-7.4_1 depends on file: /compat/linux/lib/libexpat.so.1 - found
===>   linux-f10-xorg-libs-7.4_1 depends on file: /compat/linux/usr/lib/libfontconfig.so.1.3.0 - found
===>   Generating temporary packing list
===>  Checking if x11/linux-f10-xorg-libs already installed
===>   linux-f10-xorg-libs-7.4_1 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of x11/linux-f10-xorg-libs
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/x11/linux-f10-xorg-libs.
Ich habe mir dabei nix gedacht, und bin einfach davon ausgegangen das die Anleitung da halt etwas älter ist (ist ja vom Januar) und inzwischen die passende Linux version mitgeliefert wird. Das gleiche mit den X11 libs für linux.

Oder habe ich da einen Denkfehler und muss es tatsächlich deinstallieren und reinstallieren? Also einfach im verzeichniss #make deinstall und #make reinstall? (und dann noch clean)

Ich habe auch mal den Matlab support angeschrieben wegs einer checksum, aber die gibts nicht. Dafür hat man mir einen anleitung geschickt wie ich aufm mac ein terminal öffne und im matlab download ein ls -laR durchführe ... :ugly:

Irgendjemand eine Idee?

Problem mit PC BSD vs. Free BSD?

die neueste Matlab version das Problem?

Oder doch einfach f10 neuinstallieren?

Johannes
 

h^2

hat ne Keule +1
Mitarbeiter
#2
also ich würde auf jeden fall in /usr/ports/x11/linux-f10-xorg-libs erstmal ein make build deinstall reinstall clean machen, warum auch nicht. Steht ja da dass mans machen soll ;)