• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Mein dmesg - da stimmt einiges nicht oder?

andras98

Well-Known Member
Themenstarter #1
Hab alles neugebaut. (Kernel, und World) so wie im Handbuch beschrieben. Gebracht hats nichts.

Meine Konf:

Amd 1ghz
HPT370 IDE Raid Controller (benötige ich nicht in Freebsd)
Adaptec SCSI Controller 2940U (an diesem hängt die HDD wo Freebsd installiert ist)
Terratec 512i Soundkarte (fm801 kompatibel)
Netzwerkkarte PCI Ne2000 kompatible (benötige ich in Fb nicht)
Netzwerkkarte PCI Realteak (funktioniert einwandfrei)
GeForce 4 Ti4200 AGP

Meine Probleme:
Die GeForce friert das System ein wenn ich die NVidiatreiber verwende. Mit dem "nv" vom X11 funktioniert sie nicht. Mit "vesa" kann ich tun und lass was ich will - er findet keine screens.
Die Soundkarte funktioniert nicht. Keine nodes werden unter /dev angelegt wenn ich entweder mit kldload ein Modul lade oder den Kernel mit pcm kompiliere. Weder kldload noch ein pcm im Kernel liefern irgendeine Rückmeldung.

Da ich ja alles neukompiliert habe und schon sooo viel Zeit reingesteckt habe möchte ich das FreeBSD nicht einfach löschen ;( Aber langsam wirds echt eng. Und trüb ohne X11 ...

Andreas

---dmesg ---
Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD 5.0-CURRENT #0: Tue Feb 4 00:11:53 CET 2003
root@jupiter.com:/usr/obj/usr/src/sys/kernel_with_pcm
Preloaded elf kernel "/boot/kernel/kernel" at 0xc06e5000.
Timecounter "i8254" frequency 1193182 Hz
Timecounter "TSC" frequency 999527984 Hz
CPU: AMD Athlon(tm) processor (999.53-MHz 686-class CPU)
Origin = "AuthenticAMD" Id = 0x642 Stepping = 2
Features=0x183f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR>
AMD Features=0xc0440000<RSVD,AMIE,DSP,3DNow!>
real memory = 268435456 (256 MB)
avail memory = 253382656 (241 MB)
Initializing GEOMetry subsystem
Pentium Pro MTRR support enabled
npx0: <math processor> on motherboard
npx0: INT 16 interface
Using $PIR table, 9 entries at 0xc00fdb10
pcib0: <Host to PCI bridge> at pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
agp0: <VIA 82C8363 (Apollo KT133A) host to PCI bridge> mem 0xd0000000-0xd3ffffff at device 0.0 on pci0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 82C686 ATA100 controller> port 0x9000-0x900f at device 7.1 on pci0
atapci0: Correcting VIA config for southbridge data corruption bug
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <VIA 83C572 USB controller> port 0x9400-0x941f at device 7.2 on pci0
pci_cfgintr: 0:7 INTD routed to irq 10
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhub0: port error, restarting port 1
uhub0: port error, giving up port 1
uhub0: port error, restarting port 2
uhub0: port error, giving up port 2
ums0: Logitech USB Mouse, rev 1.10/6.10, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
uhci1: <VIA 83C572 USB controller> port 0x9800-0x981f at device 7.3 on pci0
pci_cfgintr: 0:7 INTD routed to irq 10
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhub1: port error, restarting port 1
uhub1: port error, giving up port 1
uhub1: port error, restarting port 2
uhub1: port error, giving up port 2
uhub2: Motorola MC141555 hub controller, class 9/0, rev 1.00/1.00, addr 2
uhub2: 5 ports with 5 removable, self powered
atapci1: <HighPoint HPT370 ATA100 controller> port 0xac00-0xacff,0xa800-0xa803,0xa400-0xa407,0xa000-0xa003,0x9c00-0x9c07 irq 10 at device 9.0 on pci0
ata2: at 0x9c00 on atapci1
ata3: at 0xa400 on atapci1
pci0: <multimedia, audio> at device 10.0 (no driver attached)
pci0: <input device> at device 10.1 (no driver attached)
ahc0: <Adaptec 2940A Ultra SCSI adapter> port 0xb800-0xb8ff mem 0xdb000000-0xdb000fff irq 11 at device 12.0 on pci0
aic7860: Ultra Single Channel A, SCSI Id=7, 3/253 SCBs
rl0: <RealTek 8139 10/100BaseTX> port 0xbc00-0xbcff mem 0xdb001000-0xdb0010ff irq 10 at device 13.0 on pci0
rl0: Realtek 8139B detected. Warning, this may be unstable in autoselect mode
rl0: Ethernet address: 00:50:fc:96:10:61
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ed0: <NE2000 PCI Ethernet (RealTek 8029)> port 0xc000-0xc01f irq 5 at device 14.0 on pci0
ed0: address 00:02:44:16:2b:63, type NE2000 (16 bit)
orm0: <Option ROMs> at iomem 0xd8000-0xdbfff,0xd4000-0xd77ff,0xd0000-0xd3fff on isa0
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x64,0x60 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> at port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
ppbus0: IEEE1284 device found /NIBBLE/ECP
Probing for PnP devices on ppbus0:
ppbus0: <HEWLETT-PACKARD DESKJET 710C> SCP,VLINK
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0c02> can't assign resources (memory)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0400> can't assign resources (port)
Timecounters tick every 10.000 msec
ad4: 19623MB <IBM-DTLA-305020> [39870/16/63] at ata2-master UDMA100
ad6: 38166MB <WDC WD400BB-00DEA0> [77545/16/63] at ata3-master UDMA100
acd0: DVD-ROM <ASUS DVD-ROM E608> at ata0-master PIO4
acd1: CD-RW <LITE-ON LTR-40125S> at ata1-master PIO4
Waiting 15 seconds for SCSI devices to settle
MBREXT Slice 5 on ad6s1:
[0] f:00 typ:7 s(CHS):1/1/1 e(CHS):255/254/255 s:63 l:42331212
[1] f:00 typ:0 s(CHS):0/0/0 e(CHS):0/0/0 s:0 l:0
da0 at ahc0 bus 0 target 2 lun 0
da0: <QUANTUM FIREBALL ST3.2S 0F04> Fixed Direct Access SCSI-2 device
da0: 20.000MB/s transfers (20.000MHz, offset 15), Tagged Queueing Enabled
da0: 3118MB (6385696 512 byte sectors: 255H 63S/T 397C)
Mounting root from ufs:/dev/da0s1a
lock order reversal
1st 0xc272a788 process lock (process lock) @ /usr/src/sys/kern/kern_descrip.c:2104
2nd 0xc26f9334 filedesc structure (filedesc structure) @ /usr/src/sys/kern/kern_descrip.c:2111
 

asg

push it, don´t hype
#4
Wo ist Deine Kernelconfig? Bitte posten.
Bitte die Ausgabe von "pciconf -l" posten.

Zum anderen, schalte im BIOS Plug-n-Play AUS. In Deiner dmesg Ausgabe sollte bei vga so etwas stehen:

vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0

Und nicht der Kram von wegen PNP und so.

Deine NVIDIA sollte bei dmesg und geladenem Modul diesen oder ähnlichen output bringen:

nvidia0: <GeForce4 MX 440> mem 0xd8000000-0xd807ffff,0xd0000000-0xd7ffffff,0xe40

Wie hast Du den NVIDIA Treiber installiert?
Wie sieht Deine XF86Config aus? Bitte posten.
Ansonsten brauche ich eine Kristallkugel.

Sound. Wenn pcm im Kernel drin ist, dann sollte der output so oder so ähnlich aussehen:

pcm0: <AudioPCI ES1373-B> port 0xe000-0xe03f irq 11 at device 10.0 on pci0

So, hier mal eine funktionierende XF86Config mit NVIDIA Treiber:

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection
Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection
Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "pex5"
Load "record"
Load "xie"
Load "xtrap"
Load "speedo"
Load "type1"
Load "freetype"
EndSection
Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
EndSection
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/sysmouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
EndSection
Section "Monitor"
Identifier "Monitor0"
HorizSync 31-70
VertRefresh 55-120
Option "DPMS"
Option "NoLogo" "1"
EndSection
Section "Device"
Identifier "NV AGP"
VendorName "nvidia"
Driver "nvidia"
# update this with the PCI id of your card. Consult the output
BusID "PCI:1:0:0"
Option "CursorShadow"
EndSection
Section "Screen"
Identifier "Screen0"
Device "NV AGP"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 1
EndSubSection
SubSection "Display"
Depth 4
EndSubSection
SubSection "Display"
Depth 8
EndSubSection
SubSection "Display"
Depth 15
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection


Hier eine Standard XF86Config mit "nv" Treiber:

Section "Module"
Load "dbe"
SubSection "extmod"
Option "xfree86-dga"
EndSubSection
Load "type1"
Load "freetype"
EndSection
Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi"

FontPath "/usr/X11R6/lib/X11/fonts/CID"
EndSection
Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "de"
EndSection
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection
Section "Monitor"
Identifier "NEC-MultiSync-FE700+"
HorizSync 31-70
VertRefresh 55-120
EndSection
Section "Device"
Identifier "Gainward-GeForce4-Pro600TV-64MB"
Driver "nv"
VideoRam 65536
EndSection
Section "Screen"
Identifier "Screen 1"
Device "Gainward-GeForce4-Pro600TV-64MB"
DefaultColorDepth 16
Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1024x768"
ViewPort 0 0
EndSubsection
EndSection
Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection
 

andras98

Well-Known Member
Themenstarter #5
...

Anbei die ganzen Files ...

die nvidia treiber möcht ich nciht verwenden. es steht extra dort dass sie nicht für freebsd5.0 geeignet sind. (ausserdem haben sie immer mein system gefreezed).
das im Bios hab ich umgestellt ... PNP OS = NO

Kernel:

---
#
# GENERIC -- Generic kernel configuration file for FreeBSD/i386
#
# For more information on this file, please read the handbook section on
# Kernel Configuration Files:
#
# http://www.FreeBSD.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig-config.html
#
# The handbook is also available locally in /usr/share/doc/handbook
# if you've installed the doc distribution, otherwise always see the
# FreeBSD World Wide Web server (http://www.FreeBSD.org/) for the
# latest information.
#
# An exhaustive list of options and more detailed explanations of the
# device lines is also present in the ../../conf/NOTES and NOTES files.
# If you are in doubt as to the purpose or necessity of a line, check first
# in NOTES.
#
# $FreeBSD: src/sys/i386/conf/GENERIC,v 1.375 2003/02/01 18:45:17 joe Exp $

machine i386
cpu I486_CPU
cpu I586_CPU
cpu I686_CPU
ident GENERIC
maxusers 0

#To statically compile in device wiring instead of /boot/device.hints
#hints "GENERIC.hints" #Default places to look for devices.

makeoptions DEBUG=-g #Build kernel with gdb(1) debug symbols

options SCHED_4BSD #4BSD scheduler
options INET #InterNETworking
options INET6 #IPv6 communications protocols
options FFS #Berkeley Fast Filesystem
options SOFTUPDATES #Enable FFS soft updates support
options UFS_ACL #Support for access control lists
options UFS_DIRHASH #Improve performance on big directories
options MD_ROOT #MD is a potential root device
options NFSCLIENT #Network Filesystem Client
options NFSSERVER #Network Filesystem Server
options NFS_ROOT #NFS usable as root device, requires NFSCLIENT
options MSDOSFS #MSDOS Filesystem
options CD9660 #ISO 9660 Filesystem
options PROCFS #Process filesystem (requires PSEUDOFS)
options PSEUDOFS #Pseudo-filesystem framework
options COMPAT_43 #Compatible with BSD 4.3 [KEEP THIS!]
options COMPAT_FREEBSD4 #Compatible with FreeBSD4
options SCSI_DELAY=15000 #Delay (in ms) before probing SCSI
options KTRACE #ktrace(1) support
options SYSVSHM #SYSV-style shared memory
options SYSVMSG #SYSV-style message queues
options SYSVSEM #SYSV-style semaphores
options _KPOSIX_PRIORITY_SCHEDULING #Posix P1003_1B real-time extensions
options KBD_INSTALL_CDEV # install a CDEV entry in /dev
options AHC_REG_PRETTY_PRINT # Print register bitfields in debug
# output. Adds ~128k to driver.
options AHD_REG_PRETTY_PRINT # Print register bitfields in debug
# output. Adds ~215k to driver.

# Debugging for use in -current
options DDB #Enable the kernel debugger
options INVARIANTS #Enable calls of extra sanity checking
options INVARIANT_SUPPORT #Extra sanity checks of internal structures, required by INVARIANTS
options WITNESS #Enable checks to detect deadlocks and cycles
options WITNESS_SKIPSPIN #Don't run witness on spinlocks for speed

# To make an SMP kernel, the next two are needed
#options SMP # Symmetric MultiProcessor Kernel
#options APIC_IO # Symmetric (APIC) I/O

device isa
device eisa
device pci

# Floppy drives
device fdc

# ATA and ATAPI devices
device ata
device atadisk # ATA disk drives
device atapicd # ATAPI CDROM drives
device atapifd # ATAPI floppy drives
device atapist # ATAPI tape drives
options ATA_STATIC_ID #Static device numbering

# SCSI Controllers
device ahb # EISA AHA1742 family
device ahc # AHA2940 and onboard AIC7xxx devices
device ahd # AHA39320/29320 and onboard AIC79xx devices
device amd # AMD 53C974 (Tekram DC-390(T))
device isp # Qlogic family
device mpt # LSI-Logic MPT-Fusion
#device ncr # NCR/Symbios Logic
device sym # NCR/Symbios Logic (newer chipsets + those of `ncr')
device trm # Tekram DC395U/UW/F DC315U adapters

device adv # Advansys SCSI adapters
device adw # Advansys wide SCSI adapters
device aha # Adaptec 154x SCSI adapters
device aic # Adaptec 15[012]x SCSI adapters, AIC-6[23]60.
device bt # Buslogic/Mylex MultiMaster SCSI adapters

device ncv # NCR 53C500
device nsp # Workbit Ninja SCSI-3
device stg # TMC 18C30/18C50

# RAID controllers interfaced to the SCSI subsystem
device asr # DPT SmartRAID V, VI and Adaptec SCSI RAID
device ciss # Compaq Smart RAID 5*
device dpt # DPT Smartcache III, IV - See NOTES for options!
device iir # Intel Integrated RAID
device mly # Mylex AcceleRAID/eXtremeRAID

# SCSI peripherals
device scbus # SCSI bus (required)
device ch # SCSI media changers
device da # Direct Access (disks)
device sa # Sequential Access (tape etc)
device cd # CD
device pass # Passthrough device (direct SCSI access)
device ses # SCSI Environmental Services (and SAF-TE)

# RAID controllers
device aac # Adaptec FSA RAID
device aacp # SCSI passthrough for aac (requires CAM)
device amr # AMI MegaRAID
device ida # Compaq Smart RAID
device mlx # Mylex DAC960 family
device pst # Promise Supertrak SX6000
device twe # 3ware ATA RAID

# atkbdc0 controls both the keyboard and the PS/2 mouse
device atkbdc # AT keyboard controller
device atkbd # AT keyboard
device psm # PS/2 mouse

device vga # VGA video card driver

device splash # Splash screen and screen saver support

# syscons is the default console driver, resembling an SCO console
device sc

# Enable this for the pcvt (VT220 compatible) console driver
#device vt
#options XSERVER # support for X server on a vt console
#options FAT_CURSOR # start with block cursor

#device agp # support several AGP chipsets

# Floating point support - do not disable.
device npx

# Power management support (see NOTES for more options)
#device apm
# Add suspend/resume support for the i8254.
device pmtimer

# PCCARD (PCMCIA) support
# Pcmcia and cardbus bridge support
device cbb # cardbus (yenta) bridge
#device pcic # ExCA ISA and PCI bridges
device pccard # PC Card (16-bit) bus
device cardbus # CardBus (32-bit) bus

# Serial (COM) ports
device sio # 8250, 16[45]50 based serial ports

# Parallel port
device ppc
device ppbus # Parallel port bus (required)
device lpt # Printer
device plip # TCP/IP over parallel
device ppi # Parallel port interface device
#device vpo # Requires scbus and da


# PCI Ethernet NICs.
device de # DEC/Intel DC21x4x (``Tulip'')
device em # Intel PRO/1000 adapter Gigabit Ethernet Card
device txp # 3Com 3cR990 (``Typhoon'')
device vx # 3Com 3c590, 3c595 (``Vortex'')

# PCI Ethernet NICs that use the common MII bus controller code.
# NOTE: Be sure to keep the 'device miibus' line in order to use these NICs!
device miibus # MII bus support
device dc # DEC/Intel 21143 and various workalikes
device fxp # Intel EtherExpress PRO/100B (82557, 82558)
device pcn # AMD Am79C97x PCI 10/100 (precedence over 'lnc')
device rl # RealTek 8129/8139
device sf # Adaptec AIC-6915 (``Starfire'')
device sis # Silicon Integrated Systems SiS 900/SiS 7016
device ste # Sundance ST201 (D-Link DFE-550TX)
device tl # Texas Instruments ThunderLAN
device tx # SMC EtherPower II (83c170 ``EPIC'')
device vr # VIA Rhine, Rhine II
device wb # Winbond W89C840F
device xl # 3Com 3c90x (``Boomerang'', ``Cyclone'')
device bge # Broadcom BCM570xx Gigabit Ethernet

# ISA Ethernet NICs. pccard nics included.
device cs # Crystal Semiconductor CS89x0 NIC
# 'device ed' requires 'device miibus'
device ed # NE[12]000, SMC Ultra, 3c503, DS8390 cards
device ex # Intel EtherExpress Pro/10 and Pro/10+
device ep # Etherlink III based cards
device fe # Fujitsu MB8696x based cards
device lnc # NE2100, NE32-VL Lance Ethernet cards
device sn # SMC's 9000 series of ethernet chips
device xe # Xircom pccard ethernet

# ISA devices that use the old ISA shims
#device le

# Wireless NIC cards
device wlan # 802.11 support
device an # Aironet 4500/4800 802.11 wireless NICs.
device awi # BayStack 660 and others
device wi # WaveLAN/Intersil/Symbol 802.11 wireless NICs.
#device wl # Older non 802.11 Wavelan wireless NIC.

#Sound

device pcm

# Pseudo devices - the number indicates how many units to allocate.
device random # Entropy device
device loop # Network loopback
device ether # Ethernet support
device sl # Kernel SLIP
device ppp # Kernel PPP
device tun # Packet tunnel.
device pty # Pseudo-ttys (telnet etc)
device md # Memory "disks"
device gif # IPv6 and IPv4 tunneling
device faith # IPv6-to-IPv4 relaying (translation)

# The `bpf' device enables the Berkeley Packet Filter.
# Be aware of the administrative consequences of enabling this!
device bpf # Berkeley packet filter

# USB support
device uhci # UHCI PCI->USB interface
device ohci # OHCI PCI->USB interface
device usb # USB Bus (required)
#device udbp # USB Double Bulk Pipe devices
device ugen # Generic
device uhid # "Human Interface Devices"
device ukbd # Keyboard
device ulpt # Printer
device umass # Disks/Mass storage - Requires scbus and da
device ums # Mouse
device urio # Diamond Rio 500 MP3 player
device uscanner # Scanners
# USB Ethernet, requires mii
device aue # ADMtek USB ethernet
device cue # CATC USB ethernet
device kue # Kawasaki LSI USB ethernet

---
 
Zuletzt bearbeitet:

andras98

Well-Known Member
Themenstarter #6
XF86Conf

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "xie"
Load "pex5"
Load "glx"
Load "dri"
Load "dbe"
Load "record"
Load "extmod"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Emulate3Buttons"
Option "Device" "/dev/sysmouse"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc101"
Option "XkbLayout" "de"
EndSection

Section "Monitor"
Identifier "Monitor0"
HorizSync 28 - 49
VertRefresh 50.0 - 60
EndSection

Section "Device"
Identifier "Card0"
Driver "nv"
ChipSet "GeForce4 Ti 4200"
Card "NVidia GeForce4 Ti 4200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection

----

hostb0@pci0:0:0: class=0x060000 card=0x00000000 chip=0x03051106 rev=0x02 hdr=0x00
pcib1@pci0:1:0: class=0x060400 card=0x00000080 chip=0x83051106 rev=0x00 hdr=0x01
isab0@pci0:7:0: class=0x060100 card=0x00001106 chip=0x06861106 rev=0x40 hdr=0x00
atapci0@pci0:7:1: class=0x01018a card=0x00000000 chip=0x05711106 rev=0x06 hdr=0x00
uhci0@pci0:7:2: class=0x0c0300 card=0x12340925 chip=0x30381106 rev=0x16 hdr=0x00
uhci1@pci0:7:3: class=0x0c0300 card=0x12340925 chip=0x30381106 rev=0x16 hdr=0x00
hostb1@pci0:7:4: class=0x060000 card=0x00000000 chip=0x30571106 rev=0x40 hdr=0x00
atapci1@pci0:9:0: class=0x018000 card=0x00011103 chip=0x00041103 rev=0x04 hdr=0x00
none0@pci0:10:0: class=0x040100 card=0x13191319 chip=0x08011319 rev=0xb2 hdr=0x00
none1@pci0:10:1: class=0x098000 card=0x13191319 chip=0x08021319 rev=0xb2 hdr=0x00
ahc0@pci0:12:0: class=0x010000 card=0x00000000 chip=0x61789004 rev=0x01 hdr=0x00
rl0@pci0:13:0: class=0x020000 card=0x813910ec chip=0x813910ec rev=0x10 hdr=0x00
ed0@pci0:14:0: class=0x020000 card=0x802910ec chip=0x802910ec rev=0x00 hdr=0x00
none2@pci1:0:0: class=0x030000 card=0x89481462 chip=0x028110de rev=0xa1 hdr=0x00
 

andras98

Well-Known Member
Themenstarter #7
vielleicht devices.hint?

hmm
kann ich ihm vielleicht mittels devices.hints einen tip geben wegen der grafikkarte?

mfg

andreas
 

asg

push it, don´t hype
#8
Re: ...

die nvidia treiber möcht ich nciht verwenden. es steht extra dort dass sie nicht für freebsd5.0 geeignet sind. (ausserdem haben sie immer mein system gefreezed)
Kann man verwenden. Läuft auf einer Maschine hier ohne Probleme.

Ist das PNP im BIOS ausgeschalten?

machine i386
cpu I486_CPU
cpu I586_CPU
cpu I686_CPU
ident GENERIC
maxusers 0
I468 und I586 kannst Du rausnehmen.
Bei ident solltest Du den Namen angeben, den Du auch Deiner Kernel-config Datei gegeben hast.

#To statically compile in device wiring instead of /boot/device.hints
#hints "GENERIC.hints" #Default places to look for devices.
makeoptions DEBUG=-g #Build kernel with gdb(1) debug symbols
Willst Du wirklich den debug Kram drin haben? Macht das System lahm und den Kernel gross. Raus mit.
Den anderen debug kram im kernel auch rausschmeissen.

Bevor ich es vergesse. Es wäre eventuell besser wenn Du 4.7 verwenden würdest da unter 5.0 immer noch Fehler drin sein könnten die einen regulären Betrieb stören und wenn man sich nicht auskennt einem das Leben schwer machen können.

#device agp # support several AGP chipsets
Warum ist das auskommentiert?

Wenn ich mich recht entsinne gab es
bei fm801 kompatiblen soundkarten mal ein Problem von 4.6 auf 4.7. In wie weit dieses Problem immer noch besteht kann ich nicht sagen.

Schau mal hier: http://freebsd.lanfear.com/scdb.html

Dort gibt es einen Eintrag zu Terratec Sound System der besagt das "pcm0" dem kernel hinzugefügt werden muss. Danach wird ein snd0 angelegt unter /dev.
 

asg

push it, don´t hype
#9
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection
Schau Dir mal meine XF86Config an (die mit "nv").
Dein "Screen 0..." sieht etwas seltsam aus, sollte so sein: Screen "Screen 0"

Section "Files"
EndSection
Was ist das?
Bitte schau Dir die Section "Files" in meiner geposteten XF86Config an.

Section "Module"
Load "xie"
Load "pex5"
Load "glx"
Load "dri"
Load "dbe"
Load "record"
Load "extmod"
Load "type1"
EndSection
Probier folgendes:

Section "Module"
Load "dbe"
SubSection "extmod"
Option "xfree86-dga"
EndSubSection
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Emulate3Buttons"
Option "Device" "/dev/sysmouse"
EndSection
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
Dafür dann "Emulate3Buttons" raus nehmen.

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc101"
Option "XkbLayout" "de"
EndSection
Driver "Keyboard"

Section "Monitor"
Identifier "Monitor0"
HorizSync 28 - 49
VertRefresh 50.0 - 60
EndSection
Das musst Du wissen...

Section "Device"
Identifier "Card0"
Driver "nv"
ChipSet "GeForce4 Ti 4200"
Card "NVidia GeForce4 Ti 4200"
EndSection
Hmmm.
Nimm ChipSet raus, ebenso Card.
Trage den VideoRam ein (64 MB --> 65536)

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
EndSection
Ok.

Probiere mal die Änderungen aus. Schaue Dir auch nochmals meine gepostete XF86Config an (für "nv").
Und dann probiere es damit aus.

Wenn es nicht geht, bitte den Fehler den X ausspuckt posten.
Und, nochmals, was macht das PNP im BIOS? Ist es aus?

Da fehlt "agp" und "pcm".
agp in den kernel mit rein, und pcm0 ausprobieren für Deine soundkarte.
 

andras98

Well-Known Member
Themenstarter #10
device pcm0

okay bau jetzt mal den kernel neu wie du beschrieben hast ...

device pcm0

devices with 0 are not likely be correct

habs deshalb wieder auf pcm geändert ...

im Bios ist PNP ausgeschalten ...

pass dann noch die xf86config an und schreib dann obs geht ;)

danke

andreas
 

asg

push it, don´t hype
#11
Hmm, mir kam das pcm0 auch etwas spanisch vor....
Evtl. muss man dabei
# For non-pnp sound cards with no bridge drivers only:
device pcm0 at isa? irq 10 drq 1 flags 0x0

angeben. Aber das ist ein Schuss ins Blaue.

Pack mal "agp" wieder mit rein in den kernel, pnp hast Du nun ja aus, XF86Config neu erstellen, und dann mal sehen.

Evtl. kannst Du ja auch "agp.ko" als Modul laden (über loader.conf --> agp_load="YES") und ersparst Dir damit den kernel bau.
 

andras98

Well-Known Member
Themenstarter #12
also ..

hab meine XF86config modifiziert....

ohne dem Chipseteintrag quitiert der xserver mit

(EE) no device found

pciconf -l

agp0@pci0:0:0: class=0x060000 card=0x00000000 chip=0x03051106 rev=0x02 hdr=0x00
pcib1@pci0:1:0: class=0x060400 card=0x00000080 chip=0x83051106 rev=0x00 hdr=0x01
isab0@pci0:7:0: class=0x060100 card=0x00001106 chip=0x06861106 rev=0x40 hdr=0x00
atapci0@pci0:7:1: class=0x01018a card=0x00000000 chip=0x05711106 rev=0x06 hdr=0x00
uhci0@pci0:7:2: class=0x0c0300 card=0x12340925 chip=0x30381106 rev=0x16 hdr=0x00
uhci1@pci0:7:3: class=0x0c0300 card=0x12340925 chip=0x30381106 rev=0x16 hdr=0x00
hostb0@pci0:7:4: class=0x060000 card=0x00000000 chip=0x30571106 rev=0x40 hdr=0x00
atapci1@pci0:9:0: class=0x018000 card=0x00011103 chip=0x00041103 rev=0x04 hdr=0x00
none0@pci0:10:0: class=0x040100 card=0x13191319 chip=0x08011319 rev=0xb2 hdr=0x00
none1@pci0:10:1: class=0x098000 card=0x13191319 chip=0x08021319 rev=0xb2 hdr=0x00
ahc0@pci0:12:0: class=0x010000 card=0x00000000 chip=0x61789004 rev=0x01 hdr=0x00
rl0@pci0:13:0: class=0x020000 card=0x813910ec chip=0x813910ec rev=0x10 hdr=0x00
ed0@pci0:14:0: class=0x020000 card=0x802910ec chip=0x802910ec rev=0x00 hdr=0x00
none2@pci1:0:0: class=0x030000 card=0x89481462 chip=0x028110de rev=0xa1 hdr=0x00

jetzt ist agp und pcm im kernel integriert
 

asg

push it, don´t hype
#13
Hmm.
Er erkennt gar keine Karte...
Komisch.

Hast Du schonmal "man nv" nachgesehen? Evtl. sagt das ja mehr.

XFree86 erkennt keine Karte...hmmm. Das sollte eigentlich nur noch ein kleines Problem sein diese in der XF86Config richtig einzutragen...

Zeigt der "dmesg -a" irgendwas an zu Deiner GeForce4 Nvidia?

Was macht der Server wenn der Chipset eingetragen ist? Mit was beendet er sich dann? Oder friert er dann ein?

Schau Dir das mal an: ftp://ftp.xfree86.org/pub/XFree86/snapshots/4.2.99.3/binaries/RELNOTES

Dort ist dann auch noch die BusID eingetragen, die Du über pciconf -l rausbekommst.

Welche XFree Version verwendest Du überhaupt?
 
Zuletzt bearbeitet:

andras98

Well-Known Member
Themenstarter #14
....

Hi,

also "man nv" geht nur bis geforce 3. Hab mein X11 aber mit xf86cfg -textmode eingestellt und da hat er mir die Geforce 4 Ti4200 angeboten mit "nv".

Im demsg kommt geforce/nvidia nicht vor.

Mit Chipset eintrag startet er ganz normal. Das Bild ist aber nicht erkennbar. Lauter bunte Linien ...
Aber laufen tut er brav.

An den Hz kanns ja nicht liegen. Hab einen TFT und brauch nur 60hz. Oder?

mfg

Andreas
 

asg

push it, don´t hype
#15
Das hatte ich auch irgendwann mal, das er nur streifen zeigte. Aber ich kann mich beim besten Willen nicht an die Lösung erinnern.
Sorry.
Ärgerlich.
Eventuell hilft nun groups.google.de oder google.de.

Ich tippe mal auf eine falsch eingestelle Monitor config. Spiel mal ein wenig mit rum.

Sorry, das hat alles nur noch mit XFree86 zu tun, da wird es sicher was bei google.de geben.
 

andras98

Well-Known Member
Themenstarter #16
danke

danke mal für die schnellen tips...

hmm die modelines hab ich auch schon oft verändert ... ich weiss echt nimma wie ... wennst googlst kommen immer nur nachrichten dass eben unter freebsd 5 die geforce 4 ein bischen holprig geht ...

die hz und vz werte hab ich aus der anleitung vom tft. was mich irritiert ist dass wenn ich "nvidia" als treiber verwende dann hab ich ein klares bild (er friert zwar nach ein paar minuten ein aber ich hab ein bild) => eigentlich müssten die modelines stimmen oder?

mfg

andreas
 

asg

push it, don´t hype
#17
Ich weiss im Moment auch nicht weiter, und der gleich bevorstehende Zahnarzttermin tut sein übriges bei dieser Denblockade :-(.

Probiere doch mal den NVIDIA Treiber von NVIDIA aus.
Hier mal ein link:

http://www.bsdforums.org/forums/showthread.php?threadid=5000

Wenn Du Zugriff auf newsgroups hast, dann frage doch mal in der Gruppe de.comp.os.unix.x11 nach. Da kennt man sicherlich schnell eine Antwort.

hth
 
Zuletzt bearbeitet: