• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

MiniDLNA: Permission denied

Themenstarter #1
Hellau Forum,

für unser kleines Heimnetzwerk wollte ich einen DLNA-Dienst aufsetzen und habe mich für MiniDLNA entschieden, weil unser TechniSat-DVBT2-Dekoder und unser T&A-Reciever damit umgehen können.

Die Installation als Package lief problemlos. Beim Start schreibt der Daemon folge Fehlermeldung ins Logfile:
minissdp.c:324: error: sendto(udp_notify=13, 192.168.1.202): Permission denied

Die Meldungen beim Start:
Code:
# minissdpd -d -i re0

minissdpd[55292]: ssdpDiscover: sendto: Permission denied
minissdpd[55292]: Unknown RTM message : rtm->rtm_type=15 len=144
Nach dem Start des MiniDLNA-Daemons:
Code:
minissdpd[55292]: (s=7) new request connection
minissdpd[55292]: (s=7) request type=4 str='uuid:4d696e69-444c-164e-9d41-901b0e26387a'
minissdpd[55292]: usn='uuid:4d696e69-444c-164e-9d41-901b0e26387a::uuid:4d696e69-444c-164e-9d41-901b0e26387a'
minissdpd[55292]: server='11.3-RELEASE-p6 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1'
minissdpd[55292]: location='http://192.168.1.202:8200/rootDesc.xml'
minissdpd[55292]: (s=7) request type=4 str='upnp:rootdevice1'
minissdpd[55292]: usn='uuid:4d696e69-444c-164e-9d41-901b0e26387a::upnp:rootdevice1'
minissdpd[55292]: server='11.3-RELEASE-p6 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1'
minissdpd[55292]: location='http://192.168.1.202:8200/rootDesc.xml'
minissdpd[55292]: (s=7) request type=4 str='urn:schemas-upnp-org:device:MediaServer:1'
minissdpd[55292]: usn='uuid:4d696e69-444c-164e-9d41-901b0e26387a::urn:schemas-upnp-org:device:MediaServer:1'
minissdpd[55292]: server='11.3-RELEASE-p6 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1'
minissdpd[55292]: location='http://192.168.1.202:8200/rootDesc.xml'
minissdpd[55292]: (s=7) request type=4 str='urn:schemas-upnp-org:service:ContentDirectory:1'
minissdpd[55292]: usn='uuid:4d696e69-444c-164e-9d41-901b0e26387a::urn:schemas-upnp-org:service:ContentDirectory:1'
minissdpd[55292]: server='11.3-RELEASE-p6 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1'
minissdpd[55292]: location='http://192.168.1.202:8200/rootDesc.xml'
minissdpd[55292]: (s=7) request type=4 str='urn:schemas-upnp-org:service:ConnectionManager:1'
minissdpd[55292]: usn='uuid:4d696e69-444c-164e-9d41-901b0e26387a::urn:schemas-upnp-org:service:ConnectionManager:1'
minissdpd[55292]: server='11.3-RELEASE-p6 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1'
minissdpd[55292]: location='http://192.168.1.202:8200/rootDesc.xml'
minissdpd[55292]: (s=7) request type=4 str='urn:microsoft.com:service:X_MS_MediaReceiverRegistrar:1'
minissdpd[55292]: usn='uuid:4d696e69-444c-164e-9d41-901b0e26387a::urn:microsoft.com:service:X_MS_MediaReceiverRegistrar:1'
minissdpd[55292]: server='11.3-RELEASE-p6 DLNADOC/1.50 UPnP/1.0 MiniDLNA/1.2.1'
minissdpd[55292]: location='http://192.168.1.202:8200/rootDesc.xml'
minissdpd[55292]: (s=7) request connection closed
Code:
# minidlnad -d -f /usr/local/etc/minidlna.conf

minissdp.c:132: error: bind(udp): Address already in use
minidlna.c:1164: info: Failed to open socket for receiving SSDP. Trying to use MiniSSDPd
minissdp.c:85: error: setsockopt(udp, IP_ADD_MEMBERSHIP): Bad file descriptor
minissdp.c:199: warn: Failed to add multicast membership for address 192.168.1.202
getifaddr.c:343: info: Enabling interface 192.168.1.202/255.255.255.0
minissdp.c:811: maxdebug: Sending ssdp:byebye [12]
minissdp.c:816: error: sendto(udp_shutdown=12): Permission denied
minissdp.c:811: maxdebug: Sending ssdp:byebye [12]
minissdp.c:816: error: sendto(udp_shutdown=12): Permission denied
minissdp.c:320: maxdebug: Sending ssdp:alive [12]
minissdp.c:324: error: sendto(udp_notify=12, 192.168.1.202): Permission denied
minissdp.c:320: maxdebug: Sending ssdp:alive [12]
[... letzte beiden Zeilen 10 mal wiederholt]
minidlna.c:1179: warn: HTTP listening on port 8200
kqueue.c:111: debug: kqueue_add 13
minissdp.c:85: error: setsockopt(udp, IP_ADD_MEMBERSHIP): Bad file descriptor
minissdp.c:199: warn: Failed to add multicast membership for address 192.168.1.202
kqueue.c:193: debug: kevent timer: 900.000000, changes: 7
Hier die Konfigurationsdatei des MiniDLNA-Daemons:
Code:
port=8200
network_interface=re0
user=dlna
media_dir=V,/home/mediabox/media/Video
media_dir=A,/home/mediabox/media/Audio
media_dir=P,/home/mediabox/media/Pictures
#merge_media_dirs=no
friendly_name=FreeBSD Mediabox
db_dir=/home/mediabox/db
#log_dir=/var/log
#log_level=general,artwork,database,inotify,scanner,metadata,http,ssdp,tivo=warn
album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Th
inotify=yes
enable_tivo=no
tivo_discovery=bonjour
strict_dlna=no
#presentation_url=http://www.mylan/index.php
notify_interval=900
serial=12345678
model_number=1
# uuid=550e8400-e29b-41d4-a716-446655440000
#minissdpdsocket=/var/run/minissdpd.sock
#root_container=.
#force_sort_criteria=+upnp:class,+upnp:originalTrackNumber,+dc:title
#max_connections=50
#wide_links=no
#enable_subtitles=yes
Irgendwelche Berechtigungen für irgendwas sind nicht korrekt, aber für was? Wie kann ich den Fehler beheben?
Der Dienst wird von keinem Gerät gefunden (wen wunderts), aber die Weboberfläche des DLNA-Dienstes wird angezeigt.

Die Versionen sind minidlna-1.2.1_6,1 und minissdpd-1.5.20180223.
 

medV2

Well-Known Member
#3
Das Log sagt address in use - aber das kann auch daher kommen, dass du ihn zu oft gestartet hast bei deinen Versuchen.
Minidlna braucht: 1900 UDP und 8200 TCP und noch irgend einen UDP highport.

An deiner Config ist mir noch aufgefallen, dass du das DB - Dir in das /home/mediabox gesetzt hast. Default ist hier /var/db. Hat dein dlna-User hier rechte?
Du startest den Dienst als root, ansonsten geht auch einiges schief, die Rechte werden dann automatisch gedroppt auf den in der config beschriebenen User.
 
Themenstarter #4
Hallo,

danke für die Antworten.

@KobRheTilla : das wars:rolleyes: Ich dachte, dass ich eine entsprechende Regel gesetzt habe, aber dem war doch nicht so...
@medV2 : Sowohl minidlna als auch minissdsd wurden nur einmal gestartet. Die Verzeichnisse haben die passenden Berechtigungen.

Für das Protokoll: es war eine fehlende IPFW-Regel.

Sorry für den Datenverkehr...

PS: Sowohl der TechniSat-Dekoder als auch der T&A-Receiver "sehen" die Mediabox und die Videos/Musik lassen sich problemlos abspielen
 
Themenstarter #6
Ich hab ja selbst minidlna, meiner startet auch wenn ich udp komplett blocke :)
Ich würd da nochmal drübersehen.
Danke für Deine Hilfe

Das Starten ist nicht das Problem, das geht bei mir auch. Nur werden die genannten Ferhlermeldungen geworfen.
Desweiteren ist die Konfiguration ist in Ordnung: alle Ordner sind vorhanden, alle Berechtigungen sind passend gesetzt und in den Verzeichnissen ist auch der zu erwartende Inhalt.

Wenn ich UDP blocke, geht nix mehr und die genannten Fehlermeldungen kommen. Wenn die Firewall offen ist (firewall_type='open'), dann funktioniert alles wie es soll. Alle Clients im Netzwerk finden den DLNA-Server und können mit ihm kommunizieren.
Am Wochenende werde ich mich um die Firewall kümmern.