• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

NAT, PPPOE und JAIL auf einem Server

marzl

Well-Known Member
Themenstarter #1
Hi,

habe hier ein klitzekleines Problem und ich weiss grad nich weiter:

Server hat folgende IP'S:
Das Jail hat die 80, wo auc h der webserver drin laufen soll.

Code:
xl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=b<RXCSUM,TXCSUM,VLAN_MTU>
        inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
        inet 192.168.1.80 netmask 0xffffffff broadcast 192.168.1.80
        ether 00:50:04:52:6e:51
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
im hauptsystem läuft ein caching dns und pppoe zur telekom.
das ding läuft erste sahne, alle normalen clients connecten sich ins internet.
nur das jail macht probleme. :(
auch von aussen kann die welt per natd_redirect auf das ding zugreifen.
aus dem jail raus komm ich auf den dns (resolv.conf 192.168.1.1) aber leider nicht weiter.
ein "telnet www.heise.de 80" endet im timeout. der dns wird vorher aber noch korrekt aufgelößt.

ich glaube das problem liegt in einer falschen route:

Code:
wwwjail# netstat -rn
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            217.5.98.148       UGS         0      791   tun0
127.0.0.1          127.0.0.1          UH          0       52    lo0
192.168.1          link#2             UC          0        0    xl0
192.168.1.1        00:50:04:52:6e:51  UHLW        0       47    lo0
192.168.1.80       00:50:04:52:6e:51  UHLW        0       37    lo0 =>
192.168.1.80/32    link#2             UC          0        0    xl0
192.168.1.88/32    link#2             UC          0        0    xl0
192.168.1.255      ff:ff:ff:ff:ff:ff  UHLWb       0       27    xl0
217.5.98.148       80.140.218.13      UH          1        0   tun0
wie bekomm ich das jail nun dazu ins internetz zu gehen?

jemand ne idee? wo hab ich den kleinen teufel übersehen? :apaul:
 
J

juedan

Guest
#3
Moooin marzl,

marzl hat gesagt.:
buhhh keiner ne idee? :) *pusch*
Schreibt telnet zufällig
"connected to www.heise.de
Escape character is '^]'" ?

Dann is ja alles gut: der wartet auf einen Befehl von Dir :D

Gib mal "get http" ein und guck Dir das Ergebnis an :D

Viele Grüße

Jürgen
 

marzl

Well-Known Member
Themenstarter #6
nein, die jail übernimmt den gateway des hosts.
in der rc.conf eingetragen ist die 192.168.1.1
 

marzl

Well-Known Member
Themenstarter #9
jaaa, wie kann ich dem nu beibringen das das die falsche route ist?
den rc.conf eintrag übersieht er ja ansceinend?

Code:
hostname="wwwjail.bsdbox.de"
ifconfig_xl0=""
defaultrouter="192.168.1.1"
 

marzl

Well-Known Member
Themenstarter #11
wenn ich den weglasse übernimmt er auch die route des hosts. hab ich schon probiert.
ohne default-eintrag war eigentlich der normalzustand. :)
 

asg

push it, don´t hype
#12
Ich habe in meinen Jails keinen defaultrouter stehen, und auch nicht im hostsystem. Konstellation wie bei Dir, soll heissen, PPPoE (via kamp), auf xl0 das GW für die internen Rechner (also gateway_enable="YES") auf dem Hostsystem, die IPs der Jails als alias auch auf xl0, rl0 geht zum DLS Modem.
 

marzl

Well-Known Member
Themenstarter #13
hast du in deiner ppp.conf dein "add default HISADDR" eintrag?

nachtrag:
gateway_enable="YES" im host ist/war aktiviert.
 
Zuletzt bearbeitet:

asg

push it, don´t hype
#14
encephalon:
set device PPPoE:rl0
set mtu max 1460
set mru max 1460
set dial
set crtscts off
set speed sync
accept lqr
disable iface-alias
disable deflate
disable pred1
disable vjcomp
disable acfcomp
disable protocomp
set log Phase LCP IPCP CCP Warning Error Alert
set ifaddr $Meine_statische_IP 0.0.0.0 0.0.0.0
add default HISADDR
set login
# Anschlusskennung
set authname $mein_auth_name
set authkey $mein_passwort
 

marzl

Well-Known Member
Themenstarter #15
mhm, och menno. warum hab ich immer son scheiss :) ?
die jails stecken ja sogar im selben netz und sind astrein von aussen erreichbar...

ich vermute es ist diese fehlerhafte route. wie kann ich die in den jails selber auf den host einstellen? im moment zeigen die ja anscheinend auf den gw des providers.

zur erinennerung:
Code:
> netstat -rn
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            217.5.98.148       UGS         0   113478   tun0
127.0.0.1          127.0.0.1          UH          0      269    lo0
192.168.1          link#2             UC          0        0    xl0
192.168.1.1        00:50:04:52:6e:51  UHLW        0       96    lo0
oder wie sieht deine route aus asg?
 
Zuletzt bearbeitet:

asg

push it, don´t hype
#16
Mein "netstat -rn":
Code:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            195.62.99.234      UGS         0  1358068   tun0
127.0.0.1          127.0.0.1          UH          0      639    lo0
192.168.0          link#2             UC          0        0    xl0
192.168.0.200      00:01:02:16:e1:38  UHLW        0   266134    lo0 =>
192.168.0.200/32   link#2             UC          0        0    xl0
192.168.0.201      00:01:02:16:e1:38  UHLW        0     1153    lo0 =>
192.168.0.201/32   link#2             UC          0        0    xl0
192.168.0.202      00:01:02:16:e1:38  UHLW        0      648    lo0 =>
192.168.0.202/32   link#2             UC          0        0    xl0
192.168.0.255      ff:ff:ff:ff:ff:ff  UHLWb       0    45970    xl0
192.168.1          link#3             UC          0        0   ath0
192.168.1.254      00:09:5b:89:ab:5d  UHLW        0        4    lo0
192.168.1.255      ff:ff:ff:ff:ff:ff  UHLWb       0    45970   ath0
195.62.99.234      213.146.112.85     UH          1        0   tun0
Ist mit Deinem vergleichbar, daher sollte Deines auch richtig sein, zumindest funktioniert es bei mir.
192.168.0.20x sind die Jails.
192.168.1.254 das GW, bzw. mein AP für mein iBook.
213.146.112.85 meine statische IP
195.62.99.234 GW kamp


Firewall eingeschalten?
Falsche natd.conf Konfig?
 
J

juedan

Guest
#17
Hallo marzl,

meine Frage von vorhin war Ernst gemeint!
Was schreibt denn telnet ganz genau?

Du bist warscheinlich schon auf dem Server und der erwartet weitere Anweisungen von Dir!
Der timeout kommt halt, weil er keine Anweisungen bekommt.

Grüße

Jürgen
 
Zuletzt bearbeitet von einem Moderator:
J

juedan

Guest
#18
Hallo asg,

asg hat gesagt.:
Mein "netstat -rn": ...
Bei mir bringt obige Anweisung nur folgendes zu Tage (FreeBSD 4.9):


www# netstat -rn
Routing tables
netstat: short read
www#

Es funtkioniert aber alles bestens! Die Jail ist 100% erreichbar, ssh geht, hmmm.
Meine Frage was hat das zu bedeuten?

Grüße

Jürgen
 

marzl

Well-Known Member
Themenstarter #19
erreichbar ist die jail ja. (seht selber :) http://www.bsdbox.de )

Du bist warscheinlich schon auf dem Server und der erwartet weitere Anweisungen von Dir! Der timeout kommt halt, weil er keine Anweisungen bekommt.
ein telnet funktioniert definitiv nicht.
der timeout kommt wegen nichterreichbarkeit zu stande :) auch ein ftp oder ssh zu einem anderen host schlägt fehl.
 

marzl

Well-Known Member
Themenstarter #20
192.168.0.20x sind die Jails.
192.168.1.254 das GW, bzw. mein AP für mein iBook.
213.146.112.85 meine statische IP
195.62.99.234 GW kamp
192.168.1.x sind die Jails.
192.168.1.1 das GW, bzw. der server selber

muss das jail in nem anderen netz sein? ne, oder?
 

marzl

Well-Known Member
Themenstarter #21
AHAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
ich HASSSE Firewalls *ichdepp*

hab mal firewall_type="open" eingestelle und nu gehts :)
grml......
ABER: asg! jetzt weiss ich das problem bei ocr :))))))))

thx euch all!