• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Nvidia-Treiber bringt die Eiszeit

Ginku

Well-Known Member
Themenstarter #1
Hallo,

hat jemand von Euch den Nvidia-Treiber sauber laufen ? Ich bin hier ziemlich ratlos... Habs genau gemacht, wie im Readme von Nvidia beschrieben -> option USER_LDT in den Kernel einkompiliert -> den Treiber runtergeladen -> make setup (sauber durchgelaufen und Modul geladen) -> und XF86Config entsprechend angepasst -> nach dem Reboot friert jetzt jedesmal die Kiste ein - aber richtig !! Ich sehe noch das Nvidia-Logo, dann startet der X-Server und Frost..nichts geht mehr außer Stecker ziehen...Kennt jemand das Symptom ? Leider ist die 3D-Beschleunigung für mich als passionierten BZFlagger ein absolutes K.O.-Kriterium - wäre sehr schade, wenn ich mich schon wieder von FreeBSD verabscheiden müsste (unter Linux läufts).

Bin für jede Vermutung dankbar..

Grüße

Ginku
 
#2
Original geschrieben von Ginku
Hallo,

hat jemand von Euch den Nvidia-Treiber sauber laufen ? Ich bin hier ziemlich ratlos... Habs genau gemacht, wie im Readme von Nvidia beschrieben -> option USER_LDT in den Kernel einkompiliert -> den Treiber runtergeladen -> make setup (sauber durchgelaufen und Modul geladen) -> und XF86Config entsprechend angepasst -> nach dem Reboot friert jetzt jedesmal die Kiste ein - aber richtig !! Ich sehe noch das Nvidia-Logo, dann startet der X-Server und Frost..nichts geht mehr außer Stecker ziehen...Kennt jemand das Symptom ? Leider ist die 3D-Beschleunigung für mich als passionierten BZFlagger ein absolutes K.O.-Kriterium - wäre sehr schade, wenn ich mich schon wieder von FreeBSD verabscheiden müsste (unter Linux läufts).

Bin für jede Vermutung dankbar..

Grüße

Ginku
Welches FreeBSD Version?
Hast du irgendwas mit device agp im Kernel?

Leider ist der Treiber schon lang nicht mehr upgedated worden - und dementsprechend buggy wie am ersten Tag.

Gruß
 

asg

push it, don´t hype
#3
Wenn Du FreeBSD 5 nutzt, musst Du einen hack machen, sonst wird das nichts, habe ich aber schonmal hier gepostet, such danach.
 

Ginku

Well-Known Member
Themenstarter #4
Re: Re: Nvidia-Treiber bringt die Eiszeit

Welches FreeBSD Version?
Hast du irgendwas mit device agp im Kernel?
Danke saintjoe, grunix,

ich habe 4.8 installiert. Müsste das "device agp" -sofern vorhanden- rausgenommen werden ?

Grüße

Ginku
 
#5
Unter der 5.0er hatte der NVidia Treiber bei mir mit device agp im Kernel auch massive Probleme verursacht - von daher, nimms einfach mal raus, und schau was passiert!

Gruß
 
#7
Hatte das gleiche Problem unter -CURRENT (unter -STABLE lief der Treiber auf Anhieb). Jedenfall sollte dein Kernel "device agp" haben, den Treiber kannst du dir mittels /usr/ports/x11/nvidia-driver installieren (der patcht das dann entsprechend). Ausserdem musste ich das ganze mit FREEBSD_AGP kompilieren und Option NvAGP 2 in der XF86Config setzen (damit wird der FreeBSD AGP verwendet, welche fuer mich unter -CURRENT funktioniert), andernfalls wird der Nvidia AGP verwendet (welche unter -CURRENT wohl seltener funktioniert)
 

Ginku

Well-Known Member
Themenstarter #8
Original geschrieben von MrFixit
Hatte das gleiche Problem unter -CURRENT (unter -STABLE lief der Treiber auf Anhieb)


Vielen Dank MrFixit, klingt irgendwie gut :-)

Was'n -CURRENT und -STABLE ? 5.0 bzw. 4.8 ?

Wenn ich den Treiber nochmal als port einspiele, müsste ich vorher den per NVIDIA Routine eingespielten Treiber deinstallieren ? Weiss jemand , wie das geht ? Das README gibt in der Richtung nichts her ...

:D Ginku
 

Ginku

Well-Known Member
Themenstarter #12
Problem gelöst

Moin zusammen,

ich war schon fleißig am Tag der Arbeit und habe das NVIDIA-Forum durchforstet:
Der einfrierende X-Server -speziell bei 4.8.- scheint eine nicht nur bei mir auftretende Erscheinung zu sein. Im Moment helfe ich mir mit folgendem Trick:

System booten / X-Server starten (ohne Window Manager nur per Eingabe von X am Prompt, also wirklich nur den Großbuchstaben X und enter) / und, sobald die typische X-Oberfläche erscheint, diese mit strg + alt + backspace wieder abschießen / dann normal mit startx bzw. kdm starten.
Ich weiss net, was da vor sich geht, aber es funzt :-) Hab' gleich mal ne Runde BZFlag gedaddelt.

Vielleicht hilfts ja irgend jemand anderem noch....

Ginku
 
#13
Also bei mir läufts wunderbar.
Hab auch FreeBSD 4.8

Code:
$ uname -sr
FreeBSD 4.8-RELEASE
$ dmesg | grep nvidia
Preloaded elf module "nvidia.ko" at 0xc058f318.
nvidia0: <GeForce4 440 Go> mem 0xdff80000-0xdfffffff,0xe0000000-0xe7ffffff,0xfc000000-0xfcffffff irq 11 at device 0.0 on pci1
Hast du XFree86 "von Hand" installiert?
Ich hab alles mit den neuesten Ports installiert.
startx oder so brauch ich nicht, hab gdm, ein "grafisches" Login.

greets

[tE]bachi
 

Ginku

Well-Known Member
Themenstarter #14
Nö - hab' mir das ISO-Image gezogen und installiert. Mit dem kleinen Schlenker kann ich aber leben.

Grüße

Ginku