OpenBSD auf einem Dell Latitude E5420

drm

Well-Known Member
Hab gerade den letzten Snapshot (amd64 vom 10.1.2012) auf meinem neuen Dell Latitude E5420 installiert und wollte mal berichten, was funktioniert. Zuerst ein paar Daten zum Laptop:

  • Intel Core i5-2520M
  • 8 GB RAM
  • Display: 1600x900 (HD) mit integrierter Webcam (Ricoh 05ca:181e)
  • eSATA, USB2.0, HDMI, VGA
  • LAN: Broadcom BCM5761
  • WLAN: Intel Centrino Ultimate-N 6300

Ich hab mich extra fuer -current entschieden, da seit dem 21.12. grundlegender Support fuer die SandyBridge Graphik vorhanden ist: http://marc.info/?l=openbsd-cvs&m=132450293804369&w=2. Achtung: Sobald man den XServer startet, kann beim Wechseln auf die Konsole kein Bild mehr angezeigt werden, sodass u.a. Meldungen beim Shutdown nicht mehr sichtbar sind.

Die Installation verlief absolut problemlos, beim ersten Reboot wurden Firmware-Dateien fuer die WLAN-Karte und die Webcam automatisch nachgeladen.

Das 'Linux' (s.u.) ist ein Arch Linux, dass soweit auf dem neusten 'Entwicklungsstand' ist. Trotzdem gibt es auch unter Arch Linux viele Dinge, die noch nicht so richtig laufen, wirklich in der Funktionalitaet unterscheiden sich Arch Linux und OpenBSD nur beim 3D-Support fuer Sandybridge (KMS), ein paar fn-Tasten und wahrscheinlich beim Bluetooth-Support. Alles in allem werden die wichtigsten Dinge sowohl unter Arch Linux als auch unter OpenBSD direkt unterstuetzt, allerdings gibt es noch ein paar Kleinigkeiten, die hoffentlich bald beseitigt werden.

Vielleicht ist diese Liste ja fuer jemanden hilfreich :)


Funktioniert:

Funktioniert nicht:
  • 3D
  • Card Reader von O2 Micro (nicht getestet, unter Linux erscheint beim Boot auch immer ein Problem mit dem Reader):
    Code:
    sdhc0 at pci4 dev 0 function 0 vendor "O2 Micro", unknown product 0x8321 rev 0x05: apic 2 int 17
    vendor "O2 Micro", unknown product 0x8331 (class mass storage subclass miscellaneous, rev 0x05) at pci4 dev 0 function 1 not configured
  • fn-Keys: Numpad, Displayhelligkeit (hat auch unter Linux Probleme, kann aber per Kernelparameter berichtigt werden), Touchpad abstellen (geht auch unter Linux nicht)
  • ALPS Touchpad: wird erkannt, kann aber nicht scrollen (noch nicht weiter getestet). Kann direkt tap-to-click. Unter Linux nur mit psmouse-elantech http://aur.archlinux.org/packages.php?ID=51343 zum scrollen animierbar.

Nicht getestet:
  • Bluetooth
  • HDMI (wird von xrandr erkannt)
  • FireWire

dmesg:
Code:
OpenBSD 5.0-current (GENERIC.MP) #172: Tue Jan 10 10:09:09 MST 2012
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
RTC BIOS diagnostic error 3f<config_unit,memory_size,fixed_disk,invalid_time>
real mem = 8481353728 (8088MB)
avail mem = 8241434624 (7859MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.6 @ 0xf20b0 (81 entries)
bios0: vendor Dell Inc. version "A02" date 07/10/2011
bios0: Dell Inc. Latitude E5420
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP APIC TCPA SSDT ASF! MCFG HPET BOOT SSDT SSDT DMAR
acpi0: wakeup devices UAR1(S3) HDEF(S4) PXSX(S4) RP01(S4) PXSX(S4) RP02(S4) PXSX(S4) RP04(S4) PXSX(S4) RP05(S4) PXSX(S4) RP06(S4) PXSX(S4) RP07(S4) PXSX(S4) RP08(S4) PEG0(S4) PEGP(S4) PEG1(S4) GLAN(S4) PEG2(S4) PEG3(S4) PXSX(S4) RP03(S4) EHC2(S1) EHCI(S1) LID_(S3) PBTN(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2494.72 MHz
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,x2APIC,POPCNT,AES,XSAVE,AVX,NXE,LONG,LAHF
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: apic clock running at 99MHz
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2494.34 MHz
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,x2APIC,POPCNT,AES,XSAVE,AVX,NXE,LONG,LAHF
cpu1: 256KB 64b/line 8-way L2 cache
cpu2 at mainbus0: apid 1 (application processor)
cpu2: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2494.34 MHz
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,x2APIC,POPCNT,AES,XSAVE,AVX,NXE,LONG,LAHF
cpu2: 256KB 64b/line 8-way L2 cache
cpu3 at mainbus0: apid 3 (application processor)
cpu3: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz, 2494.34 MHz
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,x2APIC,POPCNT,AES,XSAVE,AVX,NXE,LONG,LAHF
cpu3: 256KB 64b/line 8-way L2 cache
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (P0P1)
acpiprt2 at acpi0: bus 1 (RP01)
acpiprt3 at acpi0: bus 2 (RP02)
acpiprt4 at acpi0: bus -1 (RP04)
acpiprt5 at acpi0: bus -1 (RP05)
acpiprt6 at acpi0: bus 9 (RP06)
acpiprt7 at acpi0: bus 10 (RP07)
acpiprt8 at acpi0: bus -1 (RP08)
acpiprt9 at acpi0: bus -1 (PEG0)
acpiprt10 at acpi0: bus -1 (PEG1)
acpiprt11 at acpi0: bus -1 (PEG2)
acpiprt12 at acpi0: bus -1 (PEG3)
acpiprt13 at acpi0: bus 3 (RP03)
acpiec0 at acpi0
acpicpu0 at acpi0: C3, C2, C1, PSS
acpicpu1 at acpi0: C3, C2, C1, PSS
acpicpu2 at acpi0: C3, C2, C1, PSS
acpicpu3 at acpi0: C3, C2, C1, PSS
acpitz0 at acpi0: critical temperature is 107 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PBTN
acpibtn2 at acpi0: SBTN
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "DELL 5CGM41B" serial 2529 type LION oem "Samsung SDI"
acpibat1 at acpi0: BAT1 not present
acpibat2 at acpi0: BAT2 not present
acpivideo0 at acpi0: VID_
acpivout0 at acpivideo0: LCD_
cpu0: Enhanced SpeedStep 2494 MHz: speeds: 2501, 2500, 2200, 2000, 1800, 1600, 1400, 1200, 1000, 800 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 2G Host" rev 0x09
vga1 at pci0 dev 2 function 0 "Intel GT2+ Video" rev 0x09
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xd0000000, size 0x10000000
inteldrm0 at vga1: apic 2 int 16
drm0 at inteldrm0
"Intel 6 Series MEI" rev 0x04 at pci0 dev 22 function 0 not configured
ehci0 at pci0 dev 26 function 0 "Intel 6 Series USB" rev 0x04: apic 2 int 16
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 6 Series HD Audio" rev 0x04: msi
azalia0: codecs: IDT/0x76e7, Intel/0x2805, using IDT/0x76e7
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 6 Series PCIE" rev 0xb4: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 28 function 1 "Intel 6 Series PCIE" rev 0xb4: msi
pci2 at ppb1 bus 2
iwn0 at pci2 dev 0 function 0 "Intel Centrino Ultimate-N 6300" rev 0x35: msi, MIMO 3T3R, MoW, address 24:77:03:31:e4:08
ppb2 at pci0 dev 28 function 2 "Intel 6 Series PCIE" rev 0xb4: msi
pci3 at ppb2 bus 3
ppb3 at pci0 dev 28 function 5 "Intel 6 Series PCIE" rev 0xb4: msi
pci4 at ppb3 bus 9
sdhc0 at pci4 dev 0 function 0 vendor "O2 Micro", unknown product 0x8321 rev 0x05: apic 2 int 17
sdmmc0 at sdhc0
vendor "O2 Micro", unknown product 0x8331 (class mass storage subclass miscellaneous, rev 0x05) at pci4 dev 0 function 1 not configured
ppb4 at pci0 dev 28 function 6 "Intel 6 Series PCIE" rev 0xb4: msi
pci5 at ppb4 bus 10
bge0 at pci5 dev 0 function 0 "Broadcom BCM5761" rev 0x10, BCM5761 A1 (0x5761100): apic 2 int 18, address d0:67:e5:3f:e4:62
brgphy0 at bge0 phy 1: BCM5761 10/100/1000baseT PHY, rev. 0
ehci1 at pci0 dev 29 function 0 "Intel 6 Series USB" rev 0x04: apic 2 int 17
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
pcib0 at pci0 dev 31 function 0 "Intel HM65 LPC" rev 0x04
ahci0 at pci0 dev 31 function 2 "Intel 6 Series AHCI" rev 0x04: msi, AHCI 1.3
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, ST9500423AS, 0002> SCSI3 0/direct fixed naa.5000c50044b25dcc
sd0: 476940MB, 512 bytes/sector, 976773168 sectors
cd0 at scsibus0 targ 1 lun 0: <HL-DT-ST, DVD+-RW GT50N, A101> ATAPI 5/cdrom removable
sd1 at scsibus0 targ 4 lun 0: <ATA, Hitachi HDS72505, K2AK> SCSI3 0/direct fixed naa.5000cca20dd7ade1
sd1: 476940MB, 512 bytes/sector, 976773168 sectors
ichiic0 at pci0 dev 31 function 3 "Intel 6 Series SMBus" rev 0x04: apic 2 int 18
iic0 at ichiic0
lisa0 at iic0 addr 0x1d: lis331dl
spdmem0 at iic0 addr 0x50: 4GB DDR3 SDRAM PC3-10600 SO-DIMM
spdmem1 at iic0 addr 0x52: 4GB DDR3 SDRAM PC3-10600 SO-DIMM
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
mtrr: Pentium Pro MTRR support
uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uvideo0 at uhub2 port 4 configuration 1 interface 0 "CN0CJ3P2724871B6C51AA00 Laptop_Integrated_Webcam_FHD" rev 2.00/11.25 addr 3
video0 at uvideo0
uhub3 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
ugen0 at uhub3 port 6 "Dell Computer Corp DW375 Bluetooth Module" rev 2.00/5.17 addr 3
vscsi0 at root
scsibus1 at vscsi0: 256 targets
softraid0 at root
scsibus2 at softraid0: 256 targets
root on sd0a (1162fc86d2c911d7.a) swap on sd0b dump on sd0b
 
Zuletzt bearbeitet:

DSBusr

Digilog native
Sobald man den XServer startet, kann beim Wechseln auf die Konsole kein Bild mehr angezeigt werden, sodass u.a. Meldungen beim Shutdown nicht mehr sichtbar sind.

Hallo,
das Verhalten hatte ich auch schon auf verschiedenen (älteren) Dell Geräten. Konkret erinnere ich mich an einen Dell Optiplex 330 mit OpenBSD 5.0 i386.
Bei manchen geht es, wenn man vom X11 aus auf die zweite Konsole schaltet.
Kernel Meldungen sieht man zwar da nicht direkt, aber man hat zumindest eine Konsole.
Ob das jetzt konkret an Dell liegt weiß ich nicht. Woanders ist es mir aber noch nicht passiert.

Grüße
Mario
 

DSBusr

Digilog native
Hallo drm,
der Dell Optiplex, von dem ich schrieb, ist ein älterer Celeron-basierter Desktop.
Da ist kein Sandy Bridge drin. Aber Onboardgrafik von Intel schon. Vielleicht liegt es an den Treiberanpassungen, die dann aber anscheinend auch bei Vorgängersystemen Probleme machen.

Grüße
Mario
 
Oben