OpenBSD - DRM Plugin fehlt? (Browser)

Ich kann ploetzlich auf Firefox keinen protected content mehr ansehen (Spotify, Netflix und Udemy etc.)

Dachte es liegt an einem firefox Update aber auf Chromium sowie auf iridium gehts auch nicht mehr.

Die error codes bringen mich auch nicht weiter. Ich habe aber herausgefunden das mir ein DRM Plugin fehlt. Deinstalliert habe ich nichts.

Und gemaess https://www.reddit.com/r/openbsd/comments/8i8u4q/drm_in_openbsd_firefox_for_netlflix/ gibts das auf openbsd nicht.

Weiss jmd. an was das liegen koennte?

Danke fuer eure Hilfe im vorraus.
 

midnight

OpenBSD & FreeBSD
Ich kann ploetzlich auf Firefox keinen protected content mehr ansehen (Spotify, Netflix und Udemy etc.)
Weiss jmd. an was das liegen koennte?

Mich verwirrt deine Frage etwas, denn unter OpenBSD konnte man noch nie Netflix schauen. Das DRM-Plugin ist und war schon immer Linux-only und funktioniert nicht nativ unter *BSD.

Unter FreeBSD kannst Du z.B. die Linux-Version von Google Chrome unter der Linux-Emulation installieren. Dort funktionert es dann, siehe: https://github.com/mrclksr/linux-browser-installer

Ich meine gelesen zu haben, dass man unter FreeBSD auch was mit Wine tricksen kann. Alle diese Moeglichkeiten funktionieren allerdings nicht unter OpenBSD, denn dort gibt es keine Linux-Emulation und auch kein Wine.
 

delta117

Well-Known Member
Die error codes bringen mich auch nicht weiter. Ich habe aber herausgefunden das mir ein DRM Plugin fehlt. Deinstalliert habe ich nich
Der Support Artikel von Udemy sagt das ein Plugin fehlt und zwar "Widevine Content Decryption Modul" ab Chrome 90 [wie schon midnight bemerkte].

Hatte das Problem unter Ubuntu auch weil bei Chromium das besagte Modul fehlt.
 
Oben