• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

picard oder hplip - Python 3 oder Python 2

Themenstarter #1
Hallo,

hat jemand ein Idee wie man picard (MusicBrainz) nutzen und drucken kann. Python wieder.
Wahrscheinlich ist es einfacher, man schafft Python 3 aus Gründen der Kompatibilität wieder ab. Python 2 wird wohl noch ewig weiter bestehen.
Ein Ende von Python 2 ist nicht in Sicht.

# pkg install hplip
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking integrity... done (3 conflicting)
- py27-qt5-widgets-5.9.2_5 conflicts with py36-qt5-widgets-5.9.2_5 on /usr/local/share/py-sip/PyQt5/QtWidgets/QtWidgetsmod.sip
- py27-qt5-gui-5.9.2_2 conflicts with py36-qt5-gui-5.9.2_2 on /usr/local/share/py-sip/PyQt5/QtGui/QtGuimod.sip
- py27-qt5-core-5.9.2_6 conflicts with py36-qt5-core-5.9.2_6 on /usr/local/bin/pyuic5
Checking integrity... done (0 conflicting)
The following 10 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
picard-2.0.4
py36-qt5-widgets-5.9.2_5
py36-qt5-gui-5.9.2_2
py36-qt5-core-5.9.2_6
py36-qt5-network-5.9.2_5

New packages to be INSTALLED:
hplip: 3.17.11
py27-qt5-widgets: 5.9.2_5
py27-qt5-gui: 5.9.2_2
py27-qt5-core: 5.9.2_6

Installed packages to be REINSTALLED:
pkg-1.10.5_5

Number of packages to be removed: 5
Number of packages to be installed: 4
Number of packages to be reinstalled: 1

The process will require 16 MiB more space.

Proceed with this action? [y/N]:
 

darktrym

Fahnenträger
#7
Ich hätte mal eine Frage zur Code-Qualität von hplip, war das HP erster Versuch mit AI Programme selbst schreiben zu lassen?