pkgsrc, libXext, USE_LANGUAGES, c++

rik

Lernender Unwissender.
Hallo.

Ich möchte gerade den Port x11/xf86-video-nv installieren, dann kommt eine Fehlermeldung:

make: stopped in /root/pkgsrc/x11/libXext.
Please consider adding fortran to USE_LANGUAGES in the package Makefile.

Please consider adding c++ to USE_LANGUAGES in the package Makefile.

Jap. Fortran ließ sich ohne Probleme hinzufügen, jedoch mag er c++ nicht. Ich habe in dem Makefile die Plätze von c++ und Fortran vertauscht. Dann hab ich Fortran ganz weggelassen.. egal was ich mach, IMMER kommt die Meldung, ich solle c++ zu der Datei hinzufügen.

Wie mach ich das jetzt?
 
Hallo,
du könntest die Verzeichnisse leeren mittels "make clean" und es erneut versuchen. Ansonsten bleibt noch die Möglichkeit PKG_PATH zu setzen und ein Binärpaket zu installieren. Derzeit funktionieren so einige Pakete nicht.
 
Okay verstehe. Heißt das etwa, dass ich keine Grafiktreiber hab? Weil libXext nicht funktionieren will?

Was meinst du mit der Möglichkeit, PKG_PATH zu setzen? Und wo bekomm ich das Binärpaket her?

Danke.
 
PKG_PATH ist eine Variable in der z.B. die Addresse eines FTP Servers drinsteht wo die Pakete zu finden sind.
Schau mal auf der Homepage unter mirrors, da findest du entsprechende Server.
mit
Code:
export $PKG_PATH="<addresse>"
kannst du die variable setzen und das ganze dann bequem mit pkg_add installieren.
 
Ich bin nochmals hier, und zwar mit einer ATI-Karte.

# export PKG_PATH="http://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/amd64/5.1/All"
# export PKG_PATH
# pkg_add -v xf86-video-ati
pkg_add: no pkg found for 'xf86-video-ati', sorry.
pkg_add: 1 package addition failed
#

Kann ich das Binärpaket auch downloaden und dann lokal installieren? Ich find da nämlich nichts ... Der Port funktioniert auch nicht.
 
Trag mal in die /etc/profile diese zeilen ein
PKG_PATH=http://ftp.NetBSD.org/pub/pkgsrc/packages/NetBSD/amd64/5.1/All; export PKG_PATH

Denn NetBSD kann dir nur Packete installieren, die es vorher runtergeladen hat.
 
Ich verstehe; Bei Abiword hat es aber funktioniert:

pkg_add -v abiword

Wichtig wäre mir vor allem der ATI-Treiber (oder auch Nvidia, kann ja Grafikkarten umbauen ;) ) und Virtualbox.
 
Dieses Packet gibt es nicht in dem Verzeichniss, zumindest das xf86-video-ati.tgz sehe ich da nicht, also kann er es auch nicht runterladen und installieren da es nicht existiert. Kann dir auch nicht konkret sagen, wo oder in welchen Packet sich der Treiber befindet. Den Nvidiatreiber denke ich, müsstest du bei Nvidia runterladen und manuel installieren.
 
Bei Nvidia? Die gibts doch nur für Windows, FreeBSD, Linux, Mac und Solaris, oder?
 
Richtig. Es existiert nur der nv-Treiber und einen uralten nicht funktionstüchtigen Nouveau-Treiber(2007). Wenn ich ein biss. Zeit finden würde(und kompetente Leute/Tester dazu) würde ich den letzteren mal aktualisieren(2010). So schwer kann's nicht sein.
Für den Nvidia-Treiber war auch mal eine Portierung(von FreeBSD) geplant, leider nie umgesetzt.
 
Vielen Dank nochmal für die Antworten.
Gibt es nicht FOSS-Treiber für ArchLinux? Wenn ja, müsste es ja nen Quellcode geben... aber das ganze händisch zu kompilieren, wird mir zu aufwändig, denke ich.

Also muss ich den nv-Treiber irgendwo herbekommen ...
 
Wenn du wissen willst, welche Treiber in welcher Version wann ihre letzte Änderung erfahren haben dann genügt ein Blick auf pkgsrc.se.
FOSS Treiber gibts wie erwähnt einige, nur musst du berücksichtigen das wohl alle BSD derzeitig abgehängt sind weil GEM/TTM/KMS Vorraussetzung der meisten Treiber sind.
Wenn du mir ein bissl Zeit gibst kann ich mal VM Instanz vorbereiten und mal schauen was los ist.
 
Bei mir geht das übersetzen auch nicht.
Mal 'ne andere Frage, kann es sein, dass die Treiber gar nicht mehr angeboten werden, weil die nun Teil der Base sind(xserver.tgz)?
 
Zuletzt bearbeitet:
Hi,

ich hate mal ähnliche "Probleme", ich konnte es lösen indem ich pkgsrc geupdatet hatte.

vg
vertex
 
pkgsrc updaten hilft auch bei mir nicht. Leider.

Vielleicht sollte ich einfach ein anderes OS installieren und NetBSD auf einen der Rechner installieren, bei denen Zuverlässigkeit nicht das wichtigste ist?
 
hast du es mal spaßeshalber in die mk.conf eingetragen?
Ich habe zwar gelesen, dass man dies nicht tun sollte, habe aber irgendwie in Erinnerung, dass es bei mir mal geholfen hatte, vor dem "pkgsrc update".
 
Der ATI-Treiber scheint auch in current Probleme zu bereiten.
Ich versteh' es trotzdem nicht, wo das Problem ist, wenn das entsprechene Paket von der CD nachzuinstalliert werden kann.
 

Anhänge

  • out.txt
    9,5 KB · Aufrufe: 409
Zurück
Oben