• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

plasma5 maxfiles

klimaschreck

Well-Known Member
Themenstarter #1
Hallo zusammen,

wenn ich mich mehrfach in plasma5 auslogge und wieder einlogge, erhalte ich ca. nach dem 5. Mal keine User Session mehr. Unter /var/log/messages erhalte ich folgende Meldungen:

Code:
May  8 22:15:38 tattoo devd: check_clients:  dropping disconnected client
May  8 22:15:47 tattoo dbus[819]: [system] Activating service name='org.kde.powerdevil.discretegpuhelper' (using servicehelper)
May  8 22:15:47 tattoo dbus[819]: [system] Successfully activated service 'org.kde.powerdevil.discretegpuhelper'
May  8 22:15:47 tattoo dbus[819]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
May  8 22:15:47 tattoo dbus[819]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
May  8 22:15:52 tattoo kernel: kern.maxfiles limit exceeded by uid 1001, (baloo_file) please see tuning(7).
May  8 22:15:53 tattoo kernel: kern.maxfiles limit exceeded by uid 1001, (kactivitymanagerd) please see tuning(7).
May  8 22:16:03 tattoo kernel: pid 2025 (ksmserver), uid 1001: exited on signal 5 (core dumped)
May  8 22:16:03 tattoo devd: notify_clients: send() failed; dropping unresponsive client
May  8 22:16:41 tattoo kernel: Failed to fully fault in a core file segment at VA 0x39000000 with size 0x4000000000 to be written at offset 0x275b000 for process baloo_file
May  8 22:16:42 tattoo kernel: pid 2034 (baloo_file), uid 1001: exited on signal 5 (core dumped)
May  8 22:16:44 tattoo dbus[819]: [system] Activating service name='org.kde.powerdevil.discretegpuhelper' (using servicehelper)
Der Parameter kern.maxfiles ist auf 25000 gesetzt, der Standardwert. Habt ihr eine Idee, woran der Fehler liegen könnte?
 

tcberner

Well-Known Member
#2
Moin moin

Das liegt daran, dass Files geöffnet werden müssen um sie zu monitoren. -- du kannst den Parameter noch weitaus höher setzen.

Ich hab >500'000 files in ~, sprich mit 250'000 gehts da schnell and ie Grenzen :D


Du kannst z.B. das Montoring der Files in baloo auch einschränken.


mfg Tobias
 

klimaschreck

Well-Known Member
Themenstarter #3
Danke für den Hinweis, aber ich habe eine andere Lösung gewählt. Ich habe baloo ausgeschaltet.
In der Datei ~/.config/baloofilerc habe die folgenden Zeilen ergänzt:

Code:
[Basic Settings]
Indexing-Enabled=false
Ich hoffe, es hat keine gravierenden Nebenwirkungen.