• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Rechner resettet nicht reproduzierbar

Morfio

Well-Known Member
Themenstarter #1
Hallo zusammen,

ich habe FreeBSD 11.2-RELEASE-p13 amd64. Mein Rechner resettet ab und an, sprich, Bildschirm wird schwarz, es dauert eine Weile, dann fährt er wieder hoch. In /var/log/messages steht nichts, auch in anderen Logs finde ich nichts.

RAM habe ich getestet, scheint in Ordnung zu sein. Reproduzierbar ist es nicht, passiert bei unterschiedlichen Arbeiten oder einfach so, egal, welche Programme offen oder eben nicht offen sind. Ich nutze KDE 5.

Hat jemand vielleicht eine Idee, was ich einschalten könnte, um weitreichendere Informationen zu bekommen, um herauszufinden, warum die Maschine ab und an resettet? Teils passiert das jeden Tag bis alle drei Tage.

Viele Grüße

Morfio
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#3
Hmm... Die Frage ist, ob das System in eine Panic läuft oder einfach stumpf aus dem Nichts rebootet. Das Problem dabei ist, dass man unter X11 eine eventuelle Panic nicht sieht. Man kann sie nur indirekt ableiten, da bei einer Panic das System einige Sekunden einfriert und dann rebootet und es das nicht einfach ohne jede Verzögerung tut.

Ich würde im ersten Schritt Crash Dumps einschalten. Dafür brauchst du eine Swap-Partition, in der Praxis reichen meistens ein bis zwei Gigabyte aus. Dann setzt du in der rc.conf dumpdev="AUTO" und führst einmal service dumpon start aus. Nach dem nächsten Crash schaust du, ob ein Dump in /var/crash liegt. Er beinhaltet auch die Panic-Meldung.

Nachtrag: @medV2 war etwas schneller.
 
#4
Hallo Morfio,
so ein Verhalten hatte ich mal bei einem Linux-Rechner: der hatte einen Netzteil-Schaden (Rechner ließ sich von einem zum anderen Tag nicht mehr booten). Das Netzteil wurde getauscht. Aber nach einiger Zeit traten dan diese Spontan-Reboots auf; nicht reproduzierbar (mal unter Last, mal im Leerlauf, mal nach einigen Stunden oder sofort nach dem Reboot) und das in immer kürzeren Abständen.
Meine Diagnose: das Netzteil hat wahrscheinlich noch irgenwas auf dem Main Board geschädigt. Ich habe den Rechner schließlich ausrangiert.
Ich weiß, das ist nicht, was Du hören wolltest und sollte nur eine mögliche Erklärung sein, die man im Hinterkopf haben sollte. Vielleicht hast Du ja mehr Glück - ich drück die Daumen

Ciao,
Photor
 

pit234a

Well-Known Member
#5
Hallo Morfio,
so ein Verhalten hatte ich mal bei einem Linux-Rechner: der hatte einen Netzteil-Schaden (Rechner ließ sich von einem zum anderen Tag nicht mehr booten). Das Netzteil wurde getauscht. Aber nach einiger Zeit traten dan diese Spontan-Reboots auf; nicht reproduzierbar (mal unter Last, mal im Leerlauf, mal nach einigen Stunden oder sofort nach dem Reboot) und das in immer kürzeren Abständen.
Meine Diagnose: das Netzteil hat wahrscheinlich noch irgenwas auf dem Main Board geschädigt. Ich habe den Rechner schließlich ausrangiert.
Ich weiß, das ist nicht, was Du hören wolltest und sollte nur eine mögliche Erklärung sein, die man im Hinterkopf haben sollte. Vielleicht hast Du ja mehr Glück - ich drück die Daumen

Ciao,
Photor
Dito.
Mein letzter Versuch war auch so ein PC vom Schrott, den ich aber unbedingt benutzen wollte, weil er doch gegenüber meinem damaligen, mehr als zehn Jahre altem PC, deutlich bessere Leistungsdaten aufwies. RAM und Netzteil waren unverdächtig und getauscht, ein Stress-Test brachte ihn zum Glühen (die Raumtemperatur stieg merklich und ich hatte es im Winter wohlig warm in meinem Verlies), aber nicht zum Absturz und zeigte keinen Fehler. Alles gut? Wenige Tage später in einer unbedenklichen Situation wieder ein plötzlicher Reboot.
Schließlich fragte ich mich selbst, wieviel Ärger ich aushalten will und entschied mich für komplett neue HW, im gleichen Gehäuse allerdings. Also neues Motherboard, CPU mit passendem RAM, neue GraKa und passendes Netzteil. Die Platten (bzw SSDs) und optische Laufwerke behielt ich, investierte außerdem in ruhige Lüfter und habe seitdem eben Ruhe!

Das soll nicht bedeuten, dass ich dir spontan und ohne deine Situation zu kennen, zu neuer HW raten möchte!
Bei mir lief die Fehlersuche und Testerei über Monate, ich war motiviert und guten Willens.
Aber schließlich sprach die Stimme der Vernunft und ich folgte ihr.
Oder umgekehrt: es gibt eigentlich keinen Grund anzunehmen, dass FreeBSD den Fehler verursacht. Deshalb bleibt eigentlich nur die HW. Und weil man die sowieso irgendwann mal erneuern sollte, kann das vielleicht ein guter Augenblick sein und einem den Ärger mit weiterer Fehlersuche ersparen. Falls das deine Situation treffen sollte.
 

Morfio

Well-Known Member
Themenstarter #6
Hi,

naja, das Zeugs ist gut drei Jahre alt, ich würde das nur ungern durch neue Hardware ersetzen, zumal es ansonsten ein recht performantes System ist.

Ich habe mal Crash Dumps eingeschaltet und gucke mal, ob man dann was sieht.

Viele Grüße

Morfio
 

foxit

Moderator
Mitarbeiter
#7
Die Einfachsten Schritte sind doch folgende:
  • Memtest (über ein paar Stunden laufen lassen)
  • stress [1]
  • Passiert es auch unter Linux/Windows
  • Alle nicht benötigten Komponenten entfernen (HDDs, Laufwerke, PCI Steckkarten etc.)
  • Gleich mal das Gehäuse reinigen/aussaugen
  • Kabel prüfen (SATA, Strom und Ein/Ausschalter! Auch USB Stecker hinten/vorne)
  • CPU Wärmeleitpaste erneuern
  • Drehen alle Lüfter? (auch vom Netzteil?)
  • Hardware tauschen (Netzteil, CPU, Mainboard)
Für stress kannst du mal folgende Einstellungen verwenden:
Code:
stress -c 4 -m 16 -i 10 -d 20 -t 400 --vm-bytes 940M --vm-keep
Der Parameter "-m X" (RAM) und "-c X" (CPU Kerne) noch anpassen. Das läuft dann für 5min. Diesen Test auch mal unter Linux machen und die Temperaturen dabei beobachten.

[1] sysutils/stress
 

Morfio

Well-Known Member
Themenstarter #8
Memetest lief einen Tag ohne Fehler, Linux/Windows ist nicht drauf. Komponenten wurden bereits entfernt. Gehäuse habe ich dabei auch schon gereinigt. SATA-Kabel könnte ich noch tauschen, mitunter liegt da der Hund begraben. Alle Lüfter drehen. Zu heiß wird das System nicht, Temperatur liegt bei der CPU zur Zeit bei 40°C. Auf Verdacht Hardware tauschen ist natürlich ein teurer Spaß, da ich hier keine Ersatzteile herumliegen habe.

stress werde ich mal probieren.
 
#9
Moin Morfio,

RAM habe ich getestet, scheint in Ordnung zu sein. Reproduzierbar ist es nicht, passiert bei unterschiedlichen Arbeiten oder einfach so, egal, welche Programme offen oder eben nicht offen sind. Ich nutze KDE 5.

Hat jemand vielleicht eine Idee, was ich einschalten könnte, um weitreichendere Informationen zu bekommen, um herauszufinden, warum die Maschine ab und an resettet? Teils passiert das jeden Tag bis alle drei Tage.
Fragen:
(*) Hast Du einen Überspannungsschutz mit Netzfilter? Wenn nein, dann besorge mal einen und prüfe, ob die Probleme noch auftreten. Es kann durchaus sein, dass Störungen auf dem Stromnetz sind (Baustelle, uralte Hausgeräte, entfernte Gewitter, usw.)
(*) Steht der Rechner frei oder in einem Regal? Sind Wollläuse im Gehäuse oder im Lüfter, die den Luftstrom behindern und dadurch irgendetwas zu heiß wird und aussteigt.

Grüßle
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#11
Der Rechner hängt an einer APC Back-UPS.
Ha! Nehme die mal raus. Ich hatte meinen Kram zu Hause bis vor einigen Wochen auch hinter einer APC Back-UPS ES 700 und immer wieder obskure, nicht nachvollziehbare Probleme. Zum Beispiel, dass mein PC Engines APU1 sporadisch seine SSD rauswarf, nur um sie noch in der gleichen Sekunde wiederzufinden. Oder das der große Eizo-Monitor plötzlich zu surren begann und leicht flimmerte. Dann kam ein Gewitter, hinterher war die USV tot und ich habe sie gezwungenermaßen rausgenommen und erst einmal provisorisch durch einfache Überspannungsschutzstecker ersetzt. Seitdem habe ich keine Probleme mehr.
 

pit234a

Well-Known Member
#13
das Zeugs ist gut drei Jahre alt,
Aber schließlich sprach die Stimme der Vernunft und ich folgte ihr.
Die Stimme der Vernunft sagt definitiv nicht, dass der derart jugendliche Systeme komplett ausgetauscht werden sollten, wenn sie ein wenig zicken.
Linux/Windows ist nicht drauf
Dafür gibt es ja Live-Systeme.
Mein Liebling ist nach wie vor Knoppix, was eine wirklich gute HW-Erkennung hat, aber per Default unbedingt in einen grafischen Desktop booten möchte. Mit störenden 3D-Efekten. Es ist halt ein Demo-System und kann aber auch out of the box eine Menge guter Sachen, die bei Fehlern helfen können oder helfen können, Fehler zu finden.
Jedes aktuelle Ubuntu sollte als Live-System benutzbar sein. Ich komme damit meist nicht gut klar und nutze meist ein Lubuntu.
http://nomadbsd.org/index.html ist ein FreeBSD-Live-System, Desktop-System, also mit Grafischer Oberfläche.

Das ist gar nicht so doof, ein Live-System mal zu starten und einige Wochen zu nutzen. Wenn der Fehler trotzdem auftritt, scheidet das installierte System aus und damit bleibt quasi nur noch HW übrig, oder ein genereller Bug im Betriebssystem und die kommen selten sowohl in GNU/Linux als auch in FreeBSD vor.

Ich halte das jedenfalls für einen sehr guten und einfach anwendbaren Tip, mal ein anderes System laufen zu lassen.
 

Morfio

Well-Known Member
Themenstarter #14
@pit234a Das Problem ist, dass der Rechner auch mal eine Woche ohne den Fehler läuft und ich ihn für die Arbeit brauche. Ich habe ihn jetzt erst einmal aus der APC genommen, mal gucken, wie es jetzt aussieht.
 

Morfio

Well-Known Member
Themenstarter #17
Ich habe jetzt alle sechs SATA-Kabel ausgetauscht. Eins (von einer der vier Platten) war tatsächlich locker, ein weiteres hing an Stecker total schräg nach oben (DVD).

Weiterhin habe ich noch geschenkten RAM ausgebaut, so dass nur noch der damals gekaufte drin ist, auch wenn Memtest nicht anschlug. Jetzt mal abwarten.
 

Illuminatus

in geheimer Mission
#18
Sollte nach Kabeltausch- und prüfung sich keine Besserung ergeben, versuche es doch bitte noch mit Firmware/Microcode Updates bei allen Komponenten bei denen es möglich ist. Mal schauen wie es weiter geht und Viel Erfolg.