• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Router -Firewall Problem

asg

push it, don´t hype
#26
Oh man.
Hmm, Langsam wiess ich hier aus der Ferne auch nicht mehr weiter.
Kann man auf das Ding von aussen irgendwie via ssh zugreifen?
Naja, Internet geht nicht, zumindest nicht mit FIREWALL im Kernel. Wenn Du das draussen lässt, dann rennt die Internetverbindung?

Was sagt denn "ifconfig -a"?

Was mir überhaupt nichts sagt ist in Deiner dmesg:

"can't re-use a leaf (nonstandard_pppoe)!"

Du kannst auch keine IPs im Internet anpingen? Die Verbindung wird überhaupt nicht hergestellt? ifconfig -a bitte posten.

Hmm, normalerweise ist das eine Arbeit von 5 Minuten, warum das bei Dir nun streikt kann ich gerade nicht feststellen (von hier).

Evtl. weiss jemand anders hier noch Rat?

Sonst lass IPFW weg, und nimm IPF als firewall und ppp -nat zum natten... Ist zwar keine wirkliche Lösung des Problems, aber bevor Du noch lange rummachst.
Ansonsten, was steht noch brauchbares im handbook?
 

asg

push it, don´t hype
#27
So, da mich das wirklich nervt wenn was nicht funktioniert was eigentlich innerhalb weniger Minuten stehen sollte, habe ich mal etwas rumgefragt und warte auf Antwort.
Mal sehen was andere dazu sagen.
 
Themenstarter #28
Oh man.
Hmm, Langsam wiess ich hier aus der Ferne auch nicht mehr weiter.
Kann man auf das Ding von aussen irgendwie via ssh zugreifen?
kein problem wenn du willst.
schicke dir die IP und PW

Naja, Internet geht nicht, zumindest nicht mit FIREWALL im Kernel. Wenn Du das draussen lässt, dann rennt die Internetverbindung?

booten mit GENERIC internet verbindung funktiert.
Du kannst bei gerne mal auf die kiste schauen wenn du das willst, weil mir fällt nix mehr ein, boote halt mit GENERIC.


Was sagt denn "ifconfig -a"?
mit GENERIC ist die online ip vorhanden Firewall kernel nicht falls du das wissen willst

Was mir überhaupt nichts sagt ist in Deiner dmesg:

anhang


"can't re-use a leaf (nonstandard_pppoe)!"

Du kannst auch keine IPs im Internet anpingen?
Nein
Die Verbindung wird überhaupt nicht hergestellt? ifconfig -a bitte posten.

keine Inet IP, nix

Hmm, normalerweise ist das eine Arbeit von 5 Minuten, warum das bei Dir nun streikt kann ich gerade nicht feststellen (von hier).

Gruß Andreas
 

Anhänge

asg

push it, don´t hype
#29
Ok, auf den ersten Blick liegt gibt es einen Unterschied zw. dem output von dmesg:

can't re-use a leaf (nonstandard_pppoe)!

Dies kommt bei dem FIREWALL Kernel vor. Leider weiss ich nicht was soll es bedeuten, aber danach habe ich schon andere gefragt. Ich warte da mal auf Antwort.

Den output von "ifconfig -a" den Du angehängt hast, das war der von FIREWALL Kernel, nehm ich mal an.
Was ist denn da PID 51:

tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1500
Opened by PID 51

Bzw. eine andere PID wenn Du nochmals den FIREWALL Kernel bootest.

Ach ja, Du weisst aber das man beim reboot einen kernel angeben kann den man EINMALIG booten möchte? Nicht das Du es sonstwie machst....

#reboot -k $kernel

Siehe "man reboot"
 
Themenstarter #30
HI

Den output von "ifconfig -a" den Du angehängt hast, das war der von FIREWALL Kernel, nehm ich mal an.
Ja, Firewall Kernel

Was ist denn da PID 51:
Das weiß ich auch nicht, bin ja Newbie :confused:+

GENERIC Kernel

Webserver# ifconfig
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::200:1cff:fede:9bbb%rl0 prefixlen 64 scopeid 0x1
ether 00:00:1c:de:9b:bb
media: Ethernet autoselect (10baseT/UTP)
status: active
rl1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet 192.168.0.100 netmask 0xffffff00 broadcast 192.168.0.255
inet6 fe80::2c0:26ff:fea1:8384%rl1 prefixlen 64 scopeid 0x2
ether 00:c0:26:a1:83:84
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
lp0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
faith0: flags=8002<BROADCAST,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
ppp0: flags=8010<POINTOPOINT,MULTICAST> mtu 1500
sl0: flags=c010<POINTOPOINT,LINK2,MULTICAST> mtu 552
tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1492
inet 217.227.197.xxx --> 217.5.98.62 netmask 0xffffffff
Opened by PID 51



Ach ja, Du weisst aber das man beim reboot einen kernel angeben kann den man EINMALIG booten möchte? Nicht das Du es sonstwie machst....

#reboot -k $kernel

Wieder mal was neues dazu gelernt, wußte ich nicht werde ich mal testen.

Willste sonst mal auf meine Rechner rauf schauen ?

Gruß Andreas
 

asg

push it, don´t hype
#31
Servus.

Jedes laufende Programm unter UNIX bekommt eine PID, eine ID des Prozesses.

gebe mal

#top

ein. Was siehst Du da in der ersten Spalte? Richtig, die PID.
Dahinter den zugehörigen Namen des Programmes.

In Deinem fall bedeutet das, das ein Prozess mit der PID 51 dies geöffnet hat.
Wie ich gerade sehe kommt das aber auch beim GENERIC vor.

Du kannst eine PID, und den dazugehörigen Prozess so rausfinden:

#ps waux | grep $PID
also
#pa s waux | grep 51

Wahrscheinlich ist PID 51 == ppp

Geb mal Deine IP und einen login, ich schau mal drauf auf die Box.