• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

syslog sendet keine Daten an remote server

Themenstarter #27
Jetzt läuft alles soweit!

Habe jetzt nur das Problem mit dem Hostnamen...eine neustarten vom syslogd hat keine Veränderung gebracht!
 

SierraX

Well-Known Member
#29
Du hast die IP und den Hostnamen auf beiden Rechnern eingetragen?
Ich hatte den /etc/hosts Eintrag nur auf dem Empfänger eingetragen. Bin davon ausgegangen dass das logisch sei, da der Sender ja seinen eigenen Name nicht mitschickt, wenn man ihm das nicht explizit befiehlt. Vielleicht kann man das beim logger oder sendendem syslogd irgendwie einstellen. Ist z.B. auch ein Problem hinter Proxy Servern oder glaube auch bei NAT. Dann selbst wenn 100 unterschiedlich Maschinen schicken der Syslog Server empfängt es immer von der gleichen IP.

edit: hab in der OpenBSD syslogd(8) man-page gesehen, dass es den Schalter -h gibt "Include the hostname when sending messages to a remote loghost."
 
Themenstarter #30
Habe auf meine TESTMASCHINE in der /etc/rc.conf das -h flag gesetzt syslogd_flags="-h" und mit kill -HUP `cat /var/run/syslog.pid` neugestartet aber leider zeigt er noch immer nur die IP in der DB.

Unter /etc/hosts habe ich keine Eintragungen getätigt.
 

mark05

Well-Known Member
#31
hi

als pflog sendet nur über ein externes script an syslog da pflog komplette pcap pakete wegschreibt.
siehe auch die OpenBSD FAQ.

eigentlich sollte der syslog eintrag reichen jedoch ist auf die position des eintrag in der syslog.conf
zu achten , vorzugsweise als letzte zeile.

tcpdump zeigt udp sauber an ./root/expire_ip6.sh pppoe0

ggf einfach mal pfctl -d , die firewall abschalten

per logger "bla" sollte eine sylog message generiert werden , siehe auch man page.

holger
 
Themenstarter #32
@mark05
Die Weiterleitung der pflogs mittels syslog an den Remote Server funktioniert ja mittlerweile.

Mein Problem ist, dass ich in meiner rsyslog DB nur die IP der Testmaschine bekommen aber leider nicht den Hostnamen.
 

mark05

Well-Known Member
#33
ok , sorry hatte das "problem" falsch verstanden.

um gast host problem zu loesen muss , wen kein dns vorhanden,
auf allen clients der hostname des clients in der /etc/hosts stehen,

die option -h sollte beim Sender ( openbsd ) auch passen.

da du rsyslog schreibst , hast du auch die entsprechenden anpassungen am rsyslogd server gemacht ?

holger
 
Themenstarter #34
Habe in allen /etc/hosts jetzt die Eintragungen getätigt und das -h flag gesetzt und neugestartet aber keine Änderung.

Habe mal gegoogelt und finde für die rsyslog-Konfiguration zwar die FromIP-Variable aber irgendwie keine Umsetzung zum Hostnamen als Bsp.!

Wenn ich es mit OPNSense teste, steht der Hostname in der DB. Es würde es auch reichen, wenn nur die IP in der DB steht - dann müsste es aber bei allen Systemen so sein! Wie muss ich dann mein rsyslog ruleset schreiben?
 
Themenstarter #36
Leider werde ich aus der Doku und google nicht schlau. Habe jetzt mal in der /etc/rsyslog.conf mit global(net.enableDNS="off") versucht, dass er in die DB nur IP's unter FromHost eingeträgt - ohne Erfolg.

Und mit den Templates weiß ich nicht wie ich die FromHost so verknüpfe, dass er stattdessen FromHost-IP nimmt und einträgt.