useranmeldung an samba-share schlägt fehl

[moR-pH-euS]

Magnum P.I.
hy,
ich habe ein kleines problem mit meinem samba-server. os ist netbsd 1.6.2, samba-version ist 3.0.2a.
ich wollte meinen samba-server so konfigurieren das nur der user samba auf die backup-freigabe zugreifen kann.

meine smb.conf sieht folgendermassen aus:

[global]
workgroup = home
#guest account = nobody
keep alive = 30
os level = 2
kernel oplocks = false
security = user
encrypt passwords = no
socket options = TCP_NODELAY
map to guest = Bad User

wins support = no

[backup]
comment = download
path = /home/morpheus/freigabe/backup
browseable = yes
public = yes
#read only = no
writeable = yes
#create mode = 0777
valid users = samba
write list = samba

wenn ich mich jetzt von einem w2k-client anmelden will und user und pass übergebe, kann ich mich nicht anmelden an die freigabe, stattdessen kommt immer wieder der screen mit benutzername und passwort...
den user samba, habe ich mit useradd angelegt und mit smbpasswd ein passwd zugewiesen.

root@netbsd-gw# cat /usr/local/samba/private/smbpasswd
samba:1002:FF50ABAA33EEF042944E2DF489A880E4:3ABE1D48EE90C22C629AA768858392D5:[U ]:LCT-4115F1DC:

folgende meldung erscheint dabe in der log.smbd, wenn ich mich versuche anzumelden

[2004/08/09 9:19:59, 1] /home/morpheus/samba-3.0.2a/source/smbd/service.c:make_connection(792)
make_connection: refusing to connect with no session setup

zu der meldung konnte ich leider weder bei google noch bei deja.com was finden...
 
Also ab Win2K muss

encrypt passwords = yes

oder der Win2K-Client gepatcht werden, damit er Passwörter unverschlüsselt überträgt.

Funktioniert der Zugriff auf den Share, wenn Du

security = share

setzt?

Gruß,

Ice
 
Samba will nicht!

Einige Tips die vielleicht helfen:

1.) Kontrolliere Deine Samba-Freigaben:
smbclient -L localhost -U samba

2.) Teste Deine Samba-Freigabe:
mkdir /mnt/smb
mount_smbfs -I localhost //samba@localhost/download /mnt/smb

3.) Verwende Webmin:
http://www.freshports.org/sysutils/webmin/

das Samba-Modul von Webmin (siehe Screenshot im Anhang) ist wirklich super! SWAT kannst Du vergessen..

4.) Vergleiche mit meiner /usr/local/etc/smb.conf:
Mir ist aufgefallen, das bei Dir die "passdb backend ="-Zeile fehlt!?

++++++++++++++++++++++++++
[global]
workgroup = ARBEITSGRUPPE
server string = Samba Server
security = user
load printers = yes
log file = /var/log/samba/log.%m
max log size = 50
passdb backend = tdbsam
socket options = TCP_NODELAY
local master = yes
dns proxy = no

[homes]
comment = Home Directories
browseable = no
writable = yes
path = /usr/home/%S/Desktop/Eigenes/Windows

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes

[backup]
comment = Backup
path = /opt
public = no
valid users = andy
writable = yes
printable = no
write list = andy
++++++++++++++++++++++++++++

5.) Viel Glück!
 

Anhänge

  • Webmin.png
    Webmin.png
    66 KB · Aufrufe: 406
Zuletzt bearbeitet:
Sorry, hab nicht gesehen dass Du NetBSD verwendest, meine Tips sind für FreeBSD! Aber vielleicht funktionieren sie auch..
 
danke für die tipps, ich probier es heute abend nochmal, wenn ich wieder daheim bin.

@ice:
mit user=share funktioniert es ja, so hatte ich es ja bis jetzt. aber nun möchte ich das nur der user samba auf die backup-freigabe zugriff hat.
 
das problem hat sich erledigt.
anscheinend war das problem, das ich insgesamt drei samba-shares von dem server gemountet hatte. ich hatte das verzeichniss backup, mp3 und filme, aber ich habe nur backup getrennt und mp3 und filme waren weiter gemountet, da ich ja nur die zugriffsrechte bei backup auf einen speziellen user ändern wollte der es mounten kann.
jetzt habe ich mal alle drei shares getrennt und siehe da ich kann als user samba die backup-freigabe mounten ;-)
danke für eure hilfe...
 
thx @zepol, das ist natürlich die ausführliche erkärung des problems das ich hatte.
also net use in zukunft nur mit ip's verwenden nie mit den hostnamen ;)
 
Jedenfalls wenn du unter zwei verschiedenen User-Id´s, auf dem gleichen "Server" dich anmelden möchtest.
 
Zurück
Oben