• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Virtualbbox 5.1 auf FreeBSD 11

BoS

Well-Known Member
Themenstarter #1
Guten Morgen,

ich kämpfe gerade mit der Installation der VirtualBox Software.
Sobald eine virtuelle Maschine (in diesem Fall Windows 2008) auf eine Netzwerkbrücke greift steht das System.
Testweise wurde eine eigene Bridge manuell erstellt, aber der gleiche Fehler.

Ich hatte es erst in ein Jail installiert und vermutete dort die Ursache, auch auf einem System direkt ist es der gleiche Fehler :-(.

Fehlermeldung: VERR_SUPDRV_COMPONENT_NOT_FOUND und dann steht das ganze

Was kann/muss ich hier verändern, um zum Ziel zu kommen?

Danke schön,
BoS

Info:
VirtualBox incl. Kerneltreiber ist mit pkg install installiert worden
 

BoS

Well-Known Member
Themenstarter #3
Ja, hatte ich vergessen zu erwähnen
kldstat gibt aus

Id Refs Address Size Name
1 25 0xffffffff80200000 1fddbf0 kernel
2 1 0xffffffff821df000 30ae98 zfs.ko
3 2 0xffffffff824ea000 adb8 opensolaris.ko
4 1 0xffffffff824f5000 59a00 pf.ko
5 1 0xffffffff8254f000 1a7c8 fuse.ko
6 2 0xffffffff8256a000 74a0 vboxnetflt.ko
7 3 0xffffffff82572000 7db28 vboxdrv.ko
8 2 0xffffffff825f0000 19a18 netgraph.ko
9 1 0xffffffff8260a000 5d18 vboxnetadp.ko
10 1 0xffffffff82821000 3705 ums.ko
 

BoS

Well-Known Member
Themenstarter #5
NAT nützt wird leider nichts

ich muss von aussen den vollen Zugriff haben wegen RDP und Konsorten :-(
 

BoS

Well-Known Member
Themenstarter #6
ja
auf dem Host und bei dem Jail Test wurde es durchgereicht in die Jail
hat bis zum Umstieg auf FBSD 11 und VB 5.1 nie Probleme gemacht

Ich habe im log noch etwas gefunden, was etwas verwunderlich ist

SUP_IOCTL_COOKIE: Version mismatch. Requested: 0x260000 Min: 0x260000 Current: 0x280000

Version des kmod Modules und der Basisversion sind gleich, 5.1.2

Was sagt uns der Künstler hier nun eigentlich?
 

BoS

Well-Known Member
Themenstarter #7
So

Hier ist die Lösung:

pkg remove virtualbox-ose-kmod

portsnap fetch update

und das aktualisierte Paket aus den Ports installieren - atm 5.1.14

BoS
 

BoS

Well-Known Member
Themenstarter #8
UPDATE:

es tut's schon wieder nicht :-(
Ursache unbekannt
Fehlermeldung: kein Treiber für das Netzwerkgerät vorhanden

BoS
 

BoS

Well-Known Member
Themenstarter #9
So

das Problem ist lokalisiert - liegt an der Abhängigkeit zum Kernel (einmal freebsd-update und nix geht mehr :-( )
War bisher noch nie so, aber gut zu wissen
Das package 5.1.12 zeigt Fehler an und ist so nicht nutzbar

Hoffentlich kann ich das bald durch etwas anderes ersetzten - die Serversoftware bleibt

kann geschlossen werden

schönes Wochenende

BoS