• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

X startet nicht mit Nvidia-Karte (nvidia-driver-340)

cabriofahrer

Well-Known Member
Themenstarter #1
Habe gerade auf einen alten Board mit Onboard Radeon HD 3000-Chip eine ältere Nvidia-Karte (Geforce 210), die nvidia-driver-340 benötigt, installiert, aber Xorg will nicht starten. Die Packages sind auf dem neuesten Stand (quarterly). Im BIOS habe ich "Primary Adapter" auf "PCIE" gestellt. Ich habe mit nvidia-xconfig die xorg.conf erstellt:

Code:
$ more /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.100

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

$
Das Nvidia-Modul ist geladen:

Code:
$ kldstat
Id Refs Address                Size Name
 1   34 0xffffffff80200000  2448d90 kernel
 2    1 0xffffffff82821000   9625c0 nvidia.ko
 3    1 0xffffffff83184000    3df60 linux.ko
 4    3 0xffffffff831c2000     3178 linux_common.ko
 5    1 0xffffffff831c6000     2668 intpm.ko
 6    1 0xffffffff831c9000      b50 smbus.ko
 7    1 0xffffffff831ca000     18a0 uhid.ko
 8    1 0xffffffff831cc000     2928 ums.ko
 9    1 0xffffffff831cf000    35b20 linux64.ko
10    1 0xffffffff83205000    18dc8 ext2fs.ko
11    1 0xffffffff8321e000     fcf0 fusefs.ko
12    1 0xffffffff8322e000     3d94 geom_linux_lvm.ko
Hier der Inhalt der /var/log/Xorg.0.log:

Code:
$ more /var/log/Xorg.0.log
[    74.205]
X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
[    74.205] Build Operating System: FreeBSD 12.1-RELEASE-p10 amd64
[    74.205] Current Operating System: FreeBSD pcsalon.local 12.1-RELEASE FreeBSD 12.1-RELEASE r354233 GENERIC amd64
[    74.205] Build Date: 24 October 2020  01:56:28AM
[    74.205] 
[    74.205] Current version of pixman: 0.40.0
[    74.205]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    74.205] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    74.205] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov  1 11:28:03 2020
[    74.206] (==) Using config file: "/etc/X11/xorg.conf"
[    74.206] (==) ServerLayout "Layout0"
[    74.206] (**) |-->Screen "Screen0" (0)
[    74.206] (**) |   |-->Monitor "Monitor0"
[    74.206] (**) |   |-->Device "Device0"
[    74.206] (**) |-->Input Device "Keyboard0"
[    74.206] (**) |-->Input Device "Mouse0"
[    74.206] (==) Automatically adding devices
[    74.206] (==) Automatically enabling devices
[    74.206] (==) Not automatically adding GPU devices
[    74.206] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    74.206] (==) FontPath set to:
        /usr/local/share/fonts/misc/,
        /usr/local/share/fonts/TTF/,
        /usr/local/share/fonts/OTF/,
        /usr/local/share/fonts/Type1/,
        /usr/local/share/fonts/100dpi/,
        /usr/local/share/fonts/75dpi/,
        catalogue:/usr/local/etc/X11/fontpath.d
[    74.206] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[    74.206] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    74.206] (WW) Disabling Keyboard0
[    74.206] (WW) Disabling Mouse0
[    74.206] (II) Loader magic: 0x42e020
[    74.206] (II) Module ABI versions:
[    74.206]    X.Org ANSI C Emulation: 0.4
[    74.206]    X.Org Video Driver: 24.1
[    74.206]    X.Org XInput driver : 24.1
[    74.206]    X.Org Server Extension : 10.0
[    74.207] (!!) More than one possible primary device found
[    74.207] (--) PCI: (1@0:5:0) 1002:9616:1849:9616 rev 0, Mem @ 0xc0000000/134217728, 0xfcff0000/65536, 0xfce00000/1048576, I/O @ 0x0000a000/256, BIOS @ 0x????????/65536
[    74.207] (--) PCI: (2@0:0:0) 10de:0a65:1043:8334 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000b800/128, BIOS @ 0x????????/65536
[    74.207] (II) LoadModule: "glx"
[    74.207] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[    74.248] (II) Module glx: vendor="NVIDIA Corporation"
[    74.248]    compiled for 4.0.2, module version = 1.0.0
[    74.248]    Module class: X.Org Server Extension
[    74.248] (II) NVIDIA GLX Module  340.108  Wed Dec 11 14:27:50 PST 2019
[    74.248] (II) LoadModule: "nvidia"
[    74.248] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[    74.249] (II) Module nvidia: vendor="NVIDIA Corporation"
[    74.249]    compiled for 4.0.2, module version = 1.0.0
[    74.249]    Module class: X.Org Video Driver
[    74.249] (II) NVIDIA dlloader X Driver  340.108  Wed Dec 11 14:09:07 PST 2019
[    74.249] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    74.249] (--) Using syscons driver with X support (version 2.0)
[    74.249] (--) using VT number 9

[    74.276] (EE) No devices detected.
[    74.276] (EE)
Fatal server error:
[    74.276] (EE) no screens found(EE)
[    74.276] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    74.276] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    74.276] (EE)
[    74.308] (EE) Server terminated with error (1). Closing log file.
$
Ich komme hier leider nicht weiter.
 

Andy_m4

Well-Known Member
#2
Ich meine mich dunkel zu erinnern, das nicht (nur) das nvidia-Kernel-Modul geladen werden muss, sondern auch nvidia-modeset
 

cabriofahrer

Well-Known Member
Themenstarter #3
Das ist aber nur bei den neueren Karten ab Treiberversion 358 oder so. Was mich stutzig macht in der Xorg.0.log sind die Meldungen

[ 74.207] (!!) More than one possible primary device found

[ 74.276] (EE) No devices detected.

Fatal server error:
[ 74.276] (EE) no screens found(EE)
[ 74.276] (EE)
 

Andy_m4

Well-Known Member
#4
Das ist aber nur bei den neueren Karten ab Treiberversion 358 oder so.
Du willst es also nicht probieren, weil Du irgendwie in Erinnerung hast, das das nicht notwendig ist? :-)


[ 74.276] (EE) No devices detected.
Evtl. probieren in der xorg.conf noch den PCI-Slot mit anzugeben (Option BusID)
Was auch noch interessant sein könnte ist die Option PrimaryGPU
um Ausgabegeräte explizit als "primary" zu deklarieren.
 

pit234a

Well-Known Member
#7
erstmal würde ich vollkommen ohne Xorg.conf probieren. Wenn es da nicht was ganz spezielles gibt, sollte es auch ohne funktionieren. Wenn doch mit xorg.conf, dann überarbeitet und zwar die Input-Device Sektionen jedenfalls raus nehmen oder zumindest den Driver = keyboard entfernen.

Sodann gibt es eine Installationsmeldung beim nvidia Treiber. Bei mir sagte der etwa so etwas:
Code:
#bei Problemen mit X, Hängern oder
#    (II) NVIDIA(0): Validated MetaModes:
#    (II) NVIDIA(0):     "NULL"
#in /var/log/Xorg.0.log
#replace ``nvidia'' with ``nvidia-modeset''
Das scheint bei dir nicht zu gelten, aber vielleicht hast du etwas anderes da stehen, was dann für dich vielleicht Sinn macht.

Trotzdem scheint mir der Hauptfehler, dass tatsächlich gar nicht erst ein Gerät erkannt wird und da wiederum kannst du dem Rat von @Andy_m4 folgen:
Code:
pit@Celsius ~:- > pciconf -lv | grep -A4 vgapci
vgapci0@pci0:101:0:0:    class=0x030000 card=0x86181043 chip=0x1c0310de rev=0xa1 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GP106 [GeForce GTX 1060 6GB]'
    class      = display
    subclass   = VGA
woraus dann in der xorg.conf ein Eintrag der Art resultiert:
Code:
Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    BusID       "PCI:101:0:0"
EndSection
wenn das denn nötig sein sollte.
Normalerweise, also ohne xorg.conf, sollte das auch so funktionieren und ich brauche den Eintrag nur deshalb, weil ich "zwei Karten" habe und denen danach jeweils einen screen zuweisen möchte.
Bei dir scheinen ebenfalls zwei Karten gefunden zu werden, obwohl du eine im BIOS versenkt hast. Vielleicht klappt das nicht wirklich?
 

cabriofahrer

Well-Known Member
Themenstarter #8
erstmal würde ich vollkommen ohne Xorg.conf probieren. Wenn es da nicht was ganz spezielles gibt, sollte es auch ohne funktionieren.
Das hatte ich schon, aber das funktioniert erfahrungsgemäß bei Nvidia-Karten nie.

Bei dir scheinen ebenfalls zwei Karten gefunden zu werden, obwohl du eine im BIOS versenkt hast. Vielleicht klappt das nicht wirklich?
Scheint so zu sein:

Code:
$ pciconf -lv | grep -A4 vgapci
vgapci0@pci0:1:5:0:    class=0x030000 card=0x96161849 chip=0x96161002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'RS780L [Radeon 3000]'
    class      = display
    subclass   = VGA
vgapci1@pci0:2:0:0:    class=0x030000 card=0x83341043 chip=0x0a6510de rev=0xa2 hdr=0x00
    vendor     = 'NVIDIA Corporation'
    device     = 'GT218 [GeForce 210]'
    class      = display
    subclass   = VGA
Ich konnte Dank Eurer Hilfe dann die xorg.conf folgendermaßen ändern und jetzt funktioniert es:

Code:
Section "Monitor"           
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "PCI:2:0:0"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
"/etc/X11/xorg.conf" 53 lines, 1222 characters
root@pcsalon:/usr/home/susy # more /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.100

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "PCI:2:0:0"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
Jetzt habe ich aber noch folgendes Problem: Die Fonts in sddm sind winzig, man kann sie kaum erkennen. Auch in Fluxbox oder gkrellm, winzig. Dieses Problem hatte ich schonmal gesehen auf einem anderen Rechner mit älterem Nvidia-Chip und entsprechender Treiberversion. Auf diesem Rechner jetzt wurde mit dem Radeon-Chip auch alles korrekt dargestellt, scheint also ein Nvidia-Problem zu sein. Hinweis: Die Auflösung des Monitors beträgt 1920x1080.
 

Andy_m4

Well-Known Member
#9

cabriofahrer

Well-Known Member
Themenstarter #10
Vielen Dank! Ich hatte tatsächlich einen dpi-Wert von 30x30. Mit dem im expliziten Abschnitt zu Nvidia erklärten Eintrag konnte ich dann in der xorg.conf den Wert auf 96 dpi setzen und jetzt ist alles OK.
Merkwürdig ist nur, dass das Problem beim gleichen Rechner mit dem eingebauten Radeon HD 3000-Chip und gleichem Bildschirm nicht auftrat. Da scheint radeonkms doch etwas besser zu machen als der proprietäre nvidia-driver-340.