• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Xorg beendet sich nicht

Themenstarter #1
Hallo,
ich bin dabei FreeBSD 12.1 auf einem Laptop (Thinkpad T460s) zu installieren.
Das Basissystem lies sich völlig problemlos installieren. Xorg habe ich dann als Paket installiert (pkg install xorg). Weitere Komponenten für den Grafikchip habe ich über ports installiert: cd /usr/ports/x11-drivers/xf86-video-intel; make install clean und cd /usr/ports/graphics/drm-kmod; make install clean. Ich habe Benutzer der Gruppe video zugeordnet und folgende Einträge vorgenommen:

/boot/loader.conf:
drm.i915.enable_rc6="7"
drm.i915.semaphores="1"
drm.i915.intel_iommu_enbled="1"
kern.vty=vt

/etc/rc.conf:
kld_list="/boot/modules/i915_skl_dmc_ver1_26_bin.ko /boot/modules/i915kms.ko"

Von der Konsole kann ich nun "startx" aufrufen und Xorg mit twm starten. Es erscheinen drei xterms und eine xclock. Wenn ich Xorg wieder beenden möchte, um zur Konsole zurückzukehren, wähle ich "Exit" aus dem twn-Menü. Tatsächlich beendet sich aber nur twn, d.h. die Rahmen und Überschriften den Fenster verschwinden. Es bleiben einfach weiße Rechtecke, in denen immer noch ein Terminal oder eine Xclock läuft. Die Terminals kann ich auch noch benutzen, um mit einem kill oder reboot tatsächlich alles zu beenden.
Ist das "normal" (und ich habe falsche Erwartungen) oder habe ich etwas falsch gemacht?

Gruß,
Karl
 

Zirias

Well-Known Member
#2
So wie du das beschreibst ist twm vermutlich einfach nicht das Programm, das direkt in der Session im Vordergrund läuft. Versuch mal, die X-Terminals zu beenden (z.B. mit ctrl+d oder per exit/logout befehl), vermutlich ist eines davon der "Hauptprozess" der Session.

Um X wirklich zu benutzen installiere entweder einen Displaymanager wie sddm, der Scripts für bestimmte Standardsessions (z.B. Plasma5) schon mitbringt, oder schreibe dein eigenes ~/.xsession Script, in dem alles im Hintergrund gestartet wird außer dem Fenstermanager selbst, so dass die X-Session genau dann endet, wenn du den Fenstermanager beendest.
 

pit234a

Well-Known Member
#3
Ist das "normal" (und ich habe falsche Erwartungen) oder habe ich etwas falsch gemacht?
das ist normal. Um X zu beenden, musst du den entsprechenden Befehl absetzen, also etwa den Prozess killen oder so. Also, in deinem Zustand, wenn du noch nicht weiter gemacht hast, wie @Zirias oben beschreibt.

Sehr hilfreich ist es in meinen Augen, das "alte Verhalten" von X einzubauen, so dass dieses durch ctrl-alt-bckspc beendet werden kann. Dazu habe ich eine Zeile
Code:
    Option        "XkbOptions" "terminate:ctrl_alt_bksp"
in meiner keyboard.conf
 

Zirias

Well-Known Member
#4
Sehr hilfreich ist es in meinen Augen, das "alte Verhalten" von X einzubauen, so dass dieses durch ctrl-alt-bckspc beendet werden kann. Dazu habe ich eine Zeile
Code:
    Option        "XkbOptions" "terminate:ctrl_alt_bksp"
in meiner keyboard.conf
Kann man machen, aber man sollte bedenken, dass damit z.B. auch jeder eine Session abschießen kann, selbst wenn sie (z.B. mit xscreensaver) gesperrt ist.