Anmeldebildschirm für lightdm auf Deutsch umstellen

Hallo,
ich verwende als Desktop-Umgebung xfce-4.14. Bisher habe xfce immer über startx gestartet.
Nun möchte ich als Login-Manager /x11/lightdm verwenden. Das Starten von xfce funktioniert auch soweit. Locale wird über ~.profile gesetzt, da weder .login_conf noch /etc/login.conf für meinen User gelesen werden.

Jetzt möchte ich noch den Anmeldebildschirm von lightdm auf Deutsch umstellen. Hier weiß ich nicht wie das gehen kann.
Verwendet jemand lightdm und kann mir helfen?

Vielen Dank,

beija-flor
 
Meine /etc/login.conf habe ich angehängt. Ich habe in meiner /etc/login.conf folgendes hinzugefügt:
Code:
#
# German Users Accounts. Setup proper environment variables.
#
german|German Users Accounts:\
    :charset=UTF-8:\
    :lang=de_DE.UTF-8:\
    :tc=default:

Dem User lightdm habe ich dann diese Login-Klasse zugewiesen:
Code:
lightdm:*:164:164:german:0:0:Light Display Manager:/var/lib/lightdm-data:/usr/sbin/nologin

Ich hatte :lang=de_DE.UTF-8:\ aber auch testweise schon einmal unter standard und xuser eingetragen. Ebenfalls ohne Erfolg.
Code:
#
# A collection of common class names - forward them all to 'default'
# (login would normally do this anyway, but having a class name
#  here suppresses the diagnostic)
#
standard:\
    :tc=default:
xuser:\
    :tc=default:

An welcher Stelle steht bei Dir:
Code:
:lang=de_DE.UTF-8:
 

bluescreen

verstört
Hallo !

Ich nutze unter Linux "lightdm" . Um den auf Deutsch umzustellen muss man
in die lightdm.conf folgenden Eintrag vornehmen !

[Seat:*]
allow-guest=false
autologin-guest=false
autologin-user=bluescreen
display-setup-script=setxkbmap de
greeter-show-manual-login=true

Die lightdm.conf sollte bei FreeBSD unter /usr/local/etc/lightdm zu finden sein !

Gruss
 

bluescreen

verstört
Hi !

Wie gesagt ... ist bei mir unter Linux .... aber die Lokalisierung sollte
wohl in der lightdm.conf vorgenommen werden !


greeter-setup-script=setxkbmap -layout de .... gibt
wohl kleine Unterschiede zwischen *BSD & Linux :rolleyes:

Gruss
 

berni51

OpenBSD user & NetBSD newbie
Ich habs mit einer Datei "10-keyboard.conf" unter /etc/X11/xorg.conf.d gelöst. Eventuell muss das Verzeichnis selbst angelegt werden.
Die Datei hat folgenden Inhalt:

Code:
Section "InputDevice"
    Identifier "Keyboard"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "de"
    Option "XkbOptions" "nodeadkeys"
EndSection

Damit hast Du auch schon im DM den deutschen Zeichensatz.
 
Erst einmal Danke für die zahlreiche Antworten. Ich habe mich wohl nicht gut genug ausgedrückt. Ich möchte eine vollständige Lokalisierung des Anmeldebildschirms in lightdm erreichen. Ich hätte gerne die Button Beschriftungen, Systemmeldungen und Menüeinträge auf Deutsch. So wie es bei vielen Linux Distributionen der Fall ist.

Den Eintrag greeter-setup-script setzt meiner Meinung nach nur das Tastaturlayout auf Deutsch. Ich mache das aber über
/usr/local/etc/X11/xorg.conf.d/keyboard-de.conf:

Code:
Section "InputClass"
      Identifier         "KeyboardDefaults"
      MatchIsKeyboard    "on"
      Option             "XkbLayout" "de"
EndSection

ganz unten, letzter Eintrag. Da stand vorher en_US.UTF.8 und ich hab’s geändert. Bei mir ist alles auf deutsch im Login außer Popups wenn ich das Passwort falsch eingebe (was mich nicht stört)
In meiner /etc/login.conf stand vorher kein Eintrag für en_US.UTF-8. Steht dieser Eintrag bei Dir isoliert an letzter Stelle? Oder ist er innerhalb einer Klasse wie default oder standard vorhanden?
Ich habe jetzt alles mögliche ausprobiert und bin leider immer noch nicht weiter.

Kann es sein das lightdm unter FreeBSD keine vollständige Lokalisierung unterstützt?
 

Lance

Well-Known Member
Danke. Ich wollte nur sichergehen, da es bei mir nicht funktioniert
Nicht aufgeben! Ich guck mal heute Abend meine ganzen Einträge durch. Im /root Verzeichnis war auch noch ein EIntrag und vielleicht noch woanders. Ich habe allerdings auch den MATE Desktop, aber das wird wohl keine Auswirkungen haben.
 
Nicht aufgeben! Ich guck mal heute Abend meine ganzen Einträge durch. Im /root Verzeichnis war auch noch ein EIntrag und vielleicht noch woanders. Ich habe allerdings auch den MATE Desktop, aber das wird wohl keine Auswirkungen haben.
Deine Unterstützung ist echt super. Vielen Dank dafür.
Ich werde die kommenden Tag einmal eine VM aufsetzten um dort zu testen.
Mittels VM kann ich dann immer einfacher wieder auf definierte Snapshots zurück greifen.
 

pit234a

Well-Known Member
das ist schon etwas älter und meine "Mitschrift" daraus ebenfalls:
/etc/rc.conf
keymap="de"

/etc/login.conf
german|German Users Accounts:\
:charset=UTF-8:\
:lang=de_DE.UTF-8:\
:tc=default:

/etc/login.conf.db anlegen: cap_mkdb /etc/login.conf

german in /etc/master.passwd mit vipw eintragen
(weil ich den nicht kann, mache ich es mit ee und rufe danach vipw auf und speichere ab)
vipw /etc/master.passwd
user:$1$ZQy8cjlU$otNcIcr1NfPN5i7bnn.sY.:1001:0:german:0:0:name user:/home/user:/bin/csh

Lokalisierung für csh/tcsh
Die Lokalisierung für csh wird systemweit in der /etc/csh.login eingestellt.
Ich habe das auch gerne in der /etc/csh.cshrc gemacht.
setenv LC_ALL de_DE.UTF-8
setenv LANG de_DE.UTF-8
setenv MM_CHARSET UTF-8

Lokalisierung für sh/bash
Die Lokalisierung für sh und bash wird systemweit in der /etc/profile eingestellt.
LC_ALL=de_DE.UTF-8; export LC_ALL
LANG=de_DE.UTF-8; export LANG
MM_CHARSET=UTF-8; export MM_CHARSET

Es gibt auch lokale Einstellungen pro User, die manche Anwendungen auswerten: ~/.login und ~/.cshrc
Manche Anwendungen sehen auch nach einer ~/.login.conf oder einer ~/.login_conf
Die Syntax ist:

.cshrc
setenv LC_ALL de_DE.UTF-8
setenv LANG de_DE.UTF-8
setenv MM_CHARSET UTF-8

.login
me:\
:charset=UTF-8:\
:lang=de_DE.UTF-8:


X in der /etc/X11/xorg.conf
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


KDM
dann noch später in der /usr/local/share/config/kdm/Xsession ganz oben eingefügt:
. /etc/profile
. ~/.profile

Das bedeutet nicht, dass daraus eine Lösung für lightdm folgt. Man müsste hierzu nochmal die Dokumentation dazu lesen. Dazu sollte eigentlich die man etwas sagen, vielleicht gibt es aber auch Infos im Netz.
Bei meinem Text oben verweise ich mal auf die letzten Zeilen, die für kdm gegolten hatten (also damals) und wo man diesem sagen musste, auf welche profile er setzen sollte.

Das Problem der Lokalisierung ist nicht zentral zu lösen und man muss an unterschiedlichsten Stellen suchen. Für viele Anwendungen gab es dann auch eigene Sprachdateien also Pakete, mit lokalisierter Sprache. Für lightdm finde ich:
Code:
pit@Celsius ~:- > pkg search lightdm
lightdm-1.30.0_2               Lightweight Display Manager
lightdm-gtk-greeter-2.0.8      GTK+ greeter for LightDM
lightdm-gtk-greeter-settings-1.2.2 Settings editor for LightDM GTK+ Greeter
Vielleicht gelingt es ja recht einfach, mit dem Settings-Editor?
 

Lance

Well-Known Member
also ich hab z.B. noch bei /root/.profile stehen:
Code:
CHARSET=iso-8859-1;    export CHARSET
LANG=de_DE.ISO8859-1;    export LANG
LC_ALL=de_DE.UTF-8; export LC_ALL
die letzte Zeile davon hatte ich hinzugefügt.

in der /etc/rc.conf habe ich noch folgenden Eintrag
Code:
keymap="de.kbd"

/root/.xprofile
Code:
setxkbmap  -layout de
 
Das bedeutet nicht, dass daraus eine Lösung für lightdm folgt. Man müsste hierzu nochmal die Dokumentation dazu lesen. Dazu sollte eigentlich die man etwas sagen, vielleicht gibt es aber auch Infos im Netz.
Bei meinem Text oben verweise ich mal auf die letzten Zeilen, die für kdm gegolten hatten (also damals) und wo man diesem sagen musste, auf welche profile er setzen sollte.

Das Problem der Lokalisierung ist nicht zentral zu lösen und man muss an unterschiedlichsten Stellen suchen. Für viele Anwendungen gab es dann auch eigene Sprachdateien also Pakete, mit lokalisierter Sprache. Für lightdm finde ich:
Code:
pit@Celsius ~:- > pkg search lightdm
lightdm-1.30.0_2               Lightweight Display Manager
lightdm-gtk-greeter-2.0.8      GTK+ greeter for LightDM
lightdm-gtk-greeter-settings-1.2.2 Settings editor for LightDM GTK+ Greeter
Vielleicht gelingt es ja recht einfach, mit dem Settings-Editor?
@Pit: Ich kenne Deine Mischrift und hatte sie auch zuvor berücksichtigt. Zudem habe ich Einstellungen der Lokalisierung betreffend an allen möglichen und unmöglichen Stellen eingetragen. Nur um zu sehen, ob es Auswirkungen hat. Leider bisher ohne Erfolg.

Bisher habe ich keine wirkliche ausführliche Doku zu lightdm gefunden. Im Netz sind die folgenden Seiten hilfreich:

https://freedesktop.org/wiki/Software/LightDM/CommonConfiguration/
https://wiki.ubuntuusers.de/LightDM/

Beide Seiten liefern mir aber keine Anhaltspunkte.
Den Setting Editor verwende ich nicht, er dient dazu die Datei lightdm-gtk-greeter.conf anzupassen. Das geht per vi genauso gut.


Das kannst Du aber auch direkt und ohne VM, wenn Du ZFS als Dateisystem verwendest.
Ich verwende ZFS. Ich möchte aber nicht permanent an meiner Konfiguration schrauben. Dann lieber eine VM verwenden. Zudem kann ich dort ein minimale System aufsetzen um dann Schritt für Schritt Anpassungen vornehmen.


also ich hab z.B. noch bei /root/.profile stehen:
Code:
CHARSET=iso-8859-1;    export CHARSET
LANG=de_DE.ISO8859-1;    export LANG
LC_ALL=de_DE.UTF-8; export LC_ALL
die letzte Zeile davon hatte ich hinzugefügt.

in der /etc/rc.conf habe ich noch folgenden Eintrag
Code:
keymap="de.kbd"

/root/.xprofile
Code:
setxkbmap  -layout de

In der /etc/rc.conf wird bei mir ebenfalls während der Installation von FreeBSD
Code:
keymap="de.kbd"
gesetzt.

Eine Datei /root/.xprofile mit dem Inhalt
Code:
setxkbmap  -layout de
habe ich bisher nicht. Ich habe die Datei mit dem Inhalt angelegt. Leider bringt das auch keine Abhilfe.
 

pit234a

Well-Known Member
vielleicht kann das ja helfen?
ich habe keine Ahnung davon udn bin eher zufällig nach zwei oder drei Klicks dort geladet. Aber da gibt es spezielle Patches, die offenbar die Sprache des lightdm setzen, wenn es sich nicht um eine Live-Version handelt.
 
da habe ich lediglich ein default:\ stehen.
Erst einmal frohe Weihnachten. :)

Ich verwende die Loginklasse german|German um die Lokalisierung für die Login Shell festzulegen, so wir dies im Handbuch beschrieben steht.
Ich hatte charset=UTF-8 und lang=de_DE.UTF-8 aber ebenfalls unter default:\ eingetragen und diese Loginklasse dem User lightdm zugewiesen. Leider hilft das bei mir ebenfalls nicht.

Hier ist meine ursprüngliche /etc/login.conf:
Code:
# login.conf - login class capabilities database.
#
# Remember to rebuild the database after each change to this file:
#
#    cap_mkdb /etc/login.conf
#
# This file controls resource limits, accounting limits and
# default user environment settings.
#
# $FreeBSD: releng/12.1/usr.bin/login/login.conf 338399 2018-08-30 15:52:03Z brd $
#

# Default settings effectively disable resource limits, see the
# examples below for a starting point to enable them.

# defaults
# These settings are used by login(1) by default for classless users
# Note that entries like "cputime" set both "cputime-cur" and "cputime-max"
#
# Note that since a colon ':' is used to separate capability entries,
# a \c escape sequence must be used to embed a literal colon in the
# value or name of a capability (see the ``CGETNUM AND CGETSTR SYNTAX
# AND SEMANTICS'' section of getcap(3) for more escape sequences).

default:\
    :passwd_format=sha512:\
    :copyright=/etc/COPYRIGHT:\
    :welcome=/etc/motd:\
    :setenv=MAIL=/var/mail/$,BLOCKSIZE=K:\
    :path=/sbin /bin /usr/sbin /usr/bin /usr/local/sbin /usr/local/bin ~/bin:\
    :nologin=/var/run/nologin:\
    :cputime=unlimited:\
    :datasize=unlimited:\
    :stacksize=unlimited:\
    :memorylocked=64K:\
    :memoryuse=unlimited:\
    :filesize=unlimited:\
    :coredumpsize=unlimited:\
    :openfiles=unlimited:\
    :maxproc=unlimited:\
    :sbsize=unlimited:\
    :vmemoryuse=unlimited:\
    :swapuse=unlimited:\
    :pseudoterminals=unlimited:\
    :kqueues=unlimited:\
    :umtxp=unlimited:\
    :priority=0:\
    :ignoretime@:\
    :umask=022:


#
# A collection of common class names - forward them all to 'default'
# (login would normally do this anyway, but having a class name
#  here suppresses the diagnostic)
#
standard:\
    :tc=default:
xuser:\
    :tc=default:
staff:\
    :tc=default:
daemon:\
    :memorylocked=128M:\
    :tc=default:
news:\
    :tc=default:
dialer:\
    :tc=default:

#
# Root can always login
#
# N.B.  login_getpwclass(3) will use this entry for the root account,
#       in preference to 'default'.
root:\
    :ignorenologin:\
    :memorylocked=unlimited:\
    :tc=default:

#
# Russian Users Accounts. Setup proper environment variables.
#
russian|Russian Users Accounts:\
    :charset=UTF-8:\
    :lang=ru_RU.UTF-8:\
    :tc=default:


#
# German Users Accounts. Setup proper environment variables.
#
german|German Users Accounts:\
    :charset=UTF-8:\
    :lang=de_DE.UTF-8:\
    :tc=default:

######################################################################
######################################################################
##
## Example entries
##
######################################################################
######################################################################

## Example defaults
## These settings are used by login(1) by default for classless users
## Note that entries like "cputime" set both "cputime-cur" and "cputime-max"
#
#default:\
#    :cputime=infinity:\
#    :datasize-cur=22M:\
#    :stacksize-cur=8M:\
#    :memorylocked-cur=10M:\
#    :memoryuse-cur=30M:\
#    :filesize=infinity:\
#    :coredumpsize=infinity:\
#    :maxproc-cur=64:\
#    :openfiles-cur=64:\
#    :priority=0:\
#    :requirehome@:\
#    :umask=022:\
#    :tc=auth-defaults:
#
#
##
## standard - standard user defaults
##
#standard:\
#    :copyright=/etc/COPYRIGHT:\
#    :welcome=/etc/motd:\
#    :setenv=MAIL=/var/mail/$,BLOCKSIZE=K:\
#    :path=~/bin /bin /usr/bin /usr/local/bin:\
#    :manpath=/usr/share/man /usr/local/man:\
#    :nologin=/var/run/nologin:\
#    :cputime=1h30m:\
#    :datasize=8M:\
#    :vmemoryuse=100M:\
#    :stacksize=2M:\
#    :memorylocked=4M:\
#    :memoryuse=8M:\
#    :filesize=8M:\
#    :coredumpsize=8M:\
#    :openfiles=24:\
#    :maxproc=32:\
#    :priority=0:\
#    :requirehome:\
#    :passwordtime=90d:\
#    :umask=002:\
#    :ignoretime@:\
#    :tc=default:
#
#
##
## users of X (needs more resources!)
##
#xuser:\
#    :manpath=/usr/share/man /usr/local/man:\
#    :cputime=4h:\
#    :datasize=12M:\
#    :vmemoryuse=infinity:\
#    :stacksize=4M:\
#    :filesize=8M:\
#    :memoryuse=16M:\
#    :openfiles=32:\
#    :maxproc=48:\
#    :tc=standard:
#
#
##
## Staff users - few restrictions and allow login anytime
##
#staff:\
#    :ignorenologin:\
#    :ignoretime:\
#    :requirehome@:\
#    :accounted@:\
#    :path=~/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/local/sbin:\
#    :umask=022:\
#    :tc=standard:
#
#
##
## root - fallback for root logins
##
#root:\
#    :path=~/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/local/sbin:\
#    :cputime=infinity:\
#    :datasize=infinity:\
#    :stacksize=infinity:\
#    :memorylocked=infinity:\
#    :memoryuse=infinity:\
#    :filesize=infinity:\
#    :coredumpsize=infinity:\
#    :openfiles=infinity:\
#    :maxproc=infinity:\
#    :memoryuse-cur=32M:\
#    :maxproc-cur=64:\
#    :openfiles-cur=1024:\
#    :priority=0:\
#    :requirehome@:\
#    :umask=022:\
#    :tc=auth-root-defaults:
#
#
##
## Settings used by /etc/rc
##
#daemon:\
#    :coredumpsize@:\
#    :coredumpsize-cur=0:\
#    :datasize=infinity:\
#    :datasize-cur@:\
#    :maxproc=512:\
#    :maxproc-cur@:\
#    :memoryuse-cur=64M:\
#    :memorylocked-cur=64M:\
#    :openfiles=1024:\
#    :openfiles-cur@:\
#    :stacksize=16M:\
#    :stacksize-cur@:\
#    :tc=default:
#
#
##
## Settings used by news subsystem
##
#news:\
#    :path=/usr/local/news/bin /bin /sbin /usr/bin /usr/sbin /usr/local/bin /usr/local/sbin:\
#    :cputime=infinity:\
#    :filesize=128M:\
#    :datasize-cur=64M:\
#    :stacksize-cur=32M:\
#    :coredumpsize-cur=0:\
#    :maxmemorysize-cur=128M:\
#    :memorylocked=32M:\
#    :maxproc=128:\
#    :openfiles=256:\
#    :tc=default:
#
#
##
## The dialer class should be used for a dialup PPP account
## Welcome messages/news suppressed
##
#dialer:\
#    :hushlogin:\
#    :requirehome@:\
#    :cputime=unlimited:\
#    :filesize=2M:\
#    :datasize=2M:\
#    :stacksize=4M:\
#    :coredumpsize=0:\
#    :memoryuse=4M:\
#    :memorylocked=1M:\
#    :maxproc=16:\
#    :openfiles=32:\
#    :tc=standard:
#
#
##
## Site full-time 24/7 PPP connection
## - no time accounting, restricted to access via dialin lines
##
#site:\
#    :ignoretime:\
#    :passwordtime@:\
#    :refreshtime@:\
#    :refreshperiod@:\
#    :sessionlimit@:\
#    :autodelete@:\
#    :expireperiod@:\
#    :graceexpire@:\
#    :gracetime@:\
#    :warnexpire@:\
#    :warnpassword@:\
#    :idletime@:\
#    :sessiontime@:\
#    :daytime@:\
#    :weektime@:\
#    :monthtime@:\
#    :warntime@:\
#    :accounted@:\
#    :tc=dialer:\
#    :tc=staff:
#
#
##
## Example standard accounting entries for subscriber levels
##
#
#subscriber|Subscribers:\
#    :accounted:\
#    :refreshtime=180d:\
#    :refreshperiod@:\
#    :sessionlimit@:\
#    :autodelete=30d:\
#    :expireperiod=180d:\
#    :graceexpire=7d:\
#    :gracetime=10m:\
#    :warnexpire=7d:\
#    :warnpassword=7d:\
#    :idletime=30m:\
#    :sessiontime=4h:\
#    :daytime=6h:\
#    :weektime=40h:\
#    :monthtime=120h:\
#    :warntime=4h:\
#    :tc=standard:
#
#
##
## Subscriber accounts. These accounts have their login times
## accounted and have access limits applied.
##
#subppp|PPP Subscriber Accounts:\
#    :tc=dialer:\
#    :tc=subscriber:
#
#
#subshell|Shell Subscriber Accounts:\
#    :tc=subscriber:
#
##
## If you want some of the accounts to use traditional UNIX DES based
## password hashes.
##
#des_users:\
#    :passwd_format=des:\
#    :tc=default:

vielleicht kann das ja helfen?
ich habe keine Ahnung davon udn bin eher zufällig nach zwei oder drei Klicks dort geladet. Aber da gibt es spezielle Patches, die offenbar die Sprache des lightdm setzen, wenn es sich nicht um eine Live-Version handelt.
Danke für den Hinweis. Ich habe mir den Bugreport unter https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1861481 durchgelesen. Ob dieser Fehler auch auf den Port x11/lightdm zutrifft kann ich nicht beurteilen, da ich mir den Source Code bisher nicht angesehene habe. Sich hier einzuarbeiten ist zudem zu aufwendig.

Zudem habe ich noch versucht die Sprache in /usr/local/share/xgreeters/lightdm-gtk-greeter.desktop einzustellen.
Auch das bringt nicht den gewünschten Erfolg:

Code:
[Desktop Entry]
Name=LightDM GTK+ Greeter
Comment=This runs the GTK+ greeter, it should only be run from LightDM
Exec=env LANGUAGE=de lightdm-gtk-greeter
Type=Application
X-Ubuntu-Gettext-Domain=lightdm
 
Ich habe die Lösung gefunden. Die Steuerung der Sprache für den Login Screen erfolgt über /usr/local/share/xgreeters/lightdm-gtk-greeter.desktop:
Ich war gestern Abend bereits auf dem richtigen Weg und habe aber die falsche Syntax verwendet. Die Umgebung wird über den Eintrag Exec=env LANG=de_DE.UTF-8 lightdm-gtk-greeter gesteuert.

Code:
[Desktop Entry]
Name=LightDM GTK+ Greeter
Comment=This runs the GTK+ greeter, it should only be run from LightDM
Exec=env LANG=de_DE.UTF-8 lightdm-gtk-greeter
Type=Application
X-Ubuntu-Gettext-Domain=lightdm
 

Lance

Well-Known Member
Cool, freut mich.

Woher hast du die Einträge? Bei mir steht teilweise was anderes drin, auch heisst die Datei hier schlicht "Slick Greeter" :

Code:
[Desktop Entry]
Name=Slick Greeter
Comment=Slick Greeter
Exec=env LANG=de_DE.UTF-8 slick-greeter
Type=Application
X-Ubuntu-Gettext-Domain=slick-greeter
 
Cool, freut mich.

Woher hast du die Einträge? Bei mir steht teilweise was anderes drin, auch heisst die Datei hier schlicht "Slick Greeter" :

Code:
[Desktop Entry]
Name=Slick Greeter
Comment=Slick Greeter
Exec=env LANG=de_DE.UTF-8 slick-greeter
Type=Application
X-Ubuntu-Gettext-Domain=slick-greeter

LightDM bringt keinen Greeter mit. Daher muss man einen Greeter selber installieren. Es gibt verschiedene Greeter für lightdm, siehe hierzu: https://github.com/canonical/lightdm

In den Ports sind die beiden folgenden Greeter
  • /x11/lightdm-gtk-greeter und
  • /x11/slick-greeter

Ich habe mich für den lightdm-gtk-greeter entschieden, da er sich gut auf meine Bedürfnisse anpassen lässt.

Ich bin gestern Abend bei der Suche nach einer Lösung auf diesen Wiki Eintrag gestoßen. Dort ist ersichtlich das man Umgebungsvariablen in /usr/share/xgreeters/lightdm-gtk-greeter.desktop (Linux) setzen kann. Mit etwas Glück hat es dann durch ausprobieren funktioniert.

Code:
/usr/share/xgreeters/lightdm-gtk-greeter.desktop

[Desktop Entry]
Name=LightDM GTK+ Greeter
Comment=This runs the GTK+ greeter, it should only be run from LightDM
Exec=env GTK_THEME=Adwaita:dark lightdm-gtk-greeter
Type=Application
X-Ubuntu-Gettext-Domain=lightdm
 

Lance

Well-Known Member
Nun ja, ich nehme das, was mir GhostBSD bietet und das gefällt mir schon sehr gut und es funktioniert. GhostBSD ist schon ein kleines FreeBSD Juwel, denn ohne wäre ich dem FreeBSD Desktop fern da - wie ich schon in diversen Posts erwähnt hatte - ich keine Zeit und Lust habe, mich um die Konfiguration eines Desktops zu kümmern.
Nun gut das jetzt alles funktioniert, so haben wir einen zufriedenen FreeBSD User mehr und der eine oder andere Leser hat vielleicht was dazugelernt.
 

pit234a

Well-Known Member
und so ein echter innerer... Dingsda wäre es mir dann natürlich, wenn der zugehörige Editor die Einstellung auch grafisch und ohne zu suchen erledigen würde. Habe aber keine Ahnung davon, was der wirklich kann und macht.

lightdm-gtk-greeter-settings-1.2.2 Settings editor for LightDM GTK+ Greeter

Mir gefällt es auch viel besser, wenn man sich mit einem Thema auseinandergesetzt hat und dann eine Lösung für sich findet, als wenn alles schon gleich fix und fertig ist. Wobei ich selbst den XDM nutze und der hat gar nichts, was er in einer bestimmten Sprache darstellen müsste und genügt meinen Anforderungen auch und weil ich vielleicht einmal im Monat neu Einlogge, hätte ich wahrscheinlich auch nichts gegen einen Englischen DM unternommen.

Wichtiger ist die Sprache für X, wenn man Passwort-Verwirrungen mit enthaltenen x und y vorbeugen möchte und vor Allem, falls man das wirklich noch remote mittels XDMCP nutzen will.
 
Oben