Budgie Desktop - Nutzt den hier jemand?

cabriofahrer

Well-Known Member
Bin zufällig darauf gestoßen und habe den Wikipedia-Artikel dazu gelesen. Ein DE, der auch für FreeBSD verfügbar ist. Die Screenshots sehen ganz nett aus, irgendwie wie Gnome3, aber mit normalem Panel, wie eben bei einem traditionellen DE. Ich poste hier mal, was "pkg install budgie" ergibt. Da sieht man schon, gdm und nautilus sind Bestandteil, also schon mal nicht schlecht. Mir stellt sich nur die Frage, ob Budgie irgendetwas bringt, wenn man wie ich z.B. sowieso MATE nutzt? Wahrscheinlich kaum. Irgendwelche Erfahrungen oder Bewertungen hier?

Code:
# pkg install budgie
Updating FreeBSD repository catalogue...
Fetching packagesite.pkg: 100%    7 MiB   1.4MB/s    00:05   
Processing entries: 100%
FreeBSD repository update completed. 32881 packages processed.
All repositories are up to date.
The following 64 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    budgie: 10.7
    budgie-backgrounds: 1.0
    budgie-control-center: 1.2.0
    budgie-desktop: 10.7.1
    budgie-desktop-view: 1.2.1
    budgie-screensaver: 5.1.0
    budgie-trash-applet: 2.1.2
    cantarell-fonts: 0.301
    clutter: 1.26.4_1
    clutter-gst3: 3.0.27_2
    clutter-gtk3: 1.8.4_2
    cogl: 1.22.8_1
    colord-gtk: 0.3.0_1
    cracklib: 2.9.7_1
    evolution-data-server: 3.44.4_3
    gdm: 42.0_5
    geocode-glib: 3.26.4
    geocode-glib2: 3.26.4
    gmime26: 2.6.23_2
    gnome-autoar: 0.4.3_1
    gnome-control-center: 43.2_1
    gnome-desktop: 42.4_1
    gnome-icon-theme-symbolic: 3.12.0
    gnome-keyring: 42.1_1
    gnome-menus: 3.36.0
    gnome-online-accounts: 3.44.0_1
    gnome-session: 42.0_1
    gnome-settings-daemon: 42.2_4
    gnome-shell: 42.4_4
    gnome-terminal: 3.44.2_1
    gom: 0.4
    grilo: 0.3.15
    grilo-plugins: 0.3.15
    gsound: 1.0.3
    gstreamer1-plugins-chromaprint: 1.22.0
    ibus: 1.5.27_2
    libadwaita: 1.3.1
    libcroco: 0.6.13_2
    libgdata: 0.18.1
    libgee: 0.20.6
    libgnomekbd: 3.26.1_1
    libgweather: 40.0_4
    libgweather4: 4.2.0_1
    libical: 3.0.8_8
    libmediaart: 1.9.6
    liboauth: 1.0.3_4
    libportal: 0.6_2
    libportal-gtk3: 0.6_2
    libpwquality: 1.4.5
    mutter: 42.4_1
    nautilus: 42.2_2
    pinentry-gnome: 1.2.1
    polkit-gnome: 0.105_3
    py39-libpeas: 1.34.0
    qogir-gtk-themes: 2023.02.27
    rest: 0.8.1_2
    tela-icon-theme: 2023.02.03
    totem: 3.38.2_3
    tracker: 2.3.4_9
    tracker3: 3.1.2_6
    xbitmaps: 1.1.2
    xdotool: 3.20211022.1,1
    xhost: 1.0.8
    xsetroot: 1.1.2

Number of packages to be installed: 64

The process will require 414 MiB more space.
73 MiB to be downloaded.

Proceed with this action? [y/N]:
 
Also ich habe ihn mal installiert, habe mich ausgeloggt (lightdm), die Budgie Session ausgewählt aber ich bekomme nur kurz einen schwarzen Bildschirm und bin wieder im Login. Dann habe ich in einer Konsole den Service lightdm gestoppt und mal gdm gestartet, doch er bricht mit einer Fehlermeldung ab. 3D-Beschleunigung habe ich mit meiner Nvidia GTX 750 (nvidia-driver-470), also weiß ich nicht, wo das Problem liegt.
Ich benutze also weiterhin MATE.
 
die haben also sogar ein eigenes Ubuntu-Flavor (Bubuntu hat ihnen wohl nicht als Name gefallen).
Damit sollte es zumindest einfach möglich sein, sich das mal auch außerhalb von FreeBSD anzusehen. Das kann sinnvoll sein, anstatt erst Fehler unter FreeBSD zu suchen, denn Erfahrungsgemäß sind "neue" Desktop-Environments es nicht Wert, sie unbedingt zum Laufen zu bringen.
Für mich ist es "einer mehr", der Powerfull, Small, Easy-to-Use, Customizable und weiß der Kuckuck was noch ist, lauter Dinge, von denen man dann nichts merkt oder die eher störende Nebeneffekte erzeugen.
 
Läuft einwandfrei ! Login über lightdm und manuell --> xinitrc

Allerdings ist noch der alte bug vorhanden !

#
Section "Device"
Option "DRI3" "false"
Option "TearFree" "True"
Option "VariableRefresh" "True"
Identifier "Card0"
Driver "amdgpu"
EndSection


DRI3 geht nicht bei Gnome, Cinnamon und Budgie !!! (Radeon Karte)

:ugly:

Gruss
 

Anhänge

  • budgie_freebsd.png
    budgie_freebsd.png
    629,6 KB · Aufrufe: 152
Na das ist ja mal ein Testbericht. ;)

Und bloß nicht wenigstens die Fehlermeldung nennen. Der "Bericht" könnte ja versehentlich informative Elemente enthalten. :-)
Scherzkekse! Der Testbericht wäre über einen funktionierenden DE gewesen. Die Fehlermeldung hätte ich genannt, wenn ich an einer Lösung des Problems interessiert gewesen wäre, war ich aber nicht. Ich hatte in der Vergangenheit wahrscheinlich das gleiche Problem, als ich mal Gnome3 ausprobieren wollte und es im 3D-Modus nicht lief (obwohl die 3D-Beschleunigung bei mir geht), sondern nur im 2D-Modus. Liegt wahrscheinlch irgendwie am Nvidia-Treiber.
Allerdings ist noch der alte bug vorhanden !

#
Section "Device"
Option "DRI3" "false"
Option "TearFree" "True"
Option "VariableRefresh" "True"
Identifier "Card0"
Driver "amdgpu"
EndSection


DRI3 geht nicht bei Gnome, Cinnamon und Budgie !!! (Radeon Karte)
Aha, ist das also das Problem? Müsste ich also in der Xorg.conf für meine Nvidia-Karte auch dri3 deaktivieren? Wo ist "dieser alte Bug" beschrieben?
 
Moin !

Der Bug mit "Dri3" ist nur bei Radeon-Karten und nur unter FreeBSD vorhanden !

Um den Fehler zu finden würde ich wie folgt vorgehen :

1. Keine xorg.conf ( und wenn doch nur minimal ! )
2. Entferne (auskommentieren ) die Einträge für gdm, lightdm & gnome aus rc.conf ! Erst den manuellen start testen !
3. Die angehängten Dateien in dein "User-Verzeichniss kopieren !
also : /home/user/.xinitrc & /home/user/.xprofile
4. Neustart ! Manuell einloggen und mal " startx " ausführen !
5. Dann mal berichten !

Gruss

P.S: Die Dateien sind nicht von mir !

pkg-message:
For install:
Copy 'xprofile' into your home directory: cp /usr/local/share/examples/budgie/xprofile ~/.xprofile
More information, https://codeberg.org/olivierd/freebsd-ports-budgie/wiki
If you want to launch new session from a console (without login manager)
cp /usr/local/share/examples/budgie/xinitrc ~/.xinitrc


:ugly:
 

Anhänge

  • xprofile.txt
    2,3 KB · Aufrufe: 87
  • xinitrc.txt
    333 Bytes · Aufrufe: 76
1. Keine xorg.conf ( und wenn doch nur minimal ! )
Die brauche ich aber, sonst bekomme ich kein X mit der Nvidia-Karte. Die ist aber auch minimal, weil mit nvidia-xconfig automatisch erstellt.

Vielen Dank für die Hinweise, ich habe die Anleitung in dem Link mal gelesen und das erscheint mir alles viel zu aufwändig, um nur mal kurz einen Desktop auszuprobieren, bei dem ich höchstwahrscheinlich sowieso nicht bleiben würde.
Ich poste aber jetzt doch mal die Fehlermeldung von GDM, nachdem ich in einer Konsole vorher LightDM gestoppt hatte:

1683715895011.jpeg
 
Eventuell läuft kein dbus, aber das ist halb geraten.
Natürlich läuft dbus, ich brauche ihn ja mindestens für lightdm:

Code:
# service dbus start
dbus already running?  (pid=1212).
# ps -ax | grep dbus
1212  -  Is    0:00.19 /usr/local/bin/dbus-daemon --system
3450  -  I     0:00.00 dbus-launch --autolaunch d5d22db4fb8cc6058ddb865953f4612
3451  -  Is    0:00.01 /usr/local/bin/dbus-daemon --syslog-only --fork --print-
3454  -  I     0:00.13 /usr/local/bin/dbus-daemon --config-file=/usr/local/shar
3482  -  I     0:00.00 dbus-launch --exit-with-session mate-session
3483  -  Is    0:00.18 /usr/local/bin/dbus-daemon --syslog --fork --print-pid 5
3486  -  I     0:00.16 /usr/local/bin/dbus-daemon --config-file=/usr/local/shar
3699  1  S+    0:00.00 grep dbus

Ein Blick in die Logfiles erspart evtl. das Raten und zeigt vielleicht die Ursache. Deswegen (frei nach einem Kinderlied): Zeig her deine Logfiles, zeig her deine...
Hatte ich mir auch gedacht, aber welche genau? Dann gerne. Und könnte es auch sein, dass gdm (aus den Quarterly Packages) einfach zufällig falsch kompiliert ist? Sowas hat man manchnal auch...
 
Erste Anlaufstellen wären für mich:
/var/log/messages
/var/log/gdm
/var/log/Xorg.0.log
/var/log/einfach-nachsehen-welche-sich-geändert-hat.log
 
Also von all den logs in /var/log/gdm

Code:
# ls
:0-greeter.log        :1-greeter.log.2    :3.log
:0-greeter.log.1    :1-greeter.log.3    :3.log.1
:0-greeter.log.2    :1-greeter.log.4    :3.log.2
:0-greeter.log.3    :1-slave.log        :3.log.3
:0-greeter.log.4    :1-slave.log.1        :3.log.4
:0-slave.log        :1.log            :4-greeter.log
:0-slave.log.1        :1.log.1        :4.log
:0-slave.log.2        :1.log.2        :4.log.1
:0-slave.log.3        :1.log.3        :4.log.2
:0-slave.log.4        :1.log.4        :4.log.3
:0.log            :2-greeter.log        :4.log.4
:0.log.1        :2.log            :5-greeter.log
:0.log.2        :2.log.1        :5.log
:0.log.3        :2.log.2        :5.log.1
:0.log.4        :2.log.3        :5.log.2
:1-greeter.log        :2.log.4        :5.log.3
:1-greeter.log.1    :3-greeter.log        :5.log.4

ist glaube ich das hier das Neueste:

Code:
# more :0-greeter.log
dbus-daemon[5651]: [session uid=92 pid=5651] Activating service name='org.a11y.Bus' requested by ':1.0' (uid=92 pid=5654 comm="/usr/local/libexec/gnome-session-check-accelerated")
dbus-daemon[5651]: [session uid=92 pid=5651] Successfully activated service 'org.a11y.Bus'
ld-elf.so.1: /usr/local/libexec/gnome-session-binary: Undefined symbol "g_string_free_and_steal"
# more :0-slave.log
# more :0.log

Ansonsten noch das hier (es war ja gestern am 10. Mai):

Code:
$ tail -n 1000 /var/log/messages | grep gdm
May 10 12:45:27 amd64 gdm-launch-environment][5648]: GLib-GObject: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
May 10 12:45:27 amd64 gdm[5634]: Gdm: GdmDisplay: Session never registered, failing
May 10 12:45:27 amd64 gdm[5634]: Gdm: Child process -5650 was already dead.
May 10 12:45:27 amd64 gdm[5634]: Gdm: Child process 5648 was already dead.
May 10 12:45:27 amd64 gdm[5634]: Gdm: Unable to kill session worker process

Scheint alles in die gleiche Kerbe zu schlagen, irgendein Fehler im Zusammenhang mit "ld-elf.so.1"?
 
Das Undefined symbol "g_string_free_and_steal" könnte ein Hinweis darauf sein, dass Du möglicherweise ne veraltete Version von glib einsetzt.
Ich würde erst mal checken, ob das Symbol tatsächlich existiert (bzw. nicht existiert).
Bei
readelf -s /usr/local/lib/libglib-2.0.so
sollte irgendwo ein ne Zeile wie
....... GLOBAL DEFAULT 13 g_string_free_and_steal
auftauchen.
Und check mal Deine glib-Version (pkg info glib). Die sollte idealerweise bei 2.76 oder höher liegen.
 
Ein "pkg upgrade" hat das Problem gelöst. Auch wenn das nicht so lange her war, dass ich das gemacht hatte, war das wohl nötig. Danach startete GDM problemlos, auch Budgie. Gefallen hat es mir allerdings nicht, es ist Gnome3 Look and Feel, auch die ganze Konfiguration, wo man erst lange herumsuchen muss, mit diesen häßlichen runden Schaltköpfen, usw. Kann ich nicht unbedingt empfehlen, ich bleibe bei LightDM/MATE.
 
Du hast ja völlig recht, aber da das letzte Upgrade wie gesagt nicht so lange her war, war das eben nicht mein erster Gedanke.
 
Kann ich nicht unbedingt empfehlen, ich bleibe bei LightDM/MATE.
Das geht hierbei um deine persönliche Geschmacksrichtung. Vielleicht gefallen vielen anderen diese „hässlichen, runden Dinger“. Bei einer Empfehlung oder dem Gegenteil würde ich ja eher praktische / technische Argumente liefern.
 
Zurück
Oben