• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Dedizierte Grafikkarte zur Entlastung des Ram's

pit234a

Well-Known Member
#26
Vergleiche einfach das Verhalten des installierten Systems mit dem, das aus Knoppix kommt.
dazu vergaß ich etwas hinzuzufügen, das ist für wichtig halte: auf magische Weise wählt Knoppix zum Booten entweder einen 64Bit- oder den 32Bit-Kernel. Es ist nämlich, wenn man rein auf Geschwindigkeit schaut, gar kein Vorteil einen 64Bit-Kern bei <= 4G RAM überhaupt zu starten. Es könnte sehr gut sein, dass ein 32Bit System da durchaus reaktiver daher kommt.

Unter Ubuntu langt doch ein sudo ubuntu-drivers autoinstall, ganz ohne Eingriff in irgendwelche Config-Dateien?
bei der letzten Installation hatte ich das über die grafischen Tools gemacht und da gab es eine eindeutige Rubrik, die gezielt angewählt werden musste, um nach "fremden" Treibern für vorhandene HW zu suchen und diese mussten dann wiederum gezielt zur Installation ausgewählt werden (und diverse Warnungen abgenickt, ohne die ja heute nichts mehr geht).
Zuvor hatte ich im Netz nach passenden Repositries gesucht und diese per apt-Befehl verfügbar gemacht, um sie dann zu installieren. Als ich diesesmal das probierte, gab es aber Fehlermeldungen, dass die neuen Repositries unberücksichtigt blieben, weil sie eine Sicherheitsverletzung darstellten und dazu hätte ich erst wieder man-pages lesen müssen, um das abzustellen. Deshalb der Griff zum grafischen Tool.
Aber, das führt vom Thema weg.
Wichtig bleibt mir: Distributionen installieren mitunter nicht direkt im ersten Automatismus, was die eigene HW am besten unterstützt. Da sollte man sich einlesen und nachforschen.
 
Themenstarter #27
Es ist nämlich, wenn man rein auf Geschwindigkeit schaut, gar kein Vorteil einen 64Bit-Kern bei <= 4G RAM überhaupt zu starten. Es könnte sehr gut sein, dass ein 32Bit System da durchaus reaktiver daher kommt.
Das stimmt. Habe auf dem gleichen PC auch ein Debian 32bit installiert. Das ist flotter, macht allerdings Probleme, die vor systemd unbekannt waren. Deshalb bin ich auch zu Devuan u. OpenBSD gewechselt.

Ich werde mal nachschauen, dabei bin ich ziemlich sicher, das ich für die Grafik keine Firmware installiert habe. Vielleicht hängt es auch damit zusammen, dass das Board lediglich einen VGA-Ausgang hat. Mein Bildschirm ein LG Flatron W2242TE hat einen VGA und einen DVI Anschluß.
 

-Nuke-

Well-Known Member
#28
Nur so nebenbei: Bis auf einem hochaktuellen Firefox (Version >= 80) unterstützt weder Firefox noch Chromium Hardware Videodecoding. In einem aktuellen Firefox kann man via about:config Webrender und VA-API Dekodierung aktivieren, das ist zur Zeit noch so halb in der Beta-Phase. Beides braucht in Kombination eine recht aktuelle GPU.

Ich weiß jetzt nicht was du für eine GPU hast (der Pentium den du genannt hast, hat keine), aber ich denke das System ist allgemein zu alt für einen H264 Hardwardekoder.

Du könntest dir jetzt natürlich eine neuere GPU mit Hardware-Videodekodierung kaufen und versuchen dies dann unter den BSDs oder Linux zum Laufen zu kriegen, aber out-of-the-box wird es das Problem nicht lösen.

Sinnvoller ist ein neuer PC, oder du drehst halt die Auflösung der YouTube-Videos runter.
 
Themenstarter #30
Ich weiß jetzt nicht was du für eine GPU hast (der Pentium den du genannt hast, hat keine), aber ich denke das System ist allgemein zu alt für einen H264 Hardwardekoder.
Code:
$ lspci -nnk | grep -i VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
    Subsystem: Gigabyte Technology Co., Ltd 82945G/GZ Integrated Graphics Controller [1458:d000]
    Kernel driver in use: i915
 

Idefixx

Well-Known Member
#31
Mein Gott, Walther! Was für ein TamTam . . . :rolleyes: In der Zeit, die Du mit dem alten Kram rumgemurkst hast, hättest Du Dir inzwischen einen gebrauchten Rechner kaufen und einrichten können, und alles lief. Wirf mal eine Blick hier rein:
Fujitsu Esprimo P520 MT - Core i5-4590 @ 3,3 GHz - 8GB RAM - 250GB SSD - DVD-RW - Win10Home

Für schlappe 209,00 Euro. Also, wenn das kein Schnäppchen ist . . .

Humor ist, wenn man trotzdem lacht . . . mal was ohne Computer
 

Anhänge

Themenstarter #33
Das Produkt ist leider ausverkauft!

Na, daß ging ja schnell! Wer hat denn da zugeschlagen? :D
Das Angebot war mit Sicherheit gut. Vielen Dank dafür! Aber als ich nachschaute war schon ausverkauft. Aber ich habe weiter vorne schon geschrieben, dass ich mir einen neuen PC zusammenstelle. So etwas wird natürlich bei der Vielzahl der Beiträge leicht überlesen.

Ich fand das alles sehr interessant und danke nochmals allen.


Aber bevor sich das weiter im Kreis dreht, würde ich den Beitrag gerne als gelöst markieren.

ENDE
 

pit234a

Well-Known Member
#34
Ich fand das alles sehr interessant und danke nochmals allen.

Aber bevor sich das weiter im Kreis dreht, würde ich den Beitrag gerne als gelöst markieren.

ENDE
So geht das nicht.
Vielleicht greife ich den Mods nun vor, aber wie ich das verstehe, gehört dir selbst nicht dein Thread.
Du kannst nicht etwas anregen/fragen/lostreten und dann nach Belieben beenden und damit allen anderen Teilnehmern der Diskussion entziehen. Es geht ja nicht um deine Befindlichkeiten und deine private Situation (obwohl die in den Antworten natürlich bestmöglich referenziert werden sollte, sofern du sie denn überhaupt geschildert hast).
Es geht um ein allgemeines Thema/Problem und die Teilnehmer äußern sich auch allgemein, so dass sie mit ihren jeweiligen Meinungen durchaus weiteren Diskussionsbedarf haben, der weit über die ursprüngliche Frage hinaus gehen kann.

Ich finde das super und lerne aus jedem Thread!

Man kann umso mehr lernen, desto mehr Information geliefert wird, desto spezifischer ein Problem gefasst werden kann.
Das fand hier eher nicht statt. Und ich sehe auch keine Lösung.
OK, manchmal gibt es keine Lösung und "mach alles neu", "kauf einen neuen PC" ist mitunter durchaus gerechtfertigt.
So gesehen ist das Problem für den Thread-Starter dann gelöst, wie Alexander der Große den Gordischen Knoten einst gelöst hat.
Für mich und wohl die Allgemeinheit ist aber nicht eindeutig nachvollziehbar, was tatsächlich Ursache der Problematik gewesen ist.
Eine Analyse fand gar nicht statt, oder habe ich was verpasst?
 
Themenstarter #35
Vielleicht greife ich den Mods nun vor, aber wie ich das verstehe, gehört dir selbst nicht dein Thread.
Du kannst nicht etwas anregen/fragen/lostreten und dann nach Belieben beenden und damit allen anderen Teilnehmern der Diskussion entziehen
Ok, diese Sichtweise ist mir bis dato unbekannt. Aber wenn das so ist, dann halte ich mich natürlich an die Regeln dieses Forums.

Was die Analyse des Problems angeht, dann mach bitte einen Vorschlag. Ich versuche ihn umzusetzen. :)
 

Idefixx

Well-Known Member
#36
Was die Analyse des Problems angeht, dann mach bitte einen Vorschlag. Ich versuche ihn umzusetzen. :)
Na, die gab es doch nun wirklich erschöpfend. Aber noch kurz zusammengefaßt:

1. Hast Du Dir die verlinkte Seite wirklich angesehen?

2. Dein Rechner ist zu alt und zu schwachbrüstig für heutiges sinnvolles Arbeiten.

3. Sieh noch mal auf die verlinkte Seite.

4. Wenn Du zu den Fricklern gehörst deren Credo lautet: "Ohne Gefrickel fühle ich mich leer und unausgefüllt" - dann frickel.

5. Willst Du weiterhin einen PC selbst zusammenbauen, dann mach es, und vergiß Nr. 1 bis 4. Glaube aber nicht, daß der besser funktioniert als ein gebrauchter PC mit 12 Monaten Garantie.

PS: Deine Silberbüchse braucht mal ne Ölung. :rolleyes:
 
Themenstarter #37
Na, die gab es doch nun wirklich erschöpfend. Aber noch kurz zusammengefaßt:
Euch kann man scheinbar nichts recht machen.

Eine Analyse fand gar nicht statt, oder habe ich was verpasst?


@Idefixx - Ich habe schon einige PC's zusammengebaut. Der hier beschriebene gehört dazu. Ich sehe keinen Vorteil im Kauf eines gebrauchen PC's. Vor allem ist es meine Entscheidung, und Du solltest Dich nicht darüber aufregen.

Naja, mir ist es zu blöd und ich verabschiede mich aus diesem Post.
 

mr44er

moderater Moderator
Mitarbeiter
#38
Euch kann man scheinbar nichts recht machen.
Was pit sagen wollte, war im Prinzip nur, dass wir hier Threads nicht schließen. Es kann immer mal sein, dass einem doch noch was, im besten Fall sinnvolles, einfällt.
Wenn 'erledigt' und nichts mehr beigetragen wird, dann rutschen die Threads sowieso automatisch nach hinten.

Ansonsten lass' dich nicht ärgern oder drängen, die Entscheidung zur Lösung liegt natürlich bei dir.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#39
Um noch mal was Produktives zu sagen: Die meisten Computer aus der Zeit können durchaus 8 Gigabyte RAM. Zumindest wenn sie vier RAM-Slos haben. Unabhängig dessen, was im Handbuch steht. Elektrisch ist da eh egal, das BIOS muss es nur initialisieren können. Und das BIOSe damals wie heute von der Stange kommen... Wenn du billig an ein wahrscheinlich DDR2-Kit mit 8 GB kommst, wäre das eventuell einen Versuch wert.
 

pit234a

Well-Known Member
#40
Wegen möglicher Analyse möchte ich nur einige Stichworte liefern:
Was sagt denn überhaupt top zum Speicherverbrauch? Gibt es denn da ausreichend Hinweise, dass der RAM tatsächlich erschöpft ist? Und wer verbraucht den denn?
Wie sieht es mit der SWAP aus? Und wie ist die "Swapiness" des Systems gesetzt? (Knoppix setzt die zB sehr niedrig). Wie verhält sich das System nach einem swapoff?
Was ist mit System-Optimierung? Wird zB ohne Journals und "noatime" gemountet? Sind 3D-Effekte abgeschaltet? Wird ein DE verwendet, das nicht sehr viele Dienste startet, ein schmaler Fenstermanager verwendet (kein Compiz)?

Sodann: welche Module werden überhaupt für die GraKa geladen? Was sagt die Xorg.0.log?
Und dann nochmal: wie sieht all dies aus, wenn mal ein anderes (Live-) System gestartet wird? Gibt es da Unterschiede? Wie wirken sich die auf das Verhalten aus?

Soweit nur mal die Fragen, die mir so adhoc einfallen und durch den Kopf gehen.
Und wie gesagt, davon habe ich hier bisher nicht viel erfahren. Der Verlauf ist zäh, was echte Information angeht.

Aber die Empfehlung für neue HW bleibt natürlich trotzdem überlaut stehen.

Euch kann man scheinbar nichts recht machen.
EUCH gibt es da auch nicht. Wir sind ja keine Gang oder Sekte oder so. Nehme ich nur mal gerade die beiden Teilnehmer vor deinem letzten Beitrag, also mich selbst und @Idefixx : uns trennen Welten und selten gibt es mal Punkte, wo wir gleicher Ansicht sind.
Und das wird auch nicht verlangt und sollte nicht dein Bestreben sein, es irgendwem hier recht zu machen.
 

cabriofahrer

Well-Known Member
#41
Code:
$ lspci -nnk | grep -i VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
    Subsystem: Gigabyte Technology Co., Ltd 82945G/GZ Integrated Graphics Controller [1458:d000]
    Kernel driver in use: i915
Es wäre vielleicht noch interessant, auf dem PC mal FreeBSD zu installieren und den Intel Grafik-Chip richtig zu konfigurieren, so wie hier beschrieben: https://wiki.freebsd.org/Graphics
 

pit234a

Well-Known Member
#42
Mein derzeitiges Sorgenkind ist ein alter MacBookAir
Der Thread ist zwar scheinbar beendet und leblos, aber ich bin derzeit doch mal wieder begeistert und möchte diese Begeisterung teilen, weil das vielleicht hilfreich sein könnte.
Der alte MacBookAir "rennt wieder".
Was heißt schon rennen, wenn man nur USB2 hat und nur einen
Intel(R) Core(TM)2 Duo CPU U9400 @ 1.40GHz
mit 4GB RAM. Halt im Rahmen seiner Möglichkeiten und das bedeutet erstaunlicherweise, dass die zehn Jahre alte HW tatsächlich flüssig zu bedienen und zu benutzen ist. Also nun wieder.

Und was hat geholfen?
Hausputz.

Also die allereinfachsten Dinge, die aber oft übersehen werden:
Gerät zerlegen und Kontakte reinigen, mehrfach ein- und ausstecken, Wärmeleitpaste erneuern, Lüfter prüfen und reinigen, alles neu montieren und zusehen, wie es wieder geht.

Für wie lange auch immer.
 

cabriofahrer

Well-Known Member
#43
Intel(R) Core(TM)2 Duo CPU U9400 @ 1.40GHz
mit 4GB RAM. Halt im Rahmen seiner Möglichkeiten und das bedeutet erstaunlicherweise, dass die zehn Jahre alte HW tatsächlich flüssig zu bedienen und zu benutzen ist. Also nun wieder.
Das ist doch ganz gut. Ich habe ein Laptop mit einem Intel Core Duo T2250 (1,73 GHz) mit nur 1 GB RAM, Geforce 7300 Go und der rennt auch super mit FreeBSD. Der hat nur ein verdammtes Überhitzungsproblem.
 
Themenstarter #44
Ansonsten lass' dich nicht ärgern oder drängen, die Entscheidung zur Lösung liegt natürlich bei dir.
Ja, ich hatte mich etwas geärgert. Das nächste Mal schlafe ich erst eine Nacht darüber, bevor ich vorschnell antworte. :)

Wenn du billig an ein wahrscheinlich DDR2-Kit mit 8 GB kommst, wäre das eventuell einen Versuch wert.
Das Board hat nur zwei Bänke. Lt. Beschreibung laufen nur 2 GB, ich habe schon 4 GB laufen; trotzdem hätte ich es einmal probiert. Aber bei ebay ist iM alles zu teuer, das lohnt sich dann wirklich nicht.

Was sagt denn überhaupt top zum Speicherverbrauch? Gibt es denn da ausreichend Hinweise, dass der RAM tatsächlich erschöpft ist? Und wer verbraucht den denn?
Der PC hat ja, wie anfangs geschrieben, nur hin und wieder bei Youtube-Videos Ruckler. Im normalen Betrieb, läuft er noch immer flott. Momentan hat das RAM ca 30% Auslastung und die CPU ca 20%.

Deine anderen Fragen offenbaren mir meine Wissenslücken. Von swapiness hatte ich noch nie etwas gehört. Habe mich aber mal eingelesen, der Wert steht standardmäßig auf 60.
Der Verlauf ist zäh, was echte Information angeht.
Naja, wie gesagt: Über die meisten Sachen, die Du anschneidest hatte ich mir keinen Kopf gemacht, bzw. sie waren mir nicht bekannt. Ansonsten habe ich die gewünschten Infos immer gepostet.

und das bedeutet erstaunlicherweise, dass die zehn Jahre alte HW tatsächlich flüssig zu bedienen und zu benutzen ist. Also nun wieder.
Also ist es möglich.

Es wäre vielleicht noch interessant, auf dem PC mal FreeBSD zu installieren und den Intel Grafik-Chip richtig zu konfigurieren, so wie hier beschrieben: https://wiki.freebsd.org/Graphics
Du hast mich ertappt, das ist mir zu aufwendig. Aber vielleicht kriege ich es unter Devuan hin.

@all: Die Nutzung von Gebrauchsgütern hat für mich primär etwas mit Nachhaltigkeit zu tun. Für mich ist es nicht die Lösung, alles was nicht mehr funktioniert wegzuschmeissen, um dann neu/gebraucht zu kaufen. Aber ich gehöre natürlich zu einer anderen Generation, als die meisten Mitglieder hier. In diesem speziellen Fall ist es so, dass ich mit diesem PC hauptsächlich Emails abrufe und surfe. Wie schon erwähnt, schaue ich auch Youtube. Die Anfangsfrage habe ich gestellt, weil mir etwas unklar war. @mr44er hat das mit Geduld sehr gut erklärt. Im Verlaufe des Gesprächs hat sich dann gezeigt, dass ich mir über vieles keine Gedanken gemacht hatte. Selbstkritisch muss ich erkennen, dass ich wohl meist den einfachen Weg gegangen bin. Das werde ich wohl ändern müssen.

Um so mehr, bewundere ich die Detailverliebtheit insbesondere von @cabriofahrer, @Yamagi und @pit234a. :)
 
#45
Du hast mich ertappt, das ist mir zu aufwendig. Aber vielleicht kriege ich es unter Devuan hin.
So aufwendig ist es eigentlich nicht, FreeBSD zu installieren und danach xorg und erstmal einen einfachen Fenstermanager wie fluxbox und zusätzlich firefox. Gerade bei Hardware, die aufgrund ihres Alters grenzwertig ist wie Dein Intel-Chip, lässt sich mit FreeBSD gut ausprobieren, was eigentlich damit noch möglich ist. Stöpsele vielleicht einfach mal eine andere Festplatte ein und die andere ab und probiere es aus. Vielleicht entdeckst Du die Faszination für FreeBSD...
 
Themenstarter #47
@Illuminatus das add-on habe ich direkt mal aktiviert. Ich habe den Eindruck, das Bild sei besser. Hoffentlich ist das nicht bloß Einbildung.
Die Statistik habe ich mal kopiert; ich kann weder Codec h.264 noch VP8/9 erkennen.

Video ID / sCPN
7C52K92tKr4 / 0S5J 8HN1 H42B
Viewport / Frames
1253x705 / 206 dropped of 24306
Current / Optimal Res
1280x720@50 / 1280x720@50
Volume / Normalized
31% / 31% (content loudness -9.5dB)
Codecs
avc1.4d4020 (298) / mp4a.40.2 (140)
Connection Speed

10878 Kbps
Network Activity

0 KB
Buffer Health

76.98 s
Mystery Text
s:4 t:484.54 b:0.000-561.520 P

Zumindest sieht es momentan gut aus. Danke. :)

Ergänzung: Habe einige Videos durchprobiert. Jetzt habe ich eines gefunden mit: VP09. Seltsam h.264 ist doch aktiviert.
 

pit234a

Well-Known Member
#49
Da kann man mal wieder sehen, wie leicht man Information verdrängt!

Während des gesamten Threads war ich nämlich davon ausgegangen, dass grundsätzlich Videos bei der Wiedergabe ruckeln.
Dass es nur um "gelegentliche Ruckler" bei YT-Videos geht, habe ich irgendwann ausgeblendet, famos.

YT-Videos sehe ich mir quasi nicht an, ohne Not gar nicht und Not tut es da selten.
Deshalb bin ich wohl ein wenig im Abseits gelandet, weil ich mal wieder von mir auf Andere geschlossen habe, ohne genau zu lesen, was "Andere" eigentlich wollen.

Dabei gab es erst kürzlich diesen erhellenden Beitrag hier:
https://www.bsdforen.de/threads/firefox-2160p-videos-und-mpv-unter-freebsd.35825/