• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

FreeBSD 12.1 auf Lenovo T470

lancs

Well-Known Member
Themenstarter #1
Hiya,

ich habe vor zirka 3 Jahren das letzte mal FreeBSD auf einen Lenovo G530 getestet, mit nur maessigen Erfolg. Mich laesst das Thema FreeBSD aber nicht los, deshalb moechte ich es nocheinmal mit einen Lenovo T470 versuchen.

LENOVO T470 20HDCTO1WW

Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
16GB DDR4-2133MHz
512GB Solid State Drive, PCIe-NVMe Opal 2.0
Intel HD Graphics 620
Intel Dual Band Wireless 8265
etc....


Ich hatte FreeBSD 12.1 auf dem Geraet schon mal installiert, aber der xf86-video-intel Treiber scheint nicht richtig zu funzen. Xfce fuehlt sich richtig traege an, und die Fenster gehen fast wie in Zeitlupe auf.

Ich hatte alles bis auf graphics/drm-kmod per pkg installiert, muss ich bei meinen Geraet evtl alles aus den Ports bauen?

Ich habe da einen Leonovo T470s Blogeintrag gefunden, ist der aus eurer Sicht noch aktuell? Gerade was das patchen angeht?

https://blog.grem.de/pages/t470s.html

Lancs
 

lme

FreeBSD Committer
#2
Deinstalliere mal das xf86-video-intel Paket und schaue, ob es mit dem dann ausgewählten "modesetting" Treiber besser läuft.
 

lancs

Well-Known Member
Themenstarter #4
Deinstalliere mal das xf86-video-intel Paket und schaue, ob es mit dem dann ausgewählten "modesetting" Treiber besser läuft.
Danke fuer den Hiwnweis, aber mit den "modesettings" Treiber wird es nicht besser eher schlimmer. Ich bin aber schon mal einen Schritt weiter, indem ich AccelMethod auf SNA gesetzt habe und ich hw.psm.synaptics_support="1" aus meiner /boot/loader.conf entfernt habe funzt es etwas besser. Die Frage ist jetzt nur, wie konfiguiere ich jetzt mein Mousepad? Unter Linux ist ja seit Jahren xf86-input-synaptics kein Thema mehr.

Lancs
 

bsd4me

Well-Known Member
#5
mhm - wundert mich ein wenig, dass es so schwierig ist. Ich habe zu Hause ein Laptop Lenovo W730, 8 cores, 16GB RAM und Intel Graphik, der läuft under xfce gut :) Schade das die Anbindung der 2. Graphikkarte (Nvidia) noch nicht so geht. Aber auch WiFi ist kein Problem. Suspend/Resume und anderen Schnickschnack brauche ich nicht - ich verstehe gar nicht, warum das so wichtig ist. Wenn man einen Laptop z.B. mit zur Arbeit bringt macht man ihn ja auch nicht dauernd an und aus... Ich jedenfalls max. 1 mal pro Tag. Und da brauche ich auch keine SSD... Naja - wie gesagt, er tuts gut :) Was Intel angeht - ich meine ich hätte auch drm "kldload /boot/modules/i915kms.ko" gesetzt :)
VG Norbert
PS: Würde ich nicht gegen Ubuntu eintauschen :)
 

serie300

Well-Known Member
#6
Mit dem update auf 12.1 mußte ich drm-next auf einem ähnlichem T570 aus den ports bauen. gibt 'nen thread von mir zum Thema. Die HD620 geht m.W. nur mit drm-next,das aber flüssig.