• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Langsame DNS-Auflösung

holgerw

Well-Known Member
Themenstarter #1
Hallo,

ich habe, wenn ich mich per SSH und dem Rechnernamen auf unser FreeBSD-NAS einlogge manchmal bis zu einer halben Minute zu warten, bis mir die Passwortabfrage angezeigt wird.
Nehme ich stattdessen die IP des NAS, kommt die Abfrage in weniger als einer Sekunde.
DNS Auflösung ist hier wohl der Punkt, bei welchem ich ansetzen muss, nur woran schrauben? Die /etc/hosts Dateien auf beiden Systemen sehen korrekt aus.

Auf unbound möchte ich bei den paar Maschinen in unserem Heimnetzwerk nicht umsteigen.
 

foxit

Moderator
Mitarbeiter
#4
wenn ich mich per SSH und dem Rechnernamen auf unser FreeBSD-NAS einlogge manchmal bis zu einer halben Minute zu warten, bis mir die Passwortabfrage angezeigt wird.
Auf dem Server in der SSHd Config Datei gibt es den Wert:
Code:
UseDNS
Dieser ist, so glaube ich auf "Yes" gesetzt. Diesen ändern und "ssh" restart sollte helfen.
 

holgerw

Well-Known Member
Themenstarter #7
Moin,

was sind denn die Ausgaben von "drill FreeBSD-NAS-Name" und "drill -x IP-der-NAS"?
Code:
drill igel.fritz.box
;; ->>HEADER<<- opcode: QUERY, rcode: NXDOMAIN, id: 55642
;; flags: qr rd ra ; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:
;; igel.fritz.box.      IN      A

;; ANSWER SECTION:

;; AUTHORITY SECTION:
box.    613     IN      SOA     a.nic.box. support.ariservices.com. 1494208711 1800 300 1814400 1800

;; ADDITIONAL SECTION:

;; Query time: 46 msec
;; SERVER: 80.241.218.68
;; WHEN: Thu Dec 20 20:39:49 2018
;; MSG SIZE  rcvd: 97
Code:
drill -x 192.168.1.20
;; ->>HEADER<<- opcode: QUERY, rcode: NXDOMAIN, id: 34569
;; flags: qr aa rd ra ; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:
;; 20.1.168.192.in-addr.arpa.   IN      PTR

;; ANSWER SECTION:

;; AUTHORITY SECTION:
168.192.in-addr.arpa.   10800   IN      SOA     localhost. nobody.invalid. 1 3600 1200 604800 10800

;; ADDITIONAL SECTION:

;; Query time: 29 msec
;; SERVER: 80.241.218.68
;; WHEN: Thu Dec 20 20:41:19 2018
;; MSG SIZE  rcvd: 102
 

holgerw

Well-Known Member
Themenstarter #9
Auf dem Server in der SSHd Config Datei gibt es den Wert:
Code:
UseDNS
Dieser ist, so glaube ich auf "Yes" gesetzt. Diesen ändern und "ssh" restart sollte helfen.
@foxit danke, das war es. Ich habe die Auskommentierung vor der Zeile weg genommen, den Service neu gestartet und nun geht es auch flott mit dem NAS-Namen.

Edit: Leider zu früh gefreut, die Resultate sind uneinheitlich. Mal geht es mit UseDNS yes flott, mal lahm, mal mit UseDNS no flott, mal lahm, hmmm.

Das muss an etwas anderem liegen. Vielleicht sind die DNS in der Fritzbox zu lahm. Ich werde die mal tauschen und weiter berichten.
Die von Google mag ich nicht so gerne nehmen, vielleicht nehme ich mal welche von https://dns.watch/

Werde weiter testen und berichten.
 
#11
Ein würg-around wäre sich ne ssh config ins home Verzeichnis zu packen und dort die ip einzutragen. Du rufst dann ssh nas auf ubd der client sucht in der conf nach einem eintrag nas - da kannst du auch keyfiles, compression etc setzen..

Löst zwar deinen dns hiccup nicht, aber gibt dafür erstmal Bequemlichkeit..
 

medV2

Well-Known Member
#12
Mach mal ssh -vvv. Ich hatte so ein Problem mal mit Linux, da liefs darauf hinaus, das ein Authentifizierungsmechanismus immer geblockt hat und deaktiviert werden musste. Wenn es das ist, würdest du dann erkennen, wo es hängt.
 
#13
Code:
drill -x 192.168.1.20
;; ->>HEADER<<- opcode: QUERY, rcode: NXDOMAIN, id: 34569
;; flags: qr aa rd ra ; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:
;; 20.1.168.192.in-addr.arpa.   IN      PTR

;; ANSWER SECTION:

;; AUTHORITY SECTION:
168.192.in-addr.arpa.   10800   IN      SOA     localhost. nobody.invalid. 1 3600 1200 604800 10800

;; ADDITIONAL SECTION:

;; Query time: 29 msec
;; SERVER: 80.241.218.68
;; WHEN: Thu Dec 20 20:41:19 2018
;; MSG SIZE  rcvd: 102
Ich würde aus deiner Ausgabe rauslesen, dass dein Reverse-DNS nicht richtig funktioniert. Die ANSWER SECTION ist leer, dürfte sie aber nicht sein. Das solltest du bereinigen, da es auch in anderen Punkten merkwürdiges Verhalten mit sich bringen kann.
 
#14
Äh Moment... ich sehe gerade, dass auch die Ausgabe von
Code:
drill igel.fritz.box
;; ->>HEADER<<- opcode: QUERY, rcode: NXDOMAIN, id: 55642
;; flags: qr rd ra ; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:
;; igel.fritz.box.      IN      A

;; ANSWER SECTION:

;; AUTHORITY SECTION:
box.    613     IN      SOA     a.nic.box. support.ariservices.com. 1494208711 1800 300 1814400 1800

;; ADDITIONAL SECTION:

;; Query time: 46 msec
;; SERVER: 80.241.218.68
;; WHEN: Thu Dec 20 20:39:49 2018
;; MSG SIZE  rcvd: 97
auch nicht passt. Deine Anfrage geht nach extern. Dürfte sie aber nicht gehen. Da passt allgemein etwas nicht. Warum nutzt du nicht die FritzBox als Nameserver? Zeig mal bitte den Inhalt von /etc/resolv.conf
 

holgerw

Well-Known Member
Themenstarter #17
Hallo,

danke für Euer Interesse, wie auch gestern kann ich erst abends genaueres Euch dazu an Angaben machen.

Ich verstehe es aber nicht so ganz: Beim Installieren des NAS-Servers und meines Desktop-Rechners habe ich nichts außergewöhnliches festgestellt bzw. dann verändert.
Bei der Netzwerkeinrichtung stimmten die von mir beim Router eingetragenen ipv4- und ipv6-Nameserver, bei search steht "fritz.box".
Die Fritz.box nutze ich somit doch als Nameserver.

Die /etc/hosts aller relevanten Rechner haben den gleichen Inhalt, u.z. nach dem Muster:
ip4-Adresse hostname.domain hostname

Den Rest der /etc/hosts habe ich der Übersicht halber einfach gelöscht, auch diese Einträge 127.0.0.0 localhost oder ähnlich. Hätte ich das viellleicht nicht tun sollen?
 

holgerw

Well-Known Member
Themenstarter #19
Okay, ich steige allmählich auch dahinter, was Columbo damit meinte, die Fritzbox als Nameserver zu benutzen.

1. Ich soll die Adresse der Fritzbox (unter welcher ich auch auf die Weboberfläche zur Konfiguration komme) als Nameserver für meine Geräte innerhalb des Heimnetzwerkes verwenden.

2. Die externen in der Fritzbox eingetragenen Nameserver dienen zur Auflösung von Namen aus dem Internet und haben mit dem internen Netzwerk nichts zu tun.

3. Und ich sollte tunlichst die 127.0.0.1 localhost Einträge in der /etc/hosts drin stehen lassen.

Habe ich das richtig verstanden?
 

holgerw

Well-Known Member
Themenstarter #21
Korrekt. Die Fritzbox löst intern selbst auf, für Externes nutzt sie die auf der Box konfigurierten Nameserver. Sie dient also quasi als DNS-Cache für dein lokales Netzwerk.

Die localhost-Definition sollte niemals aus /etc/hosts entfernt werden.

Rob
Danke für die Bestätigung, Robert.

Oh je, eigentlich ist es ja klar, dass externe Nameserver gar nix aus meinem Netzwerk auflösen können (können dürfen). Ich habe externe DNS und interne Nameserver-Auflösung in einen Topf geworfen, das ist mir schon etwas peinlich.

Aber gut, wieder ein paar neue Details in Sachen Netzwerk gelernt. Mal schauen, ob ich das heute Abend dann hinbekomme.
 

cabriofahrer

Well-Known Member
#22
1. Ich soll die Adresse der Fritzbox (unter welcher ich auch auf die Weboberfläche zur Konfiguration komme) als Nameserver für meine Geräte innerhalb des Heimnetzwerkes verwenden.
Das bedeutet im Klartext wahrscheinlich, dass man diese Adresse in die /etc/resolv.conf der betreffenden Geräte eintragen muss.

Mal eine Frage an alle: Das Thema des Heim- bzw. kleinen Netzwerks allgemein mit Router vom ISP (hier in diesem Fall Fritzbox) ist
sehr interessant. Könnte mal hier erläutert werden, wie man das im Basissystem enthaltene unbound genau bzw. sinnvoll nutzen kann? Die Erklärung im Handbook ist für mich nicht so ganz aufschlussreich. Wenn man es startet, wird jedenfalls die /etc/resolv.conf überschrieben und bei einem Neustart, ohne den Service unbound ebenfalls mitzustarten, kommt man auf einmal nicht mehr ins Internet.

Weiter Frage in diesem Zusammenhang: Könnte man auf den Heimroutern (wie hier Fritzbox) einfach pfsense bzw. FreeBSD installieren, oder verweigert der ISP den Betrieb, wenn er im Router seines Endkunden nicht sein eigenes Betriebsystem erkennt?
 

holgerw

Well-Known Member
Themenstarter #23
Das bedeutet im Klartext wahrscheinlich, dass man diese Adresse in die /etc/resolv.conf der betreffenden Geräte eintragen muss.
Nein, bei wird das durch DHCP (MAC bezogene IP-Vergabe) per Router an die Rechner unseres Netzwerkes vergeben.

Mal eine Frage an alle: Das Thema des Heim- bzw. kleinen Netzwerks allgemein mit Router vom ISP (hier in diesem Fall Fritzbox) ist
sehr interessant. Könnte mal hier erläutert werden, wie man das im Basissystem enthaltene unbound genau bzw. sinnvoll nutzen kann? Die Erklärung im Handbook ist für mich nicht so ganz aufschlussreich. Wenn man es startet, wird jedenfalls die /etc/resolv.conf überschrieben und bei einem Neustart, ohne den Service unbound ebenfalls mitzustarten, kommt man auf einmal nicht mehr ins Internet.
Kannst Du dafür bitte einen eigenen Thread eröffnen (an welchem ich mich übrigens rege beteiligen würde)? Wäre schade, wenn das in diesem Thread als Nebenthema untergehen würde. Zu unbound habe ich mir nämlich auch schon Gedanken gemacht und finde dazu entweder ausführlichste Tutorien, bei denen ich mangels Kenntnis das für meine bescheidenen Zwecke Relevante nicht so leicht herauspicken kann, oder aber, ich finde spärliche Ausführungen im Handbuch, mit denen ich ebenfalls wenig anfangen kann.