Netzwerk : Zwei Router

bluescreen

verstört
Moin !

Habe da folgendes Problemchen :

Router_1 = 192.168.0.1 - Fritzbox (Kabelrouter) --> Direkte Verbindung ins Netz .

Router_2 = 192.168.11.1 - Verbunden mit Fritzbox , stellt Verbindung mit einem VPN-Server her .
( Tomato Software)


Router_1 ist PC angeschlossen
Router_2 ist SAT-Receiver und Handy per Wlan angeschlossen


Jetzt habe ich die angewohnheit , wenn ich am PC sitze , per Stream vom Receiver Fernsehen
zu schauen !
Leider ist das Netzwerk nicht zu erreichen !

Welche möglichkeiten habe ich von Router_1 auf`s Netzwerk von Router_2 zuzugreifen ?


Gruss
:ugly:
 

Yamagi

Possessed With Psi Powers
Teammitglied
Das ist der Klassiker: Die fehlende Rückroute. Router_2 hat eine Route zu Router_1, dir fehlt aber eine Route von Router_1 zu Router_2. Somit weiß Router_1 nicht, wo er mit Paketen für 192.168.11.0/24 hin soll und schickt sie auf sein Default Gateway. Also ins Internet. Du musst also aus der Fritzbox eine statische Route setzen, die alles an 192.168.11.0/24 über 192.168.11.1 schickt. Ich meine, dass Fritzboxen das im Gegensatz zu den meisten Plastikroutern können.

EDIT: Das ist etwas missverständlich ausgedrückt. Router_2 muss in beiden Netzen hängen. Und die Zieladresse für die Route ist seine Adresse in 192.168.0.0/24.
 

mogbo

Banned
1. DHCP über Router_1 und über Router_2 die Ports für DHCP durchreichen, sowie das Netzwerk hinter Router_2 via NAT durchgeben
2. In Router_2, Router_1 als Gateway eintragen und nötige Ports durchreichen
3. Nur Ports in Router_2 durchreichen

Falls du nur über Router_1 ein DHCP vergibst, schränke den Adressbereich so ein, dass du Router_2 eine statische IP zuweisen kannst! Router_2 muss im Endeffekt nur die Ports durchreichen, aber sobald der hinter einer Firewall liegt, könntest du ihn auch rein zum durchnavigieren nutzen (quasi Router ohne blockende Firewall).

Welche möglichkeiten habe ich von Router_1 auf`s Netzwerk von Router_2 zuzugreifen ?
Simples durchnavigieren von gezielten oder allen Ports oder Netzwerk von innen zum Device (zB via ssh_tunnel) tunneln (ist denke ich in deinem Fall nur unnötig kompliziert).

Falls das Netzwerk nicht nach innen telefoniert, könnte man das mit Zusatzregel in Router_1 richten

Edit: Falls es die Option in Router_2 gibt, mach ihn zum reinen Router und vergib DHCP über Router_1. Sollte so simpel gehen. Damit sollten alle weiteren Probleme verschwinden. Für VPN mach die IP von Router_2 statisch
 

CommanderZed

OpenBSD User
Teammitglied
Ja, Router zwei muss die default-route zu router 1 haben und sollte ohne NAT Routen. Router 1 muss eine Route für das 2. Subnetz von Router_2 mit der IP von Router 2 im Netz von router 1 haben.

Die Fritzbox kann das, ich habe einen einfachen Buffallo-Router der Client im WLAN der Fritz-Box ist und die "Dahinterliegenden" Rechner mit dem Netz 1 verbindet, das funktioniert extrem gut. Wenn man DHCP möchte muss der 2. Router aber für sein lokales Netz DHCP Server sein.
Für DNS kann man auf den Clients entweder die Fritz-Box verwenden oder aber auch den Router 2 als DNS-Server für das Router-2 Netz verwenden und entsprechend an die FritzBox weiterleiten.
 

klimaschreck

Well-Known Member
Hallo zusammen,

ich habe das gleiche Problem. Mein Hauptrouter ist eine Fritzbox mit dem DSL-Anschluss. Sie hat die IP-Bereich 192.168.178.xx (volles Class C Netz). Der zweite Router hat den IP-Bereich 192.168.0.xx (auch volles Class C Netz). Der zweite Router ist mit dem Hauptrouter verbunden und hat für den Hauptrouter die IP-Adresse 192.168.178.10.

Die eine Richtung klappt, die andere (von 192.168.178.x zu 192.168.0.x) leider nicht.

Darauf habe ich in der Fritzbox eine statische Route angelegt. Mit */24 geht es in der Fritzbox nicht: Ich habe die Felder
- IP Netzwerk: 192.168.0.0
- Subnetzmask: 255.255.255.0
- Gateway: 192.168.178.10

belegt. Leider klappt es auch mit dieser statischen Route nicht. Habt ihr einen Tipp?
 

klimaschreck

Well-Known Member
Von 192.168.0.x komme ich in das Internet und kann auf 192.168.178.1 zugreifen.

Von 192.168.178.x komme ich in das Internet, kann aber z.B. nicht auf 192.168.0.7 zugreifen.
 
Oben