• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Neue Installation OpenBSD 6.2 fehlgeschlagen.

ralli

BSD Fanboy
Themenstarter #1
Habe heute morgen OpenBSD 6.2 als Iso Image auf CD gebrannt und neu installiert. Die Grundinstallation lief ordnungsgemäß durch, danach blieb nach einem Reboot der Bildschirm schwarz. Meine Vermutung ist, das der neue Intel Treiber der Übeltäter ist. Werde darüber nachdenken, wie ich weiter verfahen soll. Bei der alten Version zu bleiben, erscheint mir auch nur eine vorübergehende Option zu sein, denn dadurch wird das Problem ja nicht gelöst. Bin ziemlich frustriert, bei allem Engagement schon wieder Sch .... Am ende bleibt mir doch wider nur FreeBSD, komme mir wie ein Depp vor, obwohl ich es wohl nicht ändern kann.
 

ralli

BSD Fanboy
Themenstarter #3
Kannst du die Maschine per ssh erreichen und Details für einen bugreport sammeln?
Hab ich noch nie gemacht, aber ich denke, dafür brauchte ich einen zweiten PC, oder? Bin im Augenblick wieder mit FreeBSD unterwegs, ich denke ich möchte erst mal ein paar Tage darüber schlafen, ob ich mir noch Mal die Mühe mache, meine weitere Zeit mit OpenBSD zu verbringen. Wenn ich mir darüber im Klaren bin, werde ich mich wieder melden.
 

mogbo

if (virus == true) {virus = false}
#4
Habe heute morgen OpenBSD 6.2 als Iso Image auf CD gebrannt und neu installiert. Die Grundinstallation lief ordnungsgemäß durch, danach blieb nach einem Reboot der Bildschirm schwarz. Meine Vermutung ist, das der neue Intel Treiber der Übeltäter ist.
Schwarzen Bildschirm bitte genauer definieren

Siehst du nach dem
Code:
#reboot
zum Upgradeabschluss nurnoch schwarz?

oder

Siehst du bis zum
Code:
boot>
und danach nurnoch schwarz?

oder

Siehst du bis zum grafischen Login alles und dann nurnoch schwarz?
 

holgerw

Well-Known Member
#7
Hallo @ralli

welche Intel-Architektur hast Du nochmal? Ich habe OpenBSD 6.2 von USB-Stick installiert, und mit dem Xserver gar keine Schwierigkeiten, ich habe ein Intel Haswell System.

Bin im Augenblick wieder mit FreeBSD unterwegs, ich denke ich möchte erst mal ein paar Tage darüber schlafen, ob ich mir noch Mal die Mühe mache, meine weitere Zeit mit OpenBSD zu verbringen. Wenn ich mir darüber im Klaren bin, werde ich mich wieder melden.
Ralph, bitte nicht falsch verstehen: Du hast Dir mit OpenBSD nunmal eine gewisse Herausforderung gesucht (meines Erachtens eines der schwierigeren Betriebsysteme, was das Handling angeht).

Soll die bisherige Mühe Deinerseits denn umsonst gewesen sein? Nachher ist es wieder eine Kleinigkeit, wo es bei Dir nur klemmt.

Ziehe das Troubleshooting hier durch und bereichere dann Deine Doku damit. Und wenn ich sehe, wie sich hier OpenBSD-Vertraute helfend ins Zeug legen, bin ich mir sicher, dass Du das hinbekommst.

Viele Grüße
Holger
 

ralli

BSD Fanboy
Themenstarter #9
Hallo Holger,

welche Intel-Architektur hast Du nochmal? Ich habe OpenBSD 6.2 von USB-Stick installiert, und mit dem Xserver gar keine Schwierigkeiten, ich habe ein Intel Haswell System.
Ich habe auch ein Intel Haswell System. Es ist ja unter OpenBSD 6.1 auch ordentlich gelaufen.

Ralph, bitte nicht falsch verstehen: Du hast Dir mit OpenBSD nunmal eine gewisse Herausforderung gesucht (meines Erachtens eines der schwierigeren Betriebsysteme, was das Handling angeht).
Nein ich verstehe nichts falsch, alles ist gut!:) Bis jetzt habe ich ja alles gmeistert.

Soll die bisherige Mühe Deinerseits denn umsonst gewesen sein? Nachher ist es wieder eine Kleinigkeit, wo es bei Dir nur klemmt.
Das habe ich mich in der Tat auch schon gefragt. Also ich gebe mir schon große Mühe und befolge alle Ratschläge unserer Experten.

Ziehe das Troubleshooting hier durch und bereichere dann Deine Doku damit. Und wenn ich sehe, wie sich hier OpenBSD-Vertraute helfend ins Zeug legen, bin ich mir sicher, dass Du das hinbekommst.
Danke für den Mutmacher und die Motivationsförderung.

Ich werde es so machen, nicht aufgeben und mich bemühen. Notfalls arbeite ich eben mit OpenBSD 6.1 weiter.... Aber so weit ist es ja noch nicht. Vielleicht läßt sich unter OpenBSd 6.2 ja der Intel Treiber von 6.1 installieren und benutzen. Jetzt will ich erst mal @mogbo Rat befolgen und sehen, was passiert....

Viele Grüße

Ralph
 

mogbo

if (virus == true) {virus = false}
#10
Ich kann ja nichts eingeben, dazu kommt es ja nicht. Oder soll ich den Code nach der Grundinstallation und vor dem reboot eingeben?
Da du nach dem Upgrade eine Neuinstallation hinbekommen hast ging ich davon aus, dass dein PC bis zum
Code:
boot>
kommt, in dem du entscheiden kannst was der PC weiterhin macht. Längeres warten (1-2 Seks) bootet direkt über /bsd oder /bsd.mp, ein upgrade über den bsd.rd usw. ...

In diesem "boot>" gelangst du via "boot -c" in die boot.conf und kannst den Treiber abstellen, somit müsste dein PC soferns am Treiber liegt bis zum Login kommen, dann hätten wir ja quasi den Beweis an was es liegt. Dein Problem ist dann nicht geklärt, aber "bewiesen". X startet dann halt nicht...

Kannst du die Maschine per ssh erreichen und Details für einen bugreport sammeln?
Führt zum gleichen Ergebnis, sofern ssh in deinem Install mit "yes" aktiviert wurde.

Der Weg über ssh hätte nach meinem Erachten mehr Möglichkeiten, du bräuchtest jedoch einen 2. PC.
 

holgerw

Well-Known Member
#11
Hmm, manchmal sind es ja Kleinigkeiten bei der Grafikchip-Architektur aber mal angenommen, wir haben auch genau die gleiche Grafik:
Was hast Du genau gemacht?

Hier mal mein Prozedere:
1. Download der install62.fs
2. Check der sha256 Summe
3. per dd auf USB-Stick gepackt
4.Vom Stick gebootet, de ausgewählt, Ethernet, Zeitzone u.s.f. , Nutzer angelegt, dann habe ich alle Sets zum Installieren ausgewählt gelassen, das automatische Partitionsschema übernommen und ein grafisches Login erlaubt
5. Das lief glatt durch ein Reboot und ich landete beim xenodm

Dann habe ich mal kde4 installiert, xenodm per rcctl deaktiviert, kdm aktiviert, messagebus aktiviert, messagebus gestartet, kdm gestartet und auch das klappt und ich kann als User holger kde4 starten.

Wie gesagt, angenommen, es liegt nicht an der Hardware (ich kann nicht genau sagen, ob bei Haswell immer der gleiche Grafikchip verbaut wird) dann hast Du irgendetwas anders gemacht. Liegt es an Unterschieden des Grafikchips, dann kann ich ab hier nicht mehr weiter helfen, da ich aus reiner Neugier nur mal das OpenBSD 6.2 angetestet habe, um zu sehen, ob ich vielleicht auch an einem schwarzen Bildschirm lande.

Viel weiter kann ich mich aus Zeitgründen mit OpenBSD gerade nicht befassen.

Achso: Ich habe den USB-Stick nicht im Uefi-Modus gebootet.
 

ralli

BSD Fanboy
Themenstarter #12
Danke Holger. Ich habe es (fast) genau so gemacht, allerdings

1. Download der install62.iso
2. Check der sha256 Summe
3. das Iso Image auf das Installationsmedium (CD) gebrannt
4. Von CD gebootet, de ausgewählt,Ethernet, Zeitzone usw.
5. Alle Sets zum Installieren ausgewählt, vorgeschlagenes Partitonschema übernommen
6. gafisches Login habe ich deaktiviert, weil ich per .xinitrc starte

Es kam noch die Meldung, das eine Mehrprozessor Maschine erkannt wurde und ein Relink auf einen dafür vorgesehenen Kernel erstellt wurde.

Das lief auch alles glatt durch, nur nach dem reboot war der Bildschirm dunkel.

Du hast mir schon sehr geholfen, danke dafür.

Ich habe das noch gemacht, was @mogbo vorgeschlagen hat, dann bottete er auch und den Bootvorgang konnte ich am Bildschirm verfolgen. OpenBSD bottete aber nicht bis zum Login Prompt, sondern bootete immer wieder automatisch neu wie in einer Endloschleife.

Es wird wohl, wie vermutet, der Intel Treiber sein. Aber wirklich weiter komme ich nicht. Ich habe wider OpenBSD 6.1 neu installiert, das funktioniert ja jetzt einwandfrei. Ich werde mal darüber nachdenken, ob ich mir eine ATI/AMD Karte zulegen, denn die werden ja auch gut unterstützt.

Und dann ist mir noch was ganz blödes passiert, ich habe noch im BIOS was verstellt, hatte nach einem Neustart auch kein Bild mehr auf dem Bildschirm. Ich habe dann den Rechner geöffnet, die BIOS Batterie für ein paar Minuten entfernt, damit das BIOS auf den Werkszustand zurück gesetzt wurde. Zumindest das hat geklappt.

Gruß

Ralph
 
#13
Bist Du wirklich 100% sicher, dass Du auch die install62.iso für amd64 und nicht die arm64 oder eine andere iso heruntegeladen hast? Mit inteldrm unter Haswell und Skylake hatte ich bis dato unter -current keine Probleme und OpenBSD 6.2 war ja vor kurzem noch genau diese -current Version. Hast Du mal eine komplette Neuinstallation probiert?
 

ralli

BSD Fanboy
Themenstarter #14
Bist Du wirklich 100% sicher, dass Du auch die install62.iso für amd64 und nicht die arm64 oder eine andere iso heruntegeladen hast? Mit inteldrm unter Haswell und Skylake hatte ich bis dato unter -current keine Probleme und OpenBSD 6.2 war ja vor kurzem noch genau diese -current Version. Hast Du mal eine komplette Neuinstallation probiert?
Habe es gerade zur absoluten Sicherheit noch einmal kontrolliert. Ja ich habe das richtige CD Image für die amd64 Architektur herunter geladen und installiert. Beides habe ich gemacht ein upgrade sowie auch eine Neuinstallation. Funktioniert bei mir leider nicht.

70 000 Mann im Stadion, wer kriegt den Ball am Kopp, immer ich.;'(
 
#15
Hm das ist strange. Vor allem, da du beim boot-prompt inteldrm deaktiviert hast.

Hast Du schon mal das -current iso getestet? Wenn Du einen USB-Stick hast, koenntest Du das -current install62.fs per dd auf den Stick hauen und sparst Dir die CD-Rohlinge.

Bei update oder bei der Installation fragt der Installer manchmal, ob Du das tty auf com0 stellen willst. Da hast Du doch nicht [Yes] eingegeben, oder?
 

ralli

BSD Fanboy
Themenstarter #16
Hm das ist strange. Vor allem, da du beim boot-prompt inteldrm deaktiviert hast.
Das finde ich auch.

Hast Du schon mal das -current iso getestet? Wenn Du einen USB-Stick hast, koenntest Du das -current install62.fs per dd auf den Stick hauen und sparst Dir die CD-Rohlinge.
Nein habe ich nicht. Kommt aber auf die todo Liste.

Bei update oder bei der Installation fragt der Installer manchmal, ob Du das tty auf com0 stellen willst. Da hast Du doch nicht [Yes] eingegeben, oder?
Da könnte ich einen Fehler gemacht haben, das werde ich mal kontrollieren. Ich habe ja zwei Platten verbaut. Auf de ersten ist OpenBSD 6.1, damit ich arbeitsfähig bleibe, auf der zweiten werde ich dann morgen mal eine Neuinstallation mit OpenBSD 6.2 machen. Danke für die Unterstüzung.
 

mapet

Active OpenBSD User
#17
Du kannst auch einfach die andere Platte mount und schauen, ob es eine /etc/boot.conf gibt:
Code:
<root@accesspoint:~> # more /etc/boot.conf                                     
stty com0 115200
set tty com0
Das stellt die Ausgabe auf com0 um. Es sollte reichen, sie zu entfernen.
 

ralli

BSD Fanboy
Themenstarter #18
So, ich habe heute morgen eine Neuinstallation gemacht. Das Ergebnis war weiterhin negativ. tty auf com0, da ist doch bereits No die Vorgabe. Ich habe dieses Mal keinen reboot gemacht nach der Grundinstallation, sondern den Rechner ausgeschaltet und dann wieder eingeschaltet und neu gebootet. Der Bildschirm blieb nicht schwarz, pausierte aber der Bootprompt hieß boot. Offensichlich suchte er den Kernel und fand ihn nicht. Am Ende der Grundinstalltion kommt immer die Meldung:

Multiprozessor maschine erkannt, relink to unique Kernel, was immer das heißen mag. @mapet, ich schau mir das an.
 
#20
Im Prinzip wird der Kernel bei jedem reboot neu gelinkt, damit dich die Speicheradressen ändern. Das erschwert Buffer Overflows und andere Angriffstechniken auf den Kernel.
 

ralli

BSD Fanboy
Themenstarter #22
Nachdem ich OpenBSD 6.2 neu auf die zweite Platte installiert habe, wollte ich sie einhängen, um mir die boot.conf anzusehen. Das scheiterte aber, irgendwie hat er da was zerschossen, aber ich werde mit meinem begrenzten technischen Wissen dieses Problem wohl nicht lösen können. Bleibt mir wohl als Option, wieder zu FreeBSd 11.1 zurück zu kehren. Ich habe mich angestrengt und alles versucht, und dachte das dieses Problem mit Eurer Unterstützung zu lösen gewesen wäre. Aber Ferndiagnosen sind auch schwierig. Nun zumindest bleibe ich BSD' ler.
 

Rakor

Administrator
Mitarbeiter
#23
Wieso kannst du nicht mounten? Hast du eine Fehlermeldung?
Mal versucht auf eine andere Platte (oder meinetwegen USB-Stick) zu installieren? Wenn die Platte sich von extern nicht mounten lässt könnte die auch nen Schlag haben.

Edit: ich hab mal Stunden damit vergeudet ein System zu installieren was immer an unterschiedlichen Punkten abgeschmiert ist. Ursache war ein fehlerhafter USB-Stick als Installationsmedium. Da können die Hashes vor dem dd noch so gut sein. Also Festspeicher können eklige Macken machen.
 

ralli

BSD Fanboy
Themenstarter #24
Wieso kannst du nicht mounten? Hast du eine Fehlermeldung?
Normalerweise mounte ich manuell aus der Konsole so:
Code:
mount /dev/sd1c /backup
Der Ordner backup existiert natürlich, weil ich ihn vorher angelegt habe. Die Fehlermeldung war:
Code:
ivalid Argument
Darauf hin habe ich folgendes in die /etc/fstab eingetragen:
Code:
/dev/sd1c /backup ffs rw 1 1
und habe neu gebootet. Beim Booten hielt er an der Stelle an, wo die HD normalerweise eingehangen wird, er blieb einfach stehen und ich solle fsck laufen lassen.
Mal versucht auf eine andere
Leider habe ich zur Zeit keinen USB Stick mehr hier rumliegen. Defekt scheint die Platte nicht zu sein, ich habe mal schnell Debian mir Gnome auf die erste eingebaute Platte installiert und von da aus die zweite HD (die angelegten Partitionen von OpenBSD 6.2 waren ja richtig angelegt), gelöscht und habe probehalber mit ext4 formatiert. Das funktionierte auch einwandfrei, die Platte konnte sofort benutzt werden, deshalb dürfte sie nach menschlichen Ermessen nicht defekt sein.
Und OpenBSD 6.2 ließ sich ja weder auf der ersten SSD einwandfrei installieren noch auf der zweiten HD (1 TB). Jetzt habe ich FreeBSD 11.1 auf der SSD und werde mal als nächsten Schritt die zweite HD formatieren. Vorher lasse ich DD drüber laufen, besser ist besser. Dann sehe ich weiter. Das wird ein paar Stunden dauern.