• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

NomadBSD - ein LiveUSB-System basierend auf FreeBSD 11.1

Rosendoktor

Well-Known Member
#26
Eigentlich solltest du das einfach per fstab übermounten können. Ich hab das damals so gemacht und das hatte wohl funktioniert (is aber wieder etwas her): http://denkrobat.de/doku.php?id=freebsd_auf_usb-stick
Danke für den Link, damit hab' ich es hinbekommen, FreeBSD rennt jetzt auch richtig gut vom USB Stick. Nicht so elegant und komfortabel wie Debian, aber es geht prima auch mit GUI und Firefox! So, und jetzt lasse ich den Thread wieder in Ruhe... :cool:
 

lme

FreeBSD Committer
#29
@marcel Ich habe noch die 0.5.0 auf dem Stick. Das ist noch FreeBSD 11.1-RELEASE ohne Patches. Könntest du das noch nachholen?
Man kann zwar auch freebsd-update(8) benutzen, aber wenn die Patches schon direkt enthalten sind, wäre das praktisch.
 

marcel

Well-Known Member
Themenstarter #30
Hi @lme ,
@marcel Ich habe noch die 0.5.0 auf dem Stick. Das ist noch FreeBSD 11.1-RELEASE ohne Patches. Könntest du das noch nachholen?
Man kann zwar auch freebsd-update(8) benutzen, aber wenn die Patches schon direkt enthalten sind, wäre das praktisch.
da bin ich Dir schon zuvor gekommen ;). Habe es seit 0.5.1 drin. Ganz frisch habe ich Version 0.5.3 hochgeladen, und ich hoffe, Du wirst angenehm überrascht sein. Die Browser (*moon und Firefox) laufen jetzt sogar besser als auf dem Festsystem, das ich auf meinem kleinen Asus Eee PC habe. Neben kleineren Änderungen habe ich jetzt auch den grafischen Bootloader von Oliver Fromme installiert.

Verbesserungsvorschläge sind immer willkommen.

Viel Spaß!
 

lme

FreeBSD Committer
#31
Hi @lme ,

da bin ich Dir schon zuvor gekommen ;). Habe es seit 0.5.1 drin. Ganz frisch habe ich Version 0.5.3 hochgeladen, und ich hoffe, Du wirst angenehm überrascht sein. Die Browser (*moon und Firefox) laufen jetzt sogar besser als auf dem Festsystem, das ich auf meinem kleinen Asus Eee PC habe. Neben kleineren Änderungen habe ich jetzt auch den grafischen Bootloader von Oliver Fromme installiert.

Verbesserungsvorschläge sind immer willkommen.

Viel Spaß!
Danke, das probiere ich gleich mal aus! :)
 

lme

FreeBSD Committer
#32
Das gefällt mir schon immer besser.

Was mir noch aufgefallen ist: Nach dem Start von OpenBox wurden 2 Instanzen von DSBbatmon angezeigt, da bist du glaube ich der richtige Ansprechpartner. ;)
Und du solltest noch die Erzeugung von Corefiles deaktivieren. Ab und zu stürzt ja schon etwas ab und dann werden ein paar bis ganz viele MBs auf den Stick geschrieben.
EDIT:
Code:
kern.coredump=0
in der sysctl.conf

Falls dir dann noch eine Upgrade-Möglichkeit auf neuere Versionen von NomadBSD einfallen würde, wäre das das Sahnehäubchen. :D
 

marcel

Well-Known Member
Themenstarter #33
Was mir noch aufgefallen ist: Nach dem Start von OpenBox wurden 2 Instanzen von DSBbatmon angezeigt, da bist du glaube ich der richtige Ansprechpartner. ;)
Hmmm. Das ist seltsam.
Und du solltest noch die Erzeugung von Corefiles deaktivieren. Ab und zu stürzt ja schon etwas ab und dann werden ein paar bis ganz viele MBs auf den Stick geschrieben.
Ich Narr habe kern.coredump=0 in die /boot/loader.conf geschrieben. Werde ich korrigieren. Danke für den Hinweis!
Falls dir dann noch eine Upgrade-Möglichkeit auf neuere Versionen von NomadBSD einfallen würde, wäre das das Sahnehäubchen. :D
Darüber habe ich auch schon nachgedacht. Mal sehen, was man da machen kann ...
Nett wäre ja auch eine GELI-home-Partition.
 

pit234a

Well-Known Member
#35
kenne ich zwar nicht, setze aber immer auf xscreensaver. oder so eben.

btw: ich habe noch nichts getestet, denn ich musste etwa fünf Downloads probieren, um die erste Version auf den PC zu bekommen (mit korrekter sha) und kaum hatte ich die drauf, gab es schon die nächste Version und bei den langen Wartezeiten für einen Download habe ich das erst mal nach hinten auf meiner Prio-Liste geschoben.
 

marcel

Well-Known Member
Themenstarter #36
Und als Softwarewunsch noch etwas, um den Bildschirm sperren zu können. metalock oder so.
Ist drin.

Die optionale geli-Verschlüsselung der home-Partition läuft auch.

btw: ich habe noch nichts getestet, denn ich musste etwa fünf Downloads probieren, um die erste Version auf den PC zu bekommen (mit korrekter sha) und kaum hatte ich die drauf, gab es schon die nächste Version und bei den langen Wartezeiten für einen Download habe ich das erst mal nach hinten auf meiner Prio-Liste geschoben.
Das ist ärgerlich. Ich würde mich da auch sehr über Empfehlungen hinsichtlich eines guten Filehosters freuen.
 

lme

FreeBSD Committer
#37
Ist drin.

Die optionale geli-Verschlüsselung der home-Partition läuft auch.
Cool! :cool:

Was mir gerade bei einem älteren Notebook aufgefallen ist: Wenn eine alte Nvidia-Grafikkarte verbaut ist, sagt der aktuelle Treiber, dass die Karte nicht unterstützt wird und mann den 340er Treiber von Nvidia nehmen soll. Lassen sich die beiden nebeneinander installieren? Vielleicht mit Auswahlmenü oder noch besser automatischer Erkennung und Auswahl des richtigen Treibers?
 

marcel

Well-Known Member
Themenstarter #38
Hallo @lme,

da hast Du mich gerade noch rechtzeitig vor der 1.0 aufgehalten :)
Was mir gerade bei einem älteren Notebook aufgefallen ist: Wenn eine alte Nvidia-Grafikkarte verbaut ist, sagt der aktuelle Treiber, dass die Karte nicht unterstützt wird und mann den 340er Treiber von Nvidia nehmen soll. Lassen sich die beiden nebeneinander installieren? Vielleicht mit Auswahlmenü oder noch besser automatischer Erkennung und Auswahl des richtigen Treibers?
Ich kann es leider nicht testen. Wenn Du so gut wärst, folgende Prozedur mal auf Deinem Livesystem durchzuführen, erwiesest Du mir einen großen Dienst:
Code:
# cp nvidia_setup.txt /usr/bin && chmod a+x /usr/bin/nvidia_setup
# rehash
# pkg fetch -y -o /tmp nvidia-driver-304
# pkg fetch -y -o /tmp nvidia-driver-340
# mkdir -p /nvidia/304
# mkdir /nvidia/340
# (cd /nvidia/304 && tar xf /tmp/All/nvidia-driver-304*.txz)
# (cd /nvidia/340 && tar xf /tmp/All/nvidia-driver-340*.txz)
# nvidia_setup
# service onestart slim
 

Anhänge

lme

FreeBSD Committer
#40
Das klappt noch nicht ganz.

Das nvidia.ko wird korrekt geladen und attached auch, aber beim Laden von nvidia-modesett.ko kommt
Code:
KLD nvidia-modeset.ko: depends on nvidia - not available or version mismatch
Der Start von slim geht übrigens auch nicht.

Code:
/usr.local.etc/rc.d/slim: ERROR: get_pidfile_from_conf: /usr/local/et/slim.conf does not exist (slim)
 
H

holgerw

Guest
#41
Das klappt noch nicht ganz.

Das nvidia.ko wird korrekt geladen und attached auch, aber beim Laden von nvidia-modesett.ko kommt
Code:
KLD nvidia-modeset.ko: depends on nvidia - not available or version mismatch
Der Start von slim geht übrigens auch nicht.

Code:
/usr.local.etc/rc.d/slim: ERROR: get_pidfile_from_conf: /usr/local/et/slim.conf does not exist (slim)
Hallo @lme

falls Du die zweite Fehlermeldung per Drag & Drop übernommen hast und es kein Tippfehler von Dir ist - dann erwartet die Software ein
/usr/local/et/slim.conf was es natürlich nicht gibt
 

marcel

Well-Known Member
Themenstarter #42
Das nvidia.ko wird korrekt geladen und attached auch, aber beim Laden von nvidia-modesett.ko kommt
Code:
KLD nvidia-modeset.ko: depends on nvidia - not available or version mismatch
Die Zeile
Code:
kldload nvidia-modeset
kannst Du aus nvidia_setup entfernen. Das nvidia-modeset-Modul wird ja auch bei 340 und 304 gar nicht mitgeliefert, bzw. gebraucht. Hätte ich ja auch vorher drauf kommen können :)

Was slim anbelangt, verweise ich mal auf @holgerw.

Danke Euch!
 

lme

FreeBSD Committer
#44
Ich bin einen Schritt weiter.

Im Startscript von slim habe ich den Pfad zur Configdatei auf /usr.local.etc/slim.conf geändert. Der Fehler tritt dann schon mal nicht mehr auf.
Ein Starten von slim bzw. X funktioniert aber immer noch nicht.

Fehlermeldung aus Xorg.0.conf:

Code:
(EE) open /dev/dri/card0: no such file or directory
(EE) Screen 0 deleted because of no matching config section
Vorher noch, dass die Module "nv", "scfb", und "vesa" nicht geladen werden konnten.

Muss ich noch eine xorg.conf erstellen?
 

marcel

Well-Known Member
Themenstarter #45
Das war abgetippt. Das Notebook hat leider keine Internetverbindung.
Könntest Du in nvidia_setup die Zeile
Code:
mount_unionfs -o ro /nvidia/${driver}/usr/local /usr/local
ändern in
Code:
mount_unionfs /nvidia/${driver}/usr/local /usr/local
?
Das sollte dann das PID-File-Problem so lösen, dass Du die Datei auch nach /usr/local/etc legen kannst.
Code:
(EE) open /dev/dri/card0: no such file or directory
(EE) Screen 0 deleted because of no matching config section
Vorher noch, dass die Module "nv", "scfb", und "vesa" nicht geladen werden konnten.

Muss ich noch eine xorg.conf erstellen?
ist /usr/local/etc/X11/xorg.conf.d/10-nvidia.conf vorhanden? Wenn nicht, dann
Code:
cp /root/10-nvidia.conf /usr/local/etc/X11/xorg.conf.d
 

lme

FreeBSD Committer
#46
Ja, jetzt bin ich fast am Ziel.

Alles wie oben gemacht, inkl. erstellen von /usr/local/etc/X11/xorg.conf.d und kopieren des Configfiles. Dann ließ sich slim aber doch nicht starten. Warum, ist leider auf den ersten Blick nicht ersichtlich.
Allerdings konnte ich als User "nomad" "startx" ausführen, das startet Openbox und alles sieht gut aus.
 

marcel

Well-Known Member
Themenstarter #47
Alles wie oben gemacht, inkl. erstellen von /usr/local/etc/X11/xorg.conf.d und kopieren des Configfiles. Dann ließ sich slim aber doch nicht starten. Warum, ist leider auf den ersten Blick nicht ersichtlich.
Könntest Du die /root/.login so abändern, dass Du unter die Zeile
Code:
kldload nvidia-modeset
die Zeile
Code:
nvidia_setup
einfügst, und dann mal einen Neustart machst?
Allerdings konnte ich als User "nomad" "startx" ausführen, das startet Openbox und alles sieht gut aus.
Super!
 

marcel

Well-Known Member
Themenstarter #48
Ok, Ich hab's! Das Problem ist, dass /nvidia/${driver}/usr/local nach /usr/local gemountet wird. Denn /usr/local/etc ist im Gegensatz zu /nvidia/${driver}/usr/local/etc ein Symlink. Das führt dazu, dass dann die Konfigurationsdateien unter /usr.local.etc nicht zugänglich sind.

Habe jetzt nvidia_setup entsprechend angepasst. Die Gültigkeit des vorherigen Posts bleibt bestehen, nur, dass das Skript ersetzt wird.
 

Anhänge

lme

FreeBSD Committer
#49
Genau, mir ist auch gerade aufgefallen, dass nach dem Union-Mount nach /usr/local in /usr/local/etc das darunterliegende Dateisystem nicht mehr sichtbar ist. Deswegen lässt sich auch slim nicht starten, weil er seine Config nicht findet.

In /root/.login ist aber noch ein Logikfehler enthalten. Da wird geprüft:

Ist nvidia verbaut? -> Ist keine /usr/local7etc/X11/xorg.conf.d/10-nvidia.conf vorhanden? -> Kopiere config, lade nvidia Treiber.

Wenn die Configdatei bereits vorhanden ist, wird der Treiber nicht geladen. Es funktioniert also nur beim ersten mal. Das kldload und nvdidia_setup muss in die darüberliegende if-Abfrage verschoben werden.

Die neue nvidia_setup probiere ich jetzt mal aus.
 

marcel

Well-Known Member
Themenstarter #50
In /root/.login ist aber noch ein Logikfehler enthalten. Da wird geprüft:

Ist nvidia verbaut? -> Ist keine /usr/local7etc/X11/xorg.conf.d/10-nvidia.conf vorhanden? -> Kopiere config, lade nvidia Treiber.

Wenn die Configdatei bereits vorhanden ist, wird der Treiber nicht geladen. Es funktioniert also nur beim ersten mal. Das kldload und nvdidia_setup muss in die darüberliegende if-Abfrage verschoben werden.
Danke Dir für den Hinweis! Wie konnte ich nur so verwirrt sein!

Ich denke, ich werde den ganzen NVIDIA-Krempel dann auch gleich in die nvidia_setup packen.