• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Router oder FreeBSD Rechner vergessen anscheinend Route zu Nameserver

serie300

Well-Known Member
Themenstarter #1
Hallo

ich habe seit einigen Wochen das Problem, daß entweder mein FreeBSD Rechner oder der Router die Adresse des Nameservers vergessen bzw. faslch setzen - so zumindest meine Annahme. Mache ich ein paar Minuten nichts auf dem Netzwerk, so baut der Browser keine Verbindung erfolgreich auf und bei Eingabe von host google.de im Terminal kommt Timeout (manchmal sogar sofort). Router ist 'ne Fritzbox, die mit dem WAN-Port über PPP an einem Glasfaserrouter hängt. FreeBSD ist 10.4 mit aktuellen Patchen. Hat jemand eine Idee, womit das zusammenhängen könnte?
Zusatzinfo: Ethernet und IP ist nicht mein Fachgebiet. Kann es sein, daß der FreeBSD Rechner mit internen Anfragen raus will (z.B. irgendein Mailserver oder sonstige vergebliche Adressauflösungen versucht ("my.domain") und der DNS dann abwürgt (ist jet5zt 'ne unbedarfte Idee)?

Serie 300
 

mr44er

moderater Moderator
Mitarbeiter
#2
Ähm....die Angaben sind alle zu vage um was zu sagen.
1.Bitte poste mal die entsprechenden configs.
2.Können Clients (WLAN, LAN) direkt an der FB 'raus'? Pingen, auflösen etc.?
3.Sagt die FB über sich selber, dass sie 'online' ist?
....to be continued :ugly:
 

serie300

Well-Known Member
Themenstarter #4
/etc/resolv.conf:
nameserver 192.168.178.1

/etc/hosts:
::1 localhost localhost.my.domain
127.0.0.1 localhost localhost.my.domain


ping 8.8.8.8 geht dann auch nicht

Nach 10 Sekunden oder so fängt sich die Sache wieder und es geht weiter
 
#6
ping 8.8.8.8 geht dann auch nicht
Wäre zB schonmal kein DNS-Problem

host google.de im Terminal kommt Timeout (manchmal sogar sofort).
Hm, hört sich ein bischen nach vollständigem Verbindungsabbruch an

Hast du eine direkte Verbindung zum Router via Kabel oder kommt D-LAN/W-Lan zum Einsatz?
Beim FreeBSD Rechner irgendwas installiert, konfiguriert was direkten Einfluss auf das Netzwerk hat (Firewall zB?).
 

serie300

Well-Known Member
Themenstarter #9
danke für die Antworten. dieMaschine in der resolv.conf ist die Fritzbox. Die Fritzbox zeigt mit der LED zumindest an, dass sie eingewählt ist. ich werde mal versuchen die box direkt zu pingen, wenn ich nicht nach draussen komme.


serie300
 
#10
danke für die Antworten. dieMaschine in der resolv.conf ist die Fritzbox. Die Fritzbox zeigt mit der LED zumindest an, dass sie eingewählt ist. ich werde mal versuchen die box direkt zu pingen, wenn ich nicht nach draussen komme.
Schon klar, meine Frage bezog sich eher auf die Verwendung von dhcp, hast du deine Werte selbst eingetragen oder wurde dies über dhcp gemacht?
 

serie300

Well-Known Member
Themenstarter #11
So bin jetz ein Schritt weiter (am Abgrund)
IP ist fest vergeben; der Nummernbereich ab 65 ist in der Fritzbox auch für feste IP angegeben
rc.conf:ifconfig_alc0="inet 192.168.178.66 netmask 255.255.255.0"
rc.conf:defaultrouter="192.168.178.1"

Fehler tritt auf wenn ich ein paar Minuten nichts auf dem Netz gemacht habe.

Wenn ich keine Verbindung mit nach außen bekomme ist der Status:

ping 192.168.178.66 --> geht
ping 192.168.178.1 --> geht nicht

hat evtl. die Netzwerkkarte (Onboard Atheros, Treiber 'alc') einen Schlag bzw. ist in eiener Art Schlafmodus?

Hat einer eine Idee?

Serie300
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#12
Mal einen Schuss ins Blaue: Die Gegenseite der NIC (also der Switch oder was du da einsetzt) versucht per "Green Ethernet" Strom zu sparen, die NIC kann es nicht und reißt ab. Was genau ist denn die Gegenseite? Und ein 'ifconfig alc0' wäre auch nicht falsch. :)
 

serie300

Well-Known Member
Themenstarter #13
Hallo

Gegenstelle ist die Fritzbox.

alc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c3198<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether 00:25:22:b4:ab:83
hwaddr 00:25:22:b4:ab:83
inet 192.168.178.66 netmask 0xffffff00 broadcast 192.168.178.255
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active


Serie300
 

mr44er

moderater Moderator
Mitarbeiter
#14
versucht per "Green Ethernet" Strom zu spare
Ja, bei neueren Fritzboxen kann man das unter den freigeschalteten 'Advanced'-Einstellungen regeln. Stell alle Ports daher auf der Fritzbox mal fest auf 1000Mbit.
Ggf. reboot der Fritzbox und dann nochmal auf deren Oberfläche prüfen, ob die Einstellung sitzt, dann weiter probieren.
 
H

Heinrich

Guest
#15
PMJI, aber wieso 1000Mbit? alc0 hatte doch 100Mbit ausgehandelt. Kann die Karte denn 1000Mbit? Andernfalls geht dann nämlich gar nichts mehr.