• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

GDM - deutsches Tastaturlayout

pit234a

Well-Known Member
#26
Also einfach gdm und gnome aus der rc.conf feuern... mit root einloggen und startx ausführen?
ich habe das schon lange nicht mehr so gemacht, aber grundsätzlich: ja.

Als root eher nicht, man startet X für gewöhnlich (aber aus Sicherheitserwägungen heraus) nicht als root.
Es gibt eine Systemweite xinitrc (/usr/local/etc/X11/xinit/xinitrc), in welcher geregelt wird, was bei startx gemacht wird. Da steht ohne Änderung so etwas am Schluss:
Code:
twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login
Wenn es keine ~/.xinitrc gibt, die das "aushebelt", dann wird also der twm gestartet und auch einige xterms und eine xclock. Zum Testen genügt das vollauf und ist vielleicht einfacher, als viele andere Möglichkeiten.
 

pit234a

Well-Known Member
#27
was ich auch noch kurz anreißen wollte:
Die verschiedenen man-pages helfen durchaus auch weiter.
So kann man etwa mit kbdmap -s sehen, welche Tastaturen unterstützt werden. Daraus ergibt sich dann der derzeit einzige Eintrag für eine deutsche Tastatur in der rc.conf als keymap="de". So weit ich das sehe, wie immer.
Mit locale -a kann man alle möglichen localen ansehen, also die Charsets. Da finden sich dann unter DE drei mögliche für Deutsch und davon ist de_DE.UTF-8 jene mit UTF-8.

Es gibt da noch mehr und weitere Befehle und das ist schon eine spannende Sache, sich da durch das System zu arbeiten und es zu verstehen. Ich selbst habe das bestimmt schon dutzende Male getan und alles doch wieder vergessen. Wenn man das nicht regelmäßig macht, fehlt die Übung. Man kann auch nach den entsprechenden Dateien direkt suchen und vieles probieren und testen. Ein einfaches man keyboard kann so eine Reise ins System schon mal gut einleiten.
 

Sadakazu

Well-Known Member
Themenstarter #28
aaaaaalllllsssssoooooo
so wie es aussieht habe ich in x tatächlich eine deutsche tastatur... jedenfalls funktioniert nach startx noch mein öäü+#- usw
Die befehle die du grad noch geschrieben hast... ja de wird unterstützt und die drei DE charsets....

So, also scheint es doch am gdm zu liegen?
fällt jemanden spontan ein loginmanager ein, der auf deutsch funktioniert? würd mir den auch mal eben installieren und das dann mal damit testen....
 

pit234a

Well-Known Member
#29
wie schon geschrieben, XDM macht das problemlos, ist klein und schnell installiert.
KDM hatt es mir früher auch gemacht, hat aber viele Abhängigkeiten und eigene Konfigurationen.
 

Sadakazu

Well-Known Member
Themenstarter #30
KDM funktioniert doch sowieso nur mit KDE4 oder irre ich mich da grad?
Ich mein... ich meide KDE schon seit Jahren (deswegen hab ich auch kein PC-BSD installiert) aber ich meine da neulich im freebsd forum noch gelesen zu haben das KDM den Gnome3 gar nicht ansprechen kann?

Ich klatsch mir eben xdm drauf und versuch damit mal mein glück ;)
 

pit234a

Well-Known Member
#31
GNOME3 weiß ich nicht, aber zu Zeiten, wo ich KDM nutzte, da konnte er alle möglichen DEs starten.
Es ist ja auch nicht gerade viel, was ein DM tut. Es müsste ihm eigentlich egal sein, was es startet. Das sind ja erst nachfolgende Routinen. So wird durch XDM das gestartet, was du in deiner /~.xsession festgelegt hast. Ähnlich funktioniert das bei größeren DM, wie KDM. Nur führt der eine eigene Liste, erkennt, wa installiert ist und was zuletzt benutzt wurde und so weiter.
 

Sadakazu

Well-Known Member
Themenstarter #32
Najaaa..... ist jetzt auch nicht der brüller......
mit xdm kann ich mich zwar jetzt mit deutscher tastatur einloggen...... dafür ist gnome jetzt zu 80% auf englisch umgestellt und lässt sich auch nicht auf deutsch umstellen... Tastatur ist auf deutsch und einige teile sind übersetzt.... das meiste jedoch nicht... zb die shell... statt Aktivitäten steht dort Activities.... das datum ist hingegen auf deutsch aber der Logoutbutton ist komplett auf englisch... naja... was heißt hier komplett... da gibts eh nur noch das Einstellungssymbol... Bildschirm sperren und ausschalten fehlen vollständig xD

Ich glaub ich gebs auf... dann bleib ich halt bei gdm und muss in den sauren apfel beißen, das ich beim login mich ein bisschen umgewöhnen muss... oder wähle ein passwort ohne sonderzeichen xD
 

Illuminatus

in geheimer Mission
#33
Naja, wie verhält es sich denn wenn du deine VirtualBox VM nicht direkt über das Konsolenfenster bedienst, dafür aber über RDP/VNC? Blöder Workaround, aber es kann ja sein dass du darin mehr Erfolg hast bzw. das Layout bequemer umschalten kannst.
 

Sadakazu

Well-Known Member
Themenstarter #34
müsste ich mich erst einlesen.... hab so noch nie mit Remotedesktops gearbeitet.... jedenfalls nicht auf Unices...
Wenn ich remote auf irgendwelchen linux kisten zugegriffen habe dann in 99,999% der fälle über ssh...
Ich weiß das mein Pi rdp installiert hat.. habs aber noch nie wirklich angefasst xD in der hinsicht mag ich mein Terminal zu sehr :D
 

Sadakazu

Well-Known Member
Themenstarter #36
Ne, hat auch nicht geklappt.... wobei ich mir auch sicher bin, das gdm_lang sich nur auf die sprachausgabe und nicht auf das Tastaturlayout bezieht....
 
#38
Ich habe mir jetzt mal die ganzen Scripte von gdm durchgelesen, die in /usr/local/etc/gdm (und Unterverzeichnissen dort) liegen. Ich tippe derzeit darauf, dass man mit setxkbmap weiterkommt, kann es aber leider erst später/am WE testen.
 

Sadakazu

Well-Known Member
Themenstarter #39
@Fusselbär das bezieht sich aber auf eine deutlich ältere version... da gehts ja noch um FreeBSD 10.1 ... ich weiß nicht genau welche gdm version da aktuell war, aber gdm macht die probleme scheinbar ja erst seit v 3.14.x ergo wird es da funktioniert haben...
@Columbo0815 ich hatte irgend wo schon gelesen, das setxkbmap in /usr/local/etc/gdm/Init/Default in die letzte Zeile eingetragen werden soll...
Hatte ich soweit auch schon getan, aber auch ohne erfolg ;)
Wobei ich setxkbmap de einmal in die letzte zeile geschrieben hatte und einmal vor exit 0.... hat aber beides nicht funktioniert.....
Auch wenn setxkbmap de in einem Terminal eintacker und mich dann wieder anmelden will.... bringt das nichts....

Lol... während des verfassens dieser antwort bin ich über ein Post aus dem arch linux forum gestoßen....
Ok, problem solved.
You can laugh, but I switched to KDE.
So kann man das Problem zwar lösen xD aber ich mag KDE einfach nicht ;)
 
#40
Tastatureinstellungen sind irgendwie immer etwas "grüzzelig", was mir vor allem daran zu liegen scheint, daß jedes fusselige Progrämmelchen die Einstellung irgendwo anders suchen geht ...
Mir schien der Blick auf GhostBSD ganz hilfreich, aber ich habe es nur in er VM und keine Zeit, groß zu suchen. Würde mich aber wundern, wenn sie den Benutzer bei der PW-Eingabe ein US-Tastatur unterschieben würden.
 

Sadakazu

Well-Known Member
Themenstarter #41
Ich hab GhostBSD auch grad runtergeladen und werds nachher mal in ner VM Testen und da mal drinne schnüffeln....
Aber eigentlich wollte ich kein Distri BSD haben ^^ einer der gründe warum ich weg will von Linux.... da kocht jeder sein eigenes süppchen... heute wird etwas hier eingestellt morgen schon wieder anders und übermorgen kommt ein kernelupdate der dann irgend einen treiber zerkloppt... ich weiß nicht wie oft mir das bei Debian schon passiert ist, das mir die Graka treiber abgerauchst sind, nachdem ein neuer Kernel kam... vor ein paar wochen wars so schlimm das ich nicht mal mehr booten konnte xD

EDIT:
Hab vorhin die maschine geklont und kde installiert...
kdm4 hat das deutsche layout übernommen....

es liegt also definitiv an gdm.....
 
#42
Du kannst aus einem FreeBSD auch ein GhostBSD basteln, es dürfte alles da sein und es gibt keine Magie oder sonstwas eigenbrötlersiches.
Ich finde es zuweilen ganz hilfreich mal über den Tellerrand zu schauen, wie "die Spezies" das so machen. Gerade bei einem Laptop ist es einen Blick wert.
 

Sadakazu

Well-Known Member
Themenstarter #43
Du, ich könnte auch aus nem FreeBSD ein DebianBSD bauen....^^ es geht ja auch nicht darum, wie das irgendwelche spezis machen...
Mir persönlich gehts darum, das ich so nahe am "original" bleiben will, wie es nur irgend möglich ist... und FreeBSD bzw BSD allgemein hat da in vielen punkten - wie ich finde - eine schönere Philosophie... BSD legt im vergleich zu linux mehr wert auf kontinuität und stabilität.... linux will immer mehr immer schneller neue features bringen...
Ob das gut oder schlecht ist lässt sich ja drum streiten ^^ und ich finde es auch gut,, wenn es Distributoren für BSD gibt.... einem absoluten einsteiger in die welt der unices würd ich auch ehr zu PC-BSD als zu FreeBSD raten....
Wie gesagt.. ich schau mir das später mal an.. wobei mein restlicher tag heut voll ist... werd ich wohl erst morgen zu kommen :( ^^
 
#44
Ich möchte peterle nicht vorgreifen.. Aber die Botschaft ist doch "GhostBSD ist im Prinzip FreeBSD. Wenn es dort geht, dann guck dir an, wie sie es gemacht haben und übernehme es in DEIN FreeBSD.". Die Botschaft war nicht "Wechsle zu GhostBSD". ;)
 

Sadakazu

Well-Known Member
Themenstarter #45
so...
da sich ein Termin grad erledigt hat konnte ich mal bisschen rumbasteln am Ghost...

/etc/rc.conf
Code:
gdm_lang="de_DE.UTF-8"
keymap="german.iso"
/etc/X11/xorg.conf.orig
Code:
Section "InputDevice"
  Identifier  "Keyboard0"
  Driver  "keyboard"
  Option  "XkbModel" "pc105"
  Option  "XkbLayout" "us"
EndSection
Gucke ich im Mate Keyboard Config tool, ist allerdings deutsch ausgewählt.... (und funktioniert, nur wieder im GDM nicht)
Mate selber ist vollständig auf englisch.... habe aber keine einstellungsmöglichkeit gefunden (GUI)

/etc/profile
Leer

/etc/login.conf
Standard Konfiguration

/usr/local/etc/gdm/locale.conf
Code:
LANG="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
Was mich jetzt zur Frage führt.... warum bietet man während der Installationsroutine eine Sprachauswahl an, wenn man doch alles auf en setzt aber in der rc.conf gdm_lang="de" reinsetzt?? irgendwie kurios...

Ich hab jetzt mal alle einstellungen durchgeführt wie ich sie auf meinem aktuellen FreeBSD laufen hab...
Und siehe da....
Das Problem bleibt.... Mate und gdm haben zwar eine deutsche sprachausgabe und mate hat auch das deutsche Tastaturlayout jetzt anerkannt.... aber gdm bleibt stur auf en hängen....

Auch auf Ghost ist die gdm version 3.16.4_1

Also... ich bleib dabei.... gdm hat irgendwo ne macke....
 
#46
Code:
==> grep key /etc/rc.conf
keymap="de"
(Das ist eine Intel Grafik mit vt!)

==> more /etc/login.conf
...
german:German Users Accounts:\
  :charset=ISO-8859-1:\
  :lang=de_DE.ISO8859-1:\
  :tc=default:
...

==> cat /usr/local/etc/X11/xorg.conf.d-available/keyboard-de.conf
Section   "InputClass"
   Identifier   "KeyboardDefaults"
(Schau Dir mal dein X logfile an, wie er die Tastatur benamst!)
   Driver     "keyboard"
   MatchIsKeyboard   "on"
   Option     "XkbLayout" "de"
EndSection
Mehr habe ich da eigentlich nicht, aber ich habe auch slim und kein gdm. :cool:

Wie man mate von englisch auf deutsch umschaltet, habe ich leider vergessen.
 

Sadakazu

Well-Known Member
Themenstarter #47
ich hab nur keine GUI gefunden... mit Mate kenn ich mich halt nicht so aus.. bei gnome3 ists halt das gnome-control-center bei Mate gibts zwar ein ähnliches werkzeug.. aber da kann man nur Tastatur einstellen ;)
Abhilfe hatte geschafft einfach von en_US auf de_DE in /usr/local/etc/gdm/locale.conf zu wechseln...

hab jetzt auch mal die anderen anpassungen vorgenommen die du gepostet hast... aber auch hier wieder.... fehlanzeige.... gdm bleibt stur auf dem englischen layout...
ich bin grad paralel dazu im ghostbsd irc channel...
dort denkt man aber ebenfalls das es an gdm liegt... das da ein bug irgendwo hängt :D

Also... denke ich mal können wir die fehlersuche erstmal auf eis legen....
Aber vielen dank für die ganzen tips und ratschläge ;)

Fühl mich hier deutlich wohler wie in so manchen Linux Foren.... ^^
 
#48
Mir schien der Blick auf GhostBSD ganz hilfreich, aber ich habe es nur in er VM und keine Zeit, groß zu suchen. Würde mich aber wundern, wenn sie den Benutzer bei der PW-Eingabe ein US-Tastatur unterschieben würden.
Das tun sie aber tatsächlich, die Tastatur bleibt US.

Wie man mate von englisch auf deutsch umschaltet, habe ich leider vergessen.
Wenn ich mkch recht entsinne, dann ging das über die /etc/login.conf und die login class, die man mit pw user mod TRALALA IRGENDWAS MIT -Gg oder so setzen mußte. man pw hilft sicherlich.
 

pit234a

Well-Known Member
#49
Alle paar Jahre wieder zitiere ich mal den folgenden Text, den ich damals von einem freundlichen Helfer hier erhielt, als ich in FreeBSD6.x alles auf DE haben wollte und das lief damals mit KDE(2 od. 3) und dem KDM und noch nicht auf UTF.
Es schadet vielleicht nicht, den alten Text sinngemäß nach zu vollziehen und abzugleichen, wie das eiegene System gesetzt ist.
Es kommt mir aber selbst sehr unwahrscheinlich vor, dass irgendeine conf etwas an diesen GDM-Verhalten ändern wird, das ich mir allerdings auch nicht erklären kann.

1.) Lokalisierung für csh/tcsh
Die Lokalisierung für csh wird systemweit in der /etc/csh.login eingestellt. Korrekte Lokalisierungseinträge für Dich sind:

Code:
setenv LANG de_DE.ISO8859-15
setenv MM_CHARSET ISO-8859-15
2.) Lokalisierung für sh/bash
Die Lokalisierung für sh und bash wird systemweit in der /etc/profile eingestellt. Korrekte Lokalisierungseinträge für Dich sind:

Code:
LANG=de_DE.ISO8859-15; export LANG
MM_CHARSET=ISO-8859-15; export MM_CHARSET

3.) Verwenden die FreeBSD-Benutzer unterschiedliche Lokalisierungen, so ist der Weg über die login.conf empfehlenswert. Aber Achtung: Ich persönlich hatte schon mehrfach Probleme mit der login.conf. Es kam vor, dass die in der login.conf definierten Einstellungen von FreeBSD nicht übernommen worden.

Für jeden Benutzer muss die zu verwendende Lokalisierung eingestellt werden. Folgende Schritte sind dazu notwendig:

/etc/login.conf modifizieren:
Code:
german|German Users Accounts:\
:charset=ISO-8859-15:\
:lang=de_DE.ISO8859-15:\
:tc=default:
/etc/login.conf.db anlegen:
Code:
# cap_mkdb /etc/login.conf
Jedem einzelnen Benutzer seine Benutzerklasse zuweisen:
Code:
# vipw
user:password:1111:11:german:0:0:USER_NAME:/home/USER_NAME:/bin/csh

dann noch in der /usr/local/share/config/kdm/Xsession ganz oben eingefügt:
. /etc/profile
. ~/.profile
 
#50
@pit

Ich glaube, das Problem bei einer systemweiten Einstellung ist, daß die ports davon betroffen sein können und entsprechend dann irgendwelche Abwege gehen können, weshalb empfohlen ist, die user einzeln umzustellen und root möglichst unverändert zu lassen - die Tastatur natürlich ausgenommen.