• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

GDM - deutsches Tastaturlayout

#77
Hallo liebe Forengemeinde,
bin neu hier und suche nach einem Tipp, wie ich GDM das deutsche Tastaturlayout beibringen kann. Ich habe alles hier geschriebene versucht - leider ohne Erfolg. Vielleicht gibt es nun nach 3 Jahren des letzten Beitrags ein Lösungsweg.:)
 

ralli

BSD Fanboy
#78
Das Problem habe ich schon seit geraumer Zeit gelöst, habe es aber leider nicht dokumentiert. Wenn ich mich richtig erinnere, gibt es unter /etc oder local/etc einen Ordner gdm, da ist eine Konfigurationsdatei, in der die amerikanische Tastatur voreingestellt ist. Einfach selbsterklärend ändern in de_DE.UTF8. Anschließend Rechner neu starten. Ich meine, ich hätte das hier im Forum mal gepostet, ganz sicher bin ich mir nicht, einfach mal suchen.
 
#79
Danke. Das Einzige, was ich gefunden habe, ist in
/usr/local/etc/gdm die Datei locale.conf. DIe sieht bei mir so aus:
Code:
LANG="de_DE.UTF-8"
LC_CTYPE="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
Ändert nur leider nicht das Tastaturlayout.
 

ralli

BSD Fanboy
#80
Danke. Das Einzige, was ich gefunden habe, ist in
/usr/local/etc/gdm die Datei locale.conf. DIe sieht bei mir so aus:
Das ist die richtige Datei, aber nur für gdm zuständig. Deutsche Lokalisation muß auch noch zusätzlich innerhalb von Gnome konfiguriert werden unter Einstellungen - Regionales???. Da muß deutsch hinzugefügt werden, dann ist alles in deutsch einschließlich der Oberfläche sowie im Texteditor, Terminal ect. Bei mir hat das funktioniert. Kann es Dir leider nicht genauer erklären, da ich kein Gnome mehr installiert habe.
 
#81
Problem ist bei der Anmeldung im gdm Umlaute und Sonderzeichen. Sonst ist alles auf Deutsch. Eine entsprechende Datei für hal gibt es auch.
 

pit234a

Well-Known Member
#82
kenne gdm zwar nicht, aber zu der Zeit wird vermutlich die Einstellung des X-Servers für die Tastatur greifen.
Versuch das mal, wie im Handbuch beschrieben: https://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/x-config.html
Bei mir macht was ich will:
Code:
pit@Celsius ~:- > cat /usr/local/etc/X11/xorg.conf.d/keyboard.conf
Section "InputClass"
    Identifier    "KeyboardDefaults"
    Driver        "keyboard"
    MatchIsKeyboard    "on"
        Option          "XkbModel" "pc105"
    Option        "XkbLayout" "de"
    Option        "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 
#83
Die keyboard.conf habe ich so auch. Leider greift die in gdm nicht. Ebenso habe ich eine /usr/local/etc/hal/fdi/policy/x11-imput.fdi mit folgendem Inhalt:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keyboard">
      <merge key="input.x11_options.XkbModel"
type="string">pc105</merge>
      <merge key="input.x11_options.XkbLayout" type="string">de</merge>
      <merge key="input.x11_options.XkbVariant"
type="string">nodeadkeys</merge>
    </match>
  </device>
</deviceinfo>
 

holgerw

Well-Known Member
#84
Hallo,

hast Du mal probiert, in die /etc/profile folgenden Eintrag zu setzen:
export LANG=de_DE.UTF-8

Danach den PC bitte neu starten.
 

pit234a

Well-Known Member
#87
https://wiki.archlinux.de/title/Login-Manager#GDM:_Standard_Tastaturlayout_w.C3.A4hlen

keine Ahnung, ob das auch für FreeBSD wirkt. Ehrlich gesagt ist es mir nicht ganz geheuer, weil ~/.dmrc doch zu einem bestimmten Nutzer gehört und ich eher eine Systemweite Zuordnung erwarten würde.

Wollte nur generell darauf hinweisen, dass man hierzu nicht nur bei FreeBSD suchen sollte.

Nochmal nachgefragt: hast du ein Tastaturlayout in der rc.conf angegeben?
 
#89
https://wiki.archlinux.de/title/Login-Manager#GDM:_Standard_Tastaturlayout_w.C3.A4hlen

keine Ahnung, ob das auch für FreeBSD wirkt. Ehrlich gesagt ist es mir nicht ganz geheuer, weil ~/.dmrc doch zu einem bestimmten Nutzer gehört und ich eher eine Systemweite Zuordnung erwarten würde.
Richtig.

Wollte nur generell darauf hinweisen, dass man hierzu nicht nur bei FreeBSD suchen sollte.

Nochmal nachgefragt: hast du ein Tastaturlayout in der rc.conf angegeben?
keymap="de.acc.kbd"
 
#90
/etc/login.conf:
Code:
#
# German Users Accounts. Setup proper environment variables.
#
german|German Users Accounts:\
    :charset=UTF-8:\
    :lang=de_DE.UTF-8:\
    :tc=default:
cap_mkdb /etc/login.conf wurde ausgeführt.