• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Mainboard mit passiver Kühlung für LC-Gehäuse

morromett

Well-Known Member
#27
..., das Paket raspberry-firmware.
Das habe ich heute morgen gemacht:
Code:
# pkg_info -a | grep -i firmware
raspberrypi-firmware-1.20200811 Raspberry Pi firmware
und danach den PI4 rebootet. Das hat aber nicht geholfen. Durch diese Installation wurden lediglich Dateien in das Verzeichnis "usr/local/share/raspberrypi-firmware/boot" übertragen/kopiert:
Code:
# ls -la /usr/local/share/raspberrypi-firmware/boot
total 45128
drwxr-xr-x  3 root  wheel     1024 Nov  5 09:13 .
drwxr-xr-x  3 root  wheel      512 Nov  5 09:13 ..
-rw-r--r--  1 root  bin       1594 Oct  4 10:00 LICENCE.broadcom
-rw-r--r--  1 root  bin      25330 Oct  4 10:00 bcm2708-rpi-b-plus.dtb
-rw-r--r--  1 root  bin      24678 Oct  4 10:00 bcm2708-rpi-b-rev1.dtb
-rw-r--r--  1 root  bin      25067 Oct  4 10:00 bcm2708-rpi-b.dtb
-rw-r--r--  1 root  bin      24800 Oct  4 10:00 bcm2708-rpi-cm.dtb
-rw-r--r--  1 root  bin      25965 Oct  4 10:00 bcm2708-rpi-zero-w.dtb
-rw-r--r--  1 root  bin      24772 Oct  4 10:00 bcm2708-rpi-zero.dtb
-rw-r--r--  1 root  bin      26333 Oct  4 10:00 bcm2709-rpi-2-b.dtb
-rw-r--r--  1 root  bin      26482 Oct  4 10:00 bcm2710-rpi-2-b.dtb
-rw-r--r--  1 root  bin      28599 Oct  4 10:00 bcm2710-rpi-3-b-plus.dtb
-rw-r--r--  1 root  bin      27980 Oct  4 10:00 bcm2710-rpi-3-b.dtb
-rw-r--r--  1 root  bin      26289 Oct  4 10:00 bcm2710-rpi-cm3.dtb
-rw-r--r--  1 root  bin      47471 Oct  4 10:00 bcm2711-rpi-4-b.dtb
-rw-r--r--  1 root  bin      47576 Oct  4 10:00 bcm2711-rpi-cm4.dtb
-rw-r--r--  1 root  bin      52480 Oct  4 10:00 bootcode.bin
-rw-r--r--  1 root  bin       7285 Oct  4 10:00 fixup.dat
-rw-r--r--  1 root  bin       5420 Oct  4 10:00 fixup4.dat
-rw-r--r--  1 root  bin       3159 Oct  4 10:00 fixup4cd.dat
-rw-r--r--  1 root  bin       8425 Oct  4 10:00 fixup4db.dat
-rw-r--r--  1 root  bin       8427 Oct  4 10:00 fixup4x.dat
-rw-r--r--  1 root  bin       3159 Oct  4 10:00 fixup_cd.dat
-rw-r--r--  1 root  bin      10277 Oct  4 10:00 fixup_db.dat
-rw-r--r--  1 root  bin      10275 Oct  4 10:00 fixup_x.dat
drwxr-xr-x  2 root  wheel     5632 Nov  5 09:13 overlays
-rw-r--r--  1 root  bin    3002048 Oct  4 10:00 start.elf
-rw-r--r--  1 root  bin    2277856 Oct  4 10:00 start4.elf
-rw-r--r--  1 root  bin     819644 Oct  4 10:00 start4cd.elf
-rw-r--r--  1 root  bin    3780296 Oct  4 10:00 start4db.elf
-rw-r--r--  1 root  bin    3037640 Oct  4 10:00 start4x.elf
-rw-r--r--  1 root  bin     819644 Oct  4 10:00 start_cd.elf
-rw-r--r--  1 root  bin    4852200 Oct  4 10:00 start_db.elf
-rw-r--r--  1 root  bin    3761192 Oct  4 10:00 start_x.elf
Ich denke, da muss schon etwas konfiguriert werden, ... aber was? Dieser bcmtmon-Treiber ich noch zu neu, denn im Internet findet man noch keine Informationen wie man diesen unter OpenBSD nutzen kann. Mit der manpage (man bcmtmon) kommt man auch nicht weiter.
Welchen securelevel hast Du auf deinem OpenBSD evtl. konfiguriert?
Code:
sysctl kern.securelevel
 

berni51

OpenBSD user & NetBSD newbie
Themenstarter #28
Ich hab ganz sicher nichts in der Richtung konfiguriert. Am securelevel hab ich auch nicht gedreht. Seltsam ...
 

morromett

Well-Known Member
#29
Ich hab ganz sicher nichts in der Richtung konfiguriert.
Kannst Du bitte bei dir in der EDK2-Firmware nachschauen, was bei "Advanced Configuration - SystemTableMode":
Code:
ACPI = 0x00000000 (default)
ACPI + Devicetree = 0x00000001
Devicetree = 0x00000002
konfiguriert ist. Bei mir ist nur ACPI (default) konfiguriert. Ich habe auf die 1. SD-Karte, "RPi4_UEFI_Firmware_v1.20" kopiert.
Du hast evtl. "RPi4_UEFI_Firmware_v1.16" und evtl. ist dort die default-Einstellung "ACPI + Devicetree" oder "Devicetree".
 

berni51

OpenBSD user & NetBSD newbie
Themenstarter #32
Nochmal zu meinem LC-Gehäuse: Hab mich entschlossen, erst einmal ausschliesslich mit vorhandenem Material zu arbeiten. Vorhanden sind das Apple-Pizza-Gehäuse und ein Mainboard vom Lenovo T410S. Das hab ich jetzt in Betrieb genommen, zwei Litzen zum Ein/Ausschalten angelötet, Speicher rein, eine m2 ngff SSD und OpenBSD drauf. Läuft seit gestern nonstop, und wenns noch ein paar Tage so weiterläuft, gehts an die mechanische Anpassung an die Pizza-Box - eine lösbare Aufgabe.
 

Anhänge

morromett

Well-Known Member
#34
Ich musste auch ändern in ACPI+Devicetree, hatte ich verdrängt. :cool:
Der Fehler ist gefunden. Es war ein Bug in der "RPi4 version "UEFI Firmware v1.20" ".

Mit der "RPi4 version "UEFI Firmware v1.21" funktioniert es:
Code:
:~ #sysctl hw.sensors      
hw.sensors.bcmtmon0.temp0=60.86 degC
Code:
:~ #dmesg | grep -i vendor
smbios0: vendor https://github.com/pftf/RPi4 version "UEFI Firmware v1.21" date 11/13/2020
Siehe auch: https://github.com/pftf/RPi4/releases/tag/v1.21
https://github.com/raspberrypi/firmware/issues/1489

Mit OpenBSD hat der PI4, ca. 8 °C mehr als mit RaspbianOS(buster).
 

berni51

OpenBSD user & NetBSD newbie
Themenstarter #35
Sehr schön, danke für die Info. Meine EDK2-Firmware ist 1.6, da gab es keine Probleme mit, werd ich auch erstmal dabei belassen.
Du betreibst deinen Raspi ungekühlt, wie ich sehe. Mit einem schönen, leisen Lüfter bin ich immer unterhalb 40°C.

Das Raspian den Prozessor kühler hält, hab ich bemerkt. Mit dem Lüfter sind die Temperaturen aber immer ziemlich gleich, egal welches OS. Habs mit Raspian, ArchLinux, Ubuntu, OpenBSD und jetzt auch mit NetBSD probiert.
 

berni51

OpenBSD user & NetBSD newbie
Themenstarter #37
Ich hab den raspi in dieses Sandwich-Gehäuse gepackt, ist von Reichelt. Bisher hat der Lüfter gut durchgehalten - und wenn nicht, gibts die für weniger als 1 € beim Chinesen.
 

Anhänge

berni51

OpenBSD user & NetBSD newbie
Themenstarter #38
Der Umbau des alten Apple LCII ist jetzt zu 99,9% abgeschlossen, und das Ergebnis befriedigt durchaus. War manchmal ein bisschen kniffelig, aber mit Dremeln, Feilen, Bohren, Löten und dem Einsatz von Distanzhülen, Kunststoffschrauben und sogar ein wenig Haustechnik ist es jetzt vollbracht.
Morgen noch einen kleinen Ausschnitt in das Cover dremeln und das Archlinux durch ein BSD ersetzen. Ja, und dann such ich noch einen WM, der dem alten McOS etwas ähnelt. Jemand eine gute Idee dazu?
 

Anhänge

pit234a

Well-Known Member
#42
Ja, und dann such ich noch einen WM, der dem alten McOS etwas ähnelt. Jemand eine gute Idee dazu?
kann mich gar nicht mehr erinnern, sah das nicht wie ne Mischung aus BeOS und CDE aus?
Ich glaube, dass es für (altes) KDE und auch für XFCE fertige Themen gab, die irgendwie BeOS (Haiku?) look-a-like waren.

Naja, ob ich die Zeit investieren wollte, ist wirklich fraglich, aber grundsätzlich habe ich das Gefühl, dass so etwas auch mit OpenBox gehen würde. Damals hatte man bei Apple noch einen Sinn in der rechten Maustaste erkannt und gerade bei OpenBox weiß ich, dass es da gute Konfigurationsmöglichkeiten gibt. Aber wahrscheinlich wenig fertige Beispiele. Wenn man alles selbst "erfinden" muss, dauert das halt sehr lange.
 

Andy_m4

Well-Known Member
#43
Zu LCII-Zeiten gab schliesslich noch kein OSX.
Eben. Das war doch eher die Zeit des legendären System 7. Damals, als man sich noch mit Microsoft beharkt hatte, wer den nun die grafische Benutzeroberfläche erfunden hat (wobei beide letztlich bei der GUI aus von Xerox Parc geklaut hatten). :-)

Ich glaube, dass es für (altes) KDE und auch für XFCE fertige Themen gab
Mit Themes kommt man auf jeden Fall recht weit. Notfalls kann man daran ja noch per Hand herumfeilen.

Falls man nicht mehr 100%ig weiß, wie es damals aussah hilft vielleicht dieser Online-Emulator weiter:
http://jamesfriend.com.au/pce-js/
 

berni51

OpenBSD user & NetBSD newbie
Themenstarter #45
Was für eine Seite !!! :D
Da gehts mir wie dem Pit: So ähh, jämmerlich, hatte ich es nicht in Erinnerung. Ich probier mal Pantheon, uwm, olvwm und TWM.
Aber übertreiben will ich's ja auch nicht, hab schon ordentlich Zeit versenkt und eine vage Ähnlichkeit reicht mir aus.
Danke für eure Tipps.
 
#46
Ohne mir den gesamten Thread durchgelesen zu haben, schau Dir doch mal den Futro S920 an, Mainboard ist D3313, die gibt es verschiedenen Ausführungen, wobei die (D3313-Ax) Varianten die günstigeren sind als die (D3313-Sx) Varianten, die (A) Variante verbraucht unter Vollast 25W und ist Passiv gekühlt, die (S) Variante habe ich leider noch nicht testen können, Die Fujitsu Thin Clients sind ursprünglich von Fujitsu Siemens, als bis vor kurzem die Firma Kontron die Fujitsu Augsburg Sparte aufgekauft hat ...
 

berni51

OpenBSD user & NetBSD newbie
Themenstarter #48
Um Mitternacht bin ich mit einer Flasche vom guten Roten nochmal an das LCII-Sourogat. Bin dann eure Vorschläge und Hinweise durchgegangen und wo's schnell ging, hab ich sie auch durchprobiert. Dabei hab ich wm kennen gelernt, von denen ich noch nie was gehört hab. Hängen geblieben bin ich dann an einem wm namens e16 mit dem Theme "winter". Ich finde, das kommt einem System 7 recht nahe.

Jetzt kann ich das Projekt quasi abschliessen - fast! Denn da ist noch eine Sache:
Installiert ist ein FreeBSD 12.1, hochgezogen auf 12.2. Das läuft wirklich sehr flott. Aber die Darstellung!!! Ist aber auch das OS, von dem ich am wenigsten Ahnung hab.

Xorg stellt den Bildschirm ordentlich in der höchsten Auflösung 1280x1024 dar. Aber die Konsole sieht grauenhaft aus!
Die Auflösung ist nur VGA mit blasser und zerfaserter Schrift.
Laut vidcontro -i mode stehen überhaupt keine Modes zur Verfügung. Bildschirmmodule kann ich nicht laden, nicht mal VESA (error 19). Will ich den i915kms laden, wird der Bildschirm schwarz und das war's.
Da bin ich im Moment noch ratlos. Aber das kann so nicht bleiben - die vorbeirauschenden Anzeigen beim Booten sind sowas von hässlich, das geht nicht.

Das Lenovo-Board hat eine Intel IronLake Grafik, dafür finde ich keinen speziellen Treiber, aber Xorg macht trotzdem was ganz ordentliches daraus. Nur die Console .....
 

Anhänge

pit234a

Well-Known Member
#50
damit das Modul auch sicher auf den Kernel passt.
wollte gerade noch den entsprechenden Thread heraussuchen, aber vielleicht genügt auch die Antwort:
mit Bezug auf die Worte von @Yamagi habe ich nämlich gelernt, dass der drm-fbsd12.0-kmod aus den Paketen zwar auf 12.1 funktioniert, nicht aber 12.2 (vielleicht noch nicht).
Wenn du ihn selbst bauen willst (und für 12.2 ist das ein muss), brauchst du die Ports und die FreeBSD-Sourcen. Mir ist es das nicht Wert gewesen und ich blieb mit den betroffenen Systemen auf 12.1

Aber die Konsole sieht grauenhaft aus!
Mit diversen Lenovos gab es Probleme mit einem UEFI-Boot. Das müsstest du mal nachlesen, ansonsten kann das helfen.
Das EFI-Boot schaltet auf einen anderen Grafik-Modus, der sehr viel besser ist. Und dann gibt es noch die kern.vty=vt in der loader.conf um das Verhalten zu beeinflussen, aber wie gesagt, bei mir hat der Unterschied mit UEFI-Boot das erst möglich gemacht.