• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Plasma 5 für FreeBSD ist da

cabriofahrer

Well-Known Member
#77
Hallo @holgerw,

wie sieht es denn nun mit der Unterstützung/Integration von dsbmc in Dolphin (ich nehme an, der heißt noch so?) aus? Du hattest Dich ja mit dem Thema beschäftigt und auch KDE4 noch extra kompiliert, um das auszuprobieren. Ich hatte da leider nichts mehr von gehört.
 

klimaschreck

Well-Known Member
#78
Danke für die Hinweise zur Installation von KDE5. Es hat soweit gut geklappt.

Mir fiel allerdings auf, dass juk zwar läuft, aber nichts mehr abspielt. Es kommt die Fehlermeldung "phonon backend could not be loaded". Und in der Tat habe ich qt5-phonon4 installiert, aber phonon selber nicht. Muss ich aus dem alten KDE4 noch phonen installieren mit den zahlreichen qt4 Ports oder gibt es bei KDE5 ein anderes music backend?
 

holgerw

Well-Known Member
Themenstarter #79
Hallo @holgerw,

wie sieht es denn nun mit der Unterstützung/Integration von dsbmc in Dolphin (ich nehme an, der heißt noch so?) aus? Du hattest Dich ja mit dem Thema beschäftigt und auch KDE4 noch extra kompiliert, um das auszuprobieren. Ich hatte da leider nichts mehr von gehört.
Hallo,

ich hatte vor Wochen mal plasma5 kompiliert, und bei kf5-solid die Option hal durch bsdisks ersetzt, bin dann aber nicht mehr zum Testen gekommen, da ich sehr viel um die Ohren habe.

Allerdings: Du kannst es doch nun bequem selbst mal ausprobieren, einfach wie hier beschrieben, plasma5 aus dem latest Repo installieren, dazu dann dsbmd/dsbmc und dann siehst Du, wie der aktuelle dolphin sich verhält.
 

holgerw

Well-Known Member
Themenstarter #80
Danke für die Hinweise zur Installation von KDE5. Es hat soweit gut geklappt.

Mir fiel allerdings auf, dass juk zwar läuft, aber nichts mehr abspielt. Es kommt die Fehlermeldung "phonon backend could not be loaded". Und in der Tat habe ich qt5-phonon4 installiert, aber phonon selber nicht. Muss ich aus dem alten KDE4 noch phonen installieren mit den zahlreichen qt4 Ports oder gibt es bei KDE5 ein anderes music backend?
Hmm, dragon-player spielt bei mir flac-Dateien nicht ab, ich habe dann kurzerhand vlc nachinstalliert. Ob da noch was fehlt, kann ich Dir nicht sagen.
 

ralli

BSD Fanboy
#81
Hmm, dragon-player spielt bei mir flac-Dateien nicht ab, ich habe dann kurzerhand vlc nachinstalliert. Ob da noch was fehlt, kann ich Dir nicht sagen.
Bei mir spielt dragon-player flac-Dateien ab. Das der codec installiert sein muß, setze ich als selbstverständlich voraus. Das ist natürlich nicht der Fall bei einer Plasma5 Minimalinstallation von KDE.
 

ralli

BSD Fanboy
#82
Mir fiel allerdings auf, dass juk zwar läuft, aber nichts mehr abspielt. Es kommt die Fehlermeldung "phonon backend could not be loaded". Und in der Tat habe ich qt5-phonon4 installiert, aber phonon selber nicht. Muss ich aus dem alten KDE4 noch phonen installieren mit den zahlreichen qt4 Ports oder gibt es bei KDE5 ein anderes music backend?
Ich habe hier noch ein KDE 4 unter OpenBSD laufen, da spielt juk einwandfrei. Nochmals, bitte bedenken, das es sich bei der Installationsanleitung für plasma5 von @holgerw um eine Minimalinstallation handelt. Da würde ich erst mal alle benötigten Codecs nachinstallieren, denn Multimedia Programme sind doch nur GUI's für die Audio und Videocodecs.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#83
Es muss - wie die Fehlermeldung andeutet - ein Phonon Backend installiert sein. Das sind multimedia/phonon-gstreamer, multimedia/phonon-vlc oder multimedia/phonon-xine.
 

holgerw

Well-Known Member
Themenstarter #84
Bei mir spielt dragon-player flac-Dateien ab. Das der codec installiert sein muß, setze ich als selbstverständlich voraus. Das ist natürlich nicht der Fall bei einer Plasma5 Minimalinstallation von KDE.
Gut, ich hatte nun allerdings auch Sachen aus kdemultimedia installiert, um einen kurzen Einblick zu bekommen. Da für mich Sound mit KDE-Anwendungen eigentlich uninteressant ist (ich nutze audacity zu Sendefertigmachen von Konzerten und vlc zum Abspielen, KDE-Soundausgabe ist das erste nach einer Installation von KDE/plasma5, was ich deaktiviere), habe ich das nicht weiter verfolgt.
Das sind multimedia/phonon-gstreamer, multimedia/phonon-vlc oder multimedia/phonon-xine.
Danke.
 
C

CrimsonKing

Guest
#85
noch eine Ergänzung zu sddm. Wer da auch deutsch haben möchte, trage bitte in die /etc/rc.conf noch folgendes (...)
Hat es eigentlich einen Grund, dass FreeBSD da nicht einfach den Gentooweg geht und direkt beim Bauen von Ports eine per make.conf voreingestellte Sprachdatei reinkompiliert? Ich meine, normalerweise benutzt man auf einem System ja nicht 32 Sprachen auf einmal, oder sehe ich da nur was nicht?

(Bei Bedarf abteilen - ich bin mir gerade nicht sicher, ob das noch on-topic genug ist.)
 

holgerw

Well-Known Member
Themenstarter #87
Hallo @Lance

beides sind Meta-Pakete, die bei Installation unterschiedliche andere Pakete mit sich ziehen.
Auf freshports kannst Du Dir bequem die jeweiligen Abhängigkeiten anschauen und vergleichen.
Zum Aufbau einer auf die eigenen Bedürfnisse angepassten Plasma5-Installation nimm nicht das kde5 Metapaket, das verhält sich ähnlich wie kde4 und Du bekommst ein sehr bandbreitiges Kooles Desktop Environement samt Spielen auf die Platte geschaufelt :D
Lieber mit dem plasma5-plasma Paket beginnen und dann mit kde-baseapps und weiteren Komponenten nach Bedarf ergänzen, finde ich zumindest besser, als eine kde5 Gesamtinstallation.
 

holgerw

Well-Known Member
Themenstarter #88
Hat es eigentlich einen Grund, dass FreeBSD da nicht einfach den Gentooweg geht und direkt beim Bauen von Ports eine per make.conf voreingestellte Sprachdatei reinkompiliert? Ich meine, normalerweise benutzt man auf einem System ja nicht 32 Sprachen auf einmal, oder sehe ich da nur was nicht?

(Bei Bedarf abteilen - ich bin mir gerade nicht sicher, ob das noch on-topic genug ist.)
Hmm, gute Frage. Das ist wohl eine Spezialität von sddm. Der kdm4 braucht keinen zusätzlichen LANG-Eintrag in der /etc/rc.conf.
Vielleicht mal direkt den sddm-Committer ansprechen, aber das Resultat von mir aus hier gerne posten, sddm hat ja sehr wohl mit plasma5 zu tun.
 
C

CrimsonKing

Guest
#89
Das ist wohl eine Spezialität von sddm. Der kdm4 braucht keinen zusätzlichen LANG-Eintrag in der /etc/rc.conf.
Wenn ich das richtig sehe, ist die Sprachdateisituation unter FreeBSD allgemein etwas zerfasert. LibreOffice hat einen Extraport für die deutsche Übersetzung, auch für Firefox muss man irgendwelche Sprachpakete nachinstallieren. Ohne Extrawurst/-paket kommt man da nicht weiter.

Bei KDE5 sollte es mich nicht wundern, wenn da sowieso alle Sprachen ungefragt mitgeliefert werden. :) (Kann das gerade nicht prüfen.)
 

ralli

BSD Fanboy
#90
Das ist kein Alleinstellungsmerkmal von FreeBSD.;) Bei anderen unixoiden OS wie Linux Distris ist das auch so. Zumindest, wenn der firefox manuell nachinstalliert wird. Bei Komplettinstallationen sieht die Situation mitunter komfortabeler aus. Aber wie immer, wird das zum Teil völlig unterschiedlich gehändelt. Unter FreeBSD und KDE 4 muß das Sprachpaket gesondert installiert werden, unter OpenBSD ebenfalls. Das gilt auch für den firefox. Warum das bei plasma5 anders ist, kann ich nur mutmaßen, dann ist das globale Sprachpaket bereits mitgeschnürt im Gesammtpaket. Danke an die Maintainer.:) Denn die deutsche Lokalisation wird ja beim sddm nur in der rc.conf aktiviert, mitinstalliert wurde sie schon.
 
C

CrimsonKing

Guest
#92
Ich habe das dann doch gerade mal geprüft: Ja, KDE Plasma scheint (wie z.B. auch Vim) ab Werk mit allen Sprachen ausgeliefert zu werden. Keine -i18n-de-Pakete notwendig. Aber die Aussage hier ist trotzdem nur teilrichtig:

da kann man dann doch eher sagen, dass das nicht OS bedingt ist
Um das mit Gentoo noch mal zu spezifizieren, weil das etwas unklar formuliert war: Trägt man in dessen make.conf etwas wie L10N="de" ein, so wird sowohl das Basissystem als auch bisher sämtliche Anwendungen, die ich ausprobiert habe (und das können), mitsamt dem deutschen Sprachpaket installiert und konfiguriert. Ohne Extra-Rumfummeln in irgendwelchen rc.conf- oder sonstigen Dateien und ohne explizites Runterladen von irgendwelchen i18n- bzw. l10n-Ports. Bislang konnte ich noch nicht feststellen, dass das bei irgendeiner Software nicht geklappt hätte. (Wenn da jemand schlauer ist als ich: Danke für Hinweise!)

Interessant ist das sicherlich nur für Programme,, die nicht sowieso entwicklerseits alle Sprachen schon an Bord haben. Was unter FreeBSD vollautomatisch deutschsprachig ist, ist es überall anders vermutlich auch. Aber zum Beispiel der Gentoo-LibreOffice-Port, der auch dort nicht ohne Extra-langpack auskäme, zieht sich die benötigte Sprachdatei einfach als Abhängigkeit rein. FreeBSD braucht dafür zwei zusätzliche Makefiles, eines davon als in nur explizit installierbaren Extraport, und ich konnte keinen Hinweis darauf finden, dass man das auch dort irgendwie global erledigen könnte.

Ich finde das vergleichsweise unschön gelöst. Aber das ist natürlich Nörgeln auf hohem Niveau: Den einen Port mehr oder weniger ... :)
 

klimaschreck

Well-Known Member
#93
Noch eine Frage zur Konfiguration von plasma: Wenn ich Settings als User aufrufe und Änderungen vornehmen will, erscheint die Meldung, dass ich dazu nicht berechtigt bin. Ich bin als User in den Gruppen wheel, video und operator. Gibt es einen Trick, wie ich die Berechtigungen erlangen kann oder zumindest nach dem root-Passwort gefragt werde, um die Änderungen zu bestätigen.

Konkret geht es mir darum, dass das plasma mir die falsche Zeitzone anzeigt. Ich wollte auf automatisch stellen oder Europe/Berlin, aber ich konnte die Änderungen nicht speichern.
 

holgerw

Well-Known Member
Themenstarter #95
@klimaschreck
ich komme erst am Dienstag wieder an meinen Rechner, daher nur eine grobe Info: Rechtsklick auf die Uhr, dann ist es glaube ich der dritte Menüeintrag, etwas wie Ändern der Zeiteinstellung, o.ä.
Dort machst Du bei den Zeitzonen zunächst bei Berlin einen Haken, und dann nimmst Du den Haken bei UTC weg.
Am Dienstag kann ich es Dir genau mitteilen.
 

ralli

BSD Fanboy
#96
Hallo @klimaschreck,

Rechtsklick Uhr

Wechsel zum Reiter Zeitzone und wähle Berlin. Du brauchst keine root Rechte, um die Zeitzone zu ändern, einfach den Button Anwenden anklicken dann kommt der Dialog zum Eingeben des Passwortes. Und hier bitte nicht das root Paßwort eingeben, sondern das Passwort Deines Useraccounts.

Zusätzlich habe ich noch im Kontextmenu Zeitformat einstellen gewählt und dort alles auf Deutschland eingestellt.

have fun! :)
 

klimaschreck

Well-Known Member
#97
Vielen Dank für den Hinweis auf den Rechtsklick mit der Uhr. Ich habe die Änderungen der Zeitzone so ändern können.

Grundsätzlich bleibt aber die Frage offen, wie ich Änderungen unter System Settings abspeichern kann. Ich habe zwar gesehen, dass ich sudo installieren könnte. Allerdings weiß ich nicht, wie ich die System Settings aus einer Shell heraus öffnen kann. Damit kann ich auch nicht sudo anwenden, oder?
 

klimaschreck

Well-Known Member
#98
Zum phonon backend:
Ich hatte zunächst phonon-vlc installiert. Ergebnis war, dass vlc auch mit audio Ausgabe lief. Leider hat juk immer noch keine Songs abgespielt. Es tauchte wieder die Fehlermeldung mit dem phonon backend auf. Darauf hin habe ich phonen-vlc und die 14 qt4-Ports wieder deinstalliert.

Geklappt hat es mit einer anderen Variante. Folgende Ports habe ich installiert:
[1/2] Installing vlc-2.2.8_4,4...
[1/2] Extracting vlc-2.2.8_4,4: 100%
[2/2] Installing qt5-phonon-vlc-0.9.1_1...
[2/2] Extracting qt5-phonon-vlc-0.9.1_1: 100%

Danach war mit juk alles ok.
 

ralli

BSD Fanboy
Um systemsettings aus der Konsole zu benutzen, ist kmcshell5 Dein Freund. kcmshell5 ist allerdings nur eine GUI für die integrierten Module. Du kannst in der Konsole alle Module anzeigen, die es verwaltet:

Code:
kcmshell5 --list
listet alle Möglichkeiten auf.

Wenn Du Datum und Zeit oder die Zeitzone ändern möchtest, rufst Du aus der Konsole folgenden Befehl auf:

Code:
kcmshell5 clock
Hier steht dann im Dialogfenster ja eindeutig, das Du Dich indentifizieren muß, bevor Du die Änderung abspeicherst.

Achtung, wie schon gepostet, nicht als Administrator, sondern als der normale angemeldete User.

Du kannst auch die GUI für die systemsettings aus der Konsole starten, und zwar mit:

Code:
systemsettings5
Das ganze funktioniert natürlich auch aus der Konsole, wenn Du Dich mit su als Superuser anmeldest. Ein zusätzliches sudo oder gksu ist hierfür nicht erforderlich.

Im übrigen hat sich in den systemsettings einiges geändert, auf das ich hier nicht eingehe . Mein Eindruck ist aber, das es gegenüber kde4 übersichtlicher geworden ist.

have fun :)