• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

SAS2308 Probleme mit ST10000VN0004-2GS11L ( Seagate IronWolf 10TB ) ?

mr44er

Well-Known Member
#76
Ich hab auch mal nach den Preisen geguckt...sehr saftig. :ugly:

hier stellt sich die Frage, ob ASRock da was aus dem Desaster mit dem C2550D4I gelernt hat
Also ich meide AsRock, weil mir mal ähnliches passierte. Das ist aber Ewigkeiten her und unbegründet durch Bauchgefühl.
Persönlich und im Bekanntenkreis bin ich mit ASUS super gefahren, aber das heißt nichts. Die einen verfluchen MSI, Gigabyte usw. bla.

Ich habe wie du meinen Serverkrams bei ebay geschossen. Ist ein Board von Tyan.
Als ich noch bei nem IT-Laden arbeitete (um 2005 rum), wurde da auch bevorzugt Tyan verbaut. Wenig bis gar keine Probleme, aber das ist eben nur die eigene Filterblase. ;)

Wenn es auf Verbauplatz nicht ankommt, dann brauchst du eigentlich nur was von den letzten 1 oder 2 Generationen günstig einkaufen, wenns denn ServerHW mit ECC sein soll. Bei nem Filer empfehle ich das, gerade bei deinen großen Platten.

Edit: Wie ich weiter oben mal erwähnte, wegen der Anbindung vom SAS2308 -> PCIe 3.0 x8 -> https://www.servethehome.com/lsi-sas-2308-raid-controller-hba-information-listing/
Wenn du schon neu kaufen musst, achte darauf, dass das Board über einen PCI-E Slot mit x8 (8 Lanes) angebunden verfügt. Ist kein 'musthave', aber der Flaschenhals ist eliminiert und zukunftssicher. Man weiß ja nie, wann man gegen SSDs tauscht und solltest du mal NVMe nutzen wollen, willst du das sowieso. ;)

Ich hab den Benchmark gefunden, hatte den anders in Erinnerung. Aber er passt genau zum Thema: https://www.servethehome.com/lsi-sas-9207-8e-sas-ii-sata-iii-hba-benchmarks/
 
Zuletzt bearbeitet:

rakso

Well-Known Member
Themenstarter #77
Hat Celeron AES-NI und ist Stromsparend?
Kann man mit einem SAS HBA die gesamte Backplane anschließen, oder? Ansonsten bräuchte ich 2x 8 SATA HBA.
An was für Produkte genau denkst du?
 

mr44er

Well-Known Member
#78
Mhm...lange keinen Celeron mehr angefasst. Früher war das ja lowcost-Schiene, daher abgespeckt in Sachen Features. Müsste man mal nach aktuellen Modellreihen schauen, aber ich denke schon, dass die aktuellen AES-NI haben. (es muss ja auch nicht Intel sein ;) )

Hast du ein Messgerät und wieviel Watt im idle wären denn ok für dich? Oder was wäre ein für dich vertretbarer €-Jahresbetrag, mal sorum gefragt? :D
Die Sache ist nämlich die:
  • TDP sind zwei paar Schuhe in den Lagern AMD und Intel
  • TDP sagt nicht, ob/wie sparsam idle ist (idle geben sich die CPUs heute nicht viel Unterschied)
  • Man sollte sich auch mal folgendes überlegen: Die dicke CPU braucht für eine Aufgabe 1 Minute, nuckelt eine Minute lang z.B. 200W, danach wieder idle und 5W. Die kleine CPU braucht für die gleiche Aufgabe 5 Minuten und nuckelt 60W.
  • Die CPU ist das geringste Problem beim Stromverbrauch, es sind eher die Platten und der Wirkungsgrad vom Netzteil. Manchmal auch das Board.

Kann man mit einem SAS HBA die gesamte Backplane anschließen
Ja, per Expander. Die Bandbreite wird aber aufgeteilt. -> https://www.hardwareluxx.de/community/f101/verwirrung-bei-sas-expander-bandbreite-1146139.html
Kann man machen, wegen Flaschenhals aber dann nicht mehr zukunftsträchtig. Ich würd mich bei einem Neukauf dann ärgern, aber ich weiß ja nicht wie du das siehst und wie dick dein Geldbeutel ist. ;)
Ich rate aber noch aus anderen Gründen vom Expander ab:
  • es kostet dich einen PCI-E Steckplatz, der bei ServerHW wegen den Lanes sehr kostbar ist
  • Edit: Ich weiß nicht, ob und welche Expander mit dem gewünschten HBA (zudem noch IT-Firmware) zusammenspielen, geschweige denn welche unter FreeBSD laufen.
  • wenn du Platten schlafen legen willst, hast du (evtl.) eine weitere KnüppelgegenSchienbein-Quelle (ich lege meine SAS-Platten schlafen, das klappt jetzt seit bald einem Jahr problemlos. SATA am HBA schlafenlegen knallt, habe ich nie hinbekommen. Das Höchste der Gefühle ist, dass ich fehlerfrei einen Mischpool mit SATA- und SAS-Platten betreibe und nur die SAS-Platten schlafenlege, damit es nicht knallt. Hat errors geworfen, wie du sie hattest mit timeout etc. alles natürlich hochriskant, aber das System ist in meiner Nähe und ich backuppe regelmäßig. (läuft aber sauber und hat jetzt schon über 200 Tage uptime). Letztes Jahr ist aus diesem Mischpool eine SATA-Platte krepiert, das Austauschen hat problemlos geklappt, keine Hänger etc. Diese SATA-Platte konnte aber 'TLER *klickmich*', was ich auch eingestellt hatte.
  • SATA am Expander wird absolut abgeraten (selber keine Erfahrung, aber wenn man was hört, dann das!) :belehren:

Du kannst entweder 2 HBAs reinstecken oder gleich einen LSI SAS2116/SAS 9201-16i (sicherheitshalber nochmal googlen nach mps-Treiber/IT-Mode usw.) und mit der Liste von @Bummibaer vergleichen.
Ich empfehle letzteres: kein Flaschenhals und nur einen PCI-E verbraten.
Solltest du dann doch alle 24 Bays bestücken (waren doch 24, wenn ich mich erinnere?), dann kannst du ja den SAS2308 ebenfalls dazustecken (oder gleich einen 24port HBA, müsste es geben?)
Alles eine Frage des Beschaffungspreises, wie lange du die Ausstattung nutzt/Amortisierung über Zeit und Stromverbrauch (ein HBA nuckelt ca. 10W, sollte man auch berücksichtigen übers Jahr und daher ob man 2 stecken will)...wobei ich aktuell keine Ahnung habe, was die HBAs kosten.
 

rakso

Well-Known Member
Themenstarter #79
ich brauche eig nur ein board mit 6-12 SATA Anschlüssen und mindestens einem 1 x PCI-E x8 slot, das ganze "relativ" Stromsparend, also kein 10 Jahre alter DualXenon oder sowas. i3, Atom, Avoton...


von "Technikaffe":
Die Avoton Prozessoren sind aktuell die sparsamsten Intel Prozessoren die mit ECC-Arbeitsspeicher umgehen können. Daher eignet sich diese Plattform ideal für ein effizientes NAS welches für kleinere Firmen oder auch im professionellen Heimbereich eingesetzt werden kann. Im direkten Vergleich mit einem Intel Core i3-4160 ist die Leistung des Intel Atom C2750 in etwa identisch.
 

rakso

Well-Known Member
Themenstarter #80
langsam wirds komisch. An dem SM-Board scheinen plötzlich 2 SATA Ports nichtmehr zu gehen. Die Platten fahren da nichtmehr hoch. Als ob ichs beim Umstecken geschrottet habe?
Jetzt ist das AsRock wieder drin. 4 Platten am oberen HBA-Port und die 5. im pool steckt am SATA_4 Anschluss (ATA2)
Bei nem Marvel-Port hagelte es schon beim Booten timeouts. Der unterste HBA Port ging mit zwei Kabeln nicht. Mit dem vom oberen gehts auch am unteren. Nun habe ich den gleichen nochmal nachbestellt. Erstmal ohne Backplane. Scrub scheint zu laufen. Dann klemme ich als nächstes die BP wieder dazwischen.

uff... ich will doch eigentlich nur damit arbeiten!
 

rakso

Well-Known Member
Themenstarter #82
Nun schaut es so aus: Eine bestimmte 10TB platte funktioniert nur am Board SATA2 Port. An keinem der Controller-Ports. In der Controller-Config (STRG-C beim boot) wird sie nicht gelistet. Beim booten spuckt freebsd diese Fehler aus.
Wie kann das denn sein?!

Im Controller kann man verschiedene Sachen einstellen. Dort was ändern?

Direct Attached Spinup Delay (Secs): 2
Direct Attached Max Targets to Spinup: 2
Report Device Missing Delay: 0
IO Device Missing Delay: 0

Danke!

Code:
        (probe0:mps0:0:15:0): INQUIRY. CDB: 12 00 00 00 24 00 length 36 SMID 204 terminated ioc 804b loginfo 31111000 scsi 0 state c xfer 0
(probe0:mps0:0:15:0): INQUIRY. CDB: 12 00 00 00 24 00
(probe0:mps0:0:15:0): CAM status: CCB request completed with an error
(probe0:mps0:0:15:0): Retrying command
ugen0.5: <vendor 0x046a product 0x0023> at usbus0
ukbd0 on uhub2
ukbd0: <vendor 0x046a product 0x0023, class 0/0, rev 2.00/2.20, addr 5> on usbus0
kbd2 at ukbd0
ugen0.6: <American Power Conversion Back-UPS RS 900G FW879.L4 .I USB FWL4> at usbus0
        (probe0:mps0:0:15:0): INQUIRY. CDB: 12 00 00 00 24 00 length 36 SMID 268 terminated ioc 804b loginfo 31111000 scsi 0 state c xfer 0
(probe0:mps0:0:15:0): CAM status: CCB request completed with an error
(probe0:mps0:0:15:0): Retrying command
 

mr44er

Well-Known Member
#83
Spinup Delay auf 15 oder gar 20 setzen, max target to spinup auf 1.

ABER das sollte alles nicht notwendig sein.

Vllt. ist durch das Umgestecke ein Kabel kaputtgegangen oder Port ausgeleiert. Jedenfalls würde ich mit dem Asrockdingens keine Experimente mehr durchführen.