• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Willkommen zu Xenforo 2.0

#28
Und das würde ich gerne vermeiden, denn bei jedem Update muss jede einzelne Code-Änderung manuell migriert und entsprechend getestet werden. Das erhöht den Aufwand massiv.
Bei vbulletin gab es als add on ein Template Modification System - das war Gold wert, gibt es aber nur für xenforo 1.
Ihr macht das schon alles richtig hier. ;)
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
Themenstarter #32
Bei vbulletin gab es als add on ein Template Modification System - das war Gold wert, gibt es aber nur für xenforo 1.
Ihr macht das schon alles richtig hier. ;)
Wir haben das Problem mit Geld gelöst. Nachdem ich 5 Jahre lang mehr schlecht als recht ein eigenes Theme gewartet habe, hatte ich die Schnauze voll. Für 25$ haben wir uns ein Theme-Framework (XenBase) und ein darauf aufbauendes Theme gekauft, was sich per WYSIWYG-Assistent anpassen lässt. Der Vorteil ist, dass man den Ärger mit dem Theme los ist. Der Nachteil, dass nicht mehr alles möglich ist...
 

TCM

Well-Known Member
#35
Ohne JS geht gar nichts mehr, wenn man nicht nur mitlesen will. Damit ist man automatisch wieder in der Situation, dass einfach so Drafts von Posts gespeichert werden. Ganz klarer Schritt nach hinten. In der Datenschutzrichtline immer noch kein Hinweis darauf.
 
#37
Ich glaub ich hab nicht genau verstanden was du damit meinst. Von wo aus willst du wo hin kommen?
Ich gehe meist von der Portalseite direkt auf die neuen Beiträge und dann zurück. Wenn ich das mich interessierende gelesen habe, bleiben oft noch welche übrig und und wenn ich die mit "Foren als gelesen lösche" lande ich unter Foren und nicht auf der Startseite. Wäre angenehm wieder auf der Startseite (oder jetzt bei "Was ist neu") zu landen. Eine Bagatelle, die aber angenehm wäre.
 
C

CrimsonKing

Guest
#38
Ich habe ein bisschen herumgespielt:
Wenn man in den Einstellungen des Brave-Browsers den Fingerprinting-Schutz deaktiviert, dann kann man hier Beiträge schreiben. (Beleg: dieser Beitrag.)

Offensichtlich ist Redactor (das WYSIWYG hier) nicht gut für die Privatsphäre (oder Brave hat einen Bug)?
 
C

CrimsonKing

Guest
#39
Haha: Im FreeBSD-Forum sehe ich mit der Änderung auch kein Eingabefeld... also vermutlich tatsächlich ein Problem in der Forensoftware.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
Themenstarter #40
Ich habe das eben mal nachvollzogen: Ich glaube, dass Xenforo Brave korrekterweise als Chromium-Derviat erkennt und entsprechendes Javascript sendet oder Features erwartet, aber Brave dann doch Dinge anders macht. Ich habe dazu einen Bug-Report bei Xenforo aufgemacht. Aber auf schnelle Hilfe würde ich nicht hoffen, wenn sie es fixen, dann wohl frühestens ins Version 2.0.7, irgendwann im späten Sommer oder so.

Ich habe außerdem ein Feature Request gestellt den Rich Text Editor wieder explizit abschaltbar zu machen. Mal schauen, ob sie darauf eingehen. Schließlich haben sie die Option entfernt und sich vielleicht etwas dabei gedacht...

Ich gehe meist von der Portalseite direkt auf die neuen Beiträge und dann zurück. Wenn ich das mich interessierende gelesen habe, bleiben oft noch welche übrig und und wenn ich die mit "Foren als gelesen lösche" lande ich unter Foren und nicht auf der Startseite. Wäre angenehm wieder auf der Startseite (oder jetzt bei "Was ist neu") zu landen. Eine Bagatelle, die aber angenehm wäre.
Achso, dann ich das gestern missverstanden. Das geht aber trotzdem nicht. Ich kann zwar die sozusagen Standardseite für die Forenansicht auf "Neue Beiträge" umstellen, aber das betrifft dann jeden Klick auf den Foren-Link oben in der Navigationsleiste. Was alles andere als intuitiv ist. Auch hier habe ich noch mal beim Support angefragt.

Sonst habe ich noch einige kleinere Änderungen:
  • Ein paar Renderfehler der Mobil-Ansicht korrigiert. Der Hinweis sich zu registrieren oder anzumelden ist immer noch auf einigen Gerätenzu breit, das ist allerdings ein Template-Bug der Upstream gefixt werden muss.
  • Das Portal routet nun korrekt, spricht kein /portal Anhängsel mehr in der URL.
 

ralli

BSD Fanboy
#42
Herzlichen Glückwunsch an das Team und vielen Dank für Eure unermüdliche Arbeit. Pünktlich zum Downtime des Forums fiel auch meine Fritzbox aus (DSL war weg) und ich bin erst seit 5 Minuten wieder online. Esrter Eindruck, sehr gut, es ist viel lesbarer und daher auch augenschonender. Das Design gefällt mir gut.
 
#43
Erstmal Glückwunsch zur Migration.
Was mir auffällt, bzw. mich verwirrt ist, dass der eigentliche Beitrag nicht oben neben dem Profilfoto beginnt, sondern dort erst das Erstellungsdatum steht - das war IIRC bisher jeweils unter dem Beitrag.

Rob
 
C

CrimsonKing

Guest
#44
Ich finde es über dem Beitrag schon ganz in Ordnung (obwohl es etwas weniger Platz einnehmen könnte IMO).
 
C

CrimsonKing

Guest
#45
Bug: Im Seitentitel fehlt ein Trennzeichen.

Code:
<title>Willkommen zu Xenforo 2.0Seite 2 | BSDForen.de - Die BSD-Community</title>
 
#46
Ich hab mich inzwischen auch von der Fahradtour erholt - mir gefällt das neue Design sehr gut, es scheint sowohl auf meinem Smartphone als auch im Chrome super zu laufen!

Tolle Arbeit und vielen Dank!
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
Themenstarter #50
Was mir auffällt, bzw. mich verwirrt ist, dass der eigentliche Beitrag nicht oben neben dem Profilfoto beginnt, sondern dort erst das Erstellungsdatum steht - das war IIRC bisher jeweils unter dem Beitrag.
Ja, es war bisher unten und nun ist es oben. Ich habe gerade einmal die verschiedenen Optionen durchprobiert, so sieht es aber am Besten aus. Man kann den rechten Teil der Zeile (u.a. die Beitragsnummer) nach unten schieben, aber nicht den linken Teil wie das Datum. Wenn man es macht, sieht es unlogisch-inkonsistent aus. Außerdem kann man den linken Teil mit Avatar und co. in die obere Zeile integrieren, aber auch das ist nur so lala.