Mein erster Eindruck von GhostBSD

Lance

Well-Known Member
Habe HDMI noch nie ausprobiert, deshalb frage ich: Gibt es denn irgendein Problem unter FreeBSD?
Unter einem Stock FreeBSD keine Ahnung aber ich hatte zu 80% erwartet ich muss im Terminal einen Befehl eingeben um HDMI anzusprechen.
Vor mehreren Monaten musste ich das, wenn ich z.B. Kopfhörer angeschlossen hatte. Die Soundausgabe wurde natürlich nicht automatisch umgeswitcht wie bei jedem anderen OS.

Das zeigt aber wieder eindrucksvoll was eine kleine Gruppe an Leuten leistet. Weiter so!! :)
 

cabriofahrer

Well-Known Member
Also ich tippe bei FreeBSD wird die Videoaudgabe automatisch funktionieren, aber bezüglich des Audios müsste man ggf. die Ausgabe als root angeben.
 

pit234a

Well-Known Member
Also ich tippe bei FreeBSD wird die Videoaudgabe automatisch funktionieren
im Grunde genommen, wie bei jedem anderen System auch, das ich kenne.
Es gibt zwei Umstände: den Boot-Zustand und die Änderung im laufenden System, wenn etwa plötzlich ein Beamer zusätzlich angesteckt wird oder ein zweiter Monitor oder auch, wenn der eine Monitor durch einen anderen ersetzt werden soll.
Den Boot-Zustand kann man ja im Grunde genommen dem Xserver und seinen Automtismen überlassen. Wenn man aber gezielt mehreren Monitoren irgendwelche Inhalte zuweisen möchte, muss das manuell erfolgen, also in einer manuellen Konfiguration (zB xorg.conf). Diese manuellen Konfigurationen macht man bequemer Weise für seine feste Situation und berücksichtigt dabei nicht, dass sich plötzlich etwas ändern könnte und dass dies deshalb dann automatisch geändert würde. In so einem Fall (der meist ja recht selten vorkommt), kann man seine manuelle Konfiguration ja einfach anpassen. Da man sie sich ja ausgedacht hat, kann man damit auch bequem umgehen. Das gilt auch für den Wechsel, etwa zu einem neuen Monitor mit anderen Eigenschaften.

Im laufenden Betrieb kann man diese Zuweisungen weitestgehend mit xrandr machen. Das neue Gerät und die benutzte Schnittstelle müssen natürlich erkannt und unterstützt sein. Damit wird aber nichts abgespeichert. Also, typischerweise, wenn ich einen Beamer anschließe. Die GUI zu xrandr ist arandr und die nötigen Rechte vorausgesetzt, kann man das dann aufrufen und sich die verfügbaren Monitore mit ihrer Auflösung anzeigen lassen (diese auch ändern) und anschließend erklären, welche Konfiguration man denn nun haben will (neuen Monitor neben dem existierenden, unterhalb oder oberhalb, einen Klon des existierenden Monitors usw).
Das funktioniert in FreeBSD (mit X-Server) nicht anders, als in Ubuntu oder was weiß ich.

Lustigerweise habe ich neulich noch erfahren, dass Anwender zwar genau das Problem hatten, sich aber massiv scheuten, den Befehl zum Starten von arandr abzusetzen. Teufelswerk, einen Befehl eintippen! Für den Nutzer entspannend fand sich dann unter "Einstellungen" auf seinem DE ein Eintrag der Art "Monitor-Setup" und der wurde dann gerne genommen und auch erfolgreich benutzt. Man ahnt es schon: es wurde nichts anderes getan, als arandr damit gestartet.
 

Lance

Well-Known Member
Korrektur: Jetzt funktionieren auch die Kopfhörer automatisch ohne dass ich das Audiosignal umstellen muss.

Aber jetzt kommt das Dicke und da wird's ernst.

Ich musste heute für eine kleine Produktion viele Audioaufnahmen mit Audacity machen:

Ich nahm zunächst das Ubuntu Laptop meiner Frau, weil´s da grad vor meiner Nase lag.(Lenovo)
Audio zu leise, keine Ahnung warum, alle Regler usw gecheckt, in wenigen Minuten keine Abhilfe gefunden; aufgegeben.

Windows 7 Laptop (Toshiba)
Aufnahme rauscht stark trotz "Rauschunterdrückung" in den Sounkarteneinstellungen

Windows 10 Laptop (Thinkpad)
Aufnahme rauscht stark

GhostBSD Laptop (Acer)
Aufnahme rauscht kaum!!

Ich erinnere mich mal dass unter GhostBSD der VLC Player ein Video ruckelfrei abspielte wo andere (stärkere!) Systeme Ruckler aufwiesen, und jetzt das!

Das BSD Gerät hat mir den Tag gerettet und die beste Aufnahmequalität an den Tag gelegt. Und hier ging es um produktives Arbeiten.

Überlegt Euch also ob ihr Linux oder *BSD nimmt für euere (Audio-) Produktion ;)

(Anbei das muss ich auch noch sagen, an meinem Mac hatte ich ein Nokia-Headset mit einer Klinke, dort war die Aufnahme absolut rauschfrei also absolut top aber das ist leider kaputtgegangen)
 

Lance

Well-Known Member
Aber tolle Auflistung mit Windows und Linux, die mal wieder beweist, dass FreeBSD auch beim Thema Sound die Nase vorn hat.
Ja die Windows Geräte waren geliehen. Und das BSD Gerät war „meine letzte Hoffnung“. Solche Qualitäten kenne ich sonst nur vom Mac bzw macOS.

Insgesamt kann ich aber nur nochmal betonen, dass (auch) GhostBSD einen guten Zahn zugelegt hat.
Und das, obwohl hier im Forum festgestellt wurde, dass Acer angeblich Schrott sei.
Ja manche Baureihen sind es tatsächlich, finde ich aber es gibt auch gute die lange halten. Die Tastatur bei meinem ist aber nicht grad der Hit.
 

christian83

Well-Known Member
Ich war ja schon einige Jahre nicht mehr in der *BSD Welt unterwegs. Hätte jetzt aber mal wieder Lust es anzutesten, aus keinen besonderen Grund, einfach mal ein Tapetenwechsel zu Linux und weil ich es eben einfach kann :-) Meint ihr GhostBSD ist da eine gute Möglichkeit mal unverbindlich zu schnuppern? Ehrlich gesagt habe ich auf eine richtige Installation wenig Lust weil es doch eher aufwändig ist mit eher ungewissen Ausgang. Die alten Hasen sparen sich bitte den Kommentar zum letzten Satz :)
 

Lance

Well-Known Member
Meint ihr GhostBSD ist da eine gute Möglichkeit mal unverbindlich zu schnuppern?
Ja klar


Ehrlich gesagt habe ich auf eine richtige Installation wenig Lust weil es doch eher aufwändig ist mit eher ungewissen Ausgang.
Genauso empfand und empfinde ich auch. Um ehrlich zu sein: ohne GhostBSD würde ich heute mit nem FreeBSD Desktop nichts zu tun haben weil ich einfach weder Zeit noch Lust hätte.

Probiers einfach aus! Ich helfe auch gerne weiter soweit ich kann
 

Lance

Well-Known Member
Also ich muss hier echt mal in den Raum werfen dass es noch nie so fehlerfrei und sauber lief wie bislang. Alle Achtung vor dem Team, was die da auf die Beine gestellt haben.
Es kam nun ein großes Update, nix zerschossen, alles läuft und endlich ist dieser kleine Lokalisierungsbug vom Tisch. (>nach Neuinstallation / Anlegen eines Nutzers war das System immer auf Englisch).

Ja, so macht FreeBSD richtig Spaß :)
 

bsd4me

Well-Known Member
...

Windows 7 Laptop (Toshiba)

Windows 10 Laptop (Thinkpad)

GhostBSD Laptop (Acer)

Ich erinnere mich mal dass unter GhostBSD der VLC Player ein Video ruckelfrei abspielte wo andere (stärkere!) Systeme Ruckler aufwiesen, und jetzt das!

Das BSD Gerät hat mir den Tag gerettet und die beste Aufnahmequalität an den Tag gelegt. Und hier ging es um produktives Arbeiten.

Überlegt Euch also ob ihr Linux oder *BSD nimmt für euere (Audio-) Produktion ;)

(Anbei das muss ich auch noch sagen, an meinem Mac hatte ich ein Nokia-Headset mit einer Klinke, dort war die Aufnahme absolut rauschfrei also absolut top aber das ist leider kaputtgegangen)
tja, es gibt viele Leute die *BSD für unbrauchbar halten. Ich habe im Laufe der Jahre als Admin erlebt, dass Ubuntu, CentOS, Windows und Apple auch Probleme gemacht haben. Es gibt kein perfektes und absolut sicheres OS, aber Vorurteile sollte man doch mal abbauen... Ich bleibe bei *BSD, weil es einfach super ist :) :)
 
Probiers einfach aus! Ich helfe auch gerne weiter soweit ich kann

Ich weiß, das Angebot war an christian83 gerichtet, aber vielleicht könntest Du (oder ein anderer Forist) mir dennoch bei einem (hoffentlich) kleinen Problem helfen - es würde mich sehr freuen.

Auf meinem Zweitrechner, einem Lenovo T530, wollte ich ein System abseits der Windowswelt installieren. Da mir BSD erheblich sympathischer als Linux ist, fiel meine Wahl auf GhostBSD.

Ich lud die Version 22.06.18 herunter und die Installation verlief absolut problemlos. Nur weigert sich der Rechner, sich per WLAN mit meiner Fritzbox 7490 zu verbinden - eingestellt ist WPA2. Er findet die Box, fragt den WLAN-Schlüssel ab - und das war's, stets erscheint die Meldung »Wi-Fi Network Authentification failed«. Das Protokoll der Fritzbox verzeichnet auch keinen Anmeldeversuch.

An der Fritzbox kann's nicht liegen, andere Rechner, Telefone, etc. lassen sich problemlos per WPA2 verbinden und auch besagter T530 funktionierte unter Windows einwandfrei.

Vermutlich ist es nur eine kleine Einstellung, die einem Kundigen bestenfalls ein müdes Lächeln zu entlocken in der Lage ist, mich als Einsteiger indes stellt sie vor ein Problem - für dessen Lösung ich sehr dankbar wäre und um die ich freundlich bitte. :)
 

Lance

Well-Known Member
Mir fallen da spontan nur zwei Sachen ein, an denen es liegen könnte:

- Probleme mit dem WLAN Treiber
oder
- Rechteproblem (würde das WLAN stets mit dem Erstaccount einrichten)
Geht das WLAN im Live-Mode?
 

pit234a

Well-Known Member
Ghost-BSD wird das wohl nicht viel anders machen, als FreeBSD und deshalb verweise ich mal auf:

Selbst dann, wenn Ghost-BSD noch eigene Komponenten dazu bringt, hilft das Handbuch sicher so viel, dass man den Fehler besser eingrenzen kann. Bei der jetzt vorliegen Beschreibung kann das ja alles Mögliche sein.
 

mr44er

moderater Moderator
Teammitglied
Ist das Numpad vielleicht aktiv? Klassiker wäre auch z.B. kein deutsches Tastaturlayout eingestellt, da reicht schon wenn z mit y vertauscht ist und das im PW vorkommt.
 

Anhänge

  • numpad.png
    numpad.png
    336,8 KB · Aufrufe: 4

CommanderZed

OpenBSD User
Teammitglied
Ich musste schon mehrfach Festellen das wpa_supplicant und co nicht mit Sonderzeichen umgehen können mit denen Windows und OpenBSD keinerlei Probleme hatten.

Letztlich ist man da imho nur streng mit ASCII und auch aus dem ASCII-Satz keine "speziellen" sachen die irgendwo ne andere bedeutung haben könnten relativ sicher - keine Anführungszeichen etc

Ausrufezeichen und Schrägstiche !/ gehen aber zb, klammern glaub ich zb nicht.

(Zumindest mit ner sehr alten Version damals)
 

Lance

Well-Known Member
Ist das Numpad vielleicht aktiv? Klassiker wäre auch z.B. kein deutsches Tastaturlayout eingestellt, da reicht schon wenn z mit y vertauscht ist und das im PW vorkommt.
Ja das hatte ich gleich ausgeklammert, da es ja nicht BSD-typisch ist, sondern auch Windows & natürlich Linux betreffen kann.

Aber stimmt, im Prinzip ist es meistens das.
Bei GhostBSD ist nach der Installation gerne mal die Sprache oder das Tastaturlayout auf Englisch obwohl man deutsch beim Installieren eingestellt hatte.
Auch nach (größeren) Updates ist das Layout oft wieder in Englisch gewesen.
Hatte mich da immer mal geärgert, dass so poplige Bugs immer wieder auftauchten.
 
Erst einmal ganz herzlichen Dank an alle! Ich weiß die Hilfe sehr zu schätzen. :)
Mir fallen da spontan nur zwei Sachen ein, an denen es liegen könnte:

- Probleme mit dem WLAN Treiber
oder
- Rechteproblem (würde das WLAN stets mit dem Erstaccount einrichten)
Geht das WLAN im Live-Mode?

Den Live-Modus habe ich auf Deinen Hinweis hin ausprobiert - auch dort funktioniert es nicht. Der einzige Unterschied ist die fehlende Fehlermeldung »Wi-Fi Network Authentification failed«. Die Verbindung kommt aber nicht zustande und auch die Fritzbox verzeichnet keinen Anmeldeversuch.
 
Ghost-BSD wird das wohl nicht viel anders machen, als FreeBSD und deshalb verweise ich mal auf:

Selbst dann, wenn Ghost-BSD noch eigene Komponenten dazu bringt, hilft das Handbuch sicher so viel, dass man den Fehler besser eingrenzen kann. Bei der jetzt vorliegen Beschreibung kann das ja alles Mögliche sein.
Danke - das Handbuch werde ich gewiß durchforsten und habe damit auch schon begommen - muß aber gestehen, im Moment von der Fülle der Informationen schier »erschlagen« zu werden. Daher meine Hoffnung, daß es sich bei dem Fehler um etwas Einfaches handelt, das ein versierter BSD-Kenner mit einem kurzen Hinweis zu lösen vermag.

Sonderzeichen im WPA2 Schlüssel?
Nein, nur Zahlen. Keine Buchstaben, keine Sonderzeichen.

Ist das Numpad vielleicht aktiv? Klassiker wäre auch z.B. kein deutsches Tastaturlayout eingestellt, da reicht schon wenn z mit y vertauscht ist und das im PW vorkommt.
Nein, danach hatte ich natürlich geschaut. Ich habe mir auch den Schlüssel bei der Eingabe anzeigen lassen - da stimmt alles.

Wie gesagt, die Fritzbox verzeichnet auch keinen Anmeldeversuch. Läge es nur am falschen Paßwort und die Verbindung funktionierte ansonsten einwandfrei, wäre ein erfolgloser Anmeldeversuch dokumentiert.

~~~

Mein laienhafter Verdacht: Könnte es an dem auf der Fritzbox eingestellten »WPA2 (CCMP)« liegen?
 

mr44er

moderater Moderator
Teammitglied
Könnte es an dem auf der Fritzbox eingestellten »WPA2 (CCMP)« liegen?
Nope, das passt auf jeden Fall.

Ich verzichte zur besseren Reichweite ganz auf 5 GHz. Falls du beide aktiv hast, dann benenne sie mal unterschiedlich. Hintergrund: Mancher Treiber kann nur 2,4 GHz, wenn sie gleich lauten kannst du nicht steuern, an welche SSID ein Client connecten soll.

AVM Stick & Surf: Auch wenn man kein weiteres AVM-Gerät hat, sollte das aktiv sein. Mein Halbwissen dazu war, dass es deaktiviert zu schlechterer Verbindung/Performance führt. Für deinen Test sollte es deaktiviert auch nicht schaden.

Alle neuen Geräte zulassen: Wenn das nicht aktiv ist, geht sowieso nichts, selbsterklärend.

WPS habe ich absichtlich nicht aktiv, auch habe ich sämtliche HW-Knöpfe an der FB deaktiviert. Kann mir nicht vorstellen, dass das Verbindungsprobleme verursacht, aber ich wollte es der Vollständigkeit zuliebe erwähnen. Testen schadet nicht. :)

Da du sagst, dass gar nichts an der FB protokolliert wird, dann ist die Sache mit den zwei (getrennten!) SSIDs für 2,4/5 GHz am wahrscheinlichsten.
 

Anhänge

  • fb1.png
    fb1.png
    152,6 KB · Aufrufe: 8
  • fb2.png
    fb2.png
    107,8 KB · Aufrufe: 8
  • fb3.png
    fb3.png
    23,6 KB · Aufrufe: 6

Lance

Well-Known Member
Falls du immer noch nicht weiterkommst, dein Treiber müsste „iwn“ sein und der braucht auch einen Firmware. Könnte ja vielleicht sein, dass diese in GhostBSD noch installiert bzw geladen werden muss.


Mit
Code:
sysctl net.wlan.devices
kannst du mal nachschauen, was er zu deiner WLAN Hardware bzw Treiber sagt.
 
Nope, das passt auf jeden Fall.

Ich verzichte zur besseren Reichweite ganz auf 5 GHz. Falls du beide aktiv hast, dann benenne sie mal unterschiedlich. Hintergrund: Mancher Treiber kann nur 2,4 GHz, wenn sie gleich lauten kannst du nicht steuern, an welche SSID ein Client connecten soll.
Es waren in der Tat beide aktiv. Ich habe sie dann unterschiedlich benannt und beide wurden auch unter »Available Connections« angezeigt. Verbindungsversuche mit dem 2,4-GHz-Netz zeigten jedoch den bekannten Fehler. Danach habe ich das 5-GHz-Netz komplett abgeschaltet, leider auch wieder ohne Ergebnis.

AVM Stick & Surf: Auch wenn man kein weiteres AVM-Gerät hat, sollte das aktiv sein. Mein Halbwissen dazu war, dass es deaktiviert zu schlechterer Verbindung/Performance führt. Für deinen Test sollte es deaktiviert auch nicht schaden.
Habe ich nachgeschaut, es war ohnehin aktiviert.

Alle neuen Geräte zulassen: Wenn das nicht aktiv ist, geht sowieso nichts, selbsterklärend.
Ja, das hatte ich ohnehin vor den Verbindungsversuchen eingestellt.

WPS habe ich absichtlich nicht aktiv, auch habe ich sämtliche HW-Knöpfe an der FB deaktiviert. Kann mir nicht vorstellen, dass das Verbindungsprobleme verursacht, aber ich wollte es der Vollständigkeit zuliebe erwähnen. Testen schadet nicht. :)

Da du sagst, dass gar nichts an der FB protokolliert wird, dann ist die Sache mit den zwei (getrennten!) SSIDs für 2,4/5 GHz am wahrscheinlichsten.
Natürlich schadet testen nie. :) Habe ich in diesem Falle auch getan, jedoch leider ohne Ergebnis.

Falls du immer noch nicht weiterkommst, dein Treiber müsste „iwn“ sein und der braucht auch einen Firmware. Könnte ja vielleicht sein, dass diese in GhostBSD noch installiert bzw geladen werden muss.


Mit
Code:
sysctl net.wlan.devices
kannst du mal nachschauen, was er zu deiner WLAN Hardware bzw Treiber sagt.
Er sagt »net.wlan.devices: iwn0«.
 

bsd4me

Well-Known Member
"Natürlich schadet testen nie" - bei Feurwerkskörpern schon ;-) Viel Erfolg bei der Fehlersuche!! Grüsslies, Norbert
 

CommanderZed

OpenBSD User
Teammitglied
Damit das hier nicht so für andere stehen bleibt:

Normalerweise haben 2,4GHZ und 5GHZ die gleiche SSID und der Treiber nutzt sauber das jeweils sinnvollste Protokoll. Ich kenn persönlich auch keinen fall wo das nicht der fall ist und bin in dem Thema eigentlich schon ganz okay orientiert.

5GHZ ist tendenziell dazu störungsfreier (2,4GHZ wird ja noch von XXX anderen Anwendungen verwendet), schneller und bietet diverse weitere Vorteile.

Der Nachteil der Reichweite ist natürlich korrekt, ich verwende deswegen für unser kleines Haus 2 APs, damit hab ich eine hervorragende Abdeckung.
 
Oben