Mein erster Eindruck von GhostBSD

Photor

Well-Known Member
Damit das hier nicht so für andere stehen bleibt:

Normalerweise haben 2,4GHZ und 5GHZ die gleiche SSID und der Treiber nutzt sauber das jeweils sinnvollste Protokoll. Ich kenn persönlich auch keinen fall wo das nicht der fall ist und bin in dem Thema eigentlich schon ganz okay orientiert.

5GHZ ist tendenziell dazu störungsfreier (2,4GHZ wird ja noch von XXX anderen Anwendungen verwendet), schneller und bietet diverse weitere Vorteile.
Hm. Ich habe zu Hause gezielt auch 2.4GHz- und 5GHz-Netz unterschiedlich benannt, gerade um gezielt zwischen beiden umschalten zu können (eventuell sogar für die hauseigene Hardware). Meist hat 2.4GHz mehr Reichweite (und folglich meldet sich das Handy da ein, weil es das erste ist, was es sieht, wenn ich nach Hause komme). Normalerweise kümmere ich mich nicht weiter darum.

Aber manchmal ist ein gezielter Wechsel - aus welchem Grund auch immer - angebracht. Dann sind unterschiedliche SSIDs recht nützlich.

Ciao,
Photor
 

mr44er

moderater Moderator
Teammitglied
In der Regel klappt das auch und ist ein sinnvoller default für Heimanwender, wenn das der einzige AP im Heimnetz und das Clientgerät nicht uralt oder der letzte Exot ist. Hat man es etwas komplexer mit mehreren APs, sogar unterschiedlichen Herstellern und fährt 802.11r, dann kann man nicht selten flapping dazwischen beobachten oder der Client 'klebt' mit 5% Empfangstärke am einen AP und wechselt nicht auf den anderen, obwohl man direkt davor steht.
Um welche Fritzbox handelt es sich denn? Ist die letzte Firmware drauf? Leider gehen mir die Ideen aus, an was es liegen könnte. Aber wenigstens konnten wir schon einiges ausschließen, was es nicht sein kann. :)
 
Um welche Fritzbox handelt es sich denn?
Es handelt sich um eine Fritzbox 7490.

Ist die letzte Firmware drauf?
Ja, Version 07.29 (laut FB die aktuelle).

Leider gehen mir die Ideen aus, an was es liegen könnte. Aber wenigstens konnten wir schon einiges ausschließen, was es nicht sein kann. :)
Als geborener Optimist glaube ich fest daran, daß wir das Problem lösen werden. :)

An der FB funktionieren alle möglichen Geräte über WLAN, von meinem Windows-10-Hauptrechner, über Android-Telefone bis zu einem Pocketbook Touch HD2. Auch bei dem Versuchs-T530 kann ich einen Hardwaredefekt mit nahezu hundertprozentiger Sicherheit ausschließen. Unter Windows 10 war dieser Rechner problem- und drahtlos verbunden.

Könnte es sein, daß sich die Lösung hier verbirgt?

Falls du immer noch nicht weiterkommst, dein Treiber müsste „iwn“ sein und der braucht auch einen Firmware. Könnte ja vielleicht sein, dass diese in GhostBSD noch installiert bzw geladen werden muss.
 

mr44er

moderater Moderator
Teammitglied
Ja, Version 07.29 (laut FB die aktuelle).
Das ist korrekt: https://download.avm.de/fritzbox/fritzbox-7490/deutschland/fritz.os/

->
Mini-PCI-Express Slot 1 mit einer der folgenden Komponenten:
  • Leer
  • ThinkPad 11b/g/n, 1x1
  • Intel Centrino Wireless-N 2200
  • Intel Centrino Advanced-N 6205
  • Intel Centrino Ultimate-N 6300
-> Lustiges Paradebeispiel
Anmerkungen
  • diese Karte unterstützt nur das 2,4GHz-Band

Welche von denen ist denn verbaut? Das mit der firmware kann natürlich sein. Ich kenne mich mit openbsd nicht aus, weiß daher nicht wie der Befehl zum Hardware anzeigen lautet oder ob das überhaupt Erkenntnis bringt.
Du könntest an dem Gerät auch mal die entsprechende Luke aufschrauben und ein Foto knipsen.
 

pit234a

Well-Known Member
Das eine Problem ist deshalb auch sicher, dass kaum jemand hier ist, der überhaupt GhostBSD nutzt.

Ich gehe stark davon aus, dass die ein Desktop-Ready-System gebaut haben und bereits Mechanismen, die es dem Nutzer erlauben die Netzwerkverbindungen grafisch zu handhaben. Ich selbst nutze auf meinen Laptops
Code:
networkmgr-6.1_1               FreeBSD/GhostBSD network connection manager
also genau den Networkmanager aus GhostBSD.
Der erfordert, je nach Version, einige Besonderheiten hinsichtlich der Nutzerrechte. Mal verlangte er doas, mal sudo und das muss auch jeweils entsprechend konfiguriert sein.
Mein Bauchgefühl sagt mir, dass möglicherweise hier der Hund begraben sein könnte. GhostBSD kann auch mal fehlerhaft sein, oder?
Wenn zB der Notwerkmanager die wpa_supplicant nicht schreiben darf, könnte das solche Probleme verursachen.
Auch Syntax-Fehler in solchen Dateien können Fehler verursachen. Und so weiter...

Deshalb nochmal mein Rat von oben: an das Handbuch halten und es mal ganz ohne GUI so weit machen und sehen, was dann passiert, wenn man als root agiert.

Meine beiden Lenovos benutzen auch iwn unter FreeBSD. Da gibt es zwar immer wieder Berichte über Performance-Probleme und Abbrüche, aber dass ein Passwort nicht richtig übermittelt wird, wenn ansonsten die Verbindung gelingt (sonst würde man den AP nicht sehen), habe ich noch nie gehört.
 

Lance

Well-Known Member
GhostBSD kann auch mal fehlerhaft sein, oder?
Leider fast immer irgendwo.
Ich denke mal entweder Rechte etc. (Siehe meinen vorigen Post dazu) oder Firmware, obwohl die eigentlich- normalerweise- mitinstalliert wird. Aber dafür hatte ich ja den Link zum Wikieintrag beigefügt.
Und da GhostBSD jetzt auch nicht mehr auf OpenRC basiert, hat es sich der FreeBSD-Basis ja auch wieder stärker angenähert und sollte deshalb leichter zu konfigurieren sein.

Ansonsten falls das alles nicht hilft, würde ich im GhostBSD Forum die Frage stellen, am besten mit dem Output des Befehls, den ich gepostet hab und vielleicht noch Einträge aus der loader.conf etc.
 
Welche von denen ist denn verbaut? Das mit der firmware kann natürlich sein. Ich kenne mich mit openbsd nicht aus, weiß daher nicht wie der Befehl zum Hardware anzeigen lautet oder ob das überhaupt Erkenntnis bringt.
Du könntest an dem Gerät auch mal die entsprechende Luke aufschrauben und ein Foto knipsen.

Eben habe ich noch einmal die Windows-10-SSD eingebaut und den Rechner hochgefahren - der Geräte-Manager zeigt eine Intel Centrino Advanced-N 6205 an.

N6205.png
 
Das eine Problem ist deshalb auch sicher, dass kaum jemand hier ist, der überhaupt GhostBSD nutzt.

Ich gehe stark davon aus, dass die ein Desktop-Ready-System gebaut haben und bereits Mechanismen, die es dem Nutzer erlauben die Netzwerkverbindungen grafisch zu handhaben. Ich selbst nutze auf meinen Laptops
Code:
networkmgr-6.1_1               FreeBSD/GhostBSD network connection manager
also genau den Networkmanager aus GhostBSD.
Genau so habe ich es auch verstanden - ausweislich der GhostBSD-Seite basiert es auf FreeBSD und soll einfach zu installieren und grafisch benutzbar sein. Im Grunde tut's das bei mir auch - bis auf die nicht funktionierende WLAN-Verbindung.
Der erfordert, je nach Version, einige Besonderheiten hinsichtlich der Nutzerrechte. Mal verlangte er doas, mal sudo und das muss auch jeweils entsprechend konfiguriert sein.
Mein Bauchgefühl sagt mir, dass möglicherweise hier der Hund begraben sein könnte. GhostBSD kann auch mal fehlerhaft sein, oder?
Wenn zB der Notwerkmanager die wpa_supplicant nicht schreiben darf, könnte das solche Probleme verursachen.
Auch Syntax-Fehler in solchen Dateien können Fehler verursachen. Und so weiter...
So tief bin ich leider in dem Thema (noch) nicht drin - was auch der Grund war, zuerst GhostBSD als Basis zu installieren und mir von dort aus die BSD-Welt langsam zu erschließen.
Deshalb nochmal mein Rat von oben: an das Handbuch halten und es mal ganz ohne GUI so weit machen und sehen, was dann passiert, wenn man als root agiert.
Dann muß ich mich in der Tat mit dem FreeBSD-Handbuch in Klausur begeben und den von Dir verlinkten Teil durcharbeiten. Mehr, als daß ich das Sytem komplett abschieße, kann ja nicht passieren. :D
Meine beiden Lenovos benutzen auch iwn unter FreeBSD. Da gibt es zwar immer wieder Berichte über Performance-Probleme und Abbrüche, aber dass ein Passwort nicht richtig übermittelt wird, wenn ansonsten die Verbindung gelingt (sonst würde man den AP nicht sehen), habe ich noch nie gehört.
Mich verwundert dieser Fehler auch sehr - die Hardware ist definitiv in Ordnung und extrem exotisch oder neu ist ein Lenovo T530 mit Intel Centrino Advanced-N 6205 ja nun wirklich nicht.
 

mr44er

moderater Moderator
Teammitglied
Lance hat natürlich Recht, ka wie ich auf OpenBSD kam. Also gut, GhostBSD hat FreeBSD als Unterbau, da weiß ich ein bisschen mehr. Und noch besser: Mein T430 hat die gleiche WLAN-Karte, die Verbindung auf meine Fritzbox 7390 funktioniert einwandfrei ohne Gefrickel. :)

Ich habe GhostBSD default installiert, lediglich präventiv durch Vorahnung beim Keyboard 'Generic 105-key' gewählt. Ist beim Thinkpad natürlich falsch, aber es ging ja nur um den Connect-Test.
Screenshot1 ist direkt vom ersten Boot, also ich musste kein Modul händisch laden oder sonstwas friemeln. 5GHz würde auch klappen, das sehe ich anhand der höheren Kanäle (z.B. 40 und 153).
Das Passwort habe ich via gui rechts oben (Screenshot2) eingegeben und war sofort verbunden.

Da ergab sich dann noch eine Vermutung, da der country code auf US steht, denn da ist bei Kanal 11 Schluss. 12 und 13 ist EU-spezifisch und das können die Fritzboxen, das weiß ich sicher. Lesestoff dazu: https://www.tecchannel.de/a/so-optimieren-sie-ihr-wlan-tempo,2079596,2

Man könnte jetzt auf DE ändern, aber ob die N6205 hardwareseitig überhaupt Kanal13 kann: "Weißichnicht1"
Weißichnicht2: Ob die Fritzbox auf 'autokanal' eingestellt ist und wenn ja, ob dann von 1-11 rangiert wird oder 1-13 oder man Kanal13 in jedem Fall explizit wählen muss.
Weißichnicht3: Ob das hier überhaupt das Problem ist.

Auf autokanal kann es eben sein, dass wenn nur einer abends seinen Router ausschaltet, dass es umspringt und im dümmsten Fall auf Kanal13.
Am besten wäre es, du schaust dir mal die Kanalauslastungsübersicht (da wo steht, dass der Scan bis zu zwei Minuten dauern kann) in der Fritzbox an und wählst dann fest Kanal 1, 6 oder 11. (der mit geringster Fremdlast).

Wenn das alles nichts taugt und dein Gebiet auf 2,4GHz 'verseucht' ist, kannst du das gleiche Spiel mit festem Kanal nochmal auf 5GHz testen, wir wissen ja jetzt, dass die Karte das ganz sicher kann (unter GhostBSD).

Zum Abgleich: Im BIOS habe ich unter Startup->UEFI only sowie CSM aus. Security->I/O Port Access->alles auf enabled
 

Anhänge

  • ghost1.jpg
    ghost1.jpg
    101,7 KB · Aufrufe: 49
  • ghost2.jpg
    ghost2.jpg
    97,2 KB · Aufrufe: 47

CommanderZed

OpenBSD User
Teammitglied
Was du auch mal schauen könntest ob du einen Kanel verwendest der IRGENDWO auf der Welt aufgrund von Regulierungen blockiert ist.

Gerade networkmgr & co. sind da manchmal sehr speziell wenn irgendwo nicht das Land gesetzt sind.
 
Vorab bitte ich um Entschuldigung für die lange Abwesenheit, die keineswegs einem Desinteresse oder gar Unhöflichkeit gegenüber den hilfsbereiten Foristen geschuldet war, sondern private Ursachen hatte. Nun geht's aber mit frischer Kraft weiter.


Lance hat natürlich Recht, ka wie ich auf OpenBSD kam. Also gut, GhostBSD hat FreeBSD als Unterbau, da weiß ich ein bisschen mehr. Und noch besser: Mein T430 hat die gleiche WLAN-Karte, die Verbindung auf meine Fritzbox 7390 funktioniert einwandfrei ohne Gefrickel. :)

Das ist erfreulich und macht mir Mut. Soweit ich weiß, ist der T430 bis auf die Bildschirmgröße mit dem T530 identisch.


Ich habe GhostBSD default installiert, lediglich präventiv durch Vorahnung beim Keyboard 'Generic 105-key' gewählt. Ist beim Thinkpad natürlich falsch, aber es ging ja nur um den Connect-Test.

Screenshot1 ist direkt vom ersten Boot, also ich musste kein Modul händisch laden oder sonstwas friemeln. 5GHz würde auch klappen, das sehe ich anhand der höheren Kanäle (z.B. 40 und 153).
Das Passwort habe ich via gui rechts oben (Screenshot2) eingegeben und war sofort verbunden.

Hattest Du das extra wegen meiner Frage installiert? Ganz herzlichen Dank! Ich weiß die Mühe sehr zu schätzen.

Zum Stand der Dinge: Im Moment ist in der Tat nur das 2,4-GHz-Band eingeschaltet. allerdings auf Autokanal.

Als ich auf dem T530 nicht weiterkam, benutzte ich auf einem anderen Rechner, einem W530 (mit der gleichen WLAN-Karte) die Liveversion von GhostBSD - und es ließ sich tatsächlich verbinden. Netz über WLAN war da, alles funktionierte. Reproduzierbar war das indes nicht - es gelang mir am nächsten Tage noch einmal und dann nicht wieder. Auf dem T530 klappte es auch mit der Liveversion kein einziges Mal.

Nun werde ich - Deinem Rate folgend - die Kanäle manuell vergeben und einzeln testen, zuerst bei 2,4 GHz, dann bei 5 GHz. Mal schauen, ob das zu einem Ergebnis führt.

Zum Abgleich: Im BIOS habe ich unter Startup->UEFI only sowie CSM aus. Security->I/O Port Access->alles auf enabled

Werde ich abgleichen, danke. Irgendwo muß doch der Hund begraben liegen.
 

mr44er

moderater Moderator
Teammitglied
Desinteresse oder gar Unhöflichkeit
Davon ging ich auch nicht aus. :)

Soweit ich weiß, ist der T430 bis auf die Bildschirmgröße mit dem T530 identisch.
Exakt.

Hattest Du das extra wegen meiner Frage installiert? Ganz herzlichen Dank! Ich weiß die Mühe sehr zu schätzen.
Jein, ich wollte eh was testen und da war der Schlenker quasi auf dem Weg. ;)

Reproduzierbar war das indes nicht - es gelang mir am nächsten Tage noch einmal und dann nicht wieder.
In ganz arg dummen Fällen verbumselt sich die config der Fritzbox, vor allem wenn diese schon über Jahre rennt, historisch wuchs und die Geräteliste Hunderte MACs enthält, die sich jemals da anmeldeten. Ob dann irgendein Puffer volläuft oder so, keine Ahnung. Ist auch nicht modellspezifisch, mir schon desöfteren passiert. Da kann es helfen, sie auf Werkseinstellung zu setzen und alles frisch einzutragen (nicht das 'kaputte' backup davon wieder einspielen). pppoe-Daten, Portfreigaben etc...normalerweise keine große Sache, zumal du ja eh gerade dran bist.
Alle Fritzboxen defaulten ja nach Schema 'FRITZ!Box $Modell' und die wenigsten Anwender ändern das. Wenn dein Nachbar aber die gleiche Box hat, wie sollte ein Client da unterscheiden? Eindeutig definiert ist das durch die (B)SSID, welche die MAC des APs ist. Das wird aber clientseitig selten gesetzt, wenn man es nicht explizit konfiguriert. -> https://www.juniper.net/documentati...topics/concept/wireless-ssid-bssid-essid.html
Das könnte natürlich noch eine klassische Stolperfalle sein, daher ändere beide SSIDs besser eindeutig. 'box1_7490_24' und 'box1_7490_5' ist so meine ganz einfache Umschiffung bei sowas. ;)

Edit: Das T430 hat rechts vom SD-Slot einen winzigen Dipschalter sowie die Kombination FN+F5 um Funk (nicht explizit WLAN!) zu schalten. Nicht immer waren das Hardwareschalter aus Sicht des Mainboards und sie wirken sich dann als Softwareschalter in Richtung Betriebssystem anders aus. Könnte beim T530 oder dem W530 z.B. genau umgekehrt sein.
Unter Windows10 bewirkt z.B. FN+F5 den Flugmodus, also könntest du damit auch mal rumspielen und Kombinationen ausprobieren.
 
Davon ging ich auch nicht aus. :)
Das beruhigt mich. :)
Jein, ich wollte eh was testen und da war der Schlenker quasi auf dem Weg. ;)
Das ändert nichts an meiner Dankbarkeit ;) - und einen entscheidenden Impuls gab es mir auch (dazu später mehr).

In ganz arg dummen Fällen verbumselt sich die config der Fritzbox, vor allem wenn diese schon über Jahre rennt, historisch wuchs und die Geräteliste Hunderte MACs enthält, die sich jemals da anmeldeten. Ob dann irgendein Puffer volläuft oder so, keine Ahnung. Ist auch nicht modellspezifisch, mir schon desöfteren passiert. Da kann es helfen, sie auf Werkseinstellung zu setzen und alles frisch einzutragen (nicht das 'kaputte' backup davon wieder einspielen). pppoe-Daten, Portfreigaben etc...normalerweise keine große Sache, zumal du ja eh gerade dran bist.
Das kann ich bestätigen - ich hatte es kürzlich erlebt (noch vor BSD) und durfte sie neu aufsetzen. Zufällig verfügte ich also über eine ziemlich frische Konfiguration ohne Altlasten.

Alle Fritzboxen defaulten ja nach Schema 'FRITZ!Box $Modell' und die wenigsten Anwender ändern das. Wenn dein Nachbar aber die gleiche Box hat, wie sollte ein Client da unterscheiden? Eindeutig definiert ist das durch die (B)SSID, welche die MAC des APs ist. Das wird aber clientseitig selten gesetzt, wenn man es nicht explizit konfiguriert. -> https://www.juniper.net/documentati...topics/concept/wireless-ssid-bssid-essid.html
Das könnte natürlich noch eine klassische Stolperfalle sein, daher ändere beide SSIDs besser eindeutig. 'box1_7490_24' und 'box1_7490_5' ist so meine ganz einfache Umschiffung bei sowas. ;)
Diesbezüglich hatte ich bereits bei der Ersteinrichtung einen unverwechselbaren Namen vergeben. Zum einem, weil offenbar zwei Nachbarn ihre Geräte mit dem Standardnamen betrieben und zum anderen aus einem ausgeprägten Individualisierungsdrang (vulgo: Spieltrieb) heraus.
Edit: Das T430 hat rechts vom SD-Slot einen winzigen Dipschalter sowie die Kombination FN+F5 um Funk (nicht explizit WLAN!) zu schalten. Nicht immer waren das Hardwareschalter aus Sicht des Mainboards und sie wirken sich dann als Softwareschalter in Richtung Betriebssystem anders aus. Könnte beim T530 oder dem W530 z.B. genau umgekehrt sein.
Unter Windows10 bewirkt z.B. FN+F5 den Flugmodus, also könntest du damit auch mal rumspielen und Kombinationen ausprobieren.
Der Schalter sitzt bei meinem T530 und W530 in der Tat an einer anderen Stelle - links vorn am Gehäuse (der SD-Slot rechts). Zum glück mußte ich hier jedoch nichts probieren.

~~~

In den letzten Tagen hatte ich mich - immer wieder zwischendurch - mit dem T530 beschäftigt. Stand der Dinge war, daß 2,4- und 5-GHz-Band getrennt und 5 GHz abgeschaltet waren, die 2,4-GHz-Kanäle hatte ich manuell vergeben.

Nun probierte ich jeden Kanal durch. Erfolglos. Auf Anraten von pit234a studierte ich das von ihm empfohlene Kapitel im FreeBSD-Handbuch und überprüfte die Konfigurationseinträge - allerdings schien auch hier alles ordnungsgemäß zu sein. Auch dem Hinweis von CommanderZed ging ich nach; m. E. war jedoch das Land korrekt gesetzt worden.

Da Kapitulation für mich keine Option darstellte, entschloß ich mich zu »indirekter Feindaufklärung«. Zuerst lud ich Knoppix 9.1 herunter - damit ließ sich der Rechner problemlos verbinden. Nun folgte NomadBSD 1.4. - exakt der gleiche Fehler wie mit GhostBSD.

Daß es bei Dir, mr44er, auf einem fast identischen Rechner problemlos lief, gab mir zu denken - logischerweise konnte es dann nicht an einer Konfigurationssache liegen; und auch meine Hardware war in Ordnung, wie Windows 10 und Knoppix gezeigt hatten. Das ließ mich nicht los - und noch tiefer forschen.

Dann stieß ich hierzuforum auf einen Eintrag, in dem der Verfasser die schlechte WLAN-Verbindungsqualität von BSD kritisierte. Daraufhin schaffte ich meinen Testrechner einige Meter weiter direkt neben die Fritzbox. Und plötzlich lief es. Problemlos. Schlüssel abgefragt, verbunden, fertig. Alles war da (wenn auch m. E. die Verbindung relativ langsam war). Nun schaltete ich das 5-GHz-Band wieder ein (Autokanal), verband mich mit der dort vergebenen SSID und auch da lief es einwandfrei. Danach stellte ich die ursprüngliche Konfiguration wieder her (2,4- und 5-GHz-Netz mit automatischer Kanalwahl und Umschaltung) und auch da geb es keinerlei Probleme. Jede Verbindung funktionierte.

Sowie ich mich mit dem Rechner einige Meter von der Fritzbox entfernte, gab es jedoch keine Verbindung mehr - weder mit Ghost- noch mit NomadBSD; mit Windows und Knoppix hingegen immer. Ein Test mit dem W530 führte zum exakt gleichen Resultat.

Da sowohl Ghost- als auch NomadBSD einen FreeBSD-Unterbau haben, stellt sich mir die Frage, ob die etwas maue Leistung des WLAN-Treibers systemimmanent ist, oder ob es eine Möglichkeit gibt, die Leistung zu erhöhen.

Sollte jemandem das Problem und eine Lösung (anderer Treiber oder (USB)-Netzwerkkarte, Konfigurationsänderungen etc.) bekannt sein, wäre ich für einen Hinweis dankbar. Funktioniert es ggf. mit dem reinen FreeBSD besser?

Aber sei’s drum - nun gilt es erst einmal für mich, sich mit GhostBSD und dessen FreeBSD-Unterbau zu befassen.

An dieser Stelle noch einmal ganz herzlichen Dank an alle Foristen für die hilfreichen Ratschläge! Ich bin wirklich erfreut über die Freundlichkeit und Hilfsbereitschaft in dieser Gemeinschaft.
 

bsd4me

Well-Known Member
Das klingt ja sehr schade - Mein Lenovo W530 und FreeBSD 13.1 hat wireless mit meiner Fritzbox keine Probleme... Ich hoffe, Du findest eine Erklärung nocht :-) Ansosnten nimm was anderes... VG Norbert
 

mr44er

moderater Moderator
Teammitglied
Das riecht irgendwie nach fehlgeschlagenem power management. Hattest du den Netzstecker bei deinen Tests drin oder hast du das auf Akku währenddessen laufen lassen? Wenn letzteres, mit Netzstecker komplett neu booten nochmal versuchen.
Auf meinem zweiten Screenshot kann man txpower 30 sehen, das T430 war durchweg am Netzstecker und die Entfernung zur Fritzbox betrug ~2m.

Das war jetzt bei mir nicht, aber steht da was von powersave bei dir? https://wiki.freebsd.org/WiFi/PowerSave
 
Oben